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Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programmi
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evi
by receipts or other documentation.  National Instruments will, at its option, repair or replace software media th
not execute programming instructions if National Instruments receives notice of such defects during the warra
period.  National Instruments does not warrant that the operation of the software shall be uninterrupted or erro

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the ou
of the package before any equipment will be accepted for warranty work.  National Instruments will pay the shi
costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate.  The document has been careful
reviewed for technical accuracy.  In the event that technical or typographical errors exist, National Instruments re
the right to make changes to subsequent editions of this document without prior notice to holders of this edition
reader should consult National Instruments if errors are suspected.  In no event shall National Instruments be lia
any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND 
SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE.  
CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  
INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER.  NATIONAL  INSTRUMENTS 
WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.  This limitation of the liability of National 
Instruments will apply regardless of the form of action, whether in contract or tort, including negligence.  Any a
against National Instruments must be brought within one year after the cause of action accrues.  National Instr
shall not be liable for any delay in performance due to causes beyond its reasonable control.  The warranty pr
herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow t
National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; 
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third par
other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mecha
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part,
without the prior written consent of National Instruments Corporation.

Trademarks
BridgeVIEW™, LabVIEW™, National Instruments™, natinst.com™, and NI-DAQ™ are trademarks of National
Instruments Corporation.

Product and company names listed are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing intended to ensure a level of reli
suitable for use in treatment and diagnosis of humans.  Applications of National Instruments products involving
medical or clinical treatment can create a potential for accidental injury caused by product failure, or by errors 
part of the user or application designer.  Any use or application of National Instruments products for or involvin
medical or clinical treatment must be performed by properly trained and qualified medical personnel, and all trad
medical safeguards, equipment, and procedures that are appropriate in the particular situation to prevent seriou
or death should always continue to be used when National Instruments products are being used.  National Instr
products are NOT intended to be a substitute for any form of established process, procedure, or equipment us
monitor or safeguard human health and safety in medical or clinical treatment.
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The BridgeVIEW User Manual contains the information you need to ge
started with the BridgeVIEW software package. This manual explai
the BridgeVIEW environment, tag configuration, human machine 
interfaces, alarms and events, and historical data logging and 
extraction. This manual also reviews the concepts of G programmin

Throughout both sections of this manual, there are activities that te
you what you need to know to build your own virtual instruments, a
ultimately, your own SCADA system. This manual presumes that y
know how to operate your computer and that you are familiar with i
operating system. 

Organization of This Manual
This manual covers two subject areas. Chapters 1 through 8 introd
BridgeVIEW concepts, and Chapters 9 through 15 describe the 
G programming language, and how it works within BridgeVIEW. Eac
chapter in the G Tutorial section discusses a different G concept, 
although you can design a VI that might incorporate several of thes
basic concepts. Therefore, we encourage you to work through all th
activities in this manual before you begin building your applications

You should save all of the VIs you create with the BridgeVIEW 
activities in the BridgeVIEW\Tutorial  directory. To view the VI(s) 
for an activity that you have not completed yourself, see the 
BridgeVIEW\Tutorial\Solutions  directory. 
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BridgeVIEW Concepts
• Chapter 1, Introduction, describes the unique BridgeVIEW 

approach to Human Machine Interface (HMI) and Supervisory 
Control and Data Acquisition (SCADA). It also contains system
configuration, installation instructions and basic information tha
explains how to start using BridgeVIEW to develop industrial 
automation applications. This chapter refers you to other chapt
or manuals for more information.

• Chapter 2, BridgeVIEW Environment, describes the BridgeVIEW 
environment. It explains the basic concepts behind G, the 
programming language upon which BridgeVIEW is built, the 
BridgeVIEW Engine Manager, system errors and events, the Ta
Monitor utility, and the Tag Browser utility. This chapter also 
explains how to access online help for BridgeVIEW and provide
an activity that illustrates how to examine the front panel and blo
diagram of a virtual instrument (VI).

• Chapter 3, Tag Configuration, explains tags, the Tag Configuration
Editor, and how you edit tags within the BridgeVIEW system. 
Before you can run a BridgeVIEW application, you must specify
tag configuration. This chapter also includes an activity that 
illustrates how to use the Tag Configuration Editor.

• Chapter 4, Human Machine Interface, explains what a Human 
Machine Interface (HMI) is and how you can monitor and contro
tags from your HMI. This chapter also describes several genera
principles of HMI programming in G, and provides activities tha
illustrate how to build your HMI using the HMI G Wizard and 
customize front panel objects with imported graphics.

• Chapter 5, Alarms and Events, introduces the basic concepts of 
alarms and events, and explains how to view, acknowledge, an
configure them within the BridgeVIEW system. This chapter als
provides activities that explain how to build an alarm summary 
display and acknowledge alarms from your HMI. 

• Chapter 6, Historical Data Logging and Extraction, explains the 
concept of a trend, how to log and extract historical data, and h
to use the Historical Trend Viewer (HTV), a utility that displays 
historical data that has been logged to disk with BridgeVIEW.

• Chapter 7, Advanced Application Topics, explains the advanced topics
you need to understand to make optimum use of BridgeVIEW for 
developing applications. The advanced topics covered in this 
chapter are the Panel G Wizard, BridgeVIEW System Control, T
Attributes VIs, and BridgeVIEW Security.
BridgeVIEW User Manual xxii © National Instruments Corporation
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• Chapter 8, Servers, explains how to use servers with BridgeVIEW
BridgeVIEW supports several types of servers including OPC 
Servers, DDE Servers, and IA Device Servers.

G Tutorial
• Chapter 9, Creating and Customizing VIs, introduces the basic 

concepts of virtual instruments and provides activities that expla
how to create the icon and connector, how to use a VI as a sub
how to use the VI Setup… option, and how to use the SubVI Node 
Setup… option.

• Chapter 10, Loops and Charts, introduces structures and explains 
the basic concepts of charts, the While Loop, and the For Loop
This chapter also provides activities that illustrate how to 
experiment with different chart modes, use a While loop and a 
chart, change the mechanical action of a Boolean switch, contr
loop timing, use a shift register, create a multiplot chart and 
customize your trend, and use a For Loop.

• Chapter 11, Case and Sequence Structures, introduces the basic 
concepts of Case and Sequence structures, and provides activ
that explain how to use the Case structure, how to use the Sequ
structure, and what sequence locals are and how to use them.

• Chapter 12, Attribute Nodes, describes objects called attribute 
nodes, which are special block diagram nodes that control the 
appearance and functional characteristics of controls and 
indicators.

• Chapter 13, Arrays, Clusters, and Graphs, introduces the basic 
concepts of polymorphism, arrays, clusters, and graphs and 
provides activities that explain auto-indexing and the Graph an
Analysis VIs. 

• Chapter 14, VI Control VIs, introduces VI Control VIs and provides
an activity that explains how to use them within BridgeVIEW. Th
VI Control VIs allow you to control when a VI is loaded into 
memory, run, and unloaded from memory. These VIs also allow
you to accomplish the following dynamically: resize a VI front 
panel, monitor the status of VI execution (running or idle), and 
monitor the status of a VI front panel (closed, open, or active).

• Chapter 15, Program Design, suggests some techniques to use whe
creating programs and offers programming style recommendatio
© National Instruments Corporation xxiii BridgeVIEW User Manual
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Appendices, Glossary, and Index
• Appendix A, HMI Function Reference, describes error handling for 

BridgeVIEW VIs and contains an explanation of the VIs in the 
BridgeVIEW VI library. In this appendix, the VIs are arranged 
alphabetically, first by VI Library name (Alarms and Events, 
Historical Data, System, Tags, and Tag Attributes), then by VI 
name. 

• Appendix B, Citadel and Open Database Connectivity, describes the 
Citadel database and the Open Database Connectivity (ODBC)
driver, and includes several examples of how to use it. 

• Appendix C, Customer Communication, contains forms to help you 
gather the information necessary to help us solve your technica
problems and a form you can use to comment on the product 
documentation.

• The Glossary contains an alphabetical list of terms used in this 
manual, including abbreviations, acronyms, metric prefixes, 
mnemonics, and symbols.

• The Index contains an alphabetical list of key terms and topics in
this manual, including the page where you can find each one.

Conventions Used in This Manual
The following conventions are used in this manual:

bold Bold text denotes a parameter, menu name, palette name, menu item, r
value, function panel item, or dialog box button or option.

italic Italic text denotes mathematical variables, emphasis, a cross referenc
an introduction to a key concept.

bold italic Bold italic text denotes an activity objective, note, caution, or warning.

monospace Text in this font denotes text or characters that you should literally ent
from the keyboard. Sections of code, programming examples, and syn
examples also appear in this font. This font also is used for the proper
names of disk drives, paths, directories, programs, subprograms, 
subroutines, device names, variables, filenames, and extensions, and
statements and comments taken from program code.

<> Angle brackets enclose the name of a key on the keyboard—for exam
<PageDown>.
BridgeVIEW User Manual xxiv © National Instruments Corporation
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- A hyphen between two or more key names enclosed in angle brackets
denotes that you should simultaneously press the named keys—for 
example, <Control-Alt-Delete>.

<Control> Key names are capitalized.

» The » symbol leads you through nested menu items and dialog box op
to a final action. The sequence File»Page Setup»Options»Substitute 
Fonts directs you to pull down the File menu, select the Page Setup item, 
select Options, and finally select the Substitute Fonts option from the last 
dialog box.

paths Paths in this manual are denoted with backslashes (\) to separate dri
names, directories, and files, as in C:\dir1name\dir2name\filename .

This icon to the left of bold text denotes the beginning of an activity, wh
contains step-by-step instructions you can follow to learn more about 
BridgeVIEW. 

This icon to the left of bold text denotes the end of an activity, which 
contains step-by-step instructions you can follow to learn more about 
BridgeVIEW.

This icon to the left of bold italicized text denotes a note, which alerts y
to important information.

Abbreviations, acronyms, metric prefixes, mnemonics, symbols, and te
are listed in the Glossary.

Related Documentation
The following documents contain information that you might find 
helpful as you read this manual:

• G Programming Reference Manual 

• BridgeVIEW Online Reference, available online by selecting 
Help»Online Reference
© National Instruments Corporation xxv BridgeVIEW User Manual
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Customer Communication
National Instruments wants to receive your comments on our produ
and manuals. We are interested in the applications you develop with
products, and we want to help if you have problems with them. To ma
it easy for you to contact us, this manual contains comment and 
configuration forms for you to complete. These forms are in 
Appendix C, Customer Communication, at the end of this manual.
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This chapter describes the unique BridgeVIEW approach to Human 
Machine Interface (HMI) and Supervisory Control and Data Acquisitio
(SCADA). It also contains system configuration, installation instruction
and basic information that explains how to start using BridgeVIEW to 
develop industrial automation applications. This chapter refers you to o
chapters or manuals for more information.

Welcome To BridgeVIEW
BridgeVIEW adds real-time process monitoring, historical trending, ala
and event reporting, online configuration tools and PLC connectivity to
premiere graphical development environment, G.

BridgeVIEW makes use of an intuitive graphical user interface combin
with a powerful graphical programming language, G, that enables you
perform data acquisition and analysis, create an operator interface or 
Human Machine Interface (HMI), and develop advanced supervisory 
control applications.

BridgeVIEW provides the following features for the development of yo
Industrial Automation applications.

• Graphical human-machine interface (HMI) 

• Easy-to-use, fill in the blank configuration utilities 

• Graphical programming tools 

• Real-Time Database (RTDB)

• Historical data collection and trending (Citadel)

• Alarm and event reporting and logging 

• Security 

• Connectivity to PLC and industrial device networks

• OPC Server Support
dgeVIEW User Manual



Chapter 1 Introduction

 

 on 

 
l 

 
n 

un 

s: 

, 

n 

u 
Required System Configuration
BridgeVIEW is distributed on a CD-ROM that includes the complete 
BridgeVIEW 1.0 release.

The Windows 95/NT version of BridgeVIEW runs on any system that 
supports Windows 95 or Windows NT 3.51 or later. You should have a
minimum of 24 MB of RAM for this version to run effectively. We 
recommend 32 MB of RAM and at least 30 MB of swap space available
your system.

Note: The standard BridgeVIEW installation requires approximately 85 MB of disk
space. A full installation requires approximately 100 MB. If you plan to instal
the NI-DAQ Server as well, you will need an additional 30 MB.

Installation
1. Insert the CD in your CD-ROM drive. 

2. Run the BridgeVIEW installer. 

a. If you have Windows 95 or Windows NT 4.0 and your system
uses the AutoPlay feature, the Welcome to BridgeVIEW scree
appears a short time after you insert the CD.

b. If you have Windows NT 3.51 or a system not using AutoPlay, r
the following program:
X:\bvsetup.exe  
where X is the letter of your CD-ROM drive.

3. Choose an installation. The installer offers several installation type
Standard, Full, Minimum, and Custom. The Standard installation 
requires approximately 85 MB. The Full installation, which also 
includes Data Acquisition, GPIB, and VISA libraries and examples
requires approximately 100 MB of disk space. The Standard 
installation is recommended.

4. After selecting an installation, follow the instructions that appear o
your screen.

Note: If you plan to use National Instruments Data Acquisition (DAQ) devices, 
VISA, or GPIB instrumentation, you can perform either a Full installation, 
which installs all necessary drivers and example programs, or a custom 
installation, in which you select the items to install.

After you have installed BridgeVIEW completely, it is ready to run. Yo
might need to re-boot your machine after installation so that updated 
system, DAQ, VISA, or GPIB drivers can be loaded properly.
BridgeVIEW User Manual 1-2 © National Instruments Corporation
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What Is BridgeVIEW?
BridgeVIEW is a software package specifically targeted at industrial 
automation applications. BridgeVIEW provides configurable solutions f
common HMI and SCADA functions while leveraging the flexibility of 
graphical programming. BridgeVIEW is built around the G programmin
language, created by National Instruments Corporation.

With BridgeVIEW, you can acquire data and control one or more 
distributed devices in an overall facility. BridgeVIEW can change set 
points or send control instructions to the individual devices while 
monitoring the entire system. It also can gather information like alarms 
measurement points from these devices.

Common devices used for data acquisition include Progammable Log
Controllers (PLCs), plug-in Data Acquisition boards, and other distribut
Input/Output (I/O) modules. BridgeVIEW device servers communicate
with these non-plug-in devices through RS-232, RS-485, TCP/IP, DDE
netDDE, direct I/O, or other proprietary interfaces. BridgeVIEW device
servers provide the necessary protocol software to communicate with t
devices. BridgeVIEW also operates directly with OPC servers.

How Does BridgeVIEW Work?
BridgeVIEW uses a combination of tags, events, and data. A tag is a 
connection to a real-world I/O point, while an event is anything that 
happens to a tag or to the BridgeVIEW Engine in general. The 
BridgeVIEW Engine communicates with device servers on one end, a
with your HMI application at the other end. The BridgeVIEW Engine 
maintains a Real-Time Database (RTDB) of tag information and logs 
historical data and events. You can build your HMI to interface with th
BridgeVIEW Engine using virtual instruments (VIs) to read and write tag 
values, view alarm information and trend data. A virtual instrument is a
BridgeVIEW function, written in the graphical programming language G
For more information about G, see any of the chapters in the G Tutorial 
section of this manual. 

Start by configuring all the tags in your system with the Tag Configurat
Editor. Then, you can launch the BridgeVIEW Engine, which reads yo
configuration file and starts monitoring tags, logging data and events. Y
can create your HMI application to display tag values, trends, and alar
You also can acknowledge alarms and control output tags. You can b
the HMI using BridgeVIEW VIs to read and write tag values, view alar
© National Instruments Corporation 1-3 BridgeVIEW User Manual
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information, acknowledge alarms, view real-time trends and retrieve 
historical data. For more information about how to get started with 
BridgeVIEW, see the Where Should I Start? section at the end of this 
chapter. 

G Programming
G is the easy to use graphical data flow programming language on wh
BridgeVIEW is based. G simplifies scientific computation, process 
monitoring and control, and test and measurement applications, and y
also can use it for a wide variety of other applications.

G was first introduced by National Instruments as the programming 
language behind LabVIEW, the program development application use
commonly for test and measurement purposes. BridgeVIEW has take
the functionality of G and enhanced it for your industrial automation nee

The G Tutorial section of this manual covers the functionality of G that yo
need to get started with most BridgeVIEW applications. For a more 
extensive explanation of BridgeVIEW functionality, see the 
G Programming Reference Manual. 

The basic concepts of G that are covered in this manual are as follow

• VIs—Virtual instruments (VIs) have three main parts: the front pan
the block diagram, and the icon/connector. The front panel specifi
the user interface of the VI. The block diagram consists of the 
executable code that you create using nodes, terminals, and wire
With the icon/connector, you can use a VI as a subVI in the block 
diagram of another VI. For more information about VIs, refer to 
Chapter 9, Creating and Customizing VIs.

• Loops and Charts—G has two structures to repeat execution of a 
sub-diagram—the While Loop and the For Loop. Both structures are 
resizable boxes. You place the subdiagram to be repeated inside 
border of the loop structure. The While Loop executes as long as 
value at the conditional terminal is TRUE. The For Loop executes a
number of times. Charts are used to display real-time trend informa
to the operator. For more information about loops and charts, refe
Chapter 10, Loops and Charts. 
BridgeVIEW User Manual 1-4 © National Instruments Corporation
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• Case and Sequence Structures—The Case structure is a conditional 
branching control structure, which executes a subdiagram based 
certain input. A Sequence structure is a program control structure that
executes its subdiagrams in numeric order. For more information 
about Case or Sequence structures, refer to Chapter 11, Case and 
Sequence Structures.

• Attribute Nodes—Attribute nodes are special block diagram nodes tha
you can use to control the appearance and functional characteristi
controls and indicators. For more information about attribute node
refer to Chapter 12, Attribute Nodes. 

• Arrays, Clusters and Graphs—An array is a resizable collection of 
data elements of the same type. A cluster is a statically sized collection 
of data elements of the same or different types. Graphs commonly
used to display data. For more information about arrays, clusters, 
graphs, refer to Chapter 13, Arrays, Clusters, and Graphs.

• VI Control VIs—A VI Control VI is a front panel object for entering
data to a VI or a subVI. Use VI Control VIs to control window 
behavior (open, close, re-size) of other VIs. For more information 
about VI Control VIs, refer to Chapter 14, VI Control VIs.

Tag Configuration
A tag value is acquired and/or controlled by a device server that 
communicates with the BridgeVIEW Engine and can be read or set by a
in your HMI application. Tags can be of the following types: input, outp
Input/Output, or memory. You can configure tags through the Tag 
Configuration Editor. A tag configuration consists of its data type, 
connection, scaling, operations, and alarms settings. For more informa
about this topic, refer to Chapter 3, Tag Configuration. 

Data Type
A tag data type can be analog, discrete, bit array, or string. Analog tags
have continuous values with a specified range (such as 0.0 to 100.0). 
Discrete tags have values that are either ON (1) or OFF (0). Bit array 
are comprised of up to 32 bits, each of which can have an ON (1) or OFF
state. String tags consist of ASCII characters or binary data and can b
any length.
© National Instruments Corporation 1-5 BridgeVIEW User Manual
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General includes the following tag attributes:

• Tag name

• Tag description

• Tag group

• Length (for bit array and string tags)

Connection
Connection includes the following tag attributes: 

• Access rights (input only, output only, Input/Output, or memory)

• Server name

• I/O group name

• Item name

• Access path (for OPC servers)

Scaling
Scaling controls the type of scaling to perform on a tag when 
communicating with a device server, and the expected engineering ra
and units for the tag.

Operations
You can specify how the BridgeVIEW Engine updates the Real-Time 
Database (RTDB), when it will log the tag data to disk, if it will log events
associated with the tag, and what value exists in the database at startup
operations that can be performed on a tag are as follows:

• Updating the Real-Time Database 

• Historical logging 

• Event logging 

• Event printing
BridgeVIEW User Manual 1-6 © National Instruments Corporation
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Alarms
An alarm is an abnormal process condition. For example, an analog tag
be configured to be in a HI alarm state when its value is greater than 2
You can set alarm limits for a tag in the Tag Configuration Editor. Eac
alarm limit has a priority associated with it to determine the severity of 
alarm.

Events
An event is something that happens within the BridgeVIEW system. 
Events can be divided into two groups, those that pertain to individual t
and those that pertain to the overall BridgeVIEW system. Events pertain
to tags include the following:

• A tag going in or out of alarm

• An operator changing the value of a tag

• An operator acknowledging an alarm

Events pertaining to the system include the following: 

• The launching or shutting down of the Engine

• A new operator logging on

• An error from a server

The Engine also maintains alarm summary and event history informat
pertaining to tags. This information can be viewed by the user’s HMI 
and/or be logged to disk.

Historical Data Logging and Extraction
You can extract data from the historical database to view the trend of 
data over time. The BridgeVIEW Engine manages logging data to the
Citadel Historical Database. A trend is a view of data over time. Trends can
be real-time (current data) or historical (logged data). You can view log
data with a user interface (HMI) or with the Historical Trend Viewer 
(HTV). For more information about historical data logging and extracti
or the Citadel Historical Database, see Chapter 6, Historical Data Logging 
and Extraction, or Appendix B, Citadel and Open Database Connectivity. 
© National Instruments Corporation 1-7 BridgeVIEW User Manual
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Security
Environment security is built into BridgeVIEW and determines access
certain parts of the BridgeVIEW environment. BridgeVIEW security is 
broken into two general categories: 

• BridgeVIEW Environment Access Privileges

• Operator Interface Security

What Is the BridgeVIEW System Architecture?
The BridgeVIEW system contains three sets of processes: the user H
Application, the BridgeVIEW Engine, and industrial automation device
servers, as shown in Figure 1-1. These processes interact through a 
client-server relationship.

 

Figure 1-1.  BridgeVIEW Architecture

The BridgeVIEW Engine, with any device servers, runs as a separate 
process independent of your HMI application. Your HMI application is 
built as a collection of VIs developed using the G programming langua

BridgeVIEW maintains a high performance Real-Time Database in 
the BridgeVIEW Engine that provides information to client applications
The BridgeVIEW Engine also performs other functions including the 
following:

• Data acquisition, engineering unit (EU) scaling, and alarm process

• Alarm and event logging

• Historical data collection and trending

Tags

• EU Scaling

• Alarming

• Event/Alarm Logging

• Trending

PLC DAQ OPC Other (including DDE)

HMIs

Real-Time Database

Servers

VIs

BridgeVIEW
Engine
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EU scaling converts the Raw Range value from the device server to th
engineering value used in the user application and vice versa. 

User HMI Application
The end user of the BridgeVIEW system sees and interacts with an H
The HMI application is a collection of VIs that you build with the 
G programming language in BridgeVIEW. You build VIs that interact wi
the BridgeVIEW Engine to read and write tag values, acknowledge alar
access historical data, and read and write tag attributes.

BridgeVIEW makes development of operator graphic displays easy an
fast. Floating palettes provide controls and functions necessary to dev
effective HMI and SCADA applications. The Controls palette provides
number of predefined objects, selected from the automation symbol libr
for building your HMI. The Functions palette provides a set of function
and VIs you can use for I/O, analysis, historical data, and networking.

BridgeVIEW Engine
The BridgeVIEW Engine is the heart of the BridgeVIEW System. It runs a
a separate process, independent of your HMI application. This minimi
interference between the Engine and your HMI. The BridgeVIEW Engi
maintains the Real-Time Database of all tag values and alarm states. 
reads values from the various device servers. These values are scale
compared with their alarm limits. If a tag is in an alarm state, the Engin
generates appropriate events and logs them to disk.

The Real-Time Database (RTDB) is an in-memory snapshot of the stat
all tags in the system. If a tag value changes more than its update dead
or its alarm state changes, the RTDB is updated. Along with tag values
RTDB also stores status, date, time, and alarm information. 

Device Servers
A device server is the application that communicates with the I/O devi
such as PLCs and plug-in cards. Several National Instruments device
servers are written to a National Instruments standard client/server 
Application Programming Interface (API) for the BridgeVIEW Engine. 
BridgeVIEW also communicates with OPC and DDE Servers. There a
different servers for different device manufacturers and communicatio
networks.

The device servers that support the BridgeVIEW Engine are stand-alo
programs launched by the BridgeVIEW Engine, and thereafter run in t
© National Instruments Corporation 1-9 BridgeVIEW User Manual
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background, reading selected input items and writing them on demand
Each server either is configured by BridgeVIEW when tags are created
has a specific configuration utility that determines communication 
parameters, I/O poll rates, and device addresses. A server completes
operation only when the BridgeVIEW Engine shuts down. 

Input items are polled at a rate determined by the BridgeVIEW I/O gro
configuration. For each input item, the device server passes the value
timestamp of when the item was sampled, and status information to th
BridgeVIEW Engine. Output items are written on demand only when th
BridgeVIEW Engine passes a new output value to the server.

The device server monitors the items and encapsulates all device- an
hardware-specific details, thereby providing a hardware- and 
software-independent layer to the user HMI and SCADA application. F
more information about device servers, see Chapter 8, Servers.

Where Should I Start?
We recommend that you work through the activities in this manual. Th
activities comprehensively illustrate how BridgeVIEW works. If you are
new to the G programming language, begin with the activities in 
Chapters 9 through 15, and then continue with those in Chapters 2 
through 8. If you are an experienced G programmer, begin with Chapt
and continue through the entire manual so that you might learn the 
important BridgeVIEW concepts, and review any G programming 
techniques that you might be familiar with already. 

Save all of the VIs you create with the BridgeVIEW activities in the 
BridgeVIEW\Tutorial  directory. There is also a Solutions directory 
(BridgeVIEW\Tutorial\Solutions ) that contains the completed VIs 
for each activity in this manual. You can view the VI for an activity that
you have not completed yet, or use the VIs in this directory as a mean
verifying your work. 

Another good place to start is the Examples  directory. Use the VI called 
readme.vi , at the top level of this directory, to browse through the 
available examples. 

If you are going to use device servers, read Chapter 8, Servers, which 
contains very important information about servers. If you are going to 
develop device servers of your own, use the BridgeVIEW Device Serv
Toolkit. 
BridgeVIEW User Manual 1-10 © National Instruments Corporation
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This chapter describes the BridgeVIEW environment. It explains the ba
concepts behind G, the programming language upon which BridgeVIEW
built, the BridgeVIEW Engine Manager, system errors and events, the 
Monitor utility, and the Tag Browser utility. This chapter also explains ho
to access online help for BridgeVIEW and provides an activity that 
illustrates how to examine the front panel and block diagram of a virtu
instrument (VI).

What Is G?
G is a programming language, much like various commercial C or BAS
development languages. However, G is different from those application
one important respect. Other programming languages are text-based 
languages that create lines of code, while G is a graphical programmin
language that creates programs in block diagram form.

You can use G with little programming experience. G engineers and 
programmers rely on graphical symbols and data flow rather than textual 
language to describe programming actions. Data flow is a programmin
system in which nodes execute when they have received all required i
data, and produce output automatically when they have executed.

G has extensive libraries of functions and subroutines for most 
programming tasks. BridgeVIEW includes conventional program 
development tools for G, so you can set breakpoints, animate program
execution to see how data passes through the program, and single-st
through the diagram to make debugging and program development ea
dgeVIEW User Manual
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How Does G Work?
G includes libraries of functions and development tools designed 
specifically for MMI development, data acquisition, and instrument 
control. G programs are called virtual instruments (VIs) because their 
appearance and operation imitate actual instruments. However, they a
analogous to functions in conventional programming languages. 

Virtual Instruments
VIs have both an interactive user interface and a source code equival
and accept parameters from higher-level VIs. VIs have three main par

• The front panel

• The block diagram 

• The icon/connector

With these features, G promotes and adheres to the concept of modu
programming. You divide an application into a series of tasks, which y
can divide again until a complicated application becomes a series of sim
subtasks. You build a VI to accomplish each subtask and then combin
those VIs on another block diagram to accomplish the larger task. Fina
your top-level VI contains a collection of subVIs that represent applicat
functions. 

Because you can execute each subVI by itself, apart from the rest of t
application, debugging is much easier. Furthermore, many low-level 
subVIs often perform tasks common to several applications, so you ca
develop a specialized set of subVIs and re-use them in different 
applications.

For more information about VIs, see Chapter 9, Creating and 
Customizing VIs, in this manual, or refer to the G Programming Reference 
Manual. 

Front Panel
VIs contain an interactive user interface, which is called the front panel, 
because it simulates the panel of a physical device. The front panel ca
contain knobs, push buttons, graphs, and other controls and indicators.
input data using a keyboard, mouse, touch screen, or other device and
view the results on the computer screen.
BridgeVIEW User Manual 2-2 © National Instruments Corporation
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The front panel contains a toolbar of command buttons and status 
indicators that you use for running and debugging VIs. It also contains 
options and alignment and distribution options for editing VIs. Pictures
the Front Panel toolbar, and its buttons, are shown below.

 

Run button—Runs the VI.

Continuous Run button—Runs the VI over and over; useful for 
debugging.

Stop button—Aborts VI execution.

Pause/Continue button—Pauses VI execution/Continues VI execution.

Font ring—Sets font options, including font type, size, style, and color

Alignment ring —Sets alignment options, including vertical, top edge, le
and so on, for two or more objects.

Distribution ring —Sets distribution options, including gaps, 
compression, and so on, for two or more objects.

Block Diagram
VIs are executed from a block diagram, which you construct in G. The 
block diagram supplies a pictorial solution to a programming problem. T
block diagram contains the source code for the VI. 

The block diagram toolbar contains additional options that are not inclu
on the front panel toolbar. Use these additional options for debugging V
The block diagram toolbar is shown below.
© National Instruments Corporation 2-3 BridgeVIEW User Manual
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Highlight Execution button—Displays data as it passes through wires.

Step Into button—Steps into loops, subVIs, and so on. 

Step Over button—Begins single stepping, steps over a loop, subVI, a
so on. 

Step Out button—Completes execution of loops, VIs, block diagrams, a
so on. 

Icon/Connector
VIs use a hierarchical and modular structure. You can use them as top-
programs, or as subprograms within other programs. A VI within anoth
VI is called a subVI. The icon/connector pane of a VI works like a graphi
parameter list so that other VIs can pass data to it as a subVI.

Tools Palette
BridgeVIEW has a floating Tools palette, which you can use to edit and 
debug VIs. You use the <Tab> key to tab through the commonly used t
on the palette. If you have closed the Tools palette, select Windows»Show 
Tools Palette to display the palette. A shortcut for bringing up the Tools 
palette is to right click while pressing the <Shift> key. The following 
illustration shows the Tools palette.

Operating tool—Places Controls and Functions palette items on the front 
panel and block diagram.

Positioning tool—Positions, resizes, and selects objects.

Labeling tool—Edits text and creates free labels.

Wiring tool—Wires objects together in the block diagram.
BridgeVIEW User Manual 2-4 © National Instruments Corporation
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Object pop-up menu tool—Brings up a pop-up menu for an object.

Scroll tool—Scrolls through the window without using the scrollbars.

Breakpoint tool—Sets breakpoints on VIs, functions, loops, sequences,
cases.

Probe tool—Creates probes on wires.

Color Copy tool—Copies colors for pasting with the Color tool.

Color tool—Sets foreground and background colors.

Note: You can pop up on an object by clicking on it with the right mouse button. 

Controls Palette
The Controls palette consists of a graphical, floating palette that opens
when you launch BridgeVIEW. You use this palette to place controls a
indicators on the front panel of a VI. Each top-level icon contains 
subpalettes. If the Controls palette is not visible, you can open it by 
selecting Windows»Show Controls Palette from the front panel menu. 
You also can right-click, or pop up, on an open area in the front panel to
access a temporary copy of the Controls palette. The Controls palette is 
available only when the front panel is the active window. The following
illustration displays the top-level of the Controls palette.
© National Instruments Corporation 2-5 BridgeVIEW User Manual
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Functions Palette
The Functions palette consists of a graphical, floating palette that open
automatically when you switch to the block diagram. You use this pale
to place nodes (constants, indicators, VIs, and so on) on the block diag
of a VI. Each top-level icon contains subpalettes.

If the Functions palette is not visible, you can select Windows»Show 
Functions Palette from the block diagram menu to display it. You can als
pop up on an open area in the block diagram to access the Functions 
palette. The Functions palette is available only when the block diagram 
the active window. The following illustration displays the top-level of th
Functions palette.

 

Controls and Indicators
Controls and indicators in G are similar to input and output parameters o
graphs in traditional programming languages. BridgeVIEW contains a
variety of controls and indicators that you can choose according to the 
of values or quantities you want to evaluate or display. 

You can configure all the controls and indicators using options from th
pop-up menus. Popping up on individual components of controls and 
indicators displays menus for customizing those components. An easy
to access the pop-up menu is to click the right mouse button on any ob
that has a pop-up menu. 

The primary data types you will use in BridgeVIEW applications are 
numeric, Boolean, string, and tag, and are described in detail in the 
following sections. 
BridgeVIEW User Manual 2-6 © National Instruments Corporation
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Numeric
You use numeric controls to enter numeric quantities, while numeric 
indicators display numeric quantities. The two most commonly used 
numeric objects are the digital control and the digital indicator, shown 
below. You can find these controls and indicators in the Numeric 
subpalette of the Controls palette.

Boolean
You use Boolean controls and indicators for entering and displaying 
Boolean (TRUE/FALSE) values. Boolean objects simulate switches, 
buttons, and LEDs. The most commonly used Boolean objects are the
vertical switch and the round LED, shown below, found in the Boolean 
subpalette.

String
You use string controls and indicators for entering and displaying ASC
characters. You can use strings for simple text messages displayed to
user and for character streams sent to serial devices, instruments, or 

Digital Control

Digital Indicator

Label

Increment Buttons

Label
© National Instruments Corporation 2-7 BridgeVIEW User Manual
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You can find the string control and indicator in Controls»String Table 
Tags. You can enter or change text inside a string control using the 
Operating tool or the Labeling tool. Enlarge string controls and indicat
by dragging a corner with the Positioning tool.

If you want to minimize space that a front panel string control or indica
occupies, select Show»Scrollbar. If this option is dimmed, you must 
increase the vertical size of the window to make it available.

Tag
You use tag controls and indicators for entering and displaying tag na
or group names contained in the loaded tag configuration (.scf ) file. You 
can find tag controls and indicators in Controls»String Table Tags. For 
more information about the tag data type, see the section Tag Data Type, in 
Chapter 4, Human Machine Interface. 

Activity 2-1. Open and Run a VI
Your objective is to familiarize yourself with the basic concepts of virtua
instruments. You will open, examine, and operate the front panel and 
block diagram of a VI.

1. Select File»Open, and open Tank Simulation.vi  from the 
BridgeVIEW\Examples\G Examples\Apps\tankmntr.llb . The 
front panel appears as shown in the following illustration.
BridgeVIEW User Manual 2-8 © National Instruments Corporation



Chapter 2 BridgeVIEW Environment

nd 
g 
ss 
d, 

ow 
2. Run the VI by clicking on the Run button in the toolbar. The button 
changes appearance to indicate that the VI is running. 

3. Use the Operating tool to change the values of the Inflow Rates a
other controls. First, highlight the old value, either by double-clickin
on the value you want to change, or by clicking and dragging acro
the value with the Labeling tool. When the initial value is highlighte
type a new value and press <Enter>. You also can click on the Enter 
button in the toolbar, or click the mouse in an open area of the wind
to enter the new value.

4. Stop the VI by clicking on the Stop button.

5. Open the block diagram of the Tank Simulator VI by choosing 
Windows»Show Diagram. 
© National Instruments Corporation 2-9 BridgeVIEW User Manual
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The following illustration shows the block diagram. 

6. Examine the different objects in the block diagram. 

Every front panel in BridgeVIEW has an accompanying block diagram
which is the VI equivalent of a program. You can think of the block 
diagram as source code. The components of the block diagram repres
program nodes such as For Loops, Case structures, and multiplication
functions. The components are wired together to show the flow of data
within the block diagram. 

The outermost structure in this diagram is the While Loop. It continues
run until the power switch is turned off. The objects inside the loop inclu
functions and subVIs that generate simulated data that is displayed on
historical trends and other objects on the front panel.
BridgeVIEW User Manual 2-10 © National Instruments Corporation
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At this point, you do not need to understand all of the structures and ob
completely. Chapters9 through15 of this manual describe in greater deta
each element that appears in a VI.

7. Close the VI.

End of Activity 2-1.

BridgeVIEW Environment Project Menu
The BridgeVIEW system is comprised of the G programming language 
a collection of software tools designed specifically for industrial 
automation applications. You can access these tools through the Project 
menu in your BridgeVIEW system. Table2-1 provides a brief description 
of the items in the Project menu.

Table 2-1.     BridgeVIEW Project Menu Items

Project Menu Item Description

Historical Trend Viewer Launches the Historical Trend Viewer (HTV). You can use the 
HTV to view historical data that has been logged in the Citadel
Historical Database. For more information about the HTV, see
Chapter 6, Historical Data Logging and Extraction. 

Launch Engine Launches the BridgeVIEW Engine. The BridgeVIEW Engine 
manages the Real-Time Database, communicates with device
servers, and performs alarm management and historical data 
logging. The BridgeVIEW Engine runs according to a 
configuration file called a .scf  (SCADA Configuration File) file. 
You can create and edit .scf  files using the Tag Configuration 
Editor. For more information about the BridgeVIEW Engine, se
the section What Is the BridgeVIEW Engine Manager? in this 
chapter.

Security»Access Levels Opens a utility you can use to add, remove, and modify access
levels in your BridgeVIEW system. If user accounts are defined
your system, you must have Administration privileges to edit th
list of access levels. For more information about security and 
access levels, see Chapter 7, Advanced Application Topics.
© National Instruments Corporation 2-11 BridgeVIEW User Manual
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Security»Change Password Opens a dialog box to change the current user’s password. Yo
must be logged in to change your password. For more informat
about security and passwords, see Chapter 7, Advanced 
Application Topics.

Security»Edit User Accounts Opens a utility you can use to create and edit user accounts in y
BridgeVIEW system. If user accounts are defined in your syste
you must have Administration privileges to create and edit use
accounts. For more information about security and user accoun
see Chapter 7, Advanced Application Topics.

Security»Login Opens a dialog box you can use to log in to the system. For m
information about security, see Chapter 7, Advanced Application 
Topics.

Security»Logout Opens a dialog box you can use to log out of the system. For m
information about security, see Chapter 7, Advanced Application 
Topics.

Security»Privileges Opens a utility you can use to view your access privileges. For
more information about security and access levels, see Chapter 7, 
Advanced Application Topics.

Server Tools»Server BrowserLaunches the Server Browser. You can use the Server Browse
view information about the BridgeVIEW device servers. For mor
information about the Server Browser, see Chapter 8, Servers.

Tag»Browser Launches the Tag Browser. You can use the Tag Browser to vi
information on all of the tags in the currently-loaded .scf  file. If 
the BridgeVIEW Engine is not running, you can use the Tag 
Browser to load a different .scf  file. For more information about 
the Tag Browser, see the section What Is the Tag Browser? in this 
chapter.

Table 2-1.     BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
BridgeVIEW User Manual 2-12 © National Instruments Corporation
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What Is the BridgeVIEW Engine Manager?
When you run any G application that accesses the BridgeVIEW Real-T
Database, the BridgeVIEW Engine launches automatically, opening ei
the tag configuration (.scf ) file that you edited most recently or the one
that your application has selected programmatically.

Launching the BridgeVIEW Engine brings up the Engine Manager 
Display, shown in Figure2-1. The Engine Manager is a window into the 
BridgeVIEW Engine, through which you can control some of the behav
of the BridgeVIEW Engine.

Figure 2-1.  Engine Manager Display

Table2-2 provides a description of each of the fields in the Engine 
Manager dialog box. This table provides basic information about the 
Engine Manager dialog box options. For a more complete understandin
how or why you might use the Engine Manager in a BridgeVIEW 

Tag»Configuration Launches the Tag Configuration Editor. You can use the Tag 
Configuration Editor to define all of the tags in your BridgeVIEW
system. Also, you can configure other Engine parameters in th
Tag Configuration Editor. For more information about the Tag 
Configuration Editor, see Chapter 3, Tag Configuration.

Tag»Monitor Launches the Tag Monitor. You can use the Tag Monitor to 
monitor the value, alarm state, and status of all tags in the syst
The Tag Monitor launches the BridgeVIEW Engine if it is not 
already running. For more information on the Tag Monitor, see t
section What Is the Tag Monitor? in this chapter.

Table 2-1.     BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
© National Instruments Corporation 2-13 BridgeVIEW User Manual
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application, you must understand how to configure tags. See Chapter 3, 
Tag Configuration. 

Table 2-2.     Engine Manager Field Descriptions

Field Description

Engine Status Displays the current status of the BridgeVIEW Engine—whether launchin
running, or stopped. 

Log Historical 
Data

Turns on or off logging of historical data to file. This button is pressed 
automatically if you selected Start logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, or 
not have a printer configured, this checkbox is disabled. 

Log Events Turns on or off logging of alarms and events to file. This button is presse
automatically if you selected Start event logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, thi
checkbox is disabled.

Print Events Turns on or off printing of alarms and events to your line printer. This butt
is pressed automatically if you selected Start printing on system start-up in 
your configuration file. If you do not have a printer configured, this checkb
is disabled.

Run/Stop Engine Starts the BridgeVIEW Engine, or stops the BridgeVIEW Engine and shu
down any loaded servers. 

Quit Engine Closes and exits the BridgeVIEW Engine process. 

Enable Error 
Dialog

Enables or disables the showing of the Error dialog box. If this box is check
a System Error Display dialog box pops up for you to acknowledge the ev
when a system error occurs. 

Server Browser Launches the Server Browser Utility. With this utility, you can see the serv
in your system, including OPC servers; view server information; and disp
the server front panel if the server is running (VI-based servers only).

Show/Hide 
System Event 
Display

Shows or hides the System Event Display.
BridgeVIEW User Manual 2-14 © National Instruments Corporation
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The Engine Manager shows the current state of the Engine, and has a
System Event Display that shows the following:

• BridgeVIEW System Events 

• When the Engine started and stopped 

• Which servers have been launched 

• Any System Errors that have occurred 

This information is written to the current BridgeVIEW System Log File
found in the BridgeVIEW\Syslog  folder. Figure2-2 shows how the 
Engine Manager Display looks when the Show System Events Display 
button is enabled.

Figure 2-2.  Engine Manager with System Events Displayed

Once the BridgeVIEW Engine is launched and running, the Engine 
Manager is minimized and appears in your Windows taskbar. Click on
BridgeVIEW Engine icon in your taskbar to bring up the Engine Manag
Display.

You can leave the BridgeVIEW Engine Manager Display minimized 
unless you need to start or stop the Engine, or start or stop historical 
logging, event logging and printing, view system events, or view serve
information.

From the Engine Manager, you can reach the Server Browser Utility, 
shown below, by pressing the Server Browser… button. With this 
utility, you can see the servers in your system, view server information
© National Instruments Corporation 2-15 BridgeVIEW User Manual
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and display the server front panel if the server is running (VI-based 
servers only).

The Server Browser is shown in the following illustration. For more 
information about device servers, see Chapter 8, Servers.

 

The Show Server User Interface button appears on the Server Browser
dialog box only when you invoke the Server Browser from the Engine 
Manager. 

If your application does not shut down within a few seconds after you cl
the BridgeVIEW Engine Manager, BridgeVIEW displays a dialog box 
notifying you to shut down your MMI application. You can ensure that 
your application shuts down when the Engine shuts down by monitorin
the shutdown output of any Tags or Alarms VI or the Engine Status VI 
your diagram. This technique is explained in Chapter 4, Human Machine 
Interface.

What Are System Errors and Events?
System errors are conditions on a system level (as opposed to a per tag
basis) that result in problematic functioning of the BridgeVIEW system
When a system error occurs, BridgeVIEW prompts the user with a dia
box. You can turn this dialog box on or off.

System events are changes in the system that cause a change in behavio
is not problematic. These include events reported by utilities such as t
Tag Configuration Editor.
BridgeVIEW User Manual 2-16 © National Instruments Corporation
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Detailed system error and event messages are logged to a system log
The messages are written to an ASCII file with a .log  extension in the 
SYSLOG directory. BridgeVIEW automatically creates this directory, if it
does not exist already. The system log file names take the format, 
YYMMDDHHMM.log where YY = year, MM = month, DD = day, HH= hour, and 
MM = minute.

What Is the Tag Browser?
With the Tag Browser utility, shown in Figure2-3, you can view the 
general configuration of all configured tags in the system. Launch the 
Browser by selecting Project»Tag»Browser. 

A list of all the configured tags appears in the listbox. Select a tag by 
clicking on it, and the configuration for that tag displays on the right. F
more detailed tag configuration information or to learn how to edit a ta
configuration, see Chapter 3, Tag Configuration.

Figure 2-3.  Tag Browser Utility
© National Instruments Corporation 2-17 BridgeVIEW User Manual
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Table2-3 describes each of the fields in the Tag Browser Utility 
dialog box. 

Table 2-3.     Tag Browser Field Descriptions

Field Description

Configuration 
File

Displays the name of the configuration file that you are browsing.

Browse If the BridgeVIEW Engine is not running, press this button to select a differen
configuration file.

Location Displays the full path of the directory containing the configuration file that you
are browsing.

Engine Status Displays the current state of the BridgeVIEW Engine, whether it is loaded, 
running or stopped.

Configured 
Tags

Displays the list of all tags currently configured. Click on a tag to display the 
configuration on the right. 

Name Displays the name of the currently selected tag. Use this display to select and
the tag name and paste it into your MMI diagram.

Description Displays the description field for the currently selected tag.

Type Displays the type of the currently selected tag: analog, discrete bit array, or st

Access Displays the access rights for the currently selected tag: Memory, Input, Out
or Input/Output.

Group Displays the group to which the selected tag belongs. If this field is blank, the
does not belong to a group.

Server Displays the name of the server that is connected to the currently selected ta
If the tag is a memory tag, no server is associated with it.

I/O Group Displays the name of the I/O group for the currently selected tag. If the tag is
memory tag, no server or I/O group is associated with it.

Item Displays the name of the item connected to the selected tag. If the tag is a me
tag, no server, I/O group, or item is associated with it.
BridgeVIEW User Manual 2-18 © National Instruments Corporation
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If the BridgeVIEW Engine is loaded, you can view the tags currently 
loaded with the Tag Browser. If the BridgeVIEW Engine is not loaded, t
Tag Browser displays the currently loaded .scf  file. Use the Browse… 
button to change the .scf  file.

The Tag Browser is a useful tool if you need to look at how a tag is 
configured while you are building your MMI VIs. You also can use the T
Browser to change the loaded configuration file.

If you want to access the configuration information for a tag 
programmatically, you can use the VIs in the Tag Attributes  palette. For 
more information about the Tag Attributes VIs, refer to Appendix A, HMI 
Function Reference.

Alarms 
Enabled

Displays whether alarms are enabled for the selected tag. 

Auto Ack Displays whether alarms for the selected tag are acknowledged automatical

Full Scale Displays the full scale engineering value for the tag. This is displayed for ana
tags only.

Zero Scale Displays the zero scale engineering value for the tag. This is displayed for an
tags only.

Units Displays the engineering unit for the tag. This is displayed for analog tags on

Table 2-3.     Tag Browser Field Descriptions (Continued)

Field Description
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What Is the Tag Monitor?
With the Tag Monitor, you can monitor the value, unit, timestamp, alar
state, and status for selected tags in the system. You launch the Tag Mo
by selecting Project»Tag»Monitor. When you first launch the Tag 
Monitor, a tag selection dialog box displays all the tags configured in t
currently selected tag configuration file. For more information about 
configuring tags, refer to Chapter 3, Tag Configuration. Figure2-4 shows 
the Tag Monitor. 

Figure 2-4.  Tag Monitor Utility

Note: Selecting the Tag Monitor from the Project menu automatically launches th
BridgeVIEW Engine if it is not running already.

Tag information is shown in a table format, sorted by tag name. When a
has a non-zero tag status, the Status column indicates if the tag statu
Warning  or Error . 
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Each of the fields and captions in the Tag Monitor Utility are described
Table2-4, Tag Monitor Utility Field Descriptions. 

Table 2-4.     Tag Monitor Utility Field Descriptions

Field Descriptions

Tag Display Table Shows information for tags you have selected in alphabetical order. Thi
information includes the value, units, timestamp, status, alarm state and
error, if any.

Trigger Tag Displays which tag, if any, you have selected to trigger refreshing of the T
Display Table. If you have selected a tag to trigger refreshing of the Tag
Display Table, the display refreshes when that tag changes value in the
database, or the monitor timeout period is exceeded, whichever occurs 

Monitor Timeout 
(secs)

Displays the time interval in seconds that the Tag Display Table is 
configured to refresh or update. If no trigger tag is selected, the display
updates at this time interval. Otherwise, the Tag Display Table refreshe
when the tag changes or the timeout interval is exceeded, whichever 
occurs first.

Status Details Brings up the Status Details dialog box, shown in Figure2-5, that displays a 
summary of the status for each tag in the system. Tags that have a war
are highlighted in blue, and tags in error are red. BridgeVIEW provides 
description of the error or warning when possible. Internal codes are 
reported by BridgeVIEW; the Server Code is returned by the server of 
the tag.

Select Tags to 
Monitor

Brings up the Select Tags to Monitor dialog box, shown in Figure2-6, that 
lets you select which tags to monitor and configure how often to refresh 
monitor display. The Available Tags list box shows the tags that are not
displayed in the Tag Display Table. By default, the timeout is set to 
1.00 second. This controls how often the Tag Display Table is refreshed.
default, no tag is selected to trigger a refresh of the Tag Display Table. Se
a tag to trigger a refresh of the Tag Display Table from the Trigger Tag Ri
Then, the Tag Display Table refreshes each time that tag is updated in 
database, or when the timeout interval elapses, whichever occurs first.
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The Status Details dialog box, shown in Figure2-5, displays a summary of 
the status for each tag in the system. For more detailed information ab
this dialog box, see Table2-4, Tag Monitor Utility Field Descriptions. 

Figure 2-5.  Status Details Dialog Box

With the Select Tags to Monitor dialog box, shown in Figure2-6, you can 
select which tags to monitor and configure how often to refresh the mon
display. For more detailed information about this dialog box, see Table2-4, 
Tag Monitor Utility Field Descriptions. 

 

Figure 2-6.  Select Tags to Monitor Dialog Box
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How Do You Access Online Help?
Choose Help»Show Help. When you place one of the tools on a subVI 
node, the Help window shows the icon for the subVI with wires attached
each terminal. The following illustration shows an example of online he
This is the Acknowledge Alarm VI from the Functions»Alarms & Events 
subpalette. 

Simple/Complex Help View
In the Help window, you can specify whether you want to display the 
simple or complex view for block diagram objects. 

Note: When you open the Help window, BridgeVIEW automatically defaults to the
simple help view. 

In simple help view, BridgeVIEW displays only the required and 
recommended inputs for VIs and functions. In complex help view, 
BridgeVIEW displays the required, recommended, and optional inputs
VIs and functions. It also displays the full path name of a VI. To access
simple help view, press the Simple/Complex Diagram Help switch or 
choose Help»Simple Help. 

In the Help window, required inputs appear in bold text, recommended
inputs appear in plain text, and optional inputs appear in gray text. Wh
designing your own VIs, you can specify which inputs are required, 
recommended, or optional by popping up on an input or output on the
© National Instruments Corporation 2-23 BridgeVIEW User Manual
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connector pane and selecting the correct option from the 
This Connection Is submenu.

Links to Online Help Files
In the Help Window, you can click on the Online Help button to access
BridgeVIEW online help as well as help files you have created using a h
compiler. For more information on creating help files, see the section 
Creating Your Own Help Files, in Chapter 1, Introduction to Programming 
in G, in the G Programming Reference Manual.
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This chapter explains tags, the Tag Configuration Editor, and how you 
tags within the BridgeVIEW system. Before you can run a BridgeVIEW
application, you must specify a tag configuration. This chapter also 
includes an activity that illustrates how to use the Tag Configuration Ed

What Is a Tag?
A tag is a connection to a real-world I/O point. The BridgeVIEW system
supports four types of tags: analog, discrete, string, and bit array. You
define and configure tags with the Tag Configuration Editor. You can 
consider a tag to be any piece of data in the Engine. The BridgeVIEW
system can log tag values and calculate alarms automatically, if config
accordingly.

A memory tag is not connected directly to an I/O point. For more 
information about memory tags, see the Connection section later in this 
chapter. 

The BridgeVIEW Engine manages the Real-Time Database (RTDB) wh
contains information about all the tags in the system. The Engine han
the following tasks: 

• Communicates with device servers

• Scales tag values

• Tracks alarms and events associated with tags, system errors and
events

• Logs tag values, alarms, events and system messages to disk
dgeVIEW User Manual
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What Is the Tag Configuration Editor?
The Tag Configuration Editor is a tool that assists you in configuring all 
parameters of the BridgeVIEW Engine. The chief component of this 
configuration is the definition of all tags in the system. Other compone
include Alarm and Event Logging, and Historical Logging. 

To start the Configuration Editor, select Project»Tag»Configuration 
from the menu bar of an open VI. Figure3-1 shows the Tag Configuration 
Editor with tanks.scf  loaded.

Figure 3-1.  Tag Configuration Editor

The Tag Configuration Editor records all tag information and Engine 
parameters and stores this information in a BridgeVIEW Configuration
File with the extension .scf  (SCADA Configuration File) The 
BridgeVIEW Engine reads this file to determine all of the parameters f
execution. With the Tag Configuration Editor, you can specify the 
following:

• Tags used in the system 

• File paths for historical data and event logging 

The .scf  file does not contain any information about the VIs in your HM
In fact, it is not specific to a single user application. Multiple user 
applications can run concurrently as long as they use the same set of
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When you launch the Tag Configuration Editor, the last opened .scf  file 
opens automatically. 

Note: Only one.scf  file can be loaded and running in the BridgeVIEW Engine at 
a time. 

If you edit a .scf  file while the Engine is running, when you select Save 
or Save As… a dialog box prompts you to confirm that you want the 
Engine to shut down and restart with the updated configuration file.

Note: Communication between the BridgeVIEW Engine and any device servers i
stopped temporarily when the Engine shuts down and restarts.

How Do You Create, Edit, or Delete a Tag?
From the main panel of the Configuration Editor, press one of the follow
buttons: Create Analog Tag(s), Create Discrete Tag(s), Create String 
Tag(s), or Create Bit Array Tag(s). A separate window prompts you to 
define a new tag. The tag name must be unique within a given configura
(.scf ) file. Select OK  on the pop-up window when you finish creating th
new tag. The change is not written to disk until you select Save from the 
File menu. For step by step instructions on using the Tag Configuratio
Editor to create a tag, see Activity3-1, later in this chapter.

To edit an existing tag, double-click on the tag name in the main scree
the Tag Configuration Editor, or select the tag name and then press theEdit 
Tag button. To delete an existing tag, select the tag name in the main p
of the Configuration Editor and select Delete Tag.

Note:  If you delete a tag, the tag and its configuration information are removed 
completely from the .scf  file. Once you delete a tag, you lose the 
configuration information pertaining to the tag. You still can retrieve 
historical and event information about the tag, but information such as the ta
description, units, range, and alarm settings is lost.

How Do You Edit Multiple Tags Simultaneously?
Use File»Export to export the tag information to a spreadsheet file, edit t
fields, and then use File»Import  to import the tag configuration 
information from the edited spreadsheet file. For more information, see
section How Do You Use Spreadsheet Files for Tag Configuration? in this 
chapter. 
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How Do You Set Default Values for Tag Configuration Fields?
You can simplify the tag configuration process by defining default valu
for several fields. For example, you might want to set data or event logg
on by default, or have the log deadband set to a particular value by def
You can set default values for tag parameters using the Set Default 
Parameters dialog box, shown below. To access this dialog box, selec
Configure»Default Parameters…. 

The default values apply when creating a new tag, importing a tag from
server registry, or importing a tag from a spreadsheet. In the case of 
spreadsheet, a value in the spreadsheet overrides the default value fo
field. For more information about the individual fields, see the section How 
Do You Configure Tags? in this chapter. 
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How Do You Use Spreadsheet Files for Tag Configuration?
With the Tag Configuration Editor, you can export tag configuration 
information to spreadsheet files, and import tag configuration informat
from spreadsheet files. The files are tab-delimited text (.txt ) files.

Select File»Export to save the file as a tab-delimited .txt  file. When you 
select Export , a dialog box prompts you to select and order the fields y
want in your spreadsheet file. If you intend to edit the spreadsheet file 
then import the edited information back into the Tag Configuration Edit
select the All >>  button to select all available fields. For easy viewing an
editing in the spreadsheet, press the Use Default Order button.

After you have edited the file, save it as a .txt  file. Then, from the Tag 
Configuration Editor, select File»Import  to import the information from 
the spreadsheet file. 

If you use spreadsheet files with the Tag Configuration Editor, it is ver
important that you understand the following points:

• If you do not choose all of the fields when exporting your data, you
will lose configuration information when you import it back to the Ta
Configuration Editor. 

• You might choose to export a subset of information, and then rely
tag default parameters when you import the data back in to the 
Configuration Editor. However, each row in the spreadsheet file m
© National Instruments Corporation 3-5 BridgeVIEW User Manual
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contain the tag name and data type fields, or the import mechanis
cannot read it. 

• Some configuration parameters, such as Historical Logging 
Configuration and Event Configuration, are inherited from the 
currently open .scf  file when you import spreadsheet data.

Note: If the tag name and data type fields are missing, the File»Import  option does 
not work on the spreadsheet file. 

For detailed information about the tag attributes you can include in an
spreadsheet you import, see the How Do You Configure Tags? section in 
this chapter.

How Do You Configure Tags?
When you configure a tag with the Tag Configuration Editor, you defin
several attributes for the tag. You can consider these attributes segme
into five categories: general, connection, operations, scaling, and alar
Each of these categories is explained in detail later in this section. 

This section contains five tables that provide descriptions of the attribu
for each of these categories, and indicates the data types to which ea
attribute applies. You can find each of these tables, listed below, in th
General, Connection, Operations, Scaling, and Alarms sections, 
respectively, of this chapter. 

• Table3-1, General Configuration Attributes

• Table3-2, Connection Configuration Attributes

• Table3-4, Operations Configuration Attributes

• Table3-5, Scaling Configuration Attributes

• Table3-7, Alarms Configuration Attributes

If you import tag configuration information from a spreadsheet, your 
spreadsheet should follow the same format as indicated in the Attribut
column of each of the tables listed above. For more information about u
spreadsheets, see the section How Do You Use Spreadsheet Files for Tag
Configuration? in this chapter. 
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Data Type
Configuration of a tag varies slightly depending on the data type. The 
following sections discuss the details of tag configuration for each 
data type.

Analog Tags
An analog tag is a continuous value representation of a connection to a
real-world I/O point or memory variable. This type of tag can vary 
continuously over a range of values within a signal range.

Use an analog tag when you want to express a continuous value (for 
example, 0 to 100).

Discrete Tags
A discrete tag is a two-state (ON/OFF) value representation of a 
connection to a real-world I/O point or memory variable. This type of t
can be either a 1 (TRUE) or a 0 (FALSE).

Use a discrete tag when you want to express a two-state (ON/OFF) v

Bit Array Tags
A bit array tag is a multi-bit value representation of a connection to a 
real-world I/O point or memory variable. This type of tag can be compris
of up to 32 discrete values.

Use a bit array tag when you have a multi-bit value in which each of the 
represents a flag or single value that is turned on or off. The maximum
length of a bit array tag is 32. 

String Tags
A string tag is an ASCII character representation of a connection to a 
real-world I/O point or memory variable.

Use a string tag when you have binary information or an ASCII value. F
instance, you might use a string tag to obtain values from a bar code re
or if you have data that does not fit into any other data type.
© National Instruments Corporation 3-7 BridgeVIEW User Manual
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The general attributes of a tag include the name of the tag your are 
configuring, the group name to use for the tag, a description of the tag,
the maximum length for string and bit array tags. Figure3-2 shows the 
General tab of the Tag Configuration dialog box.

Figure 3-2.  General Attributes Dialog Box
BridgeVIEW User Manual 3-8 © National Instruments Corporation
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Table3-1 provides descriptions of the general attributes of a tag. For ta
attribute information about the other configuration categories, see 
Tables3-2, 3-4, 3-5, and3-7.

 
Table 3-1.     General Configuration Attributes

Attribute
Applies to 
Data Types

 
Description

 Tag Name all Determines the name of the tag you are configuring. Always re
to a tag by its name. Tag names are not case sensitive and c
include any combination of printable characters (including 
space) with the exception of “/” (forward slash) and “\” 
(backslash). 

Tag Group all Determines the group name to use for this tag. You can use 
groups to assist in alarm management and reporting and to h
organize tags in an application. 

Tag 
Description

all Provides a description of the tag. 

Maximum 
Length

string, 
bit array

Determines the maximum number of bits in the bit array. The 
length is between 1 and 32 for bit array tags. String tags can 
of any length.
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Connection
You associate a tag with its real-world I/O point by assigning it a Server, 
I/O Group , and Item in the Connection tab of the Tag Configuration 
dialog box, shown in Figure3-3. If an I/O Group does not already exist fo
the server, you must create one before you can select or enter an item
the tag. The I/O Group is user-defined and provides you with a place t
configure the rate and deadband for an item. For IAK and VI-based serv
you select the device as part of the I/O group configuration. For OPC 
servers, the I/O group conforms to an OPC group.

When you edit a tag, use the ring inputs to assign values to the tag. For 
information about device servers, see Chapter 8, Servers. Use the Create, 
Edit , and Delete buttons to configure I/O Groups and Items. 

 

Figure 3-3.  Tag Connection Dialog Box

If a device server does not appear in the server name list, you must ru
configuration or registration utility for your server before BridgeVIEW ca
access the server.
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Table3-2 provides descriptions of the connection attributes, and indica
the data types to which each attribute applies. For tag attribute informa
about the other configuration categories, see Tables3-1, 3-4, 3-5, or3-7.

 
Table 3-2.     Connection Configuration Attributes

Attribute
Applies to 
Data Types

 
Description

Data Type all Determines the data type of the tag you are configuring. 
BridgeVIEW tags can be analog, discrete, bit array, or string. 

Tag Access all Determines the access rights for a tag. Tags can have acces
rights of Memory, Input only, Output only, or Input/Output. 
Memory tags are not directly connected to real-world I/O point
You can use memory tags to monitor and control calculated 
values and enable historical trending and alarming on these 
values. Input only, Output only, and Input/Output tags are 
connected to real-world I/O points according to the Server, 
Device, and Item fields. 

Server all Determines the device server that manages the communicatio
the tag value. If the tag is a memory tag, this attribute is not us

I/O Group all Determines the I/O Group to use for this tag. Select the I/O Gro
that this tag will use. The I/O Group is associated with the serv
At least one I/O Group must be created for the server in order
configure a tag to use a server’s item. If the tag is a memory t
this attribute is not used.

Item Name 
Filter

all Determines the string to filter the list of configured items. If th
tag is a memory tag, this attribute is not used.

Item all Determines the register, channel, or item on the device for thi
tag. This might be a PLC register, a data acquisition channel,
OPC item ID, or a DDE item, depending on the server used fo
this tag. If the tag is a memory tag, this field is not used.

Access Path all Determines the access path for the selected server. If the tag
memory tag or if the server does not have access paths, this 
attribute is not used.
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I/O Group Configuration
I/O Groups are used to configure item rate and deadband for items of
server and to select a specific device, if the server uses devices. For se
that support resource configuration, you also can use I/O groups to 
configure devices and communication resources. For OPC servers, an
group conforms to the concept of an OPC group, which is user-defined
controls timing. An I/O Group is associated with only one server and, if t
server uses devices, with only one device. A server can have multiple
Groups associated with it. 

The following section provides descriptions of the operations that can 
performed on an I/O Group.

I/O Group Configuration Options
The Create… button invokes the I/O Group Configuration dialog box, 
which you can use to specify group name and timing parameters. For
servers that support resource configuration, you also can use this dialog
to select and configure devices and to configure communication resou

The Edit…  button invokes the I/O Group Configuration dialog box for th
I/O Group selected in the I/O Group list. Use this dialog box to change
group name and timing parameters. For servers that support resource
configuration, you also can use this dialog box to select and configure
devices and to configure communication resources.

The Delete button invokes a confirmation dialog box. If confirmed, the I/O
Group is deleted from the server configuration. Deleting an I/O Group d
not delete the device and communication resource from the server 
configuration.
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Figure 3-4.  I/O Group Configuration Dialog Box

Table3-3 provides descriptions of the operations that can be performed
an I/O Group.

 
Table 3-3.     I/O Group Configuration Attributes

Attribute
 

Description

I/O Group Name Determines the name of the I/O Group you are configuring. I/O Gro
names are not case sensitive and can include any combination of
printable characters (including spaces) with the exception of “/” 
and “\”.

I/O Group Description Provides a description for the I/O Group.

I/O Group
Update Rate (secs)

Determines the rate for the server to update the item value in the 
engine for all tags using the I/O Group. The server can have other
configuration options that determine the actual update rate. This is
rate at which BridgeVIEW requests that all tags configured with th
update rate be updated.
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Server Configuration Options
Use this group of fields to configure and select server resources. Som
all of the fields in this group might not be used depending on the serve
type. An IAK server will have both the Device and Communication 
Resource configuration capabilities. The following sections provide 
information on configuration options for communication resources and
devices. 

Communication Resource Configuration Options
For IAK servers, use the Create… button to invoke a new, untitled IAK 
Create Communication Resource Configuration dialog box. This 
configuration option is not used for other classes of servers.

For IAK servers, use the Edit…  button to invoke the IAK Edit 
Communication Resource dialog box for the currently selected 
communication resource. This configuration option is not used for othe
classes of servers.

I/O Group Deadband
(% of range)

Determines the deadband for the server to update the item value in
engine for all tags configured with the I/O Group. Use 0% if you do
not want the server to apply deadbands to the item.

Note: Not all servers support deadbands, and some 
might ignore this value.

Server Name Indicates the Server Name associated with the I/O Group you are
configuring.

Communication Resource Provides a means to configure (create, edit, or delete) a 
communication resource. This field is valid only for IAK servers.

I/O Group Device Determines a specific device used by the I/O Group and Server for 
tag. If the associated server is an OPC Server, this attribute is not u

Device Comm Resource Indicates the communication resource associated with the selecte
device. This field is valid only for IAK servers.

Table 3-3.     I/O Group Configuration Attributes (Continued)

Attribute
 

Description
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For IAK servers, use the Delete button to remove the selected 
communication resource from the server configuration. This configurat
option is not used for other classes of servers. 

Device Configuration Options—Configuring Device Names
This option is available for servers that allow users to configure device
names. OPC Servers do not use device names. For DDE Servers, the d
name is used to specify the DDE application and topic. See How Do You 
Connect a Tag to a DDE Server? in this chapter for more information.

The Add… button invokes the Device Entry dialog box, which you can u
to add a new device name for a selected server. If the server does no
support device configuration, or if the selected device name is not vali
this button is disabled.

The Edit…  button invokes the Device Entry dialog box, which you can u
to edit an existing device name for a selected server. If the server doe
support device configuration, or if the selected device name is not vali
this button is disabled.

The Delete button invokes a confirmation dialog box. If confirmed, the 
selected device name is removed from the device list. If the server doe
support device configuration, or if the selected device name is not vali
this button is disabled.

Device Configuration Options—Configuring Device Resources
This option is supported by servers that allow users to configure devic
resources.

Use the Create… button to invoke a new, untitled Create Device 
Configuration dialog box. The options in this dialog box will vary 
depending on the type of server. If the server does not support device
configuration, this button is disabled.

Use the Edit…  button to invoke the Edit Device Configuration dialog bo
for the device currently selected in the device list. The options in this dia
box will vary depending on the type of server. If the server does not sup
device configuration, this button is disabled.

Use the Delete button to remove the selected device from the server 
configuration. If the server does not support device configuration, this 
button is disabled.
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Item Configuration
Use the Item Connection fields in the Connection tab (see Figure3-3) to 
select and configure the item and access path (for certain OPC Serve
only) for a tag. The following section describes the operations that can
performed on an I/O Group.

Item Configuration Options—Configuring Item Names
This option is available for servers that allow users to configure 
item names.

The Add… button invokes the Item Entry dialog box, which you can us
to add a new item for a selected server. If the server has access paths
also can use this dialog box to add an access path. If the server does 
support item configuration, this button is disabled.

The Edit…  button invokes the Item Entry dialog box, which you can us
to edit an existing item name for a selected server. If the server has ac
paths, you also can edit an access path. If the server does not suppor
configuration, or if the selected item is not valid, this button is disabled

The Delete button invokes a confirmation dialog box. If confirmed, the 
selected item is removed from the item list. If the server has access p
the selected access path is removed from the access path list. If the s
does not support item configuration, or if the selected item is not valid, 
button is disabled.

Item Configuration Options—Configuring Item Resources
This option is supported by servers that allow users to configure item 
resources.

The Create… button invokes a server-dependent configuration dialog b
which you can use to configure a new item for a selected server. If the
server does not support item configuration, this button is disabled.

The Edit…  button invokes a server-dependent configuration dialog bo
which you can use to edit the configuration of the selected item. If the 
server does not support item configuration, or if the selected item is no
valid, this button is disabled.

The Delete button invokes a confirmation dialog box. If confirmed, the 
selected item is removed from the server configuration.
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The Browse… button, which only applies to OPC Servers that support 
browsing, invokes the Browse OPC Server dialog box. Use this button
browse the list of available items and select an item and associated 
access path.

What Is a Memory Tag?
Memory tags are not connected directly to I/O points. They exist only in t
BridgeVIEW RTDB. To configure a memory tag, set the Access Rights of 
a tag to Memory.

When Should You Use a Memory Tag?
Use memory tags when you want to perform alarm calculations, or log
historical data and event information on data that is either a 
software-generated value or a combination of values from different I/O
readings. Below are some examples illustrating when to use memory 

Example 1—When Not to Use a Memory Tag
You do not need to use a memory tag for program variables unless yo
want to use the historical and event logging or alarm management 
capabilities of the BridgeVIEW Engine.

An HMI displays the trend of a temperature tag and the difference betw
the current reading and a previous reading to allow operators to see th
current rate of change in the temperature value. Although the individu
values are logged for historical trends, the current difference is not.

You can configure the BridgeVIEW Engine to include the tag reading 
temperature. The block diagram of the HMI reads the tag value and pa
it to a real-time trend indicator. The difference between the current read
and the previous value is calculated in the diagram and passed to a fr
panel numeric indicator. The diagram retains the current temperature v
and uses it after taking the next reading. Because the system does no
to perform any alarm management or historical logging based on the 
difference, no memory tag is used.

Example 2—When to Use a Memory Tag
A simple device server returns several items of data that, through a lin
combination of values, represent a meaningful measurement in enginee
units. The design of the device and its server software makes it difficu
combine these values within the server to make a single tag. The valu
interest is not the individual points but the linear combination of these 
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points. The operators need historical trends and alarm management b
on this single value.

In this situation, you can define a separate tag for each server item an
memory tag with engineering range and units of the final measuremen
the block diagram of the HMI VI, read individual tag values and calcula
the linear combination of values in the diagram. Write the calculated va
to the memory tag in the Real-Time Database and the BridgeVIEW Eng
performs historical logging and alarm calculations according to the 
memory tag configuration.

Note: To learn more about how to build HMI VIs, refer to Chapter 4, Human 
Machine Interface.

How Do You Automatically Generate Tags 
from Server Information? 
Use the Configuration Wizard to create tags from the server informatio
When you run the server configuration utilities for the servers on your 
system, you can define devices and items for the I/O points that the se
monitor and control. You can automatically create tags from these item
with the Configuration Wizard For IAK and VI-based servers, server 
information is read from the Common Configuration Database (CCDB
For OPC servers that support it, server information is read by browsing
server address space.

The Configuration Wizard is useful particularly if you want the 
BridgeVIEW Engine to monitor a large number of the I/O points in you
system. To invoke the Configuration Wizard, press the Configuration 
Wizard  button on the main screen of the Tag Configuration Editor. Fo
more information on servers, see Chapter 8, Servers.

How Do You Connect a Tag to an OPC Server?
You connect to an OPC server just like you connect to the National 
Instruments device servers from the Connection tab of the Tag 
Configuration dialog box. Any OPC servers installed on your machine 
listed in the server name list. Select the OPC server you want to use. C
an I/O Group for the server, specifying the group deadband and update
And select or enter the Item name, which is the same as the OPC Ser
Item ID. You also can select or enter an access path for OPC servers 
server supports that.
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How Do You Connect a Tag to a DDE Server?
Although no BridgeVIEW servers are based on Dynamic Data Exchan
(DDE), you can connect a tag to any existing DDE Server. Select DDE 
Server as your server in the connection tab of the Tag Configuration Ed
to communicate with DDE servers. DDE Servers have an Application 
Name, Topic, and Item. In BridgeVIEW, the device in the I/O Group 
Configuration dialog box is set to appname|topic  (“|” = the “pipe” 
symbol) and the item in the Connection tab of the Tag Configuration dia
box is set to item . For example, to connect a tag to cell R1C1 (item) of 
spreadsheet sheet1  (topic) in Excel (application), set the tag fields to th
following:

Server: DDE Server

Device: Excel|sheet1 (in I/O Group Configuration dialog box)
Item: R1C1

To specify a particular sheet ("sheet one" ) within an open Excel file 
(book1.xls ), set the device field to the following:

Device: Excel|[book1.xls]sheet1 (in I/O Group Configuration
dialog box)

How Do You Define a Group of Tags for Alarming?
While editing a tag, pull down the Tag Group Ring in the General tab of 
Tag Configuration dialog box. You can select an existing tag group or 
define a new tag group by selecting Enter New…. To create, edit, or delete
tag group definitions, select Tag Groups… from the Configure menu 
from the main Configuration Editor panel.

You can use tag groups to help define a subset of tags in the system.
groups are helpful when you want to examine the alarm states for a su
of tags in the system. See Chapter 5, Alarms and Events, for more 
information on alarm groups.
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Operations
The operations attributes include when to update the tag value in the 
RTDB, whether to log data to a historical file, whether to log events 
associated with the tag, and information about the initial value of the ta
Engine startup. Figure3-5 shows the Operations Tab of the Analog Tag
Configuration dialog box. With this section of the dialog box, you can 
inform the BridgeVIEW Engine of what to do with the data in the RTDB

 

Figure 3-5.  Tag Operations Dialog Box

Table3-4 provides descriptions of the operations attributes, and indica
the data types to which each attribute applies. For tag attribute informa
about the other configuration categories, see Tables3-1, 3-2, 3-5, and3-7.
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Table 3-4.     Operations Configuration Attributes

Attribute
Applies to 
Data Types

 
Description

Update 
Deadband

all Determines when the Real-Time Database (RTDB) updates t
value for this tag. It is used to improve system performance a
prevent unnecessary processing of tag values in the RTDB. T
field is expressed differently for analog, discrete, string, and b
array tags. For analog tags, Update Deadband is a percent of
scale. The database updates analog tags only when a new ta
value is different than the currently stored value by at least th
Update Deadband. Use 0% if you want each new value for the 
to be saved in the RTDB. For discrete, string, and bit array ta
Update Deadband is expressed as either Always or On Change.

Log Data analog, 
discrete,
bit array 

Determines whether a tag value is logged to historical files. 

Log Data 
Deadband

analog, 
discrete, 
bit array

Determines when tag values are logged to disk. It is used to 
improve system performance and prevent unnecessary loggin
data to disk. Like Update Deadband, the field is expressed 
differently for analog, discrete, and bit array tags. For analog 
tags, Update Deadband is a percent of full scale. The 
BridgeVIEW Engine writes new analog tag values to historica
files only when a new tag value is different than the last logge
value by at least the Log Data Deadband. Use 0% if you wan
each new value for the tag to be logged. For discrete and bit ar
tags, Update Deadband is expressed as either Always or On 
Change.

Log 
Resolution

analog Determines the resolution in engineering units for logging a ta
value in the Citadel Historical Database. Tag values are writte
to the database in a compressed format with the resolution 
specified by Log Resolution. Use 0.0  if you want the exact value 
written to the Citadel Historical Database. Notice that logging th
exact value requires more time and disk space. The default va
is 0.1 . 

Log/Print 
Events

all Determines whether events associated with the tag (for exam
changes in alarm state) are logged to event log files or printed
a line printer. 
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What Is Deadband?
In process instrumentation, deadband is the range through which an inpu
signal can vary without initiating an observable change in output signa
Deadband usually is expressed in percent of full scale. Although the te
deadband generally applies only to analog tags, other tag types have 
limited type of deadband. A checkbox allows you to determine if upda
to the RTDB and historical data files should occur with any new data fr
the device server or if the value has changed.

Note: The BridgeVIEW Engine performs historical logging and alarm managemen
operations based on new values in the RTDB. If you set the Update Deadba
too high, the RTDB might not be updated. This could result in inadequate 
historical logging or alarm management.

How Do You Use Deadband to Increase Engine 
Throughput?
The BridgeVIEW Engine uses Update Deadband and Log Deadband 
values to eliminate unnecessary processing on minor data value chan
Deadband allows you to define a significant change. The Engine ignore
operation if the change in data is not considered significant. Deadban
expressed as percent of full scale. For example, if the tag engineering r
is 0 to 200 liters, a deadband of 5% is 10 liters. In addition, through I/O
group configuration, you can configure a server to apply a deadband to
items associated with that I/O group. Not all servers implement deadba
OPC servers support deadbands.

Set Initial 
Value

all Determines whether an initial value is used for this tag. If Set 
Initial Value is OFF for this tag, the tag value is marked as 
uninitialized until its value is updated. 

Initial Value all The initial value used for this tag when Set Initial Value is ON. 
the tag is an Output only or Input/Output tag, the BridgeVIEW
Engine sends the Initial Value to the server at Engine startup.
the tag is an Input only or Memory tag, the Initial Value is store
in the RTDB at startup. 

Table 3-4.     Operations Configuration Attributes (Continued)

Attribute
Applies to 
Data Types

 
Description
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How Do You Configure a Tag to Log Its Data 
or Events?
While editing a tag, click on the Log Data or Log/Print Events checkbox. 
If you want to log historical data or events, the BridgeVIEW Engine mu
have these processes enabled. To turn them on, open the Engine Ma
and manually turn on the processes with the panel buttons, or, configur
Engine to turn on these processes automatically at startup. To configur
Engine in this way, pull down the Configure menu from the Tag 
Configuration Editor and select Historical…  or Events…. You also can 
enable these parameters programmatically with System VIs that enab
event or historical data logging.

How Do You Set Initial Tag Value at Startup?
While editing a tag, select the Set Initial Value checkbox. Then enter the
initial value in the adjacent Initial Value  field.

Scaling
These attributes include what type of scaling to perform on a tag when
communicating with the device server and the expected engineering ra
and units for the tag.

Table3-5, provides descriptions of the scaling configuration attributes,
and indicates the data types to which each attribute applies. For tag 
attribute information about the other configuration categories, see 
Tables3-1, 3-2, 3-4, and3-7.
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Table 3-5.     Scaling Configuration Attributes

Attribute
Applies to 
Data Types

 
Description

Raw Full 
Scale

analog Determines the full scale (maximum) value used by the serve
for a tag. 

Raw Zero 
Scale

analog Determines the zero scale (minimum) value used by the serve
for a tag.  

Eng Full 
Scale

analog Determines the full scale (maximum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Full Scale must be greater than Engineering Zer
Scale. 

Eng Zero 
Scale

analog Determines the zero scale (minimum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Zero Scale must be less than Engineering Full Sc

Units analog Determines the engineering units for a tag. Examples include
degrees Celsius, liters, and kilograms. 

Scaling analog, 
discrete, 
bit array

Determines the type of scaling algorithm to be used for a tag.
The scaling methods differ according to tag data type. You ca
configure analog tags to have linear or square root scaling. Y
can configure discrete tags to have invert scaling. You can 
configure bit array tags to have mask scaling. All tags can be 
configured to have no scaling.

Coerce analog Determines whether to coerce data so that it is valid for the targ
If scaling to output, the value must be within the raw (device 
server) range. If scaling to input, the value must be within the
engineering (HMI) range. 
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The next sections explain how to scale data. Often your application ne
BridgeVIEW to manipulate the raw data used in the device server to p
in a form, called engineering units, suitable for the operators. The follow
sections describe the options for individual data types.

Note: There is no scaling for string tags.

Analog Tags
You can define the raw range and engineering range for a tag to perfo
simple conversions between the two ranges. The raw range, defined b
Raw Full Scale and Raw Zero Scale, refers to the values used by the d
server. Engineering range, defined by Engineering Full Scale and 
Engineering Zero Scale, refers to the values used by the BridgeVIEW
Engine and HMI. Pull down the Scaling ring and select Linear  to enable a 
linear (mx + b) conversion between raw and engineering ranges. Selec
Square Root to enable a square root conversion between the raw and 
engineering ranges. Figure3-6 shows the Scaling tab of the Analog Tag 
Configuration dialog box. 

Scaling Invert 
Mask

bit array Determines which bits are inverted for a bit array tag. Bits in th
mask that are 1 are inverted; bits that are 0 are not inverted. The 
default mask is 0, indicating that none of the bits are inverted. In
bit-wise logic terminology, the Engine performs an XOR with th
Invert Mask to produce the scaled value. 

Scaling Select 
Mask

bit array Determines which bits are used for the bit array tag. Bits in th
mask that are 1 have their values passed through to the RTDB
bits that are 0 are set to zero, regardless of the value received 
from the server. In bit-wise logic terminology, the Engine 
performs an AND with the Select Mask to produce the scaled
value. 

Table 3-5.     Scaling Configuration Attributes (Continued)

Attribute
Applies to 
Data Types

 
Description
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Figure 3-6.  Analog Tag Scaling Dialog Box

The following examples describe linear and square root scaling. 

Example—Linear Scaling
A device server returns a simple voltage from 0 to 5 volts. The voltage
related to a position sensor, and the real-world position is measured in
centimeters, with 0 volts mapped to 50 cm and 5 volts mapped to 100

Configure the tag to have raw range from zero (Raw Zero Scale) to fiv
(Raw Full Scale). Select Linear , and set the engineering range from 
50 (Eng Zero Scale) to 100 (Eng Full Scale).

Example—Square Root Scaling
A flow meter measures the flow rate of a liquid using a differential press
reading. The device server provides 4–20 mA readings. The actual flo
measured in gallons per minutes (GPM). 4 mA corresponds to 0 GPM
20 mA corresponds to 100 GPM.

Configure the tag to have raw range from 4 (Raw Zero Scale) to 20 (R
Full Scale). Select Square Root Scaling and set the engineering range 
from 0 (Eng Zero Scale) to 100 (Eng Full Scale). 
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How Do You Assign Units to an Analog Tag?
Use the Engineering Unit  ring to assign units to a tag. If the desired unit 
not in the list, select Enter New… and enter the desired unit. In the 
previous example, you would be able to select units of GPM.

Discrete Tags
The only scaling available for discrete tags is invert scaling. Click the 
Invert Data checkbox, shown in Figure3-7 to advise the BridgeVIEW 
Engine to invert the discrete value when it communicates with the dev
server.

  

Figure 3-7.  Scaling for Discrete Tag Configuration
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Bit Array Tags
Bit array tags can have invert and/or select mask scaling. You can use
invert mask to determine which bits are inverted between the device se
and the BridgeVIEW Engine. You can use the select mask to determine
bits you do not need. Figure3-8 shows the Scaling tab of the Bit Array Tag
Configuration dialog box, and Table3-6 provides examples of tags 
configured for bit array scaling.

 

Figure 3-8.  Scaling for Bit Array Tag Configuration
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Alarms
These attributes include whether to enable alarms, under what 
circumstances a tag is in alarm, the priority level of an alarm, and how
alarms are acknowledged. Each alarm limit has a priority, ranging betw
1 and 15. In BridgeVIEW, 15 is the highest priority and 1 is the lowest

There are two main types of alarms:

• Alarms based on status

• Alarms based on tag values

Configuration for alarms based on tag values is specific to data type. 
Therefore, many alarm attributes apply to only a subset of the BridgeVI
tag data types. For more information about how to access alarm 
information, build alarm summary displays, and retrieve historical eve
files, see Chapter 5, Alarms and Events.

Table 3-6.     Bit Array Scaling Examples

Tag Name Length Raw Value Invert Mask Select Mask Scaled Value

Tag 1 8 0x0F 0x00 0xFF 0x0F

Tag 2 8 0x0F 0x33 0xFF 0x3C

Tag 3 8 0x0F 0x33 0x0F 0x0C

Tag 4 8 0x0F 0x00 0x33 0x30

Tag 5 8 0x0F 0x33 0x33 0x30

Tag 6 16 0x0FF0 0x000F 0x00FF 0x00FF
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Table3-7 provides descriptions of the alarm attributes, and indicates th
data types to which each attribute applies. For tag attribute informatio
about the other configuration categories, see Tables3-1, 3-2, 3-4, or3-5. 

Table 3-7.     Alarms Configuration Attributes 

Attribute
Applies to 
Data Types

 
Description

Alarms 
Enabled

all Determines whether alarms are enabled for a tag. 

Alarm 
Deadband

analog Determines the amount an analog tag value must diverge from
alarm limit before the alarm condition returns to normal. Alarm
Deadband is expressed in percent of full scale. 

Auto Ack all Determines how alarms can be acknowledged. If set to Auto Ac
the alarm is acknowledged automatically when the tag value 
returns to the NORMAL state. If set to User Must Ack, the alarm
will remain unacknowledged until the user acknowledges it, 
regardless of the alarm state. 

Bad Status 
Enabled

all Determines whether to enable Bad Status alarms for the tag.

Bad Status 
Priority

all Determines the value (between 1 and 15) for the alarm priorit
for the Bad Status alarm, where 15 represents the highest prior

HI_HI 
Enabled

analog Determines whether to enable HI_HI alarms for a tag. 

HI_HI Limit analog Determines the value, in engineering units, that invokes a HI_
alarm condition. The tag alarm state remains HI_HI until the ta
value goes below the HI_HI alarm limit minus the alarm 
deadband. 

HI_HI 
Priority

analog Determines the value (between 1 and 15) for the alarm priorit
for the HI_HI alarm, where 15 represents the highest priority. 

HI Enabled analog Determines whether to enable HI alarms for a tag. 

HI Limit analog Determines the value, in engineering units, that invokes a HI 
alarm condition. The tag alarm state remains HI until the tag 
value goes below the HI alarm limit minus the alarm deadban
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HI Priority analog Determines the value (between 1 and 15) for the alarm priorit
for the HI alarm, where 15 represents the highest priority. 

LO Enabled analog Determines whether to enable LO alarms for the tag. 

LO Limit analog Determines the value, in engineering units, that invokes a LO
alarm condition. The tag alarm state remains LO until the tag 
value goes above the LO alarm limit plus the alarm deadband

LO Priority analog Determines the value (between 1 and 15) for the alarm priorit
for the LO alarm, where 15 represents the highest priority. 

LO_LO 
Enabled

analog Determines whether to enable LO_LO alarms for a tag. 

LO_LO Limit analog Determines the value, in engineering units, that invokes a 
LO_LO alarm condition. The tag alarm state remains LO_LO 
until the tag value goes above the LO_LO alarm plus the alar
deadband. 

LO_LO 
Priority

analog Determines the value (between 1 and 15) for the alarm priorit
for the LO alarm, where 15 represents the highest priority. 

Discrete 
Enabled

discrete, 
bit array

Determines whether to enable tag value alarms for discrete a
bit array tags.

Alarm on discrete, 
bit array

Determines whether a discrete tag should be alarm on ON (hig
or OFF (low). Determines whether a bit array goes into alarm
all of its bits are in alarm or if any of its bits are in alarm. This 
field is used only if both Alarms Enabled and Discrete Enable
fields are set to TRUE.

Discrete 
Priority

discrete, 
bit array

Determines the value (between 1 and 15) for the alarm priorit
for the tag value alarm, where 15 represents the highest prior

Table 3-7.     Alarms Configuration Attributes  (Continued)

Attribute
Applies to 
Data Types

 
Description
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Alarm Invert 
Mask

bit array Determines which bits are inverted before calculating the alar
state. Bits in the mask that are 1 are inverted; thus, cause an alarm
when low (0). Bits that are 0 are not inverted; thus, cause an 
alarm when high (1). The default mask is 0, indicating that non
of the bits are inverted. In bit-wise logic terminology, the Engin
performs an XOR with the Invert Mask to produce the alarm 
state. The Alarm Invert Mask is applied to the scaled value af
any relevant scaling masks have been applied. 

Alarm Select 
Mask

bit array Determines which bits are used for the bit array alarm 
calculation. Bits in the mask that are 1 are used in the alarm 
calculation; bits that are 0 will not cause an alarm, regardless of
their value. In bit-wise logic terminology, the Engine performs a
AND with the Select Mask to produce the alarm state. The Alar
Select Mask is applied to the scaled value after any relevant 
scaling masks have been applied. 

Alarm 
Message

discrete, 
bit array

Determines the string used to provide additional information 
about the meaning of an alarm condition. 

Tag Last 
Modified

all Indicates when the last edit to a tag occurred. 

Table 3-7.     Alarms Configuration Attributes  (Continued)

Attribute
Applies to 
Data Types

 
Description
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How Do You Configure Alarms for a Tag?
While editing a tag, click the Enable Alarms checkbox. Alarms are 
generated depending on the value or state of a tag. The alarms based
value vary with the tag data type. But for any tag, if the status is bad, a 
Status alarm is generated. By default, Bad Status Alarm is enabled an
the highest priority (15). You can change this selection from the Alarms
of the Tag Configuration Editor, shown in Figure3-9.

Analog Tags
Analog tags have four alarm levels: HI_HI, HI, LO, and LO_LO. By 
providing separate alarm levels, you can provide more information abo
the nature of the alarm condition.

 

Figure 3-9.  Alarms for Analog Tag Configuration

Alarms are calculated after scaling is performed. Alarm levels are 
expressed in engineering units.
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Discrete Tags
Discrete tags have one alarm state—either the tag is in alarm or it is n
You can determine whether a tag is in alarm when it is ON (High) or O
(Low). Figure3-10 shows the Alarms tab of the Discrete Tag 
Configuration dialog box. 

 

Figure 3-10.  Alarms for Discrete Tag Configuration

Bit Array Tags
You can enable one of two types of alarms for bit array tags. Alarm on A
indicates that the overall tag is in alarm if any of the bits are in alarm st
Alarm on All means that the overall tag is in alarm only if all of the bits a
in alarm state. You can use the Invert Mask to determine the bits that sh
use alarm on low (OFF) rather than the default alarm on high (ON). Yo
can use the Select (AND) Mask to determine the bits that should be 
considered for the alarm. If you have bits in the Select Mask that are z
(OFF), these bits are not used in calculation of the tag alarm state. 
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Figure3-11 shows the Alarms tab of the Bit Array Tag Configuration 
dialog box.

Figure 3-11.  Alarms for Bit Array Tag Configuration

String Tags
String tags have no alarm states based on tag value. They only suppor
Status alarms.

What Is Alarm Deadband on Analog Tags?
Alarm Deadband is a method commonly used to avoid repetitive alarm
messages because of a tag value that hovers near the alarm limit. Ala
Deadband defines how much a tag value must change from the alarm 
before it is considered normal. For example, if a tag that represents a 
temperature value hovers near an alarm limit of 40 degrees Celsius, th
might go in and out of alarm many times in a relatively short period of tim
Table3-8 shows examples of events with Alarm Deadband set to 0.0%
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This type of situation clogs event files with redundant information and c
cause operators some frustration in having to acknowledge alarms 
constantly when the tag has not changed significantly. You can use th
Alarm Deadband to alleviate this problem. 

For the tag to go into alarm, it must go above the exact Alarm Value (in
above example, 40). However, to be considered normal again, it must l
the Alarm Value by an amount greater than the Alarm Deadband. For
example, if the range is 0 to 100 degrees Celsius, an Alarm Deadband
1.0% (one degree Celsius) eliminates unnecessary events. Table3-9 shows 
examples of events with Alarm Deadband set to 1.0%. 

How Do You Keep an Alarm Unacknowledged 
after the Alarm Returns to Normal?
While editing a tag, select the Alarm Acknowledgement Mode ring and 
choose either Auto Ack on Normal or User Must Ack.

Table 3-8.     Events with Alarm Deadband = 0.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 Yes  Normal

9:15:15 40.1 Yes  HI 

9:15:20 38.5 Yes  Normal

Table 3-9.     Events with Alarm Deadband = 1.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 No  HI

9:15:15 40.1 No  HI

9:15:20 38.5 Yes Normal
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Auto Ack on Normal
With this option enabled, when a tag returns to normal state, the alarm
automatically acknowledged. A message is logged to the event file if ev
logging is turned on for the tag. By default, Auto Ack On Normal is 
enabled.

User Must Ack
With this option enabled, an alarm remains unacknowledged until the 
operator acknowledges the alarm.

Activity 3-1. Configure a Tag, and View the 
Tag Configuration Parameters 
and Tag Values

The objective of this activity is to use the Tag Configuration Editor to 
configure tags for an HMI application and to become familiar with the 
Tag Browser and Tag Monitor utilities.

As with all servers, you must register the Tanks Server VI before you 
use it. Most of the activities in this manual require the Tanks Server VI
you must run the Register Tanks Server VI, as indicated in the steps be
For more information about registering servers, see Chapter 8, Servers. 

1. Open the Register Tanks Server VI, which is located in the 
BridgeVIEW\_servers\Tanks Server  directory. 

2. Run the VI.

3. Close the VI. 

4. Launch the Tag Configuration Editor by selecting 
Project»Tag»Configuration. This launches the Tag Configuration 
Editor.
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5. Select the configuration file by selecting File»Open and choosing 
mytanks.scf  from the BridgeVIEW\Tutorial  directory. This 
loads mytanks.scf  into the Tag Configuration Editor, as shown in
the following illustration.

Note: This configuration file uses data simulated by the Tanks Server. You must 
ensure that the Tanks Server is registered with the BridgeVIEW Engine by 
selecting Project»Server Tools»Server Browser. If you do not see Tanks 

Server in the Registered Servers list, run the Register Tanks Server.vi 

from the BridgeVIEW\_servers\Tanks Server directory.

If any of the tags in the Tag Configuration Editor List have a prohibited
symbol, shown at left, next to them, you have not registered the Tanks
Server VI yet. You must register this server before you can use it. For
information about how to register this server, see steps 1 through 3 in
activity. 

6. Create a tag called Product  by selecting the Create Analog Tag(s)… 
button. 

7. Table3-10 contains the settings you should choose when configuri
your new analog tag. Enter the values listed in the Setting column for 
each attribute in the Tag Configuration dialog box to configure the 
connection, operations, scaling, and alarms. For example, in the 
General tab of the Tag Configuration dialog box, you should type i
Product  as the tag name. After entering all of the values, press th
OK  button to set the tag configuration.
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Note: You also can specify a tag name by selecting the proper I/O connections (t
access, item, etc.) and then clicking on Paste Item Name to Tag Name. After 
doing so, the item name appears in the Tag Name field. 

Table 3-10.     Configuration Settings for Activity 3-1

Category Attribute Setting

General Tag Name Product

Tag Group group1

Tag Description Volume of finished 
product in liters

Connection Tag Access Input Only

Server Name Tanks Server

I/O Group ALL

Item tank2

Operations Update Deadband 
(% of range)

1.00

Set Initial Value Enabled, 0.00

Log/Print Events Enabled

Log Data Enabled

Log Deadband (% of 
range)

5.00

Log Resolution
(engineering units)

0.10
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Scaling Engineering Unit Liters

Scaling <none>

Raw Full Scale 1000.00

Raw Zero Scale 0.00

Coerce to Range Disabled

Alarms Enable Alarms Enabled

Alarm Acknowledge 
Mode

Auto Ack on Normal

Alarm Deadband 
(% of range)

1.00

HI_HI Enabled, Limit = 
950.00, Priority = 1

HI Enabled, Limit = 
800.00, Priority = 1

LO Disabled

LO_LO Disabled

Bad Status Alarm Enabled, Priority = 1

Table 3-10.     Configuration Settings for Activity 3-1 (Continued)

Category Attribute Setting
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8. Modify the Mixer , Liquid  and Powder  tags, as specified in 
Table3-11, to configure them for Historical Logging and Alarm 
Acknowledgement. To edit a tag configuration, select the tag in th
Tag Configuration Editor listbox and double-click or press the 
Edit Tag… button.

Table 3-11.     Configuration Modifications for Activity 3-1

Category Attribute Setting

Operations Log Data Enabled

Log Deadband 
(% of range)

0.00

Log Resolution 0.10

Alarms Enable Alarms Enabled

Alarm Acknowledge 
Mode

User must Ack
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9. Save the configuration by selecting File»Save. The modified .scf  file 
is provided for you in the BridgeVIEW\Tutorial\Solutions  
directory.

10. View the tag configuration using the Tag Browser. From a VI fron
panel, choose Project»Tag»Browser… and select different tag names
to see the configuration parameters. The Tag Browser is shown in
following illustration. 

11. Close the Tag Browser.
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12. View the tag value and status of the Product tag with the Tag Moni
Select Project»Tag»Monitor…. Select Product and click on the 
Add>> button. Then select OK . The Select Tags to Monitor dialog 
box is shown in the following illustration. 

The Tag Monitor is a quick way to look at tag values and alarm states
without building an HMI. It is also a great debugging tool. When you 
launch the Tag Monitor, it automatically launches the Engine. The Eng
loads the last .scf  file saved. In this case, it uses mytanks.scf . The Tag 
Monitor is shown in the following illustration.

13. Close the Tag Monitor.

End of Activity 3-1.
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How Do You Configure Other Engine Parameters?
There are other Engine parameters you can configure within the Tag 
Configuration Editor. You can define your Historical Logging 
Configuration and Event Configuration by selecting 
Configure»Historical… or Events… through the BridgeVIEW Tag 
Configuration Editor dialog box, shown in Figure3-1. 

How Do You Turn on Historical and Event Logging at Startup?
To turn on historical and event logging at startup, select 
Configure»Historical… or Events… from the Tag Configuration Editor. 
Checkboxes in each dialog box turn on historical and event logging at
system startup. For more information, see Chapter 5, Alarms and Events, 
and Chapter 6, Historical Data Logging and Extraction.

How Do You Set the File Paths for Historical and Events Files?
From the main panel of the Tag Configuration Editor, select 
Configure»Historical… or Events…. The dialog box allows you to set the
path to the directories containing historical or events files.

How Do You Configure Shifts?
Shifts are valuable in configuring event logging. Shift start and stop tim
determine how event files are segmented, and end of shift reports can
these configuration files to determine process and line statistics. From
main panel of the Tag Configuration Editor, select Configure»Events…. 
The panel has a shift display with which you can edit the configuration

How Do You Configure Engine Parameters?
The BridgeVIEW Engine has several default settings for Engine 
parameters. However, you can override these defaults within the Buffe
Configuration dialog box by selecting Configure»Engine from the Tag 
Configuration Editor. 

The BridgeVIEW Engine allocates certain amounts of memory for vario
queues. You can configure some of the parameters used by the Engin
Tags VIs to allocate memory for the Engine buffers yourself, but it is 
recommended that you use the default values. The parameters you ca
configure are listed in Table3-12. For more information about these 
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parameters or the VIs that contain them, refer to Appendix A, HMI 
Function Reference. 

Table 3-12.     Configurable Memory Allocation Parameters

Parameter Description Default Value

System Events 
display (lines

Determines the maximum number of lines of text to be 
displayed in the System Errors and Events display of the 
Engine Manager.

20 

Error Message 
repeat rate 
(seconds)

Determines the time, in seconds, that recurring error 
messages should be repeated to the user. For example, 
an undefined tag message error will be repeated only 
after this value is exceeded.

600 secs 
(10 minutes)

Event History 
Buffer size 
(elements) 

Determines the length, in elements of the queue that 
handles event information sent from the Engine to 
.evt files.

2000

Historical Log 
Queue (elements)

Determines the length, in elements, of the queue that 
handles data sent from the engine to the Citadel 
historical database.

2000

Server Input Queue 
size (elements) 

Determines the length, in elements, of the queue that 
handles data sent from the device servers to the Engine.

2000

Server Input Queue 
binary size (bytes)   

Determines the length, in bytes, of the queue that 
handles binary data (string tags) sent from the device 
servers to the Engine.

2000

Server Output 
Queue size 
(elements)   

Determines the length, in elements, of the queue that 
handles data sent from the Engine to the device servers.

2000

Server Output 
Queue binary size 
(bytes) 

Determines the length, in bytes, of the queue that 
handles binary data (string tags) sent from the Engine to 
the device servers.

2000

Server Shutdown 
timeout (seconds) 

Determines the time, in seconds, that the Engine will 
wait for all active device servers to shutdown before 
asking the user if the servers should be forcefully 
terminated.

30
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Note: Although you can configure these parameters, it is highly recommended th
you maintain the default values.

How Do You Launch Server Configuration Utilities from 
the Tag Configuration Editor?

When you register a server in your system, BridgeVIEW registers the 
location of its configuration utility, if it exists. You can access the serve
configuration utilities from the Servers menu of the Tag Configuration 
Editor.

Note: When you update the server registry while the Tag Configuration Editor is 
running, select Servers»Refresh to prompt the Tag Configuration Editor to 
read the updated information. 

How Do You Access or Change Tag Configuration 
Information in Your Application?

BridgeVIEW allows you read/write access of tag configuration informati
to use in your application. This is often helpful when displaying 
engineering units, scales, and other information about the tag or chan
a tag from Offscan to Onscan. The Tag Attributes VIs obtain and determ
this information. 

The Tag Attributes VIs are listed below. For complete information abo
these, and other VIs, see Appendix A, HMI Function Reference. 

• Get Tag Attribute

• Set Tag Attributes

• Set Multiple Tag Attributes

• Get Tag Description Group

• Get Tag I/O Connection Info

• Get Tag Logging Info

• Get Tag Range and Units

• Get Tag Alarm Enabled

• Get Analog Tag Alarm Limit

• Get Discrete Tag Alarm Setting

• Get Bit Array Tag Alarm Setting

• Get Tag Bad Status Alarm
BridgeVIEW User Manual 3-46 © National Instruments Corporation



© National Instruments Corporation 4-1 Bri
Chapter

4
Human Machine Interface
ow 

MI 

 

ne 

I, 
ogic, 

s 
 

 

This chapter explains what a Human Machine Interface (HMI) is and h
you can monitor and control tags from your HMI. This chapter also 
describes several general principles of HMI programming in G, and 
provides activities that illustrate how to accomplish the following: 

• Build your HMI using the HMI G Wizard

• Customize front panel objects with imported graphics

Note: To understand the concepts, and to complete most tasks associated with 
building an HMI, you should be familiar with the basic functionality of G 
programming. If you have not completed the G Tutorial section of this manual, 
you should do so now. 

The example diagrams shown in this chapter are taken from several H
examples you can find in the BridgeVIEW\Examples\HMI Examples  
folder.

What Is an HMI?
An HMI is the interface through which an operator interacts with the 
BridgeVIEW system and with the outside environment that BridgeVIEW
monitors and controls. The operator is the end user of the system.

To monitor the changes in configured tags in real time, you can build o
or more Human Machine Interface (HMI) applications.

BridgeVIEW includes a set of VIs with which you can control your HM
access the Real-Time Database and Citadel, perform calculations and l
and switch between different displays. The BridgeVIEW VI library 
includes Alarms and Events VIs, Historical Data VIs, System VIs, Tag
VIs, and Tag Attributes VIs. For more information about these VIs, see
Appendix A, HMI Function Reference. For more information about the G
VI Library, see the Online Reference.
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There are several general G programming principles with which you sho
be familiar before you build an HMI. These principles are listed below:

• Building basic G front panels and diagrams

• Using controls and indicators

• Using the tag data type

• Using the basic principles of dataflow programming

• Using basic programming constructs such as the Sequence struct
and While Loop

• Using the Time and Dialog VI library

To learn about any of the topics above, see the G Tutorial section of this 
manual and complete the activities. For more detailed information, see
G Programming Reference Manual. 

For more advanced HMI programming, you also should know how to u
the G control and indicator attribute nodes and the VI Control VIs. For
more information about this topic, see Chapter 12, Attribute Nodes.

You might want to divide your HMI into several panels so the operator 
navigate through them using buttons on the screen. The Panel G Wiz
helps you generate the navigation system by automatically generating 
and attaching it to front panel buttons. For more information about the
Panel G Wizard, see Chapter 7, Advanced Application Topics.

How Do You Build an HMI?
To build an HMI, use the graphical controls and indicators to lay out th
user interface objects on the front panel, and a special set of VI librarie
the block diagram to do the following:

• Read and write tag values

• View and acknowledge alarm states and events

• Display historical and real-time data 

• Read tag configuration and security information

• Control the BridgeVIEW system programmatically

• Access and change tag attributes

• Control output tags
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Front Panel Objects
A front panel is the user interface of a virtual instrument (VI). You build
the front panel of a VI with a combination of controls and indicators 
representing the values of the tags. Controls are the means of supply
data to your VI, and indicators display data that your VI generates. Th
are many types of controls and indicators available from the Controls 
palette, shown in the following illustration. You can choose objects to pl
on your front panel such as real-time trend displays, alarms and even
displays, and numeric indicators. You also can choose automation sym
such as vessels, pumps, and valves. 

 

To develop an HMI application, configure your tags, create the front pa
interface and then use the HMI G Wizard to build your block diagram. F
more information about how to use the HMI G Wizard, refer to the 
HMI G Wizard section in this chapter. If you prefer to build the block 
diagram on your own, without the assistance of the HMI G Wizard, yo
may do so, or you can get started by building a basic block diagram w
the HMI G Wizard and then building upon that to create a more advan
HMI on your own. 

HMI G Wizard
The HMI G Wizard provides an easy interface for you to generate 
repetitive pieces of diagram code. If you are new to G programming, t
HMI G Wizard can be an immense help in building simple tag monitori
and control loops. 

Vessels

Pipes, Pumps,
and Valves

Alarms and Events

Booleans

Automation 
Decorations

Graphs
(Real-Time Trend, 
Historical Trend)

Tag Controls 
and Indicators

(Acknowledge 
Alarm Button)
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The HMI G Wizard associates a front panel control or indicator with a t
and generates the necessary Wizard subdiagram for a configuration th
you specify. Table4-1 provides a list of front panel objects, and explains
how the HMI G Wizard operates on each of them. 

Table 4-1.     HMI G Wizard Operations

HMI Function Front Panel Object Description

Control analog tags Numeric Control Invoke the HMI G Wizard on a numeric control 
to associate an analog output tag value with that 
control. You can set the colors and blink options 
under alarm conditions, and specify the updates 
to happen only when the control value changes.

Display analog 
values

Numeric Indicator Invoke the HMI G Wizard on a numeric indicator to
associate an analog input tag value with that 
indicator. You can set the color and blink options 
under alarm conditions.

Control discrete tags

Acknowledge 
alarms

Boolean Control Invoke the HMI G Wizard on a Boolean control to
associate a discrete output tag value or an alarm 
acknowledgement state (Alarm Acknowledgemen
with that control. When you invoke the Wizard for
the first time on a Boolean control, the 
Configuration dialog box is set for Tag Value. To 
change the control association from tag value to 
alarm acknowledgement mode, change the Attach 
Control to:  ring to Alarm Acknowledgement. 
Select a set of tags that requires acknowledgeme
when the Control value is set to TRUE. You can se
blink and color options under Alarm Conditions. 
A preformatted Acknowledge Alarm button is 
contained in the Boolean Controls palette. 
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Display discrete 
values 

Indicate 
an alarm state

Boolean Indicator Invoke the HMI G Wizard on a Boolean indicator 
to associate a discrete input tag value or an alarm
state with that indicator. When you invoke the 
Wizard for the first time on a Boolean indicator, 
the Configuration dialog box is set for Tag Value. 
You can set blink and color options under Alarm 
Conditions. To change the control association 
from tag value to alarm state, change the Attach 
Indicator to:  ring to Tag Alarm State. Select the 
tag for which the indicator will display the alarm 
state.

Control string tags String Control Invoke the HMI G Wizard on a string control 
to associate a string output tag value with that 
control. You can set the colors and blink options 
under alarm conditions, and specify the updates 
to happen only when the control value changes.

Display string 
values

String Indicator Invoke the HMI G Wizard on a string indicator to 
associate a string input tag value with that indicato
You can set the color and blink options under alarm
conditions.

Display alarm 
summary 

Alarm Summary 
Display or any Table 
Indicator 

Invoke the HMI G Wizard on a table indicator to 
obtain a summary of current alarms (Alarm 
Summary). You can set the HMI G Wizard to 
Alarm Summary mode by setting the value of the 
Use this Indicator for: ring to Alarm Summary. 
You can select a set of tags whose alarms require
monitoring. You also can set colors of 
acknowledged and unacknowledged alarms and 
column format of the summary. Preformatted 
alarm summary indicators are contained in the 
Alarms and Events palette. 

Table 4-1.     HMI G Wizard Operations (Continued)

HMI Function Front Panel Object Description
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Display event 
history information

Event History 
Display or any Table 
Indicator 

Invoke the HMI G Wizard on a table indicator to 
obtain a history of past events and alarms (Event
History). For an event history display, you can set
the HMI G Wizard to Event History mode by 
setting the value of the Use this Indicator for: 
ring to Event History. You can select a set of tags
whose history needs to be displayed. You also ca
set colors of acknowledged and unacknowledged
alarms, normal and event entries, and column 
format of the summary. Preformatted event histor
indicators are contained in the Alarms and Events 
palette. 

Display a real-time 
trend

Real-Time Trend or 
Waveform Chart 
Indicator

Invoke the HMI G Wizard on a real-time trend or
waveform chart indicator to select a set of tags fo
which the values need to be displayed in a chart 
(real-time trend).

Display a historical 
trend

Historical Trend or 
XY Graph Indicator

Invoke the HMI G Wizard on a historical trend or 
XY graph indicator to select a set of tags for which
the values need to be displayed in an XY graph 
(historical trend).

Table 4-1.     HMI G Wizard Operations (Continued)

HMI Function Front Panel Object Description
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To invoke the Wizard, pop up on a front panel object, and select 
HMI G Wizard… . For example, the HMI G Wizard dialog box for an 
analog input tag appears in Figure4-1 by popping up on a numeric 
indicator.

Figure 4-1.  HMI G Wizard Dialog Box

When you invoke the HMI G Wizard on one of the front panel objects lis
in Table4-1, a dialog box appears for that object. You can associate th
front panel object with a tag, and set the various parameters. When yo
select OK  in the dialog box, the Wizard generates diagram code accord
to the dialog entries and pastes the code on the block diagram. 
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Generate the Block Diagram
Once you associate a front panel object with a tag and set the various
parameters, the HMI G Wizard generates the appropriate code and pl
it on the block diagram. For example, using the HMI G Wizard for Analo
Indicator, shown in Figure4-1, the following Wizard subdiagram appears
on the block diagram.

Front Panel Object and Wizard Subdiagram 
Association
When the HMI G Wizard has created a block diagram, there is an 
association between the front panel object and the generated Wizard 
subdiagram. The association is protected by a Wizard lock which prevents 
you from editing the Wizard subdiagram. The lock glyph on the loop, 
shown at left, indicates that the Wizard has locked the subdiagram. W
the subdiagram is locked, you can pop up on the front panel object, se
HMI G Wizard… , and change your selections in the dialog box. To ed
the Wizard subdiagram, pop up on the Wizard subdiagram and select
Release Wizard Lock, as shown below.

Note: Once you have released the Wizard lock, the association is broken. The Wiz
no longer identifies the Wizard subdiagram as being created by it. 
BridgeVIEW User Manual 4-8 © National Instruments Corporation



Chapter 4 Human Machine Interface

es
Activity 4-1. Use the HMI G Wizard
Your objective is to create a simple HMI using the HMI G Wizard.

For this activity, you will use the tags configured in mytanks.scf , which 
you edited in Activity3-1 and is located in the BridgeVIEW\Tutorial  
directory. 

Note: Before you can begin this activity, you must have completed Activity3-1, 
Configure a Tag, and View the Tag Configuration Parameters and Tag Valu, 
in Chapter 3.

1. Place a real-time trend from the Controls»Graph subpalette on your 
front panel. Pop up on the object and select Show»Label. Type 
Real-Time Trend  in the label.

2. Pop up on the trend and select HMI G Wizard… . 
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3. Now you can select a list of tags to monitor. Select Mixer , and click 
on Add, as shown in the following illustration.

 

If you do not see a list of available tags or the tag name Mixer  is not 
in the list when you click on the Tag menu ring, pop up on the menu
ring and select Tag Browser… to select the correct .scf  file. Press 
the Browse… button on the Tag Browser to bring up a dialog box an
select mytanks.scf . This dialog box automatically appears if no 
.scf  file is currently selected. 

If the Engine is running already, the Browse… button is dimmed and 
you cannot change the .scf  file until you stop the Engine. The Tag 
Browser shows you a summary of the configuration parameters of
tags in the file. 

When you have selected the proper .scf  file from the Tag Browser, 
click on OK  to return to the HMI G Wizard.
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4. Click on OK . Notice that the HMI G Wizard has created the block 
diagram for you, as shown in the following illustration. 

5. Return to the front panel and run the VI. It launches the Engine if i
not running already. The Engine reads mytanks.scf  and launches the 
Tanks Server. 

6. Now, you can see the Mixer tag values being monitored in the 
real-time trend. Select Operate»Stop to stop the VI.

Diagrams generated by the HMI G Wizard have a lock on the top righ
corner of the outermost structure. You cannot edit the code inside the
structure until you release the lock. However, you can pop up on the fr
panel object, select HMI G Wizard, and change your selections in the 
dialog box. When you press OK , the changes are incorporated into the 
previously generated diagram. 

The locked code is very tightly coupled with the front panel object. If y
delete the front panel object, the block diagram associated with it is del
automatically. 

7. Save the VI as My Tank HMI.vi  in the BridgeVIEW\Tutorial  
directory.

End of Activity 4-1.
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How Do You Customize Front Panel Objects?
You can customize BridgeVIEW controls and indicators to change the
default appearance on the front panel with the Control Editor. You also
save these controls for use in other VIs. Programmatically, they functi
the same as standard BridgeVIEW controls.

Control Editor
You launch the Control Editor by selecting a control on the front panel w
the Positioning tool and choosing Edit»Edit Control… . The Control 
Editor appears with the selected front panel object in its window. The 
Control Editor has two modes: the Edit mode and the Customize mod

The Edit mode allows you to pop up on a control and manipulate its 
setting(s). The Control dialog box is shown below.

Figure 4-2.  Control Dialog Box

While in the Customize mode, you can move the individual component
a control around with respect to each other. For a listing of what you c
manipulate in customize mode, select Windows»Show Parts Window. 
Not only can you customize the appearance, but you can use the cont
other VIs. Save it as a custom control by selecting Save. You can save it 
with different definitions such as control, type definition, or strict type 
definition which controls how much of the control can be modified in oth
VIs. After you save the control, you can place it on other front panels us
the Controls»Select a Control… option. For more information, refer to 
Chapter 22, Custom Controls and Type Definitions, in the G Programming 
Reference Manual.

When you edit a control, a new window opens with a copy of the contr
You can customize the control by coloring it, changing its size, adding n
elements to clusters, and so on. These changes do not affect the origin
until you select File»Apply Changes, or you close the window and selec
YES to the prompt concerning replacing the original control.
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If you want to use the control in other VIs, you can save it as a custom
control by selecting File»Save. After you save the control, you can place 
on other front panels using the Controls»Select a Control…. 

Importing Graphics
You can import graphics from other programs for use as background 
pictures, as items in ring controls, or parts of other front panel controls
Before you use a picture in BridgeVIEW, you must load it into the 
BridgeVIEW clipboard. You can load an example of this type of control 
popping up in a front panel, selecting Controls»Select a Control…, and 
opening Example\G Examples\General\Controls\ 

custom.llb\box .

If you copy an image directly from a paint program to the Windows 
clipboard and then switch to BridgeVIEW, BridgeVIEW automatically 
imports the picture to the BridgeVIEW clipboard. Or you can select 
Edit»Import Picture from File…  to import a graphics file into the 
BridgeVIEW clipboard. Once a picture is in the BridgeVIEW clipboard
you can paste it as a static picture on your front panel, or you can use
Import Picture  option of a pop-up menu, or the Import Picture options 
in the Control Editor. Picture files supported include EMF, BMP, and 
WMFfiles.

Activity 4-2. Import a Graphic Image into 
BridgeVIEW

Your objective is to use a graphic image created in an external drawin
package in a BridgeVIEW front panel control.

1. In BridgeVIEW, select File»New to create a new VI. With the front 
panel open, select a Horizontal Pointer Slide from 
Controls»Numeric. Pop up on the slide (click on it with the right 
mouse button) and select Change to Indicator.
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2. With the Positioning tool, grab the upper-right corner of the slide a
stretch it to the right, to make the slide longer.  If you hold down th
<Shift> key when you click and drag the mouse, you will restrict th
stretch to one direction.  Move the Digital Display of the slide to a 
central location below the slide.

3. Select the slide with the Positioning tool and select 
Edit»Edit Control . The Control Editor window appears, as shown i
the following illustration. 

4. Click on the Edit Mode button in the Control Editor toolbar. The 
wrench changes to a pair of tweezers to illustrate that you are in 
Customize mode. In Customize mode, the control is broken into 
several parts. You cannot operate the control while the Control Ed
is in Customize mode.

5. Select Edit»Import Picture from File  from the Control Editor menu 
bar. A file dialog box prompts you to select a picture file to open. Op
boat1.wmf  from the BridgeVIEW\Tutorial directory.

6. Pop up on the pointer of the slide and select Import Picture . The boat 
image is imported onto the triangular pointer of the slide, as shown
the following illustration. 
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7. Click on the pair of tweezers to return to Edit mode. You can finis
editing the control in Edit mode. 

8. Pop up on the housing of the slide and select Scale»Style»None. The 
scale for the slide disappears.

9. Change tools to the Color tool. To do this, you either can select the
from the palette, if visible, or you can use the <Tab> key to rotate 
through the tools until the Color tool is selected. Pop up on the hous
for the slide with the Color tool, and select the transparent color. T
housing disappears, as shown in the following illustration. 
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With the Operator tool, you can operate the “slide.” Notice that the
digital display continues to update as you move the boat on the scr
If you want to hide the digital display, pop up on the boat and dese
Show»Digital Display.

10. Save this control as Boat1.ctl  in the BridgeVIEW\Tutorial  
directory.

End of Activity 4-2.

How Do You Configure Front Panel Objects 
Programmatically?
BridgeVIEW has objects called attribute nodes which are special block
diagram nodes you can use to control the appearance and functional 
characteristics of controls and indicators from your diagram. You can 
attributes such as display colors, visibility, position, blinking, trend scal
and many more. See Chapter 12, Attribute Nodes, or Chapter 7, Advanced 
Application Topics, for more information.

How Do You Monitor and Control Tags? 
The Tags VI library and Alarms and Events VI library contain VIs for yo
HMI application to interact with the BridgeVIEW Real-Time Database.
These are the primary VIs you use to build your HMI. You can use the
VIs to accomplish the following:

• Read tag values

• Write tag values

• Monitor tag and tag group alarm and event states 

• Acknowledge alarms by tag and tag group

There are other VI libraries that contain VIs with which you can add 
additional functionality and sophistication to your HMI. These VIs do n
interact directly with the BridgeVIEW RTDB. Instead, you can query a
well as control other features of the BridgeVIEW system. These VI 
libraries are as follows:

• Tag Attributes 

• Historical Data 

• System, which includes Security VIs
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You can reach these VIs through the Functions palette, shown below. 

Tag Data Type
BridgeVIEW has a special data type called the tag data type that is aw
of the available tag names and tag group names contained in the curr
.scf  file. All BridgeVIEW functions that can operate on tags or tag grou
use the tag data type. The tag data type is marked with a valve glyph.
Constants and wires in the block diagram carrying this tag information 
displayed in purple.

The tag control and indicator can be found in the Controls»Strings palette.  
The tag constant can be found in the Functions»Tags palette.  The 
Functions»Tags palette also contains functions that convert between a 
data type and a string data type, and a special “not a tag” constant.  T
following illustration shows the tag control, indicator and constant as th
appear on the front panel and block diagram. 

Alarms and Events

System and Security

Tag Attributes 

Historical Data

Tags and Constants) 
(Read, Write and Trend 
Tags

Front Panel View of Tag Controls and Indicators

Block Diagram View of a Tag Control and Indicator, and Tag Constant
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Tag controls, indicators and constants also can be contained in arrays
Many BridgeVIEW VIs operate on arrays of tags.

When you drop a tag control, indicator, or constant on a front panel, y
can click on the right menu ring button of the tag control to display a lis
the available tags and tag groups and select one. 

Tag groups are distinguished from individual tags in the list by a folde
glyph. A special group <ALL> also appears in the list. This is a default 
group that contains all the tags in your .scf  file. The following illustration 
shows a list of tags and tag groups.

You also can enter the name of the tag you want to use. The tag cont
performs a Type Look Ahead as you type, and displays the closest ta
group name to what you enter. By default, the tag control does not allo
you to enter a name that is not contained in the current .scf  file. 

You can configure each tag control, indicator, or constant to permit en
of names not contained in the current .scf  file by popping up on the tag 
object and selecting Allow undefined tags. If a tag name is not in your 
.scf  file, you cannot select it.
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The tag data type imports tag and tag group names from a tag configur
file (.scf ). When you launch BridgeVIEW, the tag data type list of 
available tag names and tag group names is automatically updated fro
your default .scf  file. The default .scf  file is the last file you edited in 
the Tag Configuration Editor. If the list of names is empty, you have n
default .scf  file.

You can change the currently selected .scf  file by opening the Tag 
Browser utility and pressing the Browse… button. To open the Tag 
Browser utility, pop up on the tag object and select Tag Browser…. 
Pressing the Browse… button brings up a dialog box from which you ca
select the .scf  file you want to use. This is possible as long as the 
BridgeVIEW Engine is not running. When the Engine is launched, it ru
the currently selected .scf  file. You cannot change the current .scf  file 
until you stop the Engine.

Tag constants in your diagram (and tag controls and indicators if they 
saved with default values) retain the tag name or tag group name sele
when your VI is saved. The name contained in the tag control, indicato
constant is dimmed when the name is not contained in the currently 
selected .scf  file. This might be because the tag name has been delet
from the .scf  file, or the VI was created using a different .scf  file. If you 
try to run the VI at this point, you will get a system error for each tag th
is undefined in the current .scf  file. You can control which .scf  file the 
BridgeVIEW Engine runs programmatically. This capability is covered 
Chapter 7, Advanced Application Topics. 

Tags VIs and Alarms and Events VIs
The Tags VIs and Alarms and Events VIs have several properties in 
common. With these VIs, you operate on tags by wiring the tag name o
group name into the tag name or group/tag name input of the VI when 
you place them in your diagram. These are required inputs. Some VIs
accept arrays of tag names or tag and tag group names. 

The Tags VIs and Alarms and Events VIs return several flags that indi
the state of the BridgeVIEW Engine. They return a Boolean error  flag to 
indicate whether the operation was successful. If the error  flag is TRUE, 
the tag specific information returned by the VI might not be valid. Som
VIs also return a more detailed value status variable. 
© National Instruments Corporation 4-19 BridgeVIEW User Manual
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All the VIs return a shutdown indication. If TRUE, this output indicates 
that the BridgeVIEW Engine is in the shutdown state, and your applicat
must finish execution so that shutdown can finish. If the BridgeVIEW 
Engine goes into the shutdown state while these VIs are waiting on an
event, the VI terminates the wait and returns immediately to the callin
diagram. You can use this output to tell your diagram to complete 
execution. 

All VIs that read information from the BridgeVIEW database can return
information immediately or wait for the database to be updated with ne
information before returning. The timeout input controls this behavior. 
This input tells the VI how long to wait, in seconds, for the tag informati
to be updated in the Real-Time Database. 

If timeout is 0 seconds, the VI does not wait at all. Instead, it immediat
reads the database and returns the current tag information. If timeout is less 
than 0, the VI continues to wait until the tag is updated or the Engine s
down. If timeout is greater than 0, the VI waits until the tag is updated 
the database, or the timeout period is exceeded, whichever occurs first,
reads the database and returns the current tag information. By default
timeout is 0 seconds. 

So if you wire nothing into the timeout input of your diagram, the VI does
not wait but reads the database, and returns immediately. How you us
timeout input depends on whether you want to implement event-driven
polled programming techniques in your HMI. 

All VIs that read information form the BridgeVIEW database have a 
changed? output that is TRUE if the returned information is new or 
updated. If the VI returns and changed? is FALSE, the VI might have 
timed out, or the information in the database did not change since the
time you read it. You can use this output to make your program more 
efficient by using a case statement to update the user interface only if
information has changed. 

Some of the more advanced Tags VIs and Alarms and Events VIs als
return an initialize headers or config changed output that tells your 
program whether your HMI object needs to be initialized with new 
information. In most cases, this corresponds to the first time the VI is 
called, and you only need to update that part of your user interface on
For more information about the Tags VI Library, refer to Appendix A, HMI 
Function Reference.
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Activity 4-3. Read a Tag
Your objective is to monitor a single tag value using the Read Tag VI.

In this activity, the Read Tag VI returns when a new value for the tag i
acquired from the Tanks Server, and updated in the RTDB, or a timeou
1 second is exceeded, whichever occurs first. This loop continues exec
until the Engine shuts down. You will use mytanks.scf  in the 
BridgeVIEW\Tutorial  directory, which you edited in Activity3-1, 
Configure a Tag, and View the Tag Configuration Parameters and Tag
Values.

Front Panel
1. Open a new VI (File»New) and place a tank on the front panel 

(Vessels»Tanks). Label the tank Product . Edit the tank scale to range
from 0 to 1000.

Block Diagram
2. To create the block diagram, pop up on the tank and select 

HMI G Wizard . Select Product for the Tag and click OK , as shown 
in the following illustration. 
© National Instruments Corporation 4-21 BridgeVIEW User Manual
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3. The HMI G Wizard generates a diagram for you that calls the Rea
Tag VI, as shown in the following illustration.

4. Pop up on the lock in the top right corner of the While Loop and se
Release Wizard Lock.

5. Using the Labeling tool, edit the timeout input to the Read Tag VI 
from its default -1.00  (indefinite) to 1.00 .
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6. Using the Positioning tool, select the bottom right corner of the Wh
Loop and expand it. 

7. Using the Wiring tool, pop up on the value timestamp output of the 
Read Tag VI and select Create Indicator. Pop up on the in alarm  
output of the Read Tag VI and select Create Indicator. The block 
diagram should appear as shown in the following illustration.

8. From the front panel, change the format of value timestamp to display 
absolute time. Pop up on the value timestamp  indicator, select 
Format & Precision, and set Format to Time & Date. Your front 
panel should appear as shown in the following illustration.

9. Save the VI as Monitor  Product.vi  in the 
BridgeVIEW\Tutorial  directory.

10. Run the VI. The Engine launches, unless it is running already. The 
level changes to reflect the changing values of the Product tag. W
the value goes over 800, the in alarm  Boolean changes from OFF to
ON, indicating an alarm condition.

End of Activity 4-3.
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How Do the Tags, and Alarms and Events VIs 
Affect Startup/Shutdown?  
When a user-defined VI runs and executes one of the Tags VIs or Ala
and Events VIs, that VI checks the status of the BridgeVIEW Engine. I
is not running, executing the VI automatically starts execution of the 
BridgeVIEW Engine. The BridgeVIEW Engine loads and executes all 
required device servers. When the VI returns, the Engine is running.

The BridgeVIEW Engine continues to run until you shut it down either 
programmatically or through the Engine Manager. As the Engine shut
down, first it checks to see if any application is running that requires it
services. If so, it waits until that application halts before shutting down
Once it shuts down, it sends a shutdown message to the device serve

You can monitor the status of the BridgeVIEW Engine with the shutdown 
output of any of the Tags VIs, Alarms and Events VIs, or the Get Engi
Status VI. 

Note: If you write applications that do not use the BridgeVIEW VIs that access th
Real-Time Database such as the VIs that retrieve historical data, those 
applications can run without the BridgeVIEW Engine running. They do not 
launch the BridgeVIEW Engine.

General Principles of G HMI Programming
You can choose how to monitor and control tag values as well as oper
interface controls and indicators in your HMI. Normally, you use one o
more While Loops in a VI diagram with a single wait operation inside o
each loop. Each While Loop executes once after its wait operation 
completes. The wait operation might be one of the Time and Dialog 
functions such as the Wait Until Next ms Multiple function. This is a poll
technique in which your diagram controls loop execution. 

Alternatively, the wait operation might be implemented using one of th
Tags VIs or Alarms and Events VIs with timeout wired to a non-zero 
value. These are the types of diagrams created by the HMI G Wizard. 
is an event-driven technique, in which a tag or alarm event controls lo
execution. Either technique is appropriate, depending on your HMI nee

You can wait on multiple events for which timing is not related to each
other in parallel on the same diagram, as long as you wait for each eve
a separate While Loop. This section covers the following topics:
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• Event-driven programming

• Polled programming

• Multiple loop applications

• Real-time trends

• Programmatic HMI indicator configuration

How Do You Implement Event-Driven Programming in G?
Event-driven programming means your block diagram waits for one or 
more events to happen and, as each event occurs, the part of your pro
waiting on that event is executed. In G, you can develop applications 
wait on different events and do operations in parallel by using multiple
While Loops in your diagram.

Figure4-3 shows an example using event-driven programming to moni
tag value and tag alarm state. One loop monitors the value of the Mixer  tag 
and another loop monitors alarm information for the Mixer  tag. These two 
loops run independently of each other. When the Mixer  tag value changes, 
or when 1.00  second has elapsed, the Read Tag VI returns and update
Mixer in Alarm , Mixer , value timestamp , and bad value  
indicators. When the alarm state  of the Mixer  tag changes, or 5.00  
seconds have elapsed, the Read Tag Alarm VI returns and updates th
alarm state  indicator, and controls the blinking of the Mixer in Alarm  
indicator. Both loops run in parallel until shutdown is TRUE.
© National Instruments Corporation 4-25 BridgeVIEW User Manual
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Figure 4-3.  Monitor Tag Value and Alarm VI

The Mixer in Alarm Blinking  attribute and the alarm state  
indicator are updated only when the changed? output of the Read Tag 
Alarm VI is TRUE. This example demonstrates how you might use the
changed? output. In this example, it is not important to use the Case 
structure because BridgeVIEW indicators update only when the displa
information actually changes. 

If you use a large number of indicators or attribute nodes or more comp
indicators such as tables and graphs, updating the indicator when cha
by using a Case structure in your diagram can improve the display 
performance of your VI. 
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How Do You Implement Polled Programming in G?
You do not have to use a separate loop for each Tags or Alarms and E
VI. This can be cumbersome to program for a large number of tag rea
although using the HMI G Wizard makes it easy to build separate loop
quickly. The alternative is to poll the database for several tags at regul
timed intervals. You usually need one While Loop in your diagram to p
your front panel controls, so you can monitor what the operator is doin
Using polling, you can combine monitoring of HMI controls with the 
reading in of tag values and alarm states. 

Figure4-4 shows an example implementing a more complex user interf
that polls all the input tags as well as the front panel Start Batch button at 
100 m/s intervals. When you leave the timeout input unwired, all Read Tag 
VIs read the BridgeVIEW database immediately by default. 

Note: In this case you must explicitly program the loop wait time by using the Wa
Until Next ms Multiple VI. If you do not, the loop operates as often as possibl
and requires most of the CPU time.

This example also illustrates use of the Write Tag VIs. In this case, the
Write Tag (discrete) VI is called only when the front panel button is 
pressed. In other cases, you might want to write the tag value at each
iteration. You also can use the Write Tag on Change VI to update the 
RTDB only when the value of the front panel control changes. This ca
improve your over all application performance.
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Figure 4-4.  Process View Display VI

How Do You Initialize and Shut Down Multiple-Loop Applications? 
When you have a multiple-loop application, you can add initialization co
before executing the loops, and some clean-up or shutdown code afte
the loops finish executing. You can use the Sequence structure for thi
purpose. Put the initialization code in the first frame of the Sequence 
structure, put all your loops in the second frame of the Sequence struc
and put the shutdown code in your final sequence. This guarantees th
none of your loops start execution until your initialization code is comple
and that all loops complete execution before you execute the shutdow
code. Figures4-7 and4-8 demonstrate this technique.
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You also can use dataflow programming to enforce sequential operatio
some cases, your diagram might be easier to read using this technique
possible that you might have some data flow between the initialization c
and the loops anyway. There is no difference in performance using eit
technique. It is purely a diagram documentation issue. Figure4-6 illustrates 
using this technique.

How Do You Display Real-Time Trends?
You can build a real-time trend by dropping a real-time trend indicator 
your front panel and popping up on it to select the HMI G Wizard. 
Alternatively, you can assemble the diagram manually using a While Lo
and the Trend Tags VI. Wire the output of the Trend Tags VI to the term
for a real-time trend indicator. The Trend Tags VI accepts an array of 
names, and returns information for a real-time trend you can wire direc
to the real-time trend or Waveform Chart indicator. You can control ho
often the trend updates by the time interval control, which, if left unwired, 
is once per second by default. The scale to % control controls the scale on
the trend. If scale to % is TRUE, the trends return as a percent (%) of fu
scale for each tag. If scale to % is FALSE, the trends return in engineering
units. If scale to % is left unwired, trend values return in engineering unit
by default. 

The Trend Tags VI always waits the specified time interval. For this reas
a Trend Tags VI usually is placed in its own While Loop because it contr
the loop execution rate. If you want to execute other VIs at the same r
that the real-time trend updates, place them in the same loop. 

Figure4-5 shows an HMI with two real-time trend displays. The Trend 

Tank Temperature  displays the trend in percent of full scale, and is 
updated every 1.0 second. The Trend Tank Level  is displayed in 
engineering units, and is updated every 2.0 seconds. The tag names p
into the Trend Tags VI are tag array constants containing the tag name
© National Instruments Corporation 4-29 BridgeVIEW User Manual
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interest. Notice that the Trend Tags VI only accepts tag names and no
group names. 

 

Figure 4-5.  Two Trend Display VI

The real-time trend indicator updates with a value for each tag every t
the indicator is written to. If a VI using this indicator is executed severa
times, it still has previous data displayed. For this reason, you might w
to initialize the real-time trend indicator before the loop begins executi
You also can control attributes of the real-time trend indicator such as t
scale. Figure4-6 shows a single real-time trend display VI that initialize
the time scale of the Trend indicator to the current time (read from Get D
Time in Seconds) and the interval corresponding to the Trend Tags time 
BridgeVIEW User Manual 4-30 © National Instruments Corporation



Chapter 4 Human Machine Interface

 to 

e 

nd 
e 

force 
 of 
f the 
 a 

on 
n 
se 
r 

n 
ls 
trol 
nto 

 
g 
interval  input. It also clears the trend display by writing an empty array
the Trends History Data attribute. 

Figure 4-6.  Initializing the Waveform Chart Indicator for a Real-Time Trend Display

This example illustrates the use of dataflow programming to enforce th
order of two structures that otherwise are not related by data flow. By 
wiring the time interval (secs) constant through the Sequence structure a
into the While Loop, the While Loop will not begin execution until the cod
in the Sequence structure has completed execution. Another way to en
this order of execution is to put the While Loop inside the second frame
the Sequence structure. Both techniques are correct. The advantage o
technique used in Figure4-6 is that it is easy to see the entire diagram at
glance.

How Can You Use Tag Attributes to Configure HMI Indicator Attributes 
Programmatically? 

Use the Tag Attributes VI library to read or change specific configurati
details of a tag. Anything you have configured in the Tag Configuratio
Editor can be queried programmatically using the Tag Attributes VIs. U
these VIs when you want to control attributes programmatically for you
front panel controls or indicators, or to display configuration informatio
on your HMI. Setting attributes programmatically for front panel contro
and indicators is an alternative to changing attribute values for the con
or indicator through the various front panel pop-up menus or by typing i
various control and indicator fields. 

Handling attributes programmatically is most useful when you use the
same indicator or control for different tags. For more information on ta
configuration, see Chapter 3, Tag Configuration. For more information 
about the Tag Attributes VIs, see the section Tag Attributes VIs in 
Appendix A, HMI Function Reference, and Chapter 7, Advanced 
Application Topics. 
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Figure4-7 shows a simple case where the scale range for all the front p
level and temperature indicators are set to the engineering scale that 
configured for the tag. A unit string display for each L1 and Temp indicator 
is initialized to the engineering unit for the respective tag. The Get Tag
Range and Units VI returns the engineering scale range information in
form that can be wired directly to a control or indicator scale range attrib
node. The VI also returns the engineering units configured for the tag.

Figure 4-7.  Using the Tag Attributes VIs to Initialize Front Panel Indicators, Frame 0
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Figure4-8 illustrates the subsequent frame of the Sequence structure. 
HMI runs in a loop, monitoring the various tags and front panel contro
until the BridgeVIEW Engine shuts down.

Figure 4-8.  Using the Tag Attributes VIs to Initialize Front Panel Indicators, Frame 1
© National Instruments Corporation 4-33 BridgeVIEW User Manual
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This chapter introduces the basic concepts of alarms and events, and
explains how to view, acknowledge, and configure them within the 
BridgeVIEW system. This chapter also provides activities that explain
how to build an alarm summary display and acknowledge alarms from
your HMI. 

What are Alarms and Events?
An alarm is an abnormal process condition pertaining to a tag. In 
BridgeVIEW, alarms are generated based on changes in a tag value 
or status.

An event is something that happens within the BridgeVIEW system. 
Events can be divided into two groups: those that pertain to individual t
and those that pertain to the overall BridgeVIEW system. Examples of
events include a change of alarm state for a tag, or the user changing
value of a tag. Examples of system events include a user logging on, t
Engine starting up, or historical logging being turned on. For more 
information about system events, see Chapter 2, BridgeVIEW 
Environment.

Alarm States
For analog tags, an alarm state can be of type HI_HI, HI, LO, or LO_L
For all data types (analog, discrete, bit array, and string), if the server 
returns a bad status, and you have enabled alarming on bad status, th
goes into Bad Status alarm. All data types except string also support al
based on tag value. If an analog tag exceeds a preconfigured alarm li
one of these alarms can occur. Discrete and bit array tags are either n
alarm or in alarm.

Alarm Limit
An alarm limit is the numeric value that an analog tag must exceed to 
into an alarm state.
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Alarm Priority
An alarm priority indicates the severity of an alarm. Priorities range fro
1 (lowest) to 15 (highest). You can filter the alarms displayed in your H
by alarm priority. 

Alarm Summary
An alarm summary is a collection of all the alarms that currently exist in
the system. In addition, if a tag previously in alarm returns to normal bu
unacknowledged, a notification is posted in the alarm summary. You c
report alarms to your HMI by using the Alarm Summary Display, which
available in the Controls»Alarms and Events palette of the front panel, 
and the Read Alarm Summary VI, which is available in the 
Functions»Alarms and Events palette from the block diagram. 

The alarms displayed in your Alarm Summary Display can be filtered 
group or tag names, priority, and acknowledgment status.

Event History
An event history is a collection of all the alarms and events pertaining to t
values that have occurred in the BridgeVIEW system since the Engine 
started. You can report recent events to your HMI by using the Event 
History Display, available in the Alarms and Events palette from the front 
panel, and by using the Read Event History VI in the Alarms and Events 
palette from the block diagram. The alarms displayed in your Event Hist
Display also can be filtered by group or tag names, priority, and 
acknowledgment status. 

How Do You Display Alarm Summary Information?
To read the alarms currently in the BridgeVIEW system, drop an Alarm
Summary Display from the Controls»Alarms and Events palette on your 
front panel. You can invoke the HMI G Wizard to create the block diagr
for an alarm summary, or you can build your own diagram. For more 
information about the HMI G Wizard, see Chapter 4, Human Machine 
Interface.

If you are building your own block diagram, use the Read Alarm Summ
VI in your block diagram. If you want to change the default fields (time
date, tag name, alarm limit) that are visible in the Alarm Summary Displ
you can use the Alarm Summary Format control from the 
Controls»Alarms and Events palette and change the checkbox selection
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You also can change the default colors of alarms, acknowledged alarms
unacknowledged tags that have returned to normal with the Color Cod
for Alarm Summary control, which also is available in the Alarms and 
Events palette.

Activity 5-1. Build an Alarm Summary Display
Your objective is to use the HMI G Wizard to display alarm summary 
information. 

1. Place an Alarm Summary Display from the Controls»Alarms and 
Events subpalette on a new front panel, as shown below. 
© National Instruments Corporation 5-3 BridgeVIEW User Manual



Chapter 5 Alarms and Events

he 
ble 
2. Pop up on the Alarm Summary Display, and select HMI G Wizard… . 
The following dialog box appears. 

3. Now, you can select the tags to monitor. In the tag list, select <ALL> to 
view alarms on all the tags that have alarms configured. Click on t
Add button to add all tags to the list. If you do not see a list of availa
tags when you click on the Tag menu ring, pop up with your right 
mouse button on the menu ring and select Tag Browser…. A dialog 
box appears and prompts you to select the desired .scf  file containing 
the configuration of your tags. Select mytanks.scf . Click on the OK  
button.
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The HMI G Wizard creates the diagram shown in the following illustratio

The diagram above uses event-driven programming to wait for an alar
summary event before updating the Alarm Summary Display. The Rea
Alarm Summary VI returns when an alarm event occurs on any of the t
in the tag constant array. The column headers for the Alarm Summary
Display are initialized when the Read Alarm Summary VI returns for th
first time, and the initialize  output is set. The Alarm Summary Display is
updated when the Read Alarm Summary VI returns with changed? set.

4. Save the VI as My Alarm Summary.vi  in the 
BridgeVIEW\Tutorial  directory. 

5. Run the VI. Now you can display the alarms on tags that have be
configured for alarms. By default, the Alarm Summary Display show
alarms as red when they are in an unacknowledged alarm state, ye
when they are acknowledged and in alarm, and green when they 
not in alarm but unacknowledged.

Note: If there are no alarms being displayed, launch the Tag Configuration Editor
(Project»Tag»Configuration) and open mytanks.scf . Edit it as indicated in 
Activity 3-1, save it, and relaunch the Engine. 

End of Activity 5-1.
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How Do You Display Event History Information?
To read all the alarms and events in the BridgeVIEW system that have
occurred since the Engine was started (unless limited by buffer size) d
the Event History Display from the Alarms and Events palette on your 
front panel. Then, you can invoke the HMI G Wizard to create the diagr
code for an event history. You also can build your own diagram and use
Read Event History VI in your block diagram. If you want to change th
default fields (time, date, tag name, alarm limit) that are visible in the Ev
History Display, you can use the Event History Format control from the
Controls»Alarms and Events palette and change the checkbox selection
You also can change the default colors of alarms, events, normal and
acknowledged alarms with the Color Codes for Event History control, 
which also is available in the Alarms and Events palette.

You also can report the status of alarms currently in the system using
output of either Read Alarm Summary VI or Read Event History VI, or 
using the Get Alarm Summary Status VI. This gives information on the
number of active alarms and unacknowledged alarms in the system. Y
can use the Alarm Summary Status control available in the Alarms and 
Events Controls palette to display this information on your HMI. 

How Do You Acknowledge Alarms? 
You can view the acknowledgment status of alarms in the Alarm Summ
or Event History Display. To acknowledge alarms currently in the syste
use the ACK  button from the Controls»Boolean palette on the front panel 
and the Acknowledge Alarms VI in the Functions»Alarms and Events 
palette in the block diagram. Activity 5-2, Acknowledge Alarms in the 
Alarm Summary Display, takes you through this process.

When you acknowledge these alarms, the acknowledgment status in 
Alarm Summary Display changes from UNACK to ACK, and the color of the 
text changes from red to yellow. These are the default colors, and you
change them.

There are two modes for handling tags that were previously in alarm b
have returned to Normal: Auto Acknowledge and User Must Acknowledge. 
These modes are configured in the Tag Configuration Editor for each 
If a tag is configured for Auto Acknowledge, when the tag returns to 
normal, the acknowledgment status automatically changes from UNACK to 
ACK. However, if it is configured for User Must Acknowledge, the statu
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remains at UNACK until the user presses the ACK  button on the HMI and 
acknowledges the alarm.

You can select the tags for which you want to acknowledge alarms. It 
good idea for this tag list to be identical to the list of tags you display ala
for in the Alarm Summary or Event History Display. For example, if yo
select group <ALL>, alarms for all tags that were configured for alarms a
reported as they occur. In the tag selection, you also can select a 
combination of tag names and groups.

Activity 5-2. Acknowledge Alarms in the 
Alarm Summary Display

Your objective is to acknowledge alarms from the HMI you built in 
Activity 5-1, Build an Alarm Summary Display.

1. Place an Acknowledge button from the Boolean subpalette on the 
front panel of the My Alarm Summary VI you created in Activity 5-1
Build an Alarm Summary Display. If your VI is running, you must stop 
the VI by pressing the Stop button or selecting Operate»Stop before 
you can do this. Your front panel should appear as shown in the 
following illustration. 
© National Instruments Corporation 5-7 BridgeVIEW User Manual
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2. Pop up on the ACK  button and select HMI G Wizard . The following 
dialog box appears. 

3. Select Alarm Acknowledgement for the Attach Control to:  option. 

4. Select the tags to monitor. In the tag list, select <ALL> to view alarms 
on all the tags that have alarms configured. Click on the Add button to 
add all tags to the list. Click OK .
BridgeVIEW User Manual 5-8 © National Instruments Corporation
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The HMI G Wizard creates the diagram shown below.

The Acknowledge Alarm VI is called when the front panel Ack button is 
pressed. This button is polled in a separate While Loop and the Read A
Summary VI waits for events in its own While Loop. 

5. Save the VI as My Alarm Summary with Ack  in the 
BridgeVIEW\Tutorial  directory.

6. Run the VI. When alarms appear in the Alarm Summary, click on 
Ack button. You can see the color of the Alarms change from red 
yellow. Acknowledged alarms that are normal disappear from the 
display.

End of Activity 5-2.
© National Instruments Corporation 5-9 BridgeVIEW User Manual
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How Do You Configure Logging and Printing 
of Alarms and Events?

You can configure logging and printing options for Alarms and Events
through the Event Configuration dialog box, shown in Figure5-1, Event 
Configuration Dialog Box. This configures the format of alarms and even
that are written to .evt  files or printed. You can reach this dialog box by
choosing Project»Tag»Configuration, and then Configure»Events from 
the Tag Configuration Editor. 

Figure 5-1.  Event Configuration Dialog Box
BridgeVIEW User Manual 5-10 © National Instruments Corporation
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Refer to Table5-1, Tag Configuration Editor Event Configuration 
Selections for a description of the general event configuration selection

Table 5-1.     Tag Configuration Editor Event Configuration Selections

Selection Description

Event Directory Determines the path to the directory where the event files are stored on d

Store absolute 
path

Determines whether the absolute path is stored.

Start event 
logging on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins logging
events when the Engine launches.

Days to keep 
event files

Determines how many days worth of event files are kept on disk. Anything
older than the number of days specified here is deleted automatically. 

Log Delimiter Determines the separator between parameters on a line. By default, it is th
character. This makes event files easy to import into a spreadsheet progr
Spreadsheet programs can handle other delimiters as well. 

Shift Display
(00:00  - 23:59 )

An array of numerics ranging between 00:00  and 23:59  hours to determine 
the length of the shift that events are logged in a file. At the end of the shi
a new event file is generated and written to. 

Start printing on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins printing
events when the Engine launches.

Printer Determines the port to which your printer is connected.

Print Delimiter Determines the separator between different parameters on a line. By defa
it is a comma. 

Min Priority Determines the minimum priority an event must have before it is logged. 
Events with priorities below this configured number are not logged. The 
minimum value is 1.

Max Priority Determines the maximum priority an event can have to be logged. Events
with priorities above this configured number are not logged. The maximum
value is 15.
© National Instruments Corporation 5-11 BridgeVIEW User Manual
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There are various format options for logging and printing. The print 
selections are a set of several parameters that determine the format o
data to be printed. Similarly, the log selections are a set of several 
parameters that determine the format of the data to be logged in an ev
file. These parameters are described in the following table. 

Table 5-2.     Event Configuration, Log, and Print Format Selections

Selection Description

Date Determines whether the date is logged or printed.

Date Format A menu ring that allows you to pick a format for the date to be printed. Th
selection is valid only if Date is selected. The menu items are: MM/DD/YYYY 
and DD/MM/YYYY.

Time Determines whether the time is logged or printed.

Time Format Determines the format for the time logged or printed. This selection is va
only if Time is selected. The menu items are: AM/PM and 24 HOUR.

Tag Name Determines whether the tag name is logged or printed.

Tag Name Field 
Length

Determines the maximum number of characters for the tag name. This 
selection is valid only if Tag Name is checked.

Event Type Determines whether the event name is logged or printed.

Group Name Determines whether the group name is logged or printed.

Group Name Field 
Length

Determines the maximum number of characters for the group name. This
selection is valid only if Group Name is checked. 

Alarm Value Determines whether the alarm value is logged or printed.

Alarm State Determines whether the alarm state is logged or printed.

Alarm Ack State Determines whether the alarm acknowledge state is logged or printed.

Alarm Priority Determines whether the alarm priority is logged or printed.

Alarm Limit Determines whether the alarm limit is logged or printed.

Operator Name Determines whether the name of the current operator is logged or printed
BridgeVIEW User Manual 5-12 © National Instruments Corporation
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How Do You Log Alarms and Events?
Events are logged in ASCII files named in the format YYMMDDHHMM.evt 
using the timestamp of the first point to be logged. YY is the Year, MM is the 
Month, DD is the Day, HH is the Hour, MM is the Minute and .evt  is the 
extension for all event log files.

There are three steps you must complete to log alarms and events. 

1. You must configure your tags to have Log/Print Events enabled. Y
configure it on a per tag basis. To select event logging for a single 
go to the panel for configuring the tag. 

2. You must configure a path to a directory for the event (.evt ) files. To 
choose the path, select Configure»Events in the Tag Configuration 
Editor. 

3. You must turn on event logging for the BridgeVIEW Engine, 
according to one of the three techniques outlined below. 

There are three techniques for turning event data logging on or off. 

• You can configure event logging in the Tag Configuration Editor. T
turn on event logging, use the pull-down menu for Configure»Events. 
Configure the path and set Start logging on system start-up to be 
TRUE. 

• For programmatic control, you can call the Enable Event Logging 
in the System palette. With this VI, you can turn event logging on o
off dynamically for all the tags in the system, while the BridgeVIEW
Engine is running. 

• The Engine Manager also has a button to turn event logging on or
If you have Supervise or higher-level privileges, you can access th
button.

Operator Name 
Field Length

Determines the maximum number of characters for the operator name. T
selection is valid only if Operator Name is checked. 

Alarm Message Determines whether the alarm message is logged or printed.

Alarm Message 
Field Length

Determines the maximum number of characters for the alarm message. 
selection is valid only if Alarm Message is checked.

Table 5-2.     Event Configuration, Log, and Print Format Selections (Continued)

Selection Description
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Table5-2, Event Configuration, Log, and Print Format Selections, 
provides a description of the event logging configuration selections.

How Do You Print Alarms and Events?
In BridgeVIEW, events are printed to a standard line printer through a
parallel port. There are three steps you must complete to print alarms 
events. 

1. You must configure your tags to have Log/Print Events enabled. Y
configure it on a per tag basis. To select event printing for a single 
go to the panel for configuring the tag. 

2. You must configure a printer for event printing. To choose the print
select Configure»Events in the Tag Configuration Editor. 

3. You must turn on event printing for the BridgeVIEW Engine, 
according to one of the three techniques outlined below. 

There are three techniques for turning event printing on or off. 

• You can configure event printing in the Tag Configuration Editor. T
turn on printing, use the pull-down menu for Configure»Events. 
Configure the printer and set Start printing on system start-up to be 
TRUE. 

• For programmatic control, you can call the Enable Printing VI in th
System palette. With this VI, you can turn event printing on or off 
dynamically for all the tags in the system, while the BridgeVIEW 
Engine is running. 

• The Engine Manager also has a button to turn event printing on or 
If you have Supervise or higher-level privileges, you can access th
button.

Table5-2, Event Configuration, Log, and Print Format Selections, 
provides a description of the printing configuration selections.

How Do You View Alarms and Events?
Event files are ASCII files and therefore can be read with any text edit
The default delimiter between the various parameters is a tab charact
which makes viewing the file in a spreadsheet program, such as Excel, 
convenient.
BridgeVIEW User Manual 5-14 © National Instruments Corporation
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This chapter explains the concept of a trend, how to log and extract 
historical data, and how to use the Historical Trend Viewer (HTV), a util
that displays historical data that has been logged to disk with BridgeVIE

What Is a Trend?
A trend is a display of tag values against time. BridgeVIEW displays ta
values with two types of trends: real-time trends and historical trends. Y
can find these trends in the Controls palette.

Real-Time Trend
A real-time trend is a display of tag values as they are collected in real 
over a relatively short period of time. You can display a real-time trend
your HMI by using the Trend Tags VI in the Tags palette in the block 
diagram. You also can use the HMI G Wizard to create a real-time tre
For more information about the HMI G Wizard, see Chapter 4, Human 
Machine Interface.

Historical Trend
A historical trend is a display of tag values that have been logged to d
This is usually over a relatively long period of time. You can display a 
historical trend in your HMI by using the Get Historical Tag List VI and
Read Historical Trend VI from the Historical Data palette from the block 
diagram. You also can view historical data by launching the HTV utility
You can use the HMI G Wizard to create a historical trend display.
dgeVIEW User Manual
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What Is Citadel?
Citadel is a high performance historical database. With Citadel, 
BridgeVIEW can log tags while continually servicing data queries.
BridgeVIEW also includes the Citadel ODBC driver that has special 
commands to perform data transforms, making it easy for you to retrie
manipulate, and analyze historical data automatically from outside the
BridgeVIEW environment. For more information, see Appendix B, Citadel 
and Open Database Connectivity. 

How Do You Log Historical Data?
There are three steps you must complete to log historical data.

1. You must configure your tags to have historical logging enabled. Y
configure it on a per tag basis. To select historical logging for a sin
tag, go to the panel for configuring the tag. 

2. You must configure a path for the historical database. To choose 
path, select Configure»Historical in the Tag Configuration Editor. 

3. You must turn on historical logging for the BridgeVIEW Engine, 
according to one of the three techniques outlined below. 

There are three techniques for turning historical data logging on or off

• You can configure historical logging in the Tag Configuration Edito
To turn on logging, use the pull-down menu for 
Configure»Historical. Configure the path and set Start logging on 
system start-up to be TRUE. 

• For programmatic control, you can call the Enable Historical Data
Logging VI in the System palette. With this VI, you can turn historical
data logging on or off dynamically for all the tags in the system, wh
the BridgeVIEW Engine is running. 

• The Engine Manager also has a button to turn historical data logg
on or off. If you have Supervise or higher-level privileges, you can
access this button.
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When you log historical data for your application, there is a coupling 
between your configuration (.scf ) file and the Citadel Historical 
Database. When you decide to archive these, take the .scf  file along with 
your historical files to the new location. Although you can retrieve 
historical data without the .scf file, you will not have the tag 
configuration information, such as engineering range and unit, unless 
archive the .scf file as well. 

Preferably, maintain the relative path between the .scf  file and the 
historical files in this new location. For example, if your .scf  file is in 
C:\ARCHIVE , keep your historical database in C:\ARCHIVE\DATA . If you 
save a new .scf  file and have not specified a historical data directory, yo
are prompted to specify the path and the directory is created for you.

How Do You Configure Historical Logging?
You can reach the Historical Logging Configuration dialog box by 
selecting Configure»Historical from the Tag Configuration Editor. 
Figure6-1 shows the Historical Logging Configuration dialog box and 
Table6-1 lists parameters you can configure for historical logging.

Figure 6-1.  Historical Logging Configuration Dialog Box
© National Instruments Corporation 6-3 BridgeVIEW User Manual
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How Do You Extract and View Data 
from Historical Log Files?

There are two methods for viewing historical data that has been logge
disk. One method is to use the Historical Data VIs and the other is to u
the Historical Trend Viewer (HTV). Both of these methods are describ
here in detail.

Historical Data VIs
There are several VIs you can use in your HMI to manipulate data log
in Citadel files. These VIs access disk files and do not require the 
BridgeVIEW Engine to be running. You can use these VIs to browse fil
extract the information in a format that can be displayed in a Historica
Trend indicator, or export the data to a spreadsheet file format. There 
several examples in the HMI Examples\Historical Data folder to 
illustrate this. The main VIs for getting historical data and manipulating
are listed below. For complete information about these or any other V
refer to Appendix A, HMI Function Reference. 

• Decimate Historical Trend

• Decimate Historical Trends

• Get Historical Tag List

Table 6-1.     Parameters You Can Configure for Historical Logging

Selection Description

Citadel Data Directory Path that determines the directory where historical data files are sto
on disk.

Store absolute path Determines whether the absolute path is stored.

Start logging on system 
start-up

Determines whether the BridgeVIEW Engine automatically begins 
logging historical data when the Engine launches.

Days to keep historical 
files

Determines how many days worth of historical log files to keep on dis
Anything older than the number of days configured here is deleted 
automatically.

Maximum time between 
log records

Time, in seconds, that determines the logging rate for tags that vary
slowly.
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• Get Historical Trend Info

• Historical Trend Statistics

• Historical Trends to Spreadsheet

• Read Historical Trend

• Read Historical Trends

The following illustration shows a VI for viewing historical data files 
anywhere in the system. 

If the Citadel Path is empty, the File Dialog function is executed. This 
brings up a File dialog box that lets the operator select the directory 
containing the historical data files.

The example then uses the tag list  returned by the Get Historical Tag 
List VI to set up a list of names in the front panel Tag List listbox. It us
the first timestamp  output to initialize the Start Timestamp  control 
on the front panel. By default, the example displays the first 60 second
worth of data on the historical data display. Historical data is displayed
using the XY Graph indicator named Historical Trend Display.
© National Instruments Corporation 6-5 BridgeVIEW User Manual
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The Read Historical Trends VI returns historical data from Start 

Timestamp  to Stop Timestamp  for the tags that are selected in the Ta
List listbox and returns data in a form that can be wired directly to an 
XY Graph.

The shift register in the while loop is used to detect user input change
the operator interface by remembering the previous Start Timestamp , 
Stop Timestamp , and the selected tag list . If any of these controls are
changed, historical data is retrieved for the new settings and the XY Gr
indicator is updated.

Activity 6-1. Use the Historical Data VIs
The objective of this exercise is to create a VI that programmatically 
reads historical information from Citadel and determines statistical 
information of the data.

In this activity, you will read previously logged data, which is included 
the BridgeVIEW\Tutorial\Data  directory. You will use mytanks.scf  
in the BridgeVIEW\Tutorial  directory, as edited in Activity3-1, 
Configure a Tag, and View the Tag Configuration Parameters and Tag
Values.

1. Open a new VI and place a Historical Trend on the panel window fr
the Controls»Graph palette. Change the maximum of the Y scale 
to 1000 .
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2. Pop up on the Historical Trend and select HMI G Wizard… . If a 
dialog box prompts you to locate a Citadel Data directory, select 
BridgeVIEW\Tutorial\Data . Complete the dialog box, as shown
in the following illustration. 

You will display previously logged data, which is included in the 
BridgeVIEW\Tutorial\Data  directory. It contains a 25-minute run of 
data. You can change the time axis to display the first minute of this d

3. Run the VI. The trend displays one minute of data. You can use th
panning tool to grab the plot and scroll to the left or right to show mo
data. Hold down the <Shift> key while you pan to constrain the 
movement to the horizontal direction.

4. Stop the VI.

5. Modify the Block Diagram to incorporate statistics. 

a. In the block diagram, pop up on the wizard lock and select 
Release Wizard Lock. Now, you can edit the diagram to 
incorporate statistics into your data retrieval application.

b. Using a For Loop and the Historical Trend Statistics.vi  
(Functions»Historical Data), build the diagram as shown below
If you click and drag the Positioning tool inside the case structu
© National Instruments Corporation 6-7 BridgeVIEW User Manual
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while holding down the <Ctrl> key, the diagram will expand to
give you some room to add the new diagram code.  

6. On the front panel, create an array of numeric indicators. Stretch 
array indicator so that four fields are showing. Then pop up on the
array indicator and select Show»Index Display to deselect the index 
display, as shown below.

7. Run the VI. 
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Initially, the historical trend displays the first minute of data in the set, 
along with the averages for the four tags. The averages are calculated o
data that is displayed. You can use the panning tool to display a differ
section of data. The averages are updated automatically.

8. Save the VI as Historical Data.vi  in the 
BridgeVIEW\Tutoria l directory. 

End of Activity 6-1.

 Historical Trend Viewer (HTV)
The HTV is a stand-alone utility that enables you to look at historical d
in your system. The HTV limits you to viewing no more than eight tags
a time. If you want to look at more tags in a single historical trend, you
should build your own utility using the Historical Data VIs. 

To start the HTV, select Project»Historical Trend Viewer…. The HTV 
is shown in the following illustration. 

Figure 6-2.  Historical Trend Viewer
© National Instruments Corporation 6-9 BridgeVIEW User Manual



Chapter 6 Historical Data Logging and Extraction

e 

he 
How Do You Select the Tags To Display?
Select File»Select Tags…, and the Select Tags dialog box appears, as 
shown in Figure6-3. With this dialog box, you can select either a .scf  file 
or a directory of Citadel files. The default is to choose a .scf  file. The 
.scf  file you choose must point to a valid directory of Citadel files. If th
BridgeVIEW Engine is running, the .scf  file being used by the 
BridgeVIEW Engine is displayed. 

 

Figure 6-3.  Select Tags Dialog Box

Note: You can look at data from only one Citadel database at a time.

Select the tags from the Available Tags list that you want to display. T
HTV displays the tags in the order that they are listed in the Tags to 
Display list.

Note: You can view configuration information about a tag by selecting it in the 
Available Tags list, and clicking on the Tag Information  button.
BridgeVIEW User Manual 6-10 © National Instruments Corporation
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How Do You Change the Time Axis?
You can change the time axis for a trend within the HTV manually, or 
using Panning buttons. 

Panning Buttons
The Panning Buttons allow you to move backward and forward through
historical data in the trend. The buttons do not affect the timespan of t
trend. For example, if the trend displays data from 9:45 to 9:55 on the s
day, the timespan is ten minutes. Table6-2 describes the Panning button 
functions.

Table 6-2.     Panning Button Functions

Button Name Description

|< Retrieve oldest data Displays the first available page of data.

<< Back to closest point Centers the display around the closest point to the left 
of the timespan. If there is no data in the previous time spa
skips to the previous end of data.

< Back one-half page Moves the display back by half of the current timespan.

> Forward one-half page Moves the display forward by half of the current timespan.

>> Forward to closest point Centers the display around the closest point to the right 
of the timespan. If there is no data in the next time span, sk
to the next start of data.

>| Most recent data Displays the most recent available page of data.
© National Instruments Corporation 6-11 BridgeVIEW User Manual
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Manual Changes
Alternatively, you can select the text at either end of the time axis and
change the data. You must enter the date in the correct format. If you m
an error, the input is ignored.

You can select and enter the time and date on the time (X) axis of the
historical trend on the HTV directly. However, the HTV responds 
immediately to any changes you make. If you want to make manual ed
to both the start and stop time on the time axis, you can select the 
Viewer»Time & Date option. When you select this option, a dialog box
appears, shown below, and you can enter the start and stop time of the
displayed in the trend.

How Do You Change the Timespan of Data 
Displayed?
The timespan indicator displays the amount of relative time between t
start and end points of the time axis. To change the amount of time betw
these points, you either can manually re-enter data in the start or end p
on the time axis, or pull down the ring for the timespan indicator.

By default, the timespan ring contains the values 1:00, 5:00, 10:00, an
30:00. Select Enter New… in the timespan ring if you would like to enter
a different amount of data to display.
BridgeVIEW User Manual 6-12 © National Instruments Corporation
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How Do You View the Value of a Tag at a Specific 
Point in Time?
The Data Display table on the HTV, shown in Figure6-2, shows the tags 
displayed in the trend, the tag description, and, for analog tags, the 
engineering units associated with the tag. The two rightmost columns s
the values of the tags at the two cursor locations in the trend. For disc
tags, the values in these columns are either “On” or “Off.” To move the
cursors, grab their pointers at the bottom of the trend display. 

How Do You Change the Y Axis?
The HTV displays two Y axes at any time. Each Y axis displays the co
of the tag associated with it. All discrete tags show their ranges as goi
from “Off” to “On.” Click on the Y axis to make it rotate through the tag
displayed in the trend.

To change the range in the Y axis for analog and bit array tags, select
text at the top or bottom of the scale and type in the desired value. Wh
you enter the value, that trend scale changes and the trend display upd
Discrete tags are displayed without Y axis scales, and ranges are sho
“On” or “Off.”

How Do You Change the Plot Colors and Style 
in the Trend?
Click on the Trend Legend. The pop-up window contains several optio
with which you can change the plot colors and styles used in the trend

How Do You Zoom In on the Trend?
The HTV Trend  palette contains a Zoom tool that allows you to zoom 
on points of interest. The Zoom tool has five modes with which you ca
zoom in on the trend: 

• Zoom by rectangle

• Zoom time scale

• Zoom Y scale

• Zoom in about one point

• Zoom out about one point

Undo Zoom resets the graph to its previous setting.
© National Instruments Corporation 6-13 BridgeVIEW User Manual
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How Do You Export Data to a Spreadsheet?
From the HTV, select File»Export…. The HTV exports the information 
currently displayed in the trend to a tab-delimited file. A dialog box 
prompts you for the name and location of the file to create. 

The HTV resamples data in periodic intervals so that all tags have the s
number of data points. The frequency defaults to a value according to
frequency of data in the historical files. If you want to override this valu
enter the frequency you want in the dialog box.

How Do You Get Online Help for the HTV?
From the HTV, pull down the Help menu and select Show Help. A floating 
window is displayed that shows help information for all of the objects o
the HTV panel.

How Do You Set Tag, Time, and Color Preferences?
Set the preference for the HTV to remember settings for display time a
color on exit by selecting Viewer»Preferences. When you exit the HTV, 
the state of the viewer is recorded.

 

Select the Remember settings on exit checkbox if you want to update your
settings each time you exit the HTV. 
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How Do You View New Data Automatically After It 
Has Been Logged to Citadel?
You can use Live Mode to watch incoming data after it has been logge
When the Engine is turned on with historical logging enabled, the Live 
button appears to the right of the panning buttons. When you click the Live 
button, the trend automatically updates periodically. Select 
Viewer»Preferences… in the HTV Preferences dialog box to set how 
often the trend will display the new data. The default is 10 seconds. If 
Always scroll with new data is checked, the display updates whenever
new data is logged or after the Scroll time has elapsed. 

While Live Mode is turned on, the values for each tag are extrapolated
the last time the trend was updated. These extrapolated values are ma
with an asterisk in the Data Display. When a cursor or slider is placed
before the extrapolation begins for a tag, the asterisk will not be prese
Turning off Live Mode also turns off extrapolation.

How Do You Incorporate the HTV 
into Your HMI Application?
The HTV is available by selecting Project»Historical Trend Viewer. 
However, in many HMI applications you might elect not to give the 
operator access to the standard menu bar. You can use the Call HTV
located in the Historical Data subpalette of the Functions palette, to call 
the HTV dynamically from your HMI application. See the section 
Historical Data VIs in Appendix A, HMI Function Reference, for details 
on how to use this or any other VI.
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Activity 6-2. Use the Historical Trend Viewer
The objective of this activity is to view logged data with the Historical 
Trend Viewer.

You will use mytanks.scf  in the BridgeVIEW\Tutorial  directory, as 
edited in Activity3-1, Configure a Tag, and View the Tag Configuration
Parameters and Tag Values. You will view previously logged data 
spanning over 25 minutes, which is included in the 
BridgeVIEW\Tutorial\Data  directory.

1. Launch the HTV by selecting Project»Historical Trend Viewer….

2. The Select Tags for HTV dialog box appears. Select the Powder, 
Mixer, Liquid, and Product tags from the list of Available Tags and
add them to the Tags to Display list. Click on OK .
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When you close the Select Tags for HTV dialog box, the Historical Tre
Viewer appears, as shown in the following illustration. 

 

The HTV displays the trends for the Powder, Mixer, Liquid and Produc
tags. The Available Data display shows the start and stop timestamps o
logged data. The status of the HTV is displayed on top of the Historica
Trend. You can see it change from Accessing Disk to Running. The leg
to the right of the Historical Trend shows the tag names and the plot co
as they appear on the trend and in the scales.

3. View the first five minutes in the data set by clicking on the first scr
button in the set below the Historical Trend. The beginning of the d
is centered in the display.

4. Scroll through the data set using the other buttons below the Histor
Trend.

5. The scales to the left of the Historical Trend show the minimum a
maximum of the Mixer and Powder tags. To view the scales for th
other tags, click on one of the scales. You can see the color and t
name in the display above the scale change. As you click, it rotate
through the list of tags displayed in the HTV.
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6. To zoom in on the data, select the magnifying glass from the pale
and click and drag over a section of the trend.

7. To see the value of a particular data point, use the two vertical cur
on the trend. You can see the value of the data point on each tren
the given cursor location in the Data Display.

8. Select File»Exit to terminate the HTV.

End of Activity 6-2.
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This chapter explains advanced topics you need to understand to mak
optimum use of BridgeVIEW for developing applications. The advance
topics covered in this chapter are listed below:

• Using the Panel G Wizard

• BridgeVIEW System Control

• Tag Attributes VIs

• BridgeVIEW Security

How Do You Build an HMI with Multiple Panels?
Consider dividing your HMI into several panels so the operator can 
navigate through them using onscreen buttons. The Panel G Wizard h
you generate the navigation system by automatically generating code
attaching it to front panel buttons.

Front Panel Buttons
Buttons are the most common mechanism for navigating through differ
panels. Operators can use buttons to close windows, invoke login prom
or display different panels. BridgeVIEW contains a variety of different 
buttons that you can use and customize. Buttons are located in the 
Controls»Boolean subpalette.
dgeVIEW User Manual
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Panel G Wizard
The Panel G Wizard provides an easy interface for you to generate a pa
navigation system for your operators. With the Panel G Wizard, you c
attach code to buttons that, when pressed by the operator, will open y
VIs. If your are new to G programming, the Panel G Wizard can be an
immense help in producing applications with multiple windows and pan

The Panel G Wizard provides the basic mechanism to attach panel 
management code to buttons. For more advanced capabilities, see thVI 
Control VIs section in this chapter.

How Do You Use the Panel G Wizard?
The Panel G Wizard only operates on Boolean controls. To invoke the
Wizard, pop up on a front panel Boolean control and select 
Panel G Wizard…. For example, the Panel G Wizard dialog box appea
in Figure7-1 by popping up on a button control.

Note: Because the code created by the Panel G Wizard contains file path 
information, some features will not generate correct code until the calling 
panel is saved to disk. For this reason, you should save your VI to disk befo
invoking the Panel G Wizard.

 

Figure 7-1.  Panel G Wizard
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The Panel G Wizard provides a mechanism to open or close a panel w
the button is pressed. You determine this action by operating the With this 
Control  ring near the top of the Panel G Wizard dialog box.

The Panel G Wizard can create code that will open three types of pan

• VIs that you have created and saved to disk

• a Login prompt

• the Historical Trend Viewer

When opening VIs that you have created, you specify the path to the V
typing it in the Path to VI control or by selecting the Browse button. You 
can configure the Panel G Wizard to store the file path as a relative pa
as an absolute path. If the VI that you connect to the button is generally 
in a path that is relative to the top-level VI, you should select the Relative 
path setting.

How Do You Configure Security 
with the Panel G Wizard?
The Panel G Wizard can create code that disables or hides the button 
operator does not have sufficient security access. You determine the ac
level required in the Panel G Wizard dialog box. Security is covered la
in this chapter.

How Do You Configure When a Button 
Will Be Polled?
Like all user interface controls in BridgeVIEW, front panel buttons are 
monitored using a polling loop mechanism. Polling will occur either un
the BridgeVIEW Engine shuts down, or, if the Always option is selected, 
until the VI stops.

Activity 7-1. Use the Panel G Wizard
Your objective is to use the Panel G Wizard to attach buttons to VIs th
you have created, to the HTV, and to a Login prompt. You will use VIs
that you created in Chapters 4, 5, and 6 in this exercise. You will use 
mytanks.scf  in the BridgeVIEW\Tutorial  directory.

1. Place a front panel button on a new front panel, as shown below. C
on the button text with the labeling tool and name the button Alarms . 
© National Instruments Corporation 7-3 BridgeVIEW User Manual
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Pop up on the button and make sure the Mechanical Action… is set to 
Latch when Released.

 

2. Save the VI as My Menu Bar.vi  in the BridgeVIEW\Tutorial  
directory.

3. Pop up on the Alarms button and select Panel G Wizard…. 
Configure the button to open the My Alarm Summary with Ack.vi  
that you created in Activity5-2, Acknowledge Alarms in the Alarm 
Summary Display, as shown below.
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4. Examine the block diagram created by the Panel G Wizard. The 
diagram code is locked as indicated by the lock icon in the upper ri
corner of the window. The locking mechanism works the same way
it does for the HMI G Wizard.

 

5. Make a copy of the Alarms button. Click on the button text with the 
labeling tool and name the button Monitor .

6. Pop up on the Monitor  button and select Panel G Wizard…. Use the 
same settings as before, but connect this button to the Monitor 

Product.vi  you created in Activity4-3, Read a Tag.

7. Make a copy of the Monitor  button. Rename the button Trend . Using 
the Panel G Wizard, connect this button to the My Tank HMI.vi  you 
created in Activity4-1, Use the HMI G Wizard.

8. Your front panel should now look like this.
 

© National Instruments Corporation 7-5 BridgeVIEW User Manual
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9. Before you run the VI, make sure that the correct mytanks.scf  file 
is being used. If the engine is currently running, you can check 
the Engine Manager display. If an incorrect .scf  file is in use, stop 
the engine and open the Tag Browser. Select Tag Browser… to 
configure BridgeVIEW to open the mytanks.scf  file in the 
BridgeVIEW\Tutorial  directory. Launch the engine either from th
Engine Manager display or by selecting Project»Launch Engine….

10. Save My Menu Bar.vi . Run the VI. When you press on one of the
buttons, the appropriate panel should open and run.

11. Experiment with other buttons to open the Historical Trend Viewe
invoke a Login prompt, and so on. You can also configure security
access checks on the buttons.

End of Activity 7-1.

VI Control VIs
The VI Control VIs provide you with several functions to control your VI
such as panel location, size, and visibility. These VIs are very useful w
your application requires a large number of different operator screens

For example, you might find it unnecessary to load certain panels into y
application until they are needed. By using these functions, you can con
when your panels are loaded into memory. You can reach the VI Cont
VIs through the Functions»VI Control palette, shown below.
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For more information about the VI Control VIs, see Chapter 14, VI Control 
VIs, or the Online Reference.

How Do You Control Panel Size?
You can use the Get Panel Size and Resize Panel VIs to query or set th
of an operator interface panel. Notice that these functions can operate
the panel size or the window size. The panel size does not include the
window title bar, scrollbars, menu bar, or toolbar, while the window siz
includes all of these components. Panel and Window sizes are given 
pixels.

How Do You Control Panel Visibility?
There are several ways to control the visibility of an operator interface
panel from your application. These options are listed below:

• Enable the Show Front Panel when Called and Close Afterwards if 
Originally Closed options in the VI Setup Execution options. This 
option applies only to subVIs.

• Enable the Show Front Panel when Called and Close Afterwards if 
Originally Closed options in the SubVI Node Setup options. This 
option applies when you call the VI as a subVI.

• Use the Call Instrument VI.

• Use the Preload Instrument VI in conjunction with the Open Panel a
Close Panel No Abort VI.

BridgeVIEW System Control
As you develop more sophisticated user interfaces, you might find that 
need to exercise control over portions of the BridgeVIEW environmen
from your own applications. The System VIs palette provides mechani
to programmatically control the BridgeVIEW Engine.

System VIs
The System VIs provide you with several functions that control actions
such as launching and shutting down the Engine, enabling and disabl
© National Instruments Corporation 7-7 BridgeVIEW User Manual
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logging, invoking the Login dialog box, and so on. You can reach the 
System VIs through the Functions»System VIs palette, shown below. 

 

For more information about the System VIs, refer to Appendix A, HMI 
Function Reference. 

How Do You Start or Stop the BridgeVIEW Engine 
from Your Application?
Use the Engine Launch VI to launch the BridgeVIEW Engine 
programmatically with a specified configuration file. Use the Engine 
Shutdown VI to stop the BridgeVIEW Engine and the servers currently
executing. For more detailed information about these or any other VIs
refer to Appendix A, HMI Function Reference.

How Do You Start or Stop Historical Logging from 
Your Application?
Use the Enable Historical Data Logging VI to start historical logging. If t
input value is TRUE, historical logging is turned on if it is currently off. I
the input value is FALSE, historical logging is turned off if it is currently o

How Do You Start or Stop Event Logging from Your 
Application?
Use the Enable Event Logging VI to start event logging. If the input va
is TRUE, event logging is turned on if it is currently off. If the input valu
is FALSE, event logging is turned off if it is currently on.

How Do You Start or Stop Event Printing from Your 
Application?
Use the Enable Printing VI to start event printing. If the input value is 
TRUE, event printing is turned on if it is currently off. If the input value 
FALSE, event printing is turned off if it is currently on.
BridgeVIEW User Manual 7-8 © National Instruments Corporation
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Tag Attributes VIs
There is a set of VIs in the Tag Attributes  palette with which you can read
or change configuration information about tags programmatically. Mos
these tag attributes are parameters you can configure for a tag with the T
Configuration Editor. They fall into five categories:

• General Tag Information

• I/O Connection

• Operations

• Scaling

• Alarms

Note: Not all parameters configured in the Tag Configuration Editor can be 
changed programmatically.

You can programmatically take a tag on or off scan. If a tag is off scan
is not processed, or updated, in the Real-Time Database, and alarms a
calculated and data is not logged. You can start these activities by put
that tag back on scan.

There are specific VIs you can use to obtain certain tag information, s
as the Get Tag Logging Info VI or the Get Tag Alarm Enabled VI. There
a generic VI called Get Tag Attribute that you can use to choose an attri
from a list and obtain its value.

If the Engine is running, you can change tag attributes programmatica
with the Set Tag Attribute or Set Multiple Tag Attributes VIs. These VI
return an error if the Engine is not running. Tag attribute changes stay
effect in the current run only. If you stop the Engine and start it again, 
changes are lost. Use these VIs in your application when you want to 
change attributes of a tag dynamically, as with logging, alarm, or scali
information, or taking a tag on or off scan. For a complete description 
the Tag Attributes VIs, refer to Appendix A, HMI Function Reference.

There are certain attributes you cannot change dynamically. These 
attributes require you to edit the .scf  file with the Tag Configuration 
Editor, and they include tag information like tag name, tag description
scaling type, engineering unit, data type (analog, discrete, bit array, stri
tag group name and access rights (input only, output only, Input/Outp
memory). 
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You cannot change tag connection information like server, IO Group, a
item dynamically either. You can change all operations, alarms, and m
scaling, and raw or engineering range information dynamically.

For more information about tag attributes, refer to any one of the five 
configuration attributes tables in the section How Do You Configure Tags? 
in Chapter 3, Tag Configuration. 

Activity 7-2. Use Tag Attributes
Your objective is to use tag attributes to change alarm limits dynamical

You will use mytanks.scf  in the BridgeVIEW\Tutorial  directory, as 
edited in Activity3-1, Configure a Tag, and View the Tag Configuration
Parameters and Tag Values.

1. Open Monitor Product.vi  from the BridgeVIEW\Tutorial  
directory. You created this VI in Activity4-3, Read a Tag. If you did 
not complete this activity, you can open the VI from the 
BridgeVIEW\Tutorial\Solutions  directory.

2. Open the block diagram, select the While loop, and delete it. Beca
you released the Wizard Lock in Activity 4-3, the HMI G Wizard wil
no longer replace the old code, but will generate additional code 
instead.

3. Pop up on the tank on the front panel and select HMI G Wizard . 
Change the Normal color to Blue, and select the Alarms to show for 
the HI alarm state only, as shown in the following illustration.
BridgeVIEW User Manual 7-10 © National Instruments Corporation
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4. Run the VI. Because the Product tag is configured to go into HI ala
when it exceeds a value of 800, you can see that the tank color is 
while the tag value is below 800. It changes from blue to red when
value goes above 800. Leave this VI running.

5. To change the HI alarm limit of Product dynamically, open a new V
Drop the Set Tag Attribute VI from the Functions»Tag Attributes 
palette.

6. Using the wiring tool, create constants for the group/tag names, tag 
attribute , and value inputs.

7. Select Product for the group/tag names input, change tag attribute  
from the default 0 to 16, and wire in 500.00  for the value as shown in 
the following illustration. 16 is the value for the HI Limit tag attribute
To look up the attributes, open the front panel of the Set Tag Attribu
© National Instruments Corporation 7-11 BridgeVIEW User Manual
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VI and select the desired tag attribute to see the attribute number in
digitial display.

8. Save the VI as Change Alarm Limit.vi  in the 
BridgeVIEW\Tutorial  directory.

9. Run this VI. This dynamically changes the HI limit for the Product t
from 800 to 500.

10. Look at Monitor Product.vi . It still should be running. However, 
now you should see the color change from blue to red when the va
exceeds 500, instead of 800.

11. Stop and close the VIs.

End of Activity 7-2.
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BridgeVIEW Security
BridgeVIEW security is broken into two general categories:

• Environment Security (User Privileges)

• Operator Interface Security

Security does not take effect until you configure it. Configuration consi
of adding users and assigning them access levels, privileges, and 
passwords.

Environment Security
Access to most BridgeVIEW utilities and the BridgeVIEW Engine can 
configured on a per-user basis. For example, not all users should be ab
configure the tags in the system or create and edit user accounts. The
privileges that can be assigned to a user are defined in Table7-1.

Table 7-1.     BridgeVIEW Environment Privileges 

Type Privilege Description

Environment 
Privileges

Use Historical Trend Viewer User can launch, configure, and use the 
Historical Trend Viewer utility

Use Tag Monitor User can launch, configure, and use the Ta
Monitor utility

Use Tag Browser User can use the Tag Browser utility

Use Server Browser User can use the Server Browser utility

Disable <Alt> Key If enabled, the <Alt> key on the keyboard is
disabled in BridgeVIEW

Configure Startup VIs User can assign VIs to launch when 
BridgeVIEW is started
© National Instruments Corporation 7-13 BridgeVIEW User Manual
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Project 
Privileges

Configure Log File Locations User can use the Tag Configuration Editor to
edit the historical and event logging 
configuration of a tag configuration, but can
not create, delete, or edit tags

Create/Edit Tags User can create, delete, and edit tags in the
Tag Configuration Editor

Use Interactive 
Server Tester

User can launch the Interactive Server 
Tester; this privilege can be configured only
if the VI Server Developer Toolkit is 
installed

Engine 
Privileges

Start/Stop Engine User can start and stop the Engine via the 
Engine Manager

Start/Stop Historical Logging User can start and stop Historical Logging 
via the Engine Manager

Start/Stop Event Logging User can start and stop Event Logging via th
Engine Manager

Start/Stop Printing User can start and stop Event Printing via th
Engine Manager

Security 
Privileges

Change Password User can change his or her own password

Create/Edit Access Levels Using the Access Levels dialog box, the use
can add, remove, and edit access levels low
than his or her own access level.

Create/Edit User Accounts User can create and edit user accounts whic
have an access level lower than his or her 
own access level

Configure User Privileges User can change the privileges assigned to
other users who have an access level lowe
than his or her own. This privilege requires 
that the user also have the Create/Edit Use
Accounts privilege, described above.

Table 7-1.     BridgeVIEW Environment Privileges  (Continued)

Type Privilege Description
BridgeVIEW User Manual 7-14 © National Instruments Corporation
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A user’s BridgeVIEW Environment privileges are completely independe
of the user’s access level, and do not directly affect access to objects i
operator interfaces that you develop for your application. See the sect 
Operator Interface Security in this chapter for more information.

How Do You Log In and Out?
To log in, choose Project»Security»Login. Type in your account name 
and password. If you do not know your login name, or have forgotten y
password, contact your BridgeVIEW administrator.

To log out, choose Project»Security»Logout.

How Do You Find Your Access Level?
After you have logged in, you can find your access level by choosing 
Project»Security»Access Levels…. When you make this selection, the 
Access Levels dialog box appears, as shown in Figure7-2. 

Figure 7-2.  Access Levels Dialog Box

You also can view your privileges by clicking the Privileges… button. For 
more information about privileges, refer to Table7-1 and to the section, 
How Do You Find Your Environment Privileges?.
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How Do You Find Your Environment Privileges?
After you have logged in, you can find your environment privileges by 
choosing Project»Security»Privileges…. When you make this selection,
the Privileges dialog box appears, as shown in Figure7-3. 

Figure 7-3.  Privileges Dialog Box

For more information about BridgeVIEW user privileges, refer to 
Table7-1.

How Do You Change Your Password?
You must be logged in to change your password. Choose 
Project»Security»Change Password. 

Type in your old password, then your new password. Type in your new
password again to verify it.

How Do You Check a User’s Privileges?
Use the Check Operator Privileges VI in the System»Security palette. this 
VI will check the current user’s privileges to see if the user has a partic
privilege. An example is shown below.
BridgeVIEW User Manual 7-16 © National Instruments Corporation
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How Do You Prompt the Operator to Log In 
to Your Application?
Use the Invoke Login DialogVI in the System»Security palette. This VI 
launches the Login dialog box and returns the user name and access 
You can have your application control login as part of its HMI. For mo
information about this or any other VI, refer to Appendix A, HMI Function 
Reference.

How Do You Programmatically Log an Operator In 
to Your Application?
Use the Programmatic Login VI in the System»Security palette. To use 
this VI, you must enter a user name and password. If successful, the u
logged in to the system, and no Login dialog box appears.

How Do You Programmatically Log an Operator Out 
of Your Application?
Use the Programmatic Logout VI in the System»Security palette. This VI 
logs the current user out of the BridgeVIEW system.

How Do You Identify the Current Operator?
Use the Get Operator Name VI in the System»Security palette. This VI 
returns the name and current BridgeVIEW operator name and access l
For more information about this or any other VI, refer to Appendix A, HMI 
Function Reference.

How Do You Restrict Access to the BridgeVIEW 
Environment?
When you install BridgeVIEW, no user accounts exist, so all users have
access to the system. You must create user accounts for the normal se
features to take effect. When you create user accounts, you assign an a
level to each account. 

When a user logs in, BridgeVIEW obtains the user’s privileges and acc
level. Your HMI VIs also can enforce security by determining whether t
current user can operate, or even see, a particular control or indicator.

See the section Operator Interface Security in this chapter for more 
information about using security in your HMI.
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How Do You Create and Modify User Accounts?
To create and modify user accounts, you must have the Create/Edit U
Accounts privilege. To change a user’s privileges, you also must have
Configure User Privileges privilege. To edit the list of user accounts, 
choose Project»Security»Edit User Accounts…, and the Edit User 
Accounts dialog box appears, as shown in Figure7-4.

Figure 7-4.  Edit User Accounts Dialog Box

Click the Add New Users>> button to create a new user account. Type 
a name, select an access level, and provide a password for the accou
modify the privileges for the account, click the Privileges… button. Click 
the Add button to complete the addition of the new user account.

Figure 7-5.  Add a User Account
BridgeVIEW User Manual 7-18 © National Instruments Corporation
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After you have defined user accounts, you also can use this utility to cre
remove, or modify accounts. To modify several user accounts at once
example, change the access level of several accounts to be the same v
hold down the <Shift> key when selecting users from the list.

Note: Once you have defined user accounts, you must have at least one “super us
account (Access Level 255, privileges to Create/Edit user Accounts and 
Configure User Privileges), unless you remove all user accounts.

Note: You can only add, remove, or modify accounts if you have the Create/Edit Us
Accounts privilege. Also, unless you are a “super user,” you can only creat
remove, or edit user accounts that have an access level lower than your ow
If you are not authorized to configure user privileges, default privileges will b
assigned to new user accounts.

How Do You Modify the List of Available 
User Access Levels?
To edit the list of access levels, select Project»Security»Access Levels. 
You must have Administration privileges to edit the list of Access Leve
Click the Edit…  button next to the list of access levels. The Edit Acces
Levels dialog box appears, in which you can add, remove, and modify
access levels. You also can edit access levels within the Edit User Acco
dialog box by pressing the Edit Access Levels button, or choosing New… 
from the Access Level ring when creating or modifying a user account
addition to the two permanent access levels 0 and 255, you can assig
to 254 access levels for use in your operator interface panels. If you rem
an access level, users who have been assigned that access level are d
to the next lower access level.

Note: You can rename, but not remove, access levels 0 and 255.

How Do You Modify a User’s BridgeVIEW 
Environment Privileges?
Use the Edit User Accounts dialog box to assign user privileges. To cha
user privileges, select Project»Security»Edit User Accounts. From the 
© National Instruments Corporation 7-19 BridgeVIEW User Manual
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account list, select the account you want to modify and press the Modify>>  
button. Press the Privileges… button to open the Privileges dialog box.

To keep any changes, click the OK  button in the Privileges dialog box and
click the Apply  button in the Edit User Accounts dialog box. 

Operator Interface Security
Operator Interface Security refers to limiting user access to elements on
your HMI screens. You can assign an access level to each HMI objec
control which users can see or operate it. 

How Do You Limit User Access to HMI Objects?
You can use security information to control visibility attributes on HMI 
objects. There is a set of security VIs you can use to implement securi
your HMI, found in the System»Security palette. For more information 
about these or any other VIs, refer to Appendix A, HMI Function 
Reference. 

As you develop your operator interface panels, you might want to rest
access to certain controls (inputs) or indicators (outputs). To do this, y
must add a security loop to your Operator Interface VI. Figure7-6 shows 
how to use the Security Monitor VI to control the visible and disabled 
attributes of a front panel control and indicator. You can apply two types
security to a control: operability and visibility. By default, controls always 
operate and are visible. A security level of zero applies to the control, 
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meaning that any user with access level zero or higher (all users) can
operate the control.

Figure 7-6.  Using the Security Monitor VI to Control Visibility

To limit user access in your HMI, pop up on the control terminal in the
diagram for which you want to apply security and select Create»Attribute 
Node. Resize the attribute node so both the “Visible”  and “Disabled”  
attributes are available. Then wire the “Visible” attribute setting  output 
to the “Visible”  terminal and the “Disabled” attribute setting  output to 
the “Disabled”  terminal.

Also connect the shutdown output of the Security Monitor VI to a NOT
function, and the output of the NOT function to the continuation node 
the security loop. This ensures that the security loop terminates when
Engine shuts down.

By placing the Security Monitor in a loop, as in Figure7-6, this HMI can 
handle the operator access level changing dynamically and still behav
appropriately.
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Activity 7-3. Apply Security to the Alarm 
Summary Display

Your objective is to assign access privileges to the Alarm Summary 
application created in Activity5-2, Acknowledge Alarms in the Alarm 
Summary Display. You also will associate specific access levels to an 
Acknowledge Boolean on your front panel.

1. Configure the BridgeVIEW environment security by selecting 
Project»Security»Edit User Accounts.

2. Select Add New Users>> and create the following new accounts:

a. User Name: Administrator ; Level: 255 ; 
Password:Administration

Press Add to create this new account.
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b. User Name: Anyone ; Level: 25; Password: Viewer

Press Add to create this new account.

3. After creating the two accounts, select << Done Adding Users. Click 
on the OK  button.

4. Unless you were previously logged in, a Login dialog box appears
Log in as Administrator , with Password Administration .

5. Open the My Alarm Summary With Ack.vi  you created in 
Activity 5-2, Acknowledge Alarms in the Alarm Summary Display.

6. Edit the block diagram of Alarm Summary with Ack.vi  to limit 
operability of the Ack button depending on the user logged in.

a. Pop up on the Ack button and select Create»Attribute Node. The 
attribute node is created in the block diagram.

b. From the block diagram, pop up on the Attribute Node. Choos
Select Item»Disabled.

c. Create a new While Loop and move the Attribute Node inside
© National Instruments Corporation 7-23 BridgeVIEW User Manual
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d. Pop up in the While Loop and drop the Security Monitor VI from
the Functions»System»Security palette.

e. Wire the “Disabled”  attribute value output of the VI to the 
Attribute Node.

f. Invert the shutdown output of the VI and wire it to the 
continuation terminal of the While Loop. 

g. With the Wiring tool, pop up on the operability access level (0
input of the Security Monitor VI and select Create Constant. 
Enter 50 into the constant.

h. Save the VI as Alarm Summary with Security.vi  in the 
BridgeVIEW\Tutorial  directory.

The completed block diagram, including the new While Loop with the 
Security Monitor VI, is shown in the following illustration. 
BridgeVIEW User Manual 7-24 © National Instruments Corporation



Chapter 7 Advanced Application Topics

ty 
ser 
7. Run the VI. Because you are logged in as Administrator , you have 
privileges to acknowledge alarms.

8. Log in as Anyone  with Password Viewer  by selecting 
Project»Security»Login.

9. The Acknowledge button is now disabled. This is because operabili
access is given to users with Level 50 or above in BridgeVIEW. U
Anyone  has an access level of 25.

10. Close the VI and log in as Administrator  again.

End of Activity 7-3.
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This chapter explains how to use servers with BridgeVIEW. BridgeVIE
supports several types of servers including OPC Servers, DDE Servers
National Instruments Standard IA Device Servers. 

OPC Servers are written to the OPC Foundation OPC Data Access 
specification and are provided by many companies. A DDE Server is a
server that supports the DDE Server interface. IA Device Servers are a
of server developed by National Instruments. There are two 
implementations of IA Device Servers: VI-based and DLL-based. The
DLL-based servers are also know as IAK Device Servers

This chapter also describes how to install and configure the IA Device
Servers available from National Instruments and how to view the serv
configuration within BridgeVIEW.

BridgeVIEW includes the NI-DAQ Server, an IA Device Server that 
supports National Instruments data acquisition boards and SCXI, on t
BridgeVIEW Development System CD. Additional device servers for 
other devices such as PLCs also are available for BridgeVIEW on the
BridgeVIEW Device Servers CD. For more information about 
BridgeVIEW device servers, inquire about the Device Servers CD, 
available from National Instruments.

What Are BridgeVIEW Device Servers?
An BridgeVIEW device server is an application that communicates with 
and manages I/O devices such as PLCs, remote I/O (Input/Output) dev
and data acquisition plug-in cards. Device servers pass real-world tag
values to the BridgeVIEW Engine in real time. Each server monitors th
device items and encapsulates all device- and hardware-specific deta
thereby establishing a device-independent I/O layer for BridgeVIEW.

An item in BridgeVIEW is a channel or variable in a real-world device. F
more information about how to connect a tag to a server and item, see
Chapter 3, Tag Configuration. 
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The device servers also handle and report communications and devic
errors to BridgeVIEW. There are different servers available for differen
device families and communication networks. 

Each device server is a stand-alone component that might include a 
configuration utility as well as the run-time application that communica
with the BridgeVIEW Engine. IA Device Servers are not built into the 
BridgeVIEW Engine itself. These servers are written to a National 
Instruments standard client/server Applications Programming Interfac
(API) for communicating with the BridgeVIEW Engine and the Commo
Configuration Database.

When BridgeVIEW runs an application, it determines from the tag 
configuration (.scf ) file which servers are needed, and which items are
needed from those servers. BridgeVIEW launches each server it needs
notifies each one to monitor the specific items of interest. Typically, 
servers monitor each input tag on a regular basis, passing the values 
BridgeVIEW Engine when they change, and updating each output tag
when the BridgeVIEW HMI application writes that tag value. The upda
rates and deadband servers use for monitoring items can be configure
part of tag configuration. You define how a server monitors the items, h
often it polls the devices, and other server-specific and device-specific
parameters through each device server configuration utility.

How Do You Install and Configure a Device Server?
BridgeVIEW works with several device servers including the NI-DAQ 
Server, the device servers available on the BridgeVIEW Device Serve
CD, and the simulation servers installed with BridgeVIEW.  In addition
you can use other servers available from companies other than Nation
Instruments.

To use a device server with BridgeVIEW, first you must install the dev
server and register it or run its configuration utility. More specific 
information on installing and registering National Instruments servers 
follows later in this section. This information is written to the Common
Configuration Database, where BridgeVIEW obtains the server 
information. For some servers, you configure devices and items with t
server-specific Configuration Utility. Then, the Tag Configuration Edito
imports server, device, and item information so you can create tags. IA
device servers allow you to directly create and configure communicati
resources, devices, and items from the Tag Configuration Editor.
BridgeVIEW User Manual 8-2 © National Instruments Corporation
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When you register a device server, its name appears in the list of serv
shown in the various Edit Tag screens of the Tag Configuration Editor
Once you configure your server, you can create a BridgeVIEW 
Configuration using that server. Depending on the server, different 
information is written to the Common Configuration Database (CCDB)
when the server is registered.

The most simple servers register no more than their names and launc
paths. You can select items by adding in the item strings in the Edit Ta
screen for each tag using that server. To select a device, you must crea
I/O Group and select or enter the device name in the I/O Group dialog 
Refer to your server documentation for the correct formats for these de
and item strings.

The IAK Servers allow you to create and configure communication 
resources, devices, and items directly in the Tag Configuration Editor.
Communication resources and devices are configured in the I/O Grou
dialog box. Items are configured in the Connection tab of the Tag 
Configuration dialog box.

Other servers register the devices to which they are connected and ava
items for those devices by name. These servers also can register the 
type, directions, and engineering range and units of the various items,
applicable. When you select these servers in the Edit Tag screens of 
BridgeVIEW Tag Configuration Editor, you must first create an I/O grou
and select a device. Then you see a list of available devices, and a lis
items connected to that device in the Edit Tags screen. For a selected d
and item, the BridgeVIEW Tag Configuration Editor imports any availab
item engineering range and unit information and also checks that the 
directions or access rights for an item are compatible with the access r
you have selected for the tag. Check your server documentation to find
if it registers device and item names and item parameters with 
BridgeVIEW. 

Installing and Configuring the NI-DAQ Server
The NI-DAQ Server is available on the BridgeVIEW Development Syste
CD. You can choose to install the NI-DAQ Server at the same time yo
install BridgeVIEW, or you can install the NI-DAQ Server at a later tim
Select the NI-DAQ Server when you are prompted to install servers.
© National Instruments Corporation 8-3 BridgeVIEW User Manual
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To install the NI-DAQ Server, follow these steps:

1. Insert the BridgeVIEW Development System CD in your 
CD-ROM drive.

Select Run… from the Start menu.

Then type 

X:\SERVERS\NI-DAQ\DISK1\SETUP

where X is the letter of your CD-ROM drive.

2. Please follow the instructions that appear on the screen.

After you install the NI-DAQ Server, you must run the NI-DAQ Server 
Configuration Utility to configure your DAQ system before you try to us
the NI-DAQ Server with BridgeVIEW. The NI-DAQ Server Configuration
Utility also registers the NI-DAQ Server so you can use it with 
BridgeVIEW. See the NI-DAQ Server Online Help for more information 
on how to configure the NI-DAQ Server.

Installing and Configuring Device Servers from the BridgeVIEW Device 
Servers CD

The BridgeVIEW Device Servers CD contains servers for several PLC
and remote I/O devices. These device servers are DLL-based servers 
the Device Server Toolkit interface to BridgeVIEW.

To install the BridgeVIEW Device Servers from the BridgeVIEW Devic
Servers CD, follow these steps.

1. Insert the CD in your CD-ROM drive.

If you are running BridgeVIEW on Windows 95 or NT 4.0,

select Run… from the Start menu.

If you are running BridgeVIEW on Windows NT 3.51,

select File»Run… from the Program Manager.

Then type

X:\SETUP.EXE

where X is the letter of your CD-ROM drive.

2. Please follow the instructions that appear on the screen.

The Installer prompts you to select one or more servers to install. It al
installs the Server Explorer, which all the device servers contained on
CD use for server configuration. After you run the installer, you must r
the Server Explorer to configure the device-specific parameters of you
BridgeVIEW User Manual 8-4 © National Instruments Corporation
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industrial network before using the server with BridgeVIEW. The Serv
Explorer also registers your server so you can use it with BridgeVIEW
Each server on-line help file documents configuration instructions spec
to each server on the CD. See the on-line help files for your server for m
information.

Registering Simulation Servers
BridgeVIEW automatically installs three servers used by several of the
BridgeVIEW examples—the Tanks Server, the SIM Server, and the 
Cookie Server. You can use these servers to experiment with Tag 
Configuration and building your HMI. You also can look at the diagram
of these servers to see how a VI-based server works.

These servers must be registered for BridgeVIEW to recognize they e
The three servers are contained in folders named Tanks Server , SIM 

Server , and Cookie Server  in the BridgeVIEW\_servers  folder. 
Within each folder, each server has a VI named Register Tanks 

Server.vi , Register SIM Server.vi , and Register Cookie 

Server.vi  respectively. To register each server, open its register VI, r
it, and close the VI. The server then appears in the BridgeVIEW list of
servers whenever you configure a tag or look at servers in the Server 
Browser utility. You can remove these servers from the server list by 
selecting the Unregister Server option in the Server Browser utility. 

How Do You Use OPC Servers with BridgeVIEW?
BridgeVIEW can communicate with any server implementing the OPC
Foundation OPC Server interface, a Microsoft COM-based standard. 
BridgeVIEW automatically finds all OPC Servers installed in your syste
Unlike Device Servers, OPC Servers do not store information in the 
Common Configuration Database, rather BridgeVIEW reads any availa
information about server capabilities and items from the server directly

OPC Servers are listed in the Server Name List when you configure a
BridgeVIEW tag using the Tag Configuration Editor. To connect a 
BridgeVIEW tag to an OPC Server item, you select the server and ente
choose the item name along with other parameters you might need to
specify, such as the access path. You also create I/O Groups for the it
specifying update rate and deadband information for each group. Each
BridgeVIEW I/O Group created in the Tag Configuration Editor is 
automatically mapped to an OPC Group in the OPC Server with the s
attributes.
© National Instruments Corporation 8-5 BridgeVIEW User Manual
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OPC Servers have an optional interface called the Server Browse Add
Space Interface. If a server supports this interface, BridgeVIEW can qu
it to find which items are available from the server and display them in 
item list when the server is selected in the Tag Configuration dialog box
this case, the Browse button in the Tag Configuration dialog box is 
enabled, and you can press this button to view the hierarchical organiza
of the server Item IDs. You also can view the Server Items and their 
attributes using the Server Browser utility. If the OPC Server does not
support this optional interface, you must enter the Item ID name for th
item in the Tag Configuration Editor item field.

The View Server Information dialog box for OPC Servers is shown bel
 

Figure 8-1.  View Server Information Dialog Box

This dialog box displays information about the OPC Server read from 
system registry, and if the OPC Server supports the Server Browse Add
Space interface, also displays the items available from the server and 
attributes. If the OPC Server does not support this interface, the No Items 
Found checkbox and the item table appear dimmed.
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How Do You Use DDE Servers with BridgeVIEW?
BridgeVIEW can communicate with any server using Microsoft Dynam
Data Exchange (DDE) as its interface. A DDE Server is treated as a sim
server in which you type in a device and item string to select a specific
point. For DDE Servers, you select DDE Server from the Server List in
the Tag Configuration Editor, and type in APPLICATION|TOPIC  for 
device, and ITEM for item. See the How Do You Connect a Tag to a DDE
Server? section in Chapter 3, Tag Configuration for more complete 
information on how to do this. If you are using Network DDE to use a DD
Server running on another machine, use the Network DDE name for t
APPLICATION part of the name. Refer to your DDE Server documentati
for the correct name for APPLICATION, the list of available TOPICS and 
ITEMS for each topic.

Note: Unlike the servers written to the BridgeVIEW IA Device Server specification
off-the-shelf DDE Servers do not register themselves with BridgeVIEW. 
Therefore, BridgeVIEW cannot launch the DDE Server automatically when i
runs your HMI application. To use a DDE Server, launch or run the DDE 
Server before you run your BridgeVIEW application. BridgeVIEW will post 
system error messages if it cannot connect to the DDE Server when it launch
the BridgeVIEW Engine. Thereafter, it attempts to reconnect to the DDE 
Server periodically. 

How Do You View BridgeVIEW Server Configuration?
The Tag Configuration Editor shows the list of available servers, and a
registered devices and items for the server in the various Edit Tag scre
You also can use the Server Browser to view information about the de
servers registered with BridgeVIEW as well as the OPC Servers prese
your system. Launch the Server Browser by selecting Projects»Server 
Tools»Server Browser… or by pressing the Server Browser… button on 
the Engine Manager Display. Use this utility to view the properties of t
devices and items registered by each server. For VI-based IA Device 
Servers, you can use this utility to display the server front panel while y
application is running if you launch it from the Engine Manager. Typical
servers run with their front panel hidden. You can use the Server Brow
to launch the server-specific configuration utility from within 
BridgeVIEW, if one is available.
© National Instruments Corporation 8-7 BridgeVIEW User Manual
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The Server Browser utility shows the server information stored in the 
active Common Configuration Database (.ccdb ) file. You can control 
which CCDB is active from the Server Explorer utility. 

Use the Server Browser to unregister a device server that you no long
want to use (BridgeVIEW device servers only). This keeps the server 
related information from appearing in the Edit Tag screens. Notice that 
invalidates any tags that use that server. Once you have unregistered
server, you can no longer connect to it from BridgeVIEW, and you mu
run its configuration utility again to register it with BridgeVIEW.

Figure 8-2.  Server Browser

The main screen of the Server Browser displays a list of servers availa
to BridgeVIEW in the Registered Servers list box if launched from the 
Engine Manager. The symbol to the left of the server name indicates 
whether it is loaded and running. A black diamond indicates that the se
is loaded and running. A white diamond indicates that the server is loa
but not running. No symbol indicates that the server is not being used in
current BridgeVIEW Tag Configuration. The Server Browser also displa
the path to the active CCDB in its title bar.

To view information registered for a specific server, double-click on th
server name in the Registered Servers list box, or press the View Server 
Devices… button. This invokes the View Server Device Information dialo
box shown in Figure8-3, View Server Information Dialog Box.
BridgeVIEW User Manual 8-8 © National Instruments Corporation
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To unregister a server that you no longer want to connect to your tags, p
the Unregister Server button with the server of interest selected in the 
Registered Servers list box. This invokes a dialog box asking you to 
confirm the operation.

Note: Unregistering a server means that BridgeVIEW can no longer access that 
server, and any tag configured to use that server no longer has a valid 
configuration. Do this only if no tags are configured to use that server and yo
no longer want to access it from the Tag Configuration Editor. This does no
apply to OPC or DDE Servers.

Registered Server Device and Item Parameters
Use the View Server Information dialog box to see a list of devices 
registered by a specific server, and for the selected device, view a tab
the registered items and item properties. The View Server Information
dialog box for BridgeVIEW device servers is shown below.

 

Figure 8-3.  View Server Information Dialog Box

You can sort this table by item name, data type, or direction, by select
which parameter you want to sort on in the Sort By: list.
© National Instruments Corporation 8-9 BridgeVIEW User Manual
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How Do You Develop an IA Device Server?
You can write an IA Device Server as a BridgeVIEW VI. Several of the
example simulation servers installed with BridgeVIEW are VI-based 
servers. Writing a VI-based IA server is a simple way to emulate hardw
or connect BridgeVIEW to a simple device. You can use the same 
BridgeVIEW development environment to create the server as you use
develop your application. The toolkit for creating a VI-based device ser
is included on the BridgeVIEW CD.

You also can implement an IA Device Server as a 32-bit Windows 
Dynamic Link Library (DLL). Most of the PLC servers for BridgeVIEW 
are implemented as DLLs. Writing a DLL-based IA Device Server requi
more work than writing a VI-based server, but it has the advantage of u
multiple Win32 threads, and thus runs and collects data in parallel wit
BridgeVIEW. DLL-based IA Device Servers also can support clients oth
than BridgeVIEW. For more information about developing BridgeVIEW
Servers, inquire about the BridgeVIEW Device Server Toolkit, available 
from National Instruments.
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This chapter introduces the basic concepts of virtual instruments and 
provides activities that explain the following:

• How to create the icon and connector

• How to use a VI as a subVI

• How to use the VI Setup… option

• How to use the SubVI Node Setup… option

For examples of custom VIs, see 
Examples\G Examples\General\viopts.llb.

What is a Virtual Instrument?
A virtual instrument (VI) is a program in the graphical programming 
language G. Virtual instrument front panels often have a user interfac
similar to physical instruments.

How Do You Build a VI?
One of the keys to creating BridgeVIEW applications is understanding 
using the hierarchical nature of the VI. After you create a VI, you can u
it as a subVI in the block diagram of a higher-level VI.

VI Hierarchy
When you create an application, you start at the top-level VI and define
inputs and outputs for the application. Then, you construct subVIs to 
perform the necessary operations on the data as it flows through the b
diagram. If a block diagram has a large number of icons, group them in
lower-level VI to maintain the simplicity of the block diagram. This 
modular approach makes applications easy to debug, understand, and
maintain.
dgeVIEW User Manual
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As with other applications, you can save your VI to a file in a regular 
directory. With G, you also can save multiple VIs in a single file called
VI library.

Saving VIs as individual files is more effective than using VI libraries 
because you can copy, rename, and delete files more easily than if yo
using a VI library. For a list of the advantages and disadvantages of u
VI libraries and individual files, see the section Saving VIs in Chapter 2, 
Building VIs, of the G Programming Reference Manual.

VI libraries have the same load, save, and open capabilities as other 
directories. VI libraries, however, are not hierarchical. That is, you can
create a VI library inside of another VI library. You cannot create a new
directory inside a VI library, either. There is no way to list the VIs in a V
library outside the BridgeVIEW environment.

After you create a VI library, it appears in the BridgeVIEW File dialog bo
as a folder with VI  on the folder icon. Regular directories appear as a fold
without the VI label.

Even though you might not save your own VIs in VI libraries, you shou
be familiar with how they work. In the various activities in this tutorial, yo
will save your VIs in the BridgeVIEW\Tutorial  directory. Solutions to 
these activities are provided in the BridgeVIEW\Tutorial\Solution s 
directory.

Controls, Constants, and Indicators
A control is an object you place on your HMI for entering data into a V
interactively or into a subVI programmatically. An indicator is an objec
you place on your HMI for displaying output. Controls and indicators in
are similar to input and output parameters, respectively, in traditional 
programming languages. An alternative to placing controls and indicat
on the front panel and then wiring them to functions or VIs on the bloc
diagram, is to create constants, controls, or indicators directly from the
block diagram. You can do this by popping up on the input terminal of
function or VI on the block diagram and selecting Create Constant or 
Create Control. This creates a control or constant of the correct data ty
and wires it to the terminal.
BridgeVIEW User Manual 9-2 © National Instruments Corporation



Chapter 9 Creating and Customizing VIs

 up 

ts, 
lete 

he 
 
 
lar, 

 see 
You can create an indicator and wire it to an output terminal by popping
on the terminal and selecting Create Indicator. You cannot delete a 
control or indicator from the block diagram. As with all front panel objec
you must go to the front panel, select the Positioning tool, and then de
the object.

Each time you create a new control or indicator on the front panel, 
BridgeVIEW creates the corresponding terminal in the block diagram. T
terminal symbols suggest the data type of the control or indicator. For
example, a DBL terminal represents a double-precision, floating-point
number; a TF terminal is a Boolean; an I16 terminal represents a regu
16-bit integer; and an ABC terminal represents a string. For more 
information about data types in G, and their graphical representations,
the G Quick Reference Card.
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Terminals
It is important that you wire the correct terminals of a function. You ca
show the icon connector to make correct wiring easier. To do this, pop
on the function and choose Show»Terminals. To return to the icon, pop up
on the function and select Show»Terminals again. 

Wires
A wire is a data path between nodes. In the wiring illustrations in this 
section, the arrow at the end of this mouse symbol shows where to click
the number printed on the mouse button indicates how many times to c
the mouse button.

The hot spot of the tool is the tip of the unwound wiring segment.

Wires are colored according to the kind of data each wire carries. Blue
wires carry integers, orange wires carry floating-point numbers, green
wires carry Booleans, and pink wires carry strings.

To wire from one terminal to another, click the Wiring tool on the first 
terminal, move the tool to the second terminal, and click on the secon
terminal. It does not matter at which terminal you start. 

When the Wiring tool is over a terminal, the terminal area blinks, to 
indicate that clicking connects the wire to that terminal. Do not hold do
the mouse button while moving the Wiring tool from one terminal to 
another. You can bend a wire once by moving the mouse perpendicul
the current direction. To create more bends in the wire, click the mous
button. To change the direction of the wire, press the spacebar. Click 
the mouse button, to tack the wire down and move the mouse 
perpendicularly.

Hot Spot
BridgeVIEW User Manual 9-4 © National Instruments Corporation
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Tip Strips
When you move the Wiring tool over the terminal of a node, a tip strip for 
that terminal pops up. Tip strips consist of small, yellow text banners t
display the name of each terminal. These tip strips should help you to 
the terminals. The illustration below displays the tip strip (Pressure) th
appears when you place the Wiring tool over the output of the Proces
Monitor VI.

Note: When you place the Wiring tool over a node, G displays wire stubs that indica
each input and output. The wire stub has a dot at its end if it is an input to 
the node.
© National Instruments Corporation 9-5 BridgeVIEW User Manual
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Wire Stretching
You can move wired objects individually or in groups by dragging the 
selected objects to a new location with the Positioning tool.

Selecting and Deleting Wires
You might wire nodes incorrectly. If you do, select the wire you want to
delete and then press <Delete>. A wire segment is a single, horizonta
vertical piece of wire. The point where three or four wire segments join
called a junction. A wire branch contains all the wire segments from one
junction to another, from a terminal to the next junction, or from one 
terminal to another if there are no junctions in between. You select a w
segment by clicking on it with the Positioning tool. Double-clicking selec
a branch, and triple-clicking selects the entire wire.

Selects a Selects a branch Selects an
entire wire

segment

segmentjunction

bend

segments
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Bad Wires
A dashed wire represents a bad wire. You can get a bad wire for a num
of reasons, such as connecting two controls, or connecting a source 
terminal to a destination terminal when the data types do not match (f
instance, connecting a numeric to a Boolean). You can remove a bad 
by clicking on it with the Positioning tool and pressing <Delete>. Choos
Edit»Remove Bad Wires or <Ctrl-B> deletes all bad wires in the block 
diagram. This is a useful quick fix to try if your VI refuses to run or retur
the Signal has Loose Ends  error message.

Note: Do not confuse a black, dashed wire with a dotted wire. A dotted wire 
represents a Boolean data type, as the following illustration shows.

Activity 9-1. Create a VI
Your objective is to build a VI.

Imagine that you have sensors that read temperature and volume rea
as voltage. You will use a VI in the BridgeVIEW\Tutorial  directory to 
simulate the temperature and volume measurements in volts. You will
write code to scale these measurements to degrees fahrenheit and lite
respectively.

1. Open a new front panel by selecting File»New. If you have closed all 
VIs, select New VI from the BridgeVIEW dialog box.

Note: If the Controls palette is not visible, select Windows»Show Controls Palette 
to display the palette. You also can access the Controls palette by popping up 
in an open area of the front panel. To pop up, right-click on your mouse.

Dashed Wire (bad)

Dotted Wire (good)
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2. Select Tank from Controls»Vessels, and place it on the front panel.

3. Type Volume  in the label text box and click anywhere on the front 
panel.

Note: If you click outside the text box without entering text, the label disappears. T
show the label again, pop up on the control and select Show»Label.

4. Rescale the tank indicator to display the tank volume between 0.0
1000.0.

a. Using the Labeling tool, double-click on 10.0  on the tank scale to 
highlight it.

b. Type 1000  in the scale and click the mouse button anywhere o
the front panel. The intermediary increments are scaled 
automatically.

5. Place a thermometer from Controls»Numeric on the front panel. 
Label it Temp and rescale it to be between 0 and 100.

6. Your front panel should look like the following illustration.

7. Open the block diagram by choosing Windows»Show Diagram. 
Select the objects listed below from the Functions palette and place 
them on the block diagram. 
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Note: If the Functions palette is not visible, select Windows»Show Functions 
Palette to display the palette. You also can access the Functions palette by 
popping up in an open area of the block diagram.

8. Place each of the following objects on the block diagram.

Process Monitor (Functions»Select a VI from the 
BridgeVIEW\Tutorial  directory)—Simulates reading a temperature 
voltage and volume value from a sensor or transducer.

Random Number Generator (Functions»Numeric)—Simulates a number 
between 0 and 1.

Multiply function (Functions»Numeric)—Multiplies two numbers and 
returns their product. In this activity, you need two of these. Drop one fr
the palette and copy and paste to create the other.

Numeric Constant (Functions»Numeric)—You need two of these. Drop 
one from the palette. Change its representation to DBL. Using the labe
tool, change its value to 10.00 . Copy and paste it.

Note: Another way to create a constant is to pop up on the terminal of a function o
VI using the Wiring tool. Select Create Constant from the floating menu. A 
constant of the appropriate data type appears.

9. To view the inputs and outputs of a function or a VI, drag the curs
on the icon and select Show Help from the Help menu. The Help 
window for the Process Monitor VI is shown below.
© National Instruments Corporation 9-9 BridgeVIEW User Manual
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10. Using the wiring tool, wire the objects as shown.

11. Using the Wiring tool, wire the remaining objects together as 
explained in the Wires section in this chapter.

Note: To move objects around on the block diagram, click on the Positioning tool 
the Tools palette.

12. Select File»Save As… and save the VI as Temp & Vol.vi  in the 
BridgeVIEW\Tutorial  directory.

13. From the front panel, run the VI by clicking on the Run button. 

14. Close the VI by selecting File»Close. 

End of Activity 9-1.
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VI Documentation
You can document a VI by choosing Windows»Show VI Info…. Type the 
description of the VI in the VI Information dialog box. Then, you can rec
the description by selecting Windows»Show VI Info… again.

You can edit the descriptions of objects on the front panel (or their 
respective terminals on the block diagram) by popping up on the object
choosing Data Operations»Description…. 

Note: You cannot change the description of a VI or its front panel objects while th
VI is running.

The following illustration is an example pop-up menu that appears wh
you are running a VI. You cannot add to or change the description wh
running the VI, but you can view any previously entered information.

You also can view the description of a front panel object by showing th
Help window (Help»Show Help) and moving the cursor over the object.
© National Instruments Corporation 9-11 BridgeVIEW User Manual
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Activity 9-2. Document a VI
Your objective is to document a VI that you have created.

1. Open the Temp & Vol.vi  created in Activity9-1 from the 
BridgeVIEW\Tutorial  directory.

2. Select Windows»Show VI Info…. Type the description for the VI, as
shown in the following illustration, and click on OK.

3. Pop up on the tank and choose Data Operations»Description…. 
Type the description for the indicator, as shown in the following 
illustration, and click OK .
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4. Pop up on the thermometer and choose Data 
Operations»Description…. Type in the description: Displays 

simulated temperature (deg F) measurement.  Click on OK .

5. Select Show Help from the Help menu. Place the cursor on Volume
and then on Temp. You can see the descriptions you typed in appe
the help window.

6. Save and close the VI.

End of Activity 9-2.

What is a SubVI?
A subVI is much like a subroutine. It is a VI that is used in the block 
diagram of another VI.

You can use any VI that has an icon and a connector as a subVI in an
VI. In the block diagram, you select VIs to use as subVIs from 
Functions»Select a VI…. Choosing this option produces a file dialog box
from which you can select any VI in the system. If you open a VI that do
not have an icon and a connector, a blank, square box appears in the c
VI's block diagram. You cannot wire to this node.

A subVI is analogous to a subroutine. A subVI node (icon/connector) i
analogous to a subroutine call. The subVI node is not the subVI itself, 
as a subroutine call statement in a program is not the subroutine itself
© National Instruments Corporation 9-13 BridgeVIEW User Manual
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block diagram that contains several identical subVI nodes calls the sa
subVI several times.

Hierarchy Window
You use the Hierarchy window (Project»Show VI Hierarchy) to display 
the dependencies of VIs by providing information on VI callers and 
subVIs. This window contains a toolbar that you can use to configure 
several types of settings for displayed items. The following illustration 
shows an example of the VI hierarchy toolbar.

You can use buttons on the Hierarchy window toolbar or the VIEW me
or pop up on an empty space in the window to access the following opti

Redraw—Rearranges nodes after successive operations on hierarchy 
if you need to minimize line crossings and maximize symmetric aesthe
If a focus node exists, you then scroll through the window so that the f
root that shows subVIs is visible.

Switch to vertical layout—Arranges the nodes from top-to-bottom, placi
roots at the top.

Switch to horizontal layout—Arranges the nodes from left-to-right, placi
roots on the left side.

Include/Exclude VIs—Toggles the hierarchy graph to include VI librarie
or exclude VIs in VI libraries.

Include/Exclude global—Toggles the hierarchy graph to include variab
or exclude global variables.

Include/Exclude typedefs—Toggles the hierarchy graph to include or 
exclude typedefs.

In addition, the View menu and pop-up menus include Show all VIs and 
Full VI Path  in Label options that you cannot access on the toolbar.

As you move the Operating tool over objects in the Hierarchy window,
displays the name of the VI below the VI icon.
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Use the <Tab> key to toggle between the Positioning and Scroll windo
tools. This feature is useful for moving nodes from the Hierarchy windo
to the block diagram.

You can drag a VI or subVI node to the block diagram or copy it to the
clipboard by clicking on the node. <Shift>-click on a VI or subVIs node 
select multiple objects for copying to other block diagrams or front pan
Double-clicking on a VI or subVI node opens the front panel of that no

Any VIs that contain subVIs have an arrow button next to the VI that y
can use to show or hide subVIs. Clicking on the red arrow button or 
double-clicking on the VI itself opens the subVIs in that VI. A black arro
button on a VI node means that all subVIs are displayed. You also can
up on a VI or subVI node to access a menu with options, such as show
or hiding subVIs, opening the VI or subVI front panel, editing the VI ico
and so on.

Search Hierarchy
You also can search currently visible nodes in the Hierarchy window b
name. You initiate the search by typing in the name of the node, anywh
on the window. As you type in the text, a search window appears, whi
displays the text as you type it in and concurrently searches through t
hierarchy. After finding the correct node, you can press <Enter> to sea
for the next node that matches the search string, or you can press 
<Shift-Enter> to find the previous node that matches the search string

Icon and Connector
Every VI has a default icon displayed in the upper-right corner of the Fr
Panel and Diagram windows. For VIs, the default is the BridgeVIEW V
icon and a number indicating how many new VIs you have opened sin
launching BridgeVIEW. You use the Icon Editor to customize the icon 
turning individual pixels on and off. To activate the Icon Editor, pop up 
the default icon in the top right corner of the Panel window and select Edit 
Icon.

The following illustration shows the Icon Editor Window. You use the 
tools at left to create the icon design in the pixel editing area. An imag
© National Instruments Corporation 9-15 BridgeVIEW User Manual
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the actual icon size appears in one of the boxes to the right of the edit
area.

The tools to the left of the editing area perform the following functions

Pencil tool—Draws and erases pixel by pixel. 

Line tool—Draws straight lines. Press <Shift> and then drag this tool t
draw horizontal, vertical, and diagonal lines.

Color Copy tool—Copies the foreground color from an element in the ic

Fill bucket tool—Fills an outlined area with the foreground color.

Rectangle tool—Draws a rectangular border in the foreground color. 
Double-click on this tool to frame the icon in the foreground color.

Filled rectangle tool—Draws a rectangle bordered with the foreground
color and filled with the background color. Double-click to frame the ico
in the foreground color and fill it with the background color.

Select tool—Selects an area of the icon for moving, cloning, or other 
changes.

Text tool—Enters text into the icon design.

Foreground/Background—Displays the current foreground and 
background colors. Click on each to get a color palette from which you 
choose new colors.
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The buttons at the right of the editing screen perform the following 
functions:

• Undo—Cancels the last operation you performed.

• OK—Saves your drawing as the VI icon and returns to the front pa

• Cancel—Returns to the front panel without saving any changes.

Depending on the type of monitor you are using, you can design a sep
icon for monochrome, 16-color, and 256-color mode. You design and s
each icon version separately. The editor defaults to Black & White , but 
you can click on one of the other color options to switch modes.

Note: If you design a color icon only, the icon does not show up in a subpalette of t
Functions palette if you place the VI in the *.lib  directory, nor will the icon 
be printed or displayed on a black and white monitor.

The connector is the programmatic interface to a VI. If you use the pan
controls or indicators to pass data to and from subVIs, these controls 
indicators need terminals on the connector pane. You define connecti
by choosing the number of terminals you want for the VI and assignin
front panel control or indicator to each of those terminals.

To define a connector, select Show Connector from the icon pane pop-up 
menu on the Panel window.

The connector icon replaces the icon in the upper-right corner of the P
window. BridgeVIEW selects a terminal pattern appropriate for your V
with controls on the left side of the connector pane, and indicators on 
right. The number of terminals selected depends on the number of con
and indicators on your front panel.

Each rectangle on the connector represents a terminal area, and you ca
the rectangles either for input or output from the VI. If necessary, you 
select a different terminal pattern for your VI.
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Activity 9-3. Create an Icon and Connector
Your objective is to make an icon and connector for a VI.

To use a VI as a subVI, you must create an icon to represent it on the b
diagram of another VI, and a connector pane to which you can connec
inputs and outputs. BridgeVIEW provides several tools with which you c
create or edit an icon for your VIs.

The icon of a VI represents it as a subVI in the block diagram of other V
It can be a pictorial representation of the purpose of the VI, or a textua
description of the VI.

1. Open Temp & Vol.vi  in the BridgeVIEW\Tutorial  directory.

2. From the front panel, pop up on the icon in the top right corner an
select Edit Icon…. You also can double click on the icon to invoke th
icon editor.

Note: You only can access the icon/connector for a VI from the front panel.

3. Erase the default icon. With the Select tool, which appears as a do
rectangle, click and drag over the section you want to delete, and p
the <Delete> key. You also can double click on the shaded rectan
in the tool box to erase the icon.

4. Draw a thermometer with the Pencil tool. 

5. Create the text with the Text tool. To change the font, double-click
the Text tool. Your icon should look similar to the following 
illustration. 
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6. Close the Icon Editor by clicking on OK . The new icon appears in the
icon pane.

7.  Define the connector terminal pattern by popping up in the icon p
on the front panel and choosing Show Connector. By default, 
BridgeVIEW selects a terminal pattern based on the number of 
controls and indicators on the front panel. Because there are two 
objects on the front panel, the connector has two terminals, as sh
at left. 

8.  Pop up on the connector pane and select Rotate 90 Degrees. Notice 
how the connector pane changes, as shown at left. 

9. Assign the terminals to Temp and Volume.

a. Click on the top terminal in the connector. The cursor 
automatically changes to the Wiring tool, and the terminal turn
black.

b. Click on the Temp indicator. A moving dashed line frames the
indicator, as shown in the following illustration.

If you click in an open area on the front panel, the dashed line disappe
and the selected terminal dims, indicating that you have assigned the
indicator to that terminal. If the terminal is white, you have not made th
connection correctly.

c. Repeat steps a) and b) to associate the bottom terminal with 
Volume indicator.

d. Pop up on the connector and select Show Icon…. 

10. Save the VI by choosing File»Save. 

Now, this VI is complete and ready for use as a subVI in other VIs. The i
represents the VI in the block diagram of the calling VI. The connector
(with two terminals) outputs the temperature and volume.
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Note: The connector specifies the inputs and outputs of a VI when you use it as a
subVI. Remember that front panel controls can be used as inputs only; front 
panel indicators can be used as outputs only.

11. Close the VI by choosing File»Close.

End of Activity 9-3.

Opening, Operating, and Changing SubVIs
You can open a VI used as a subVI from the block diagram of the call
VI by double-clicking on the subVI icon or by selecting Project»This VI’s 
SubVIs. You will see a palette containing all the subVIs of the calling V
Select the subVI you want to open.

Any changes you make to a subVI alter only the version in memory un
you save the subVI. The changes affect all instances of the subVI and
just the node you used to edit the VI.

Activity 9-4. Call a SubVI
Your objective is to build a VI that uses the Temp & Vol.vi  as a subVI.

The Temp & Vol VI you built in Activity9-1, returns a temperature and 
volume. You will take a volume reading and convert the value to gallo
when a switch is pressed.

Front Panel
1. Open a new front panel by selecting File»New.

2. Select a Horizontal Switch from the Controls»Boolean palette and 
label it volume . Place free labels on the front panel to indicate Liters  
and Gallons .

3. Select a meter from Controls»Numeric and place it on the front panel.
Label it Tank Volume . 
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4. Change the range of the meter to accommodate values ranging 
between 0.0 and 1000.0. With the Operating tool, double-click on 
high limit and change it from 10.0 to 1000.0. Switch to the positioni
tool and resize the meter by dragging out one of the corners and 
expanding the control.

Block Diagram
5. Go to the block diagram by selecting Windows»Show Diagram.

6. Pop up in a free area of the block diagram and choose 
Functions»Select a VI…. A dialog box appears. Select 
Temp & Vol.vi in the BridgeVIEW\Tutorial  directory. Click 
on Open in the dialog box. BridgeVIEW places the Temp & Vol VI 
on the block diagram.
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7. Add the other objects to the block diagram as shown in the follow
illustration.

Numeric Constant (Functions»Numeric)—Add a numeric constant to the
block diagram. Assign the value 3.785  to the constant by using the 
Labeling tool. This is the conversion factor for switching from liters to 
gallons.

Select Function (Function»Comparison)—Returns the value wired to the
TRUE or FALSE input, depending on the Boolean input.

Divide function (Functions»Numeric)—Divides the value in liters by 
3.785 to convert it to gallons.

8. Wire the diagram objects as shown.

9. Return to the front panel and click on the Run button in the toolbar. 
The meter shows the value in liters.

10. Click on the switch to select Gallons . The meter shows the value in
gallons.

11. Save the VI as Using Temp & Vol.vi  in the 
BridgeVIEW\Tutorial  directory.

End of Activity 9-4.
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How Do You Debug a VI?
A VI cannot compile or run if it is broken. Normally, the VI is broken whil
you are creating or editing it, until you wire all the icons in the diagram
it still is broken when you finish, try selecting Remove Bad Wires from 
the Edit  menu. Often, this fixes a broken VI.

When your VI is not executable, a broken arrow appears instead of the Run 
button. To list the errors, click on the broken Run button. Click on one of 
the errors listed and then click on Find to highlight the object or terminal 
that reported the error.

You can animate the VI block diagram execution by clicking on the 
Execution Highlighting button. Execution highlighting is commonly used
with single-step mode to trace the data flow in a block diagram.

For debugging purposes, you might want to execute a block diagram n
by node. This is known as single-stepping. To enable the single-step m
click on the Step Into button or Step Over button. This action then causes
the first node to blink, denoting that it is ready to execute. Then you ca
click on either the Step Into or Step Over button again to execute the node
and proceed to the next node. If the node is a structure or VI, you can s
the Step Over button to execute the node but not single-step through the 
node. For example, if the node is a subVI and you click on the Step Over 
button, you execute the subVI and proceed to the next node but canno
how the subVI nodes execute. To single step through a structure or su
select the Step Into button.

Click on the Step Out button to finish execution of the block diagram 
nodes and/or complete single stepping. For more information about 
debugging, see Chapter 4, Executing and Debugging VIs and SubVIs, in the 
G Programming Reference Manual.

For more information about block diagrams, and the options available fr
the block diagram window, see the section Block Diagram in Chapter 2, 
BridgeVIEW Environment. 
© National Instruments Corporation 9-23 BridgeVIEW User Manual



Chapter 9 Creating and Customizing VIs

 

s 
 

 

e 

is 
Activity 9-5. Debug a VI in BridgeVIEW
Your objective is to use the probe tool and the probe window and to 
examine data flow in the block diagram using the execution highlighting
feature.

1. Open Using Temp & Vol.vi  from the BridgeVIEW\Tutorial  
directory.

2. Select Windows»Show Diagram.

3. If the Tools palette is not open, select Windows»Show Tools Palette. 

4. Select the Probe tool from the Tools palette. Click with the Probe tool 
on the wire coming out of the Divide function. A Probe window pop
up with the title Probe 1  and a yellow glyph with the number of the
probe, as shown in the following illustration. The Probe window 
remains open, even if you switch to the front panel.

5. Return to the front panel. Move the Probe window so you can view
both the probe and volume values as shown in the following 
illustration. Run the VI. The volume in gallons appears in the Prob
window while Tank Volume  displays the value in liters.

Note: The volume values that appear on your screen may be different than what 
shown in this illustration. Refer to the Numeric Conversion section in 
Chapter 3, Loops and Charts, in the G Programming Reference Manual for 
more information.
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6. Close the Probe window by clicking in the close box at the top of t
Probe window title bar. 

Another useful debugging technique is to examine the flow of data in t
block diagram using the execution highlighting feature.

7. Return to the block diagram of the VI.

8. Begin execution highlighting by clicking on the Highlight Execution 
button, in the toolbar. The Highlight Execution button changes to an 
illuminated light bulb.

9. Click on the Run button to run the VI, and notice that execution 
highlighting animates the VI block diagram execution. Moving 
bubbles represent the flow of data through the VI. Also notice that d
values appear on the wires and display the values contained in th
wires at that time, as shown in the following block diagram, just as
you had probed the wire.

You also can use the single stepping buttons if you want to walk throu
the graphical code, one step at a time. 

10. Begin single-stepping by clicking on the Step Over button, in the 
toolbar. 

11. Step into the Temp & Vol subVI by clicking on the Step Into button, 
in the toolbar. Clicking on this button opens the front panel and blo
diagram of your Temp & Vol subVI. Click on the Step Over button 
until the VI finishes executing. 

12. Finish executing the block diagram by clicking on the Step Out 
button, in the toolbar. Clicking on this button completes all remaini
sequences in the block diagram.

End of Activity 9-5. 
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How Do You Customize a VI?
There are several ways to configure how your VIs execute. You acces
these options by popping up on the icon pane in the upper-right corne
the front panel and choosing VI Setup…. 

A VI Setup dialog box appears showing setup options for execution of
VI, appearance of the panel, and documentation. You can learn how to
these options in Activity9-6, in this chapter. For more detailed 
information, see Chapter 6, Setting up VIs and SubVIs, in the G 
Programming Reference Manual.

Set Window Options
The Window Options control the appearance of the VI when running. 
switch from Execution Options to Window Options, click on the downwa
pointing arrow in the menu bar.

SubVI Node Setup
You also can configure how a subVI executes. The configuration optio
are available by popping up on the subVI icon (in the block diagram of 
calling VI), and choosing SubVI Node Setup…. The following illustration 
shows the SubVI Node Setup dialog box.
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Note: If you select an option from the VI Setup… dialog box of a VI, the option 
applies to every instance of that VI. If you select an option from the SubVI 
Node Setup dialog box, the option applies only to that particular node.

Activity 9-6. Use Setup Options for a SubVI
Your objective is to build a VI that prompts the operator to enter 
information.

You will create a VI that launches a dialog box to obtain information fro
the user upon execution. Once the user enters the information and pre
a button, the dialog box disappears. 

Front Panel
1. Open a new front panel and place some string controls and a butto

shown in the following illustration. 
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Block Diagram
2. Build the block diagram shown in the following illustration.

3. Create the icon for the VI as shown at left. To access the Icon Ed
pop up on the icon pane of the front panel and select Edit Icon .

4. Switch to the connector pane by popping up on the icon pane and
selecting Show Connector.

5. Build the connector. Notice that the default connector pane is not w
you see illustrated to the left. To get the correct connector pane, ch
Patterns from the pop-up menu on the connector. Choose the patt
with three inputs and two outputs. Then choose Flip Horizontal . Now 
you can connect the Date  and Time  controls to the two connectors on
the left side of the icon, and the Name Answer , Date Answer , and 
Time Answer  indicators to the three connectors on the right side o
the icon, as shown in the following illustration. After creating the 
connector, return to the icon display.

6. Save the VI as Get Operator Info.vi  in the 
BridgeVIEW\Tutorial  directory. 

7. Now you can customize the VI with the VI setup options to make it 
look like a dialog box.
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a. Pop up on the icon and select VI Setup. Configure the Execution 
Options as shown in the following illustration. 

b. Select Window Options and make the selections shown in the 
following illustration.
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8. After you finish with the VI Setup options, resize the front panel as 
shown in the following illustration so you do not see the three strin
indicators.

9. Save and close the VI. 

Now you will use this VI as a subVI.

Front Panel

10. Open a new front panel.

11. Place a Waveform Chart (Controls»Graph) on the front panel and 
label it Temperature Data .

12. Modify the scale of the chart, so that its upper limit is set to 90.0 a
its lower limit is set to 70.0. Pop up on the chart and choose 
Show»Legend to hide the legend. Pop up on the chart again and 
choose Show»Palette to hide the palette. 
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13. Build the rest of the front panel as shown in the following illustratio

Block Diagram
14. Create a Sequence structure and add the following to frame 0, as

shown in the following illustration.

Get Date/Time String function (Functions»Time & Dialog)—Outputs the 
current date and time.
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Get Operator Info VI (Functions»Select a VI… from the 
BridgeVIEW\Tutorial  directory)—Pops open its front panel and 
prompts the user to enter a name, the date, and the time.

Boolean constant (Functions»Boolean)—Controls whether the input date
and time string are TRUE. To set this option to TRUE, click on the const
with the Operating tool.

15. Pop up on the Sequence structure and select Add Frame After  from 
the pop-up menu.

16. Place a While Loop inside frame 1 of the Sequence structure.

17. Add the objects shown in the following illustration.

Temp & Vol VI (Functions»Select a VI… from the 
BridgeVIEW\Tutorial  directory)—Returns one temperature 
measurement from a simulated temperature sensor.

Wait Until Next ms Multiple function (Functions»Time 
& Dialog)—Causes the For Loop to execute in ms.

Numeric constant (Functions»Numeric)—You can also pop up on the 
Wait Until Next Tick Multiple function and select Create Constant to crea
automatically and wire the numeric constant. The numeric constant de
execution of the loop for 500 ms (0.5 seconds).

Not function (Functions»Boolean)—Inverts the value of the STOP button 
so that the While Loop executes repeatedly until you click on STOP. 
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18. Save the VI as Pop-up Panel Demo.vi  in the 
BridgeVIEW\Tutorial  directory.

19. Run the VI. The front panel of the Get Operator Info VI opens and
prompts you to enter your name, the date, and the time. Click on t
Continue button to return to the calling VI. Then temperature data
acquired until you click on the STOP button.

Note: The front panel of the Get Operator Info VI opens because of the options yo
selected from the VI Setup dialog box. Do not try to open the front panel of th
subVI from the block diagram of the My Pop-Up Panel Demo VI.

20. Close all windows.

End of Activity 9-6.
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This chapter introduces structures and explains the basic concepts of c
the While Loop, and the For Loop. This chapter also provides activities 
illustrate how to accomplish the following: 

• Experiment with different chart modes

• Use a While Loop and a chart

• Change the mechanical action of a Boolean switch

• Control loop timing

• Use a shift register

• Create a multiplot chart and customize your trend

• Use a For Loop

What is a Structure?
A structure is a program control element. Structures control the flow of
data in a VI. G has four structures: the While Loop, the For Loop, the C
structure, and the Sequence structure. This chapter introduces the Wh
Loop and For Loop structures along with the chart and the shift registe
The Case and Sequence structures are explained in Chapter 11, Case and 
Sequence Structures, of this manual. 

While and For Loops are basic structures for programming with G, so 
can find them in most of the G examples as well as the activities in thi
manual. You also can find more information on loops in Chapter 18, 
Structures, in the G Programming Reference Manual.

For examples of structures, see G Examples\General\structs.llb . 
For examples of charts, see G Examples\General\Graphs\ 

charts.llb . 
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Charts
A chart is a numeric plotting indicator. You can find two types of charts 
the Controls»Graph palette: waveform chart (or real-time trend) and 
intensity chart. You can customize charts to match your data display 
requirements or to display more information. Features available for ch
include: a scrollbar, a legend, a palette, a digital display, and represent
of scales with respect to time. For more information about charts, see 
Chapter 15, Graph and Chart Controls and Indicators, in your 
G Programming Reference Manual.

Chart Modes
The following illustration shows the three chart display options availab
from the Data Operations»Update Mode: strip chart, scope chart, and 
sweep chart. The default mode is strip chart. (If the VI still is running, th
Data Operations submenu is the pop-up menu for the chart.)
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Faster Chart Updates
You can pass an array of multiple values to the chart. The chart treats t
inputs as new data for a single plot. Refer to the charts.vi  example 
located in G Examples\General\Graphs\charts.llb.

Stacked Versus Overlaid Plots
Later in this chapter, Activity10-6 shows how to create a multiplot chart 
with overlaid plots. You also can stack plots on a chart. Refer to the 
charts.vi  example located in G Examples\General\

Graphs\charts.llb.

Activity 10-1. Experiment with Chart Modes
Your objective is to view a chart as your VI runs in strip chart mode, 
scope chart mode, and sweep chart mode.

1. Open Charts.vi , located in the following directory: 
BridgeVIEW\Examples\G Examples\General\ 

Graphs\charts.11b.

2. Run the VI.

The strip chart mode has a scaling display similar to a paper tape strip c
recorder. As each new value is received, it is plotted at the right margin
old values shift to the left.

The scope chart mode has a retracing display similar to an oscilloscope
the VI receives each new value, it plots the value to the right of the las
value. When the plot reaches the right border of the plotting area, the 
erases the plot and begins plotting again from the left border. The sco
chart is significantly faster than the strip chart because it is free of the
processing overhead involved in scrolling.

The sweep chart mode acts much like the scope chart, but it does not
blank when the data hits the right border. Instead, a moving vertical lin
marks the beginning of new data and moves across the display as the
adds new data.
© National Instruments Corporation 10-3 BridgeVIEW User Manual
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3. With the VI still running, pop up on any chart, and select Update 
Mode, and change the current mode to that of another chart. Notice
difference between the various charts and modes.

4. Stop and close the VI.

End of Activity 10-1.

While Loops
A While Loop is a structure that repeats a section of code until a condi
is met. It is comparable to a Do Loop or a Repeat-Until Loop in tradition
programming language.

The While Loop, shown in the following illustration, is a resizable box yo
use to execute the diagram inside it until the Boolean value passed to
conditional terminal (an input terminal) is FALSE. The VI checks the 
conditional terminal at the end of each iteration; therefore, the While Lo
always executes at least once. The iteration terminal is an output num
terminal that contains the number of times the loop has executed. Howe
the iteration count always starts at zero, so if the loop runs once, the 
iteration terminal outputs 0.

The While Loop is equivalent to the following pseudocode:

Do

Execute Diagram Inside the Loop (which sets the 

condition)

While Condition is TRUE

conditional
terminal

iteration
terminal
BridgeVIEW User Manual 10-4 © National Instruments Corporation
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Activity 10-2. Use a While Loop and a Chart
Your objective is to use a While Loop and a chart for acquiring and 
displaying data in real time.

You will build a VI that generates random data and displays it on a ch
A knob control on the front panel adjusts the loop rate between 0 and 
seconds and a switch stops the VI. You will change the mechanical ac
of the switch so you do not have to turn on the switch each time you run
VI. Use the front panel in the following illustration to get started.

Front Panel

1. Open a new front panel by selecting File»New.

2. Place a Vertical Switch (Controls»Boolean) on the front panel. Label 
the switch Enable .

3. Use the Labeling tool to create free labels for ON and OFF. Select the 
Labeling tool, and type in the label text. With the Color tool, shown
left, make the border of the free label transparent by selecting the 
the bottom left corner of the Color palette.

4. Place a waveform chart (Controls»Graph) on the front panel. Label 
the chart Random Signal . The chart displays random data in real 
time.
© National Instruments Corporation 10-5 BridgeVIEW User Manual
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Note: Make sure that you select a waveform chart and not a waveform graph. In th
Graph palette, the waveform chart appears closest to the left side.

5. Pop up on the chart and choose Show»Digital Display, and 
Show»Scroll Bar to hide the palette and legend. The digital display
shows the latest value. 

6. Rescale the chart from 0.0  to 1.0 . Use the Labeling tool to replace the
HI limit of 10.0  with 1.0 . 

7. Place a knob (Controls»Numeric) on the front panel. Label the knob
Loop Delay (sec) . This knob controls the timing of the While 
Loop. Pop up on the knob and deselect Show»Digital Display to hide 
the digital display. 

8. Rescale the knob. Using the Labeling tool, double-click on 10.0  in the 
scale around the knob, and replace it with 2.0 . 

Block Diagram
9. Open the block diagram and create the diagram in the following 

illustration.

a. Place the While Loop in the block diagram by selecting it from
Functions»Structures. The While Loop is a resizable box that is
not dropped on the diagram immediately. Instead, you have th
chance to position and resize it. To do so, click in an area abo
and to the left of all the terminals. Continue holding down the 
mouse button and drag out a rectangle that encompasses the
terminals. 
BridgeVIEW User Manual 10-6 © National Instruments Corporation



Chapter 10 Loops and Charts

the 

he 

 on 

it 
as 
dom 

ff 
 the 

 

hart 

e 
b. Select the Random Number (0–1) function from 
Functions»Numeric.

c. Wire the diagram as shown in the Block Diagram, connecting 
Random Number (0–1) function to the Random Signal chart 
terminal, and the Enable switch to the conditional terminal of t
While Loop. Leave the Loop Delay terminal unwired for now.

10. Return to the front panel and turn on the vertical switch by clicking
it with the Operating tool. 

11. Save the VI as Random Signal.vi  in the BridgeVIEW\Tutorial  
directory. 

12. Run the VI.

The While Loop is an indefinite looping structure. The diagram within 
executes as long as the specified condition is TRUE. In this example, 
long as the switch is on (TRUE), the diagram continues to generate ran
numbers and display them on the chart.

13. Stop the VI by clicking on the vertical switch. Turning the switch o
sends the value FALSE to the loop conditional terminal and stops
loop.

14. Scroll through the chart. Click and hold down the mouse button on
either arrow in the scrollbar. 

15. Clear the display buffer and reset the chart by popping up on the c
and choosing Data Operations»Clear Chart.

Note: The display buffer default size is 1,024 points. You can increase or decreas
this buffer size by popping up on the chart and choosing Chart  History 
Length…. You only can use this feature when the VI is not running.

End of Activity 10-2.
© National Instruments Corporation 10-7 BridgeVIEW User Manual
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Mechanical Action of Boolean Switches
You might notice that each time you run the VI, you must turn on the 
vertical switch and then click the Run button in the toolbar. With G, you 
can modify the mechanical action of Boolean controls. 

There are six possible choices for the mechanical action of a Boolean
control:

• Switch When Pressed 

• Switch When Released 

• Switch Until Released 

• Latch When Pressed 

• Latch When Released 

• Latch Until Released

Below are figures depicting each of these boolean switches, as well a
description of each of these mechanical actions. 

Switch When Pressed action—Changes the control value each time y
click on the control with the Operating tool. The action is similar to that
a ceiling light switch, and is not affected by how often the VI reads the
control.

Switch When Released action—Changes the control value only after y
release the mouse button, during a mouse click, within the graphical 
boundary of the control. The action is not affected by how often the VI
reads the control. This action is similar to what happens when you click
a check mark in a dialog box; it becomes highlighted but does not cha
until you release the mouse button. 

Switch Until Released action—Changes the control value when you c
on the control. It retains the new value until you release the mouse bu
at which time the control reverts to its original value. The action is simi
to that of a doorbell, and is not affected by how often the VI reads the 
control.

Latch When Pressed action—Changes the control value when you clic
the control. It retains the new value until the VI reads it once, at which po
the control reverts to its default value. (This action happens regardless
whether you continue to press the mouse button.) This action is simila
that of a circuit breaker and is useful for stopping While Loops or havin
the VI do something only once each time you set the control. 
BridgeVIEW User Manual 10-8 © National Instruments Corporation
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Latch When Released action—Changes the control value only after yo
release the mouse button. When your VI reads the value once, the co
reverts to the old value. This action guarantees at least one new value
with Switch When Released, this action is similar to the behavior of butt
in a dialog box; clicking on this action highlights the button, and releas
the mouse button latches a reading.

Latch Until Released action—Changes the control value when you click
the control. It retains the value until your VI reads the value once or un
you release the mouse button, depending on which one occurs last.

Activity 10-3. Change the Mechanical Action 
of a Boolean Switch

Your objective is to experiment with the different mechanical actions o
Boolean switches.

1. Open the Random Signal.vi  from the BridgeVIEW\Tutorial  
directory. The default value of the Enable  switch is FALSE.

2. Modify the vertical switch so it is used only to stop the VI. Change t
switch so that you do not need to turn on the switch each time you
the VI.

a. Turn on the vertical switch with the Operating tool. 

b. Pop up on the switch and choose Data Operations»Make 
Current Value Default. This makes the ON position the defaul
value.

c. Pop up on the switch and choose Mechanical Action»Latch 
When Pressed.

3. Run the VI. Click on the Enable  switch to stop the acquisition. The 
switch moves to the OFF position momentarily and is reset back to
ON position.

4. Save the VI.

Note: For your reference, BridgeVIEW contains an example that demonstrates the
behaviors, called the Mechanical Action of Booleans VI. It is located in 
Examples\G Examples\General\Controls\booleans.llb . 

End of Activity 10-3.
© National Instruments Corporation 10-9 BridgeVIEW User Manual



Chapter 10 Loops and Charts

 as 
n 

 

lower 

l 
Timing
When you ran the VI in the previous activity, the While Loop executed
quickly as possible. However, you can slow it down to iterate at certai
intervals with the functions in the Functions»Time & Dialog palette.

The timing functions express time in milliseconds (ms), however, your
operating system might not maintain this level of timing accuracy. On 
Windows 95/NT, the timer has a resolution of 1 ms. This is hardware 
dependent, so on slower systems, such as an 80386, you might have 
resolution timing.

Activity 10-4. Control Loop Timing
Your objective is to control loop timing and ensure that no iteration is 
shorter than the specified number of milliseconds.

1. Open random signal.vi , as modified and saved in Activity10-2, 
from the BridgeVIEW\Tutorial  directory.

2. Modify the VI to generate a new random number at a time interva
specified by the knob, as shown in the following illustration.
BridgeVIEW User Manual 10-10 © National Instruments Corporation
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Wait Until Next ms Multiple function (Functions»Time & Dialog)—
Multiply the knob terminal by 1000 to convert the knob value in seconds
milliseconds. Use this value as the input to the Wait Until Next ms Multip
function. 

Multiply function (Functions»Numeric)—The multiply function 
multiplies the knob value by 1000 to convert seconds to milliseconds.

Numeric constant (Functions»Numeric)—The numeric constant holds the
constant by which you must multiply the knob value to get a quantity i
milliseconds. Thus, if the knob has a value of 1.0, the loop executes o
every 1000 milliseconds (once per second).

3. Run the VI. Rotate the knob to get different values for the loop del
Notice the effects of the loop delay on the update of the Random 

Signal  display.

4. Save the VI as Random Signal with Delay.vi  in the 
BridgeVIEW\Tutorial  directory. Close the VI. 

End of Activity 10-4.

Preventing Code Execution in the First Iteration
The While Loop always executes at least once, because G performs t
loop test for continuation after the diagram executes. You can constru
While Loop that pretests its conditional terminal by including a Case 
structure inside the loop. Wire a Boolean input to the Case structure 
selector terminal so the subdiagram for the FALSE condition executes
the code in the While Loop should not execute. 

The subdiagram for the TRUE condition contains the work of the Whil
Loop. The test for continuation occurs outside the Case structure, and
results are wired to the conditional terminal of the While Loop and the
© National Instruments Corporation 10-11 BridgeVIEW User Manual
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selector terminal of the Case structure. In the following illustration, lab
represent the pretest condition.

This example has the same result as the following pseudocode:

While (pretest condition)

Do actual work of While Loop

Loop
BridgeVIEW User Manual 10-12 © National Instruments Corporation
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Shift Registers
Shift registers (available for While Loops and For Loops) transfer value
from one loop iteration to the next. You can create a shift register by 
popping up on the left or right border of a loop and selecting Add Shift 
Register.

The shift register contains a pair of terminals directly opposite each ot
on the vertical sides of the loop border. The right terminal stores the d
upon the completion of an iteration. That data shifts at the end of the 
iteration and appears in the left terminal at the beginning of the next 
iteration, as shown in the following illustration. A shift register can hold
any data type—numeric, Boolean, string, array, and so on. The shift 
register automatically adapts to the data type of the first object you wir
the shift register.
© National Instruments Corporation 10-13 BridgeVIEW User Manual
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You can configure the shift register to remember values from several 
previous iterations. This feature is useful for averaging data points. Yo
create additional terminals to access values from previous iterations b
popping up on the left or right terminal and choosing Add Element. For 
example, if a shift register contains three elements in the left terminal, 
can access values from the last three iterations, as shown in the follow
illustration.

Before Loop Begins First Iteration

Subsequent Iterations Last Iteration

Initial
Value

Previous
Value

New
Value

Initial
Value

New
Value

New
Value

New
Value

Previous
Value

Previous values are
available at the left
terminals

Contains i-1

Contains i-2

Contains i-3

Pop up on left
terminal to add
new elements or
use Positioning
tool to resize the
left terminal to
expose more
elements

Latest value
passes to
right terminal

Pop up on
border for
new shift register
BridgeVIEW User Manual 10-14 © National Instruments Corporation



Chapter 10 Loops and Charts

t. 

y 
Activity 10-5. Use a Shift Register
Your objective is to build a VI that displays a running average on a char

Front Panel
1. Open a new front panel and create the objects as shown in the 

following illustration.

2. Change the scale of the Waveform chart to range from 0.0  to 2.0 .

3. After adding the vertical switch, pop up on it and select Mechanical 
Action»Latch When Pressed and set the ON state to be the default b
choosing Operate»Make Current Values Default.

Block Diagram
4. Build the block diagram shown in the following illustration.
© National Instruments Corporation 10-15 BridgeVIEW User Manual
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5. Add the While Loop (Functions»Structures) in the block diagram 
and create the shift register.

a. Pop up on the left or right border of the While Loop and choos
Add Shift Register.

b. Add an extra element by popping up on the left terminal of the
shift register and choosing Add Element. Add a third element in 
the same manner as the second.

Random Number (0–1) function (Functions»Numeric)—This function 
generates random data ranging between 0 and 1.

Compound Arithmetic function (Functions»Numeric)—In this activity, 
the compound arithmetic function returns the sum of random numbers f
two iterations. To add more inputs, pop up on an input and choose Ad
Input from the pop-up menu.

Divide function (Functions»Numeric)—In this activity, the divide 
function returns the average of the last four random numbers.

Numeric Constant (Functions»Numeric)—During each iteration of the 
While Loop, the Random Number (0–1) function generates one rando
value. The VI adds this value to the last three values stored in the left 
terminals of the shift register. The Random Number (0–1) function divid
the result by four to find the average of the values (the current value p
the previous three). Then the average is displayed on the waveform c

Wait Until Next ms Multiple function (Functions»Time & Dialog)—This 
function ensures that each iteration of the loop occurs no faster than t
millisecond input. The input is 500 milliseconds for this activity. If you po
up on the icon and choose Show»Label, the label Wait Until Next ms 
Multiple appears.
BridgeVIEW User Manual 10-16 © National Instruments Corporation



Chapter 10 Loops and Charts

d 

l 

d.

If 
lue 

a 

p 
er, 
that 
ast 
hift 
e 
 

the 
6. Pop up on the input of the Wait Until Next ms Multiple function an
select Create Constant. A numeric constant appears and is 
automatically wired to the function.

7. Type 500  in the label. The numeric constant wired to the Wait Unti
Next ms Multiple function specifies a wait of 500 milliseconds 
(one half-second). Thus, the loop executes once every half-secon

Notice that the VI initializes the shift registers with a random number. 
you do not initialize the shift register terminal, it contains the default va
or the last value from the previous run and the first few averages are 
meaningless.

8. Run the VI and observe the operation. 

9. Save this VI as Random Average.vi  in the BridgeVIEW\Tutorial  
directory. 

Note: Remember to initialize shift registers to avoid incorporating old or default dat
into your current data measurements

End of Activity 10-5.

Using Uninitialized Shift Registers
You initialize a shift register by wiring a value from outside a While Loo
or For Loop to the left terminal of the shift register. Sometimes, howev
you want to execute a VI repeatedly with a loop and a shift register, so 
each time the VI executes, the initial output of the shift register is the l
value from the previous execution. To do that, you must leave the left s
register terminal unwired from outside the loop. Leaving the input to th
left shift register terminal unwired preserves state information between
subsequent executions of a VI.

The following illustration shows an example of a subVI that calculates 
running average of four data points. The VI uses an uninitialized shift 
register (with three additional elements) to store previous data points.
© National Instruments Corporation 10-17 BridgeVIEW User Manual
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Each time the VI is called, running average  is computed from the new 
input and the previous three values. Then the new value is saved into
shift register, and the previous two values are moved up in the shift regi
There is no input value wired to the input side of the left shift registers
all three values are preserved for the next execution of the VI.

Because this subVI has nothing wired to the condition terminal, it execu
exactly once when called. The While Loop in this subVI is not used to lo
several times, but to store values in the loop shift registers between ca

When the Running Average VI is loaded into memory, the uninitialized
shift registers are set to zero automatically. If the shift registers are wi
to Boolean values, the initial value is FALSE.
BridgeVIEW User Manual 10-18 © National Instruments Corporation
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Activity 10-6. Create a Multiplot Chart and 
Customize Your Trends

Your objective is to create a chart that can accommodate more than 
one plot. 

Front Panel
1. Open the Random Average.vi  you created in Activity10-5. 

2. Modify the Front Panel as shown in the following illustration. 

a. If the scrollbar is present, hide it by popping up on the chart a
selecting Show»ScrollBar.

b. Using the Positioning tool, stretch the legend to include two plo

c. Show the digital display by popping up on the chart, and choos
Show»Digital Display. Move the legend if necessary.

d. Rename Plot 0 to Current Value  by double-clicking on the 
label with the Labeling tool and typing in the new text. You ca
resize the label area by dragging either of the left corners with 
Positioning tool. Rename Plot 1 to Running Avg  in the same 
way. 

e. For the Current Value  plot, change the interpolation to 
unconnected, the point style to square, and the color to green. 
can change the plot style and color by popping up on the lege
© National Instruments Corporation 10-19 BridgeVIEW User Manual
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Block Diagram
3. Modify the block diagram, as shown in the following illustration, to

display both the average and the current random number on the 
same chart. 

Bundle function (Functions»Cluster)—In this activity, the Bundle 
function bundles the average and current value for plotting on the cha
The bundle node appears as shown at left when you place it in the blo
diagram. You can add additional elements by using the Resizing curs
(accessed by placing the Positioning tool at the corner of the function)
enlarge the node. 

Note: The order of the inputs to the Bundle function determines the order of the plo
on the chart. For example, if you wire the raw data to the top input of the 
Bundle function and the average to the bottom, the first plot corresponds to t
raw data and the second plot corresponds to the average. 

4. From the front panel, run the VI. The VI displays two plots on the 
chart. The plots are overlaid. That is, they share the same vertical s

5. From the block diagram, run the VI with execution highlighting turne
on to see the data in the shift registers. 

6. Turn execution highlighting off. From the front panel, run the VI. 
While the VI is running, use the buttons from the palette to modify t
chart. You can reset the chart, scale the X or Y axis, and change 
display format at any time. You also can scroll to view other areas
zoom into areas of a graph or chart. 

You can use the X and Y buttons to rescale the X and Y axes, respective
If you want the graph to autoscale either of the scales continuously, cl
on the lock switch to the left of each button to lock on autoscaling.
BridgeVIEW User Manual 10-20 © National Instruments Corporation
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You can use the other buttons to modify the axis text precision or to con
the operation mode for the chart. Experiment with these buttons to exp
their operation, scroll the area displayed, or zoom in on areas of the c

7. Format the scales of the waveform chart to represent either absolu
relative time. To select the x scale time format, pop up on the x-sc
and select Formatting… . 

a. Choose absolute time by selecting the Time & Date option from 
the Format and Precision menu ring. This changes the dialog 
box to the one shown below. For the waveform chart to start a
certain time and increment at certain intervals, you can edit theXo 
and dX values respectively.

b. Format the chart to display the data starting from noon, 
Oct. 24, 1996 and increment every 10 minutes, as shown abo

Note: Modifying the axis text format often requires more physical space than was
originally set aside for the axis. If you change the axis, the text may becom
larger than the maximum size that the waveform can correctly present. To 
correct this, use the Resizing cursor to make the display area of the chart 
smaller.

8. To select the relative time format, select Numeric from the Format 
and Precision menu ring. Then you can select the Relative Time 
© National Instruments Corporation 10-21 BridgeVIEW User Manual
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(seconds) option in the dialog box and represent the time in second
Modify the dialog box, as shown below, and then select Close. 

9. Run the VI. 

10. Save the VI as Multiple Random Plot.vi  in the 
BridgeVIEW\Tutorial  directory.

End of Activity 10-6.

For Loops
A For Loop is a resizable structure. Like the While Loop, it is not dropp
on the diagram immediately. Instead, a small icon representing the Fo
Loop appears in the block diagram, and you have the opportunity to s
and position it. To do so, first click in an area above and to the left of all
terminals. While holding down the mouse button, drag out a rectangle 
encompasses the terminals you want to place inside the For Loop. Wh
you release the mouse button, G creates a For Loop of the size and po
BridgeVIEW User Manual 10-22 © National Instruments Corporation
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you selected. You place the For Loop on the block diagram by selectin
from Functions»Structures. 

The For Loop executes the diagram inside its border a predetermined
number of times. The For Loop has two terminals, explained below.

Count terminal (an input terminal)—The count terminal specifies the 
number of times to execute the loop. 

Iteration terminal (an output terminal)—The iteration terminal contains t
number of times the loop has executed.

The For Loop is equivalent to the following pseudocode:

For i = 0 to N-1

Execute Diagram Inside The Loop

The following illustration shows a For Loop that generates 100 random
numbers and displays the points on a chart.

Numerical
Output

Loop Count
Numerical Input
© National Instruments Corporation 10-23 BridgeVIEW User Manual
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Numeric Conversion
Until now, all the numeric controls and indicators you have used have b
double-precision, floating-point numbers represented with 32 bits. G, 
however, can represent numerics as integers (byte, word, or long) or 
floating-point numbers (single-, double-, or extended-precision). The 
default representation for a numeric is a double-precision, floating-poi

If you wire two terminals together that are of different data types, 
G converts one of the terminals to the same representation as the oth
terminal. As a reminder, G places a gray dot, called a coercion dot, on the 
terminal where the conversion takes place.

For example, consider the For Loop count terminal. The terminal 
representation is a long integer. If you wire a double-precision, 
floating-point number to the count terminal, G converts the number to 
long integer. Notice the gray dot in the count terminal of the first For Lo

Note: When the VI converts floating-point numbers to integers, it rounds to the 
nearest integer. If a number is exactly halfway between two integers, it is 
rounded to the nearest even integer. For example, the VI rounds 6.5 to 6, b
rounds 7.5 to 8.

Gray
Dot
BridgeVIEW User Manual 10-24 © National Instruments Corporation



Chapter 10 Loops and Charts

 

g 

.

Activity 10-7. Use a For Loop
Your objective is to use a For Loop and shift registers to calculate the
maximum value in a series of random numbers. 

Front Panel
1. Open a new front panel and add the objects shown in the followin

illustration.

a. Place a digital indicator on the front panel and label it Maximum 

Value .

b. Place a waveform chart on the front panel and label it Random 

Data . Change the scale of the chart to range from 0.0  to 1.0 .

c.  Pop up on the chart and choose Show»Scrollbar and 
Show»Digital Display. Pop up and hide the palette and legend

d. Resize the scrollbar with the positioning tool. 
© National Instruments Corporation 10-25 BridgeVIEW User Manual
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Block Diagram
2. Open the block diagram and modify it as shown in the following 

illustration.

3. Place a For Loop (Functions»Structures) on the block diagram. 

4. Add the shift register by popping up or right-clicking on the right o
left border of the For Loop and choosing Add Shift Register. You can 
learn more about shift registers in the next section.

5. Add the following objects to the block diagram.

Random Number (0–1) function (Functions»Numeric)—This function 
generates the random data.

Numeric Constant (Functions»Numeric)—The For Loop needs to know 
how many iterations to make. In this case, you execute the For Loop 1
times.

Numeric Constant (Functions»Numeric)—You set the initial value of the 
shift register to zero for this exercise because you know that the outpu
the random number generator is from 0.0 to 1.0.

You must know something about the data you are collecting to initializ
shift register. For example, if you initialize the shift register to 1.0, then t
value is already greater than all the expected data values, and is alway
maximum value. If you did not initialize the shift register, then it would
contain the maximum value of a previous run of the VI. Therefore, you
could get a maximum output value that is not related to the current se
collected data. 
BridgeVIEW User Manual 10-26 © National Instruments Corporation
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Max & Min function (Functions»Comparison)—Takes two numeric 
inputs and outputs the maximum value of the two in the top right corner 
the minimum of the two in the bottom right corner. Because you only a
interested in the maximum value for this exercise, wire only the maxim
output and ignore the minimum output.

6. Wire the terminals as shown. If the Maximum Value terminal were
inside the For Loop, you would see it continuously updated, but 
because it is outside the loop, it contains only the last calculated 
maximum.

Note: Updating indicators each time a loop iterates is time-consuming and you 
should try to avoid it when possible to increase execution speed.

7. Run the VI. 

8. Save the VI as Calculate Max.vi in the BridgeVIEW\Tutorial  
directory. 

End of Activity 10-7.
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This chapter introduces the basic concepts of Case and Sequence 
structures, and provides activities that explain the following:

• How to use the Case structure

• How to use the Sequence structure

• What sequence locals are and how to use them

Both Case and Sequence structures can have multiple subdiagrams, 
configured like a deck of cards, of which only one is visible at a time. A
the top of each structure border is the subdiagram display window, which 
contains a diagram identifier in the center and decrement and incremen
buttons at each side. The diagram identifier indicates which subdiagra
currently is displayed. For Case structures, a diagram identifier is eith
TRUE or FALSE. For Sequence structures, a diagram identifier is the 
number of the frame in the sequence (0 ton – 1).

Clicking on the decrement (left) or increment (right) button displays th
previous or next subdiagram, respectively. Incrementing from the last 
subdiagram displays the first subdiagram, and decrementing from the 
subdiagram displays the last.

For more information about Case and Sequence structures, refer to 
Chapter 18, Structures, in the G Programming Reference Manual.

Case Structure
The Case structure has two or more subdiagrams, or cases, exactly one of 
which executes when the structure executes. This depends on the val
the Boolean or numeric scalar you wire to the external side of the selec
terminal or selector. If a Boolean is wired to the selector, the structure h
two cases, FALSE and TRUE. If a numeric is wired to the selector, the
structure can have from 0 to 215 – 1 cases. Initially, only the 0 and 1 case
are available.
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A Case structure is shown in the following illustration.

Note: Case statements in other programming languages generally do not execut
any case if a case is out of range. If you do not want out-of-range values to
activate the highest or lowest cases in BridgeVIEW, you either must pretest 
selector data for out-of-range numbers, or include a trap case that does 
nothing for out-of-range values.

Activity 11-1. Use the Case Structure
Your objective is to build a VI that checks a number to see if it is positiv
If the number is positive, the VI calculates the square root of the numbe
otherwise, the VI returns an error.

Front Panel
1. Open a new front panel and create the objects as shown in the 

following illustration.
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The Number control supplies the number. The Square Root Value  
indicator displays the square root of the number. The free label acts a
note to the user.

Block Diagram
2. Build the diagram as shown in the following illustration.

3. Place a Case structure (Functions»Structures) in the block diagram. 
Enlarge the Case structure by dragging one corner with the Positio
tool.

Greater Or Equal To 0? function (Functions»Comparison)—Returns a 
TRUE if the number input is greater than or equal to 0.

Square Root function (Functions»Numeric)—Returns the square root of 
the input number.

Selector 
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Numeric Constant (Functions»Numeric)—In this activity, the constant 
indicates the numeric value of the error.

One Button Dialog function (Functions»Time & Dialog)—In this activity, 
the function displays a dialog box that contains the message 
Error...Negative Number .

String Constant (Functions»String)—Enter text inside the box with the 
Labeling tool.

The VI executes either the TRUE case or the FALSE case. If the numb
greater than or equal to zero, the VI executes the TRUE case and retu
the square root of the number. The FALSE case outputs –99999.00 a
displays a dialog box with the message Error...Negative Number .

Note: You must define the output tunnel for each case. When you create an outp
tunnel in one case, tunnels appear at the same position in all the other cas
Unwired tunnels appear as white squares. 

4. Return to the front panel and run the VI. Try a number greater tha
zero and a number less than zero by changing the value in the dig
control you labeled Number. Notice that when you change the digita
control to a negative number, BridgeVIEW displays the error mess
you set up in the FALSE case of the Case structure.

5. Save the VI as Square Root.vi in the BridgeVIEW\Tutorial 

directory.

VI Logic
The block diagram in this activity has the same effect as the following 
pseudocode in a text-based language.

if (Number >= 0) then

Square Root Value = SQRT(Number)

else

Square Root Value = -99999.00

Display Message "Error...Negative Number"

end if

End of Activity 11-1.
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Sequence Structures
The Sequence structure, which looks like frames of film, executes bloc
diagrams sequentially. In conventional programming languages, the 
program statements execute in the order in which they appear. In data
programming, a node executes when data is available at all of the nod
inputs, although sometimes it is necessary to execute one node befor
another. BridgeVIEW uses the Sequence structure as a method to co
the order in which nodes execute. BridgeVIEW places the diagram tha
VI executes first inside the border of Frame 0, it places the diagram it 
executes second inside the border of Frame 1, and so on. As with the 
structure, only one frame is visible at a time.

A Sequence structure is shown in the following illustration.

Activity 11-2. Use a Sequence Structure
Your objective is to build a VI that computes the time it takes to genera
a random number that matches a given number.

Front Panel
1. Open a new front panel and build the front panel shown in the 

following illustration. Be sure to modify the controls and indicators 
described in the text following the illustration. 
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The Number to Match  control contains the number you want to match
The Current Number  indicator displays the current random number. Th
# of iterations  indicator displays the number of iterations before a
match. Time to Match  indicates how many seconds it took to find the
matching number.

Block Diagram
2. Open the block diagram. 

3. Place the Sequence structure (Functions»Structures) in the block 
diagram.

4. Enlarge the structure by dragging one corner with the Resizing cursor. 
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5. Create a new frame by popping up on the frame border and choo
Add Frame After . Repeat this step to create frame 2.

6. Build the block diagram shown in the following illustrations.
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Frame 0 in the previous illustration contains a small box with an arrow
it. That box is a sequence local variable which passes data between fram
of a Sequence structure. You can create sequence locals on the borde
frame. Then, the data wired to a frame sequence local is available in 
subsequent frames. However, you cannot access the data in frames 
preceding the frame in which you created the sequence local.

7. Create the sequence local by popping up on the bottom border of
Frame 0 and choosing Add Sequence Local.

The sequence local appears as an empty square. The arrow inside the s
appears automatically when you wire a function to the sequence local

8. Finish the block diagram as shown in the opening illustration of th
Block Diagram section.

Tick Count (ms) function (Functions»Time & Dialog)—Returns the 
number of milliseconds that have elapsed since power on. For this acti
you need two Tick Count functions.

Random Number (0–1) function (Functions»Numeric)—Returns a 
random number between 0 and 1.

Multiply function (Functions»Numeric)—In this activity, the function 
multiplies the random number by 100.

Numeric Constant function (Functions»Numeric)—In this activity, the 
numeric constant represents the maximum number that can be multip

Round to Nearest function (Functions»Numeric)—In this activity, the 
function rounds the random number between 0 and 100 to the nearest w
number.

Not Equal? function (Functions»Comparison)—In this activity, the 
function compares the random number to the number specified in the f
panel and returns a TRUE if the numbers are not equal. Otherwise, th
function returns FALSE.

Increment function (Functions»Numeric)—In this activity, the function 
increments the While Loop count by 1.

Subtract function (Functions»Numeric)—In this activity, the function 
returns the time (in milliseconds) elapsed between frame 2 and frame
© National Instruments Corporation 11-9 BridgeVIEW User Manual
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Divide function (Functions»Numeric)—In this activity, the function 
divides the number of milliseconds elapsed by 1000 to convert the num
to seconds.

Numeric constant (Functions»Numeric)—In this activity, the function 
converts the number from milliseconds to seconds.

In Frame 0, the Tick Count (ms) function returns the current time in 
milliseconds. This value is wired to the sequence local, where the valu
available in subsequent frames. In Frame 1, the VI executes the While L
as long as the number specified does not match the number that the Ra
Number (0–1) function returns. In Frame 2, the Tick Count (ms) functi
returns a new time in milliseconds. The VI subtracts the old time (pass
from Frame 0 through the sequence local) from the new time to comp
the time elapsed.

9. Return to the front panel and enter a number inside the Number to 

Match control  and run the VI.

10. Save the VI as Time to Match.vi in the BridgeVIEW\Tutorial 

directory.

End of Activity 11-2.
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This chapter describes objects called attribute nodes, which are speci
block diagram nodes that control the appearance and functional 
characteristics of controls and indicators. 

With attribute nodes, you can set attributes such as display colors, 
visibility, position, blinking, trend scales, and many more. To create an
attribute node, select Create»Attribute Node from the pop-up menu of the
front panel object or from the terminal in the block diagram, as shown 
the following illustration.

You can modify the characteristic listed in the node or several 
characteristics by expanding the node. To expand a node, select it with
Positioning tool. Place your mouse over the node, and when your curs
changes to a frame in the corner of the node, drag it to the desired siz
Then, you can select attributes by clicking on the node with the Opera
dgeVIEW User Manual
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tool and choosing the desired attribute from the pop-up menu, as show
the following illustration.

Because there are many different attributes for front panel objects, you
use the Help Window from the Help menu to display the descriptions, d
types, and acceptable values of attributes. For more information abou
accessing help in BridgeVIEW, see the section How Do You Access Online
Help? in Chapter 2, BridgeVIEW Environment, of this manual. 

With attribute nodes, you can assign characteristics or read the curren
state of an attribute by popping up on the attribute and selecting Change 
to Read.
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Activity 12-1. Use an Attribute Node
Your objective is to create a VI that indicates a high limit condition using
attribute nodes. You will use the Blink  and Fill Color  attributes of a Tank 

indicator  to indicate whether a randomly generated tank level has 
gone above the user-defined limit. 

Front Panel
1. Open a new front panel and create it as shown in the following 

illustration.

2. Rescale the tank from 0.0  to 100.0 .

3. Set the default Limit Setting to be 50.00 .
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Block Diagram
4. Create the block diagram as shown below.

Not function (Functions»Boolean)—In this exercise, the Not function 
inverts the value of the Stop button so that the While Loop executes 
repeatedly until you click on the Stop button. (The default state of the 
button is FALSE.) 

Random Number Generator (Functions»Numeric)—Generates raw data 
between 0 and 1 to fill the tank on your front panel. This value is multipl
by 100 to provide a value between 0 and 100. 

Greater or Equal? (Functions»Comparison)—Compares the raw data to 
the Limit Setting input. If the value is equal to or larger than the limit inp
a TRUE value is passed to the Case Structure. 

Attribute Node (Pop up on the Tank terminal)—Select Create»Attribute 
Node from the Tank terminal. Pop up on the attribute and choose 
Select»Fill Color. 

Color Box Constant (Functions»Numeric»Additional Numeric 
Constants)—Wire this constant to define a red color to Fill Color in the
TRUE case and a blue color in the FALSE Case. Pop up on the const
with the Color tool in order to select the color. 
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Wait Until Next ms Multiple (Functions»Time & Dialog)—Wire a 
numeric constant of 1000 to execute the loop every second. 

5. Run the VI. The level of the tank is compared to the Limit Setting  
control. If the tank value is greater than or equal to the Limit Settin
value, the tank color changes to red. If the data falls below the lim
the color of the tank changes to blue.

6. Save the VI as Tank Limit.vi  in the BridgeVIEW\Tutorial 

directory. 

End of Activity 12-1.
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This chapter introduces the basic concepts of polymorphism, arrays, 
clusters, and graphs and provides activities that explain auto-indexing
the Graph and Analysis VIs.

What is Polymorphism?
Polymorphism is the ability of a function to adjust to input data of differen
types, dimensions, or representations. Most G functions are polymorp
For example, the following illustrations show some of the polymorphic
combinations of the Add function.

In the first combination, the two scalars are added together, and the re
is a scalar. In the second combination, the scalar is added to each ele
of the array, and the result is an array. An array is a collection of data.
more detailed information about arrays, see the following section. In th
third combination, each element of one array is added to the correspon
element of the other array. You also can use other combinations, such
clusters of numerics or arrays of clusters.

You can apply these principles to other G functions and data types. 
G functions are polymorphic to different degrees. Some functions mig
accept numeric and Boolean inputs, others might accept a combinatio
any other data types. For more information about polymorphism, see 
Online Reference»Function and VI Reference. 
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Arrays
An array consists of a collection of data elements that are all the same 
An array has one or more dimensions and up to 231 – 1 elements per 
dimension, memory permitting. You access each array element throug
index. The index is in the range 0 to n – 1, where n is the number of 
elements in the array. The following 1D array of numeric values illustra
this structure. Notice that the first element has index 0, the second elem
has index 1, and so on.

How Do You Create and Initialize Arrays?
If you need an array as a source of data in your block diagram, you ca
choose Functions»Array and then select and place the array shell on yo
block diagram. Using the Operating tool, you can choose a numeric 
constant, Boolean constant, or string constant to place inside the emp
array. The following illustration shows an example array shell with a 
numeric constant inserted into the array shell.

To create an array, select Array & Cluster  from the Controls palette and 
place the array shell on your front panel.  Then select an object (nume
for example) and place that inside the array shell.  This creates an arr
numerics.

Note: You also can create an array and its corresponding control on the front pan
and then copy or drag the array control to the block diagram to create a 
corresponding constant.

For more information on how to create array controls and indicators on
front panel, see Chapter 14, Array and Cluster Control and Indicators, in 
the G Programming Reference Manual. 

1.2
0

3.2
1

8.2
2

8.0
3

4.8
4

5.1
5

6.0
6

1.0
7

2.5
8

1.7
9index

10-element array
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There are several ways to create and initialize arrays on the block diag
Some block diagram functions also produce arrays, as the following 
illustration shows.

Array Controls, Constants, and Indicators
You create array controls, constants, and indicators on the front panel
block diagram by combining an array shell with a numeric, Boolean, stri
or cluster. An array element cannot be another array, chart, or graph. 
examples of arrays, see G Examples\General\ arrays.llb .

Auto-Indexing
For Loop and While Loop structures can index and accumulate arrays
their boundaries automatically. These capabilities collectively are calle
auto-indexing. When you enable auto-indexing and wire an array of an
dimension from an external node to an input tunnel on the loop border
components of that array enter the loop, one at a time, starting with the
component. The loop indexes scalar elements from 1D arrays, 1D arra
from 2D arrays, and so on. The opposite action occurs at output tunne
elements accumulate sequentially into 1D arrays, 1D arrays accumula
into 2D arrays, and so on.

Note: Auto-indexing is the default for every array wired to a For Loop. You can
disable auto-indexing by popping up on the tunnel (entry point of the input
array) and selecting Disable Indexing.

String to Byte Array

x[i]=ASCII code
of ith character

Sine Pattern
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By default, auto-indexing is disabled for every array wired to a While 
Loop. Pop up on the array tunnel of a While Loop to enable auto-index

Activity 13-1. Create an Array with 
Auto-Indexing

Your objective is to create an array using the auto-indexing feature of 
For Loop and plot the array in a waveform graph.

You will build a VI that generates an array using the Generate Wavefo
VI and plots the array in a waveform graph. You also will modify the VI 
graph multiple plots.

Front Panel
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1. Open a new front panel.

2. Place an array shell from Controls»Array & Cluster  in the front 
panel. Label the array shell Waveform Array .

3. Place a digital indicator from Controls»Numeric inside the element 
display of the array shell, as the following illustration shows. This 
indicator displays the array contents.

4. Place a waveform graph from Controls»Graph in the front panel. 
Label the graph Waveform Graph .

5. Enlarge the graph by dragging a corner with the Resizing cursor.

6. Hide the legend and palette.

7. Disable autoscaling by popping up on the graph and deselecting 
Y Scale»Autoscale Y. 

8. Use the Text tool to rescale the Y axis to range from –0.5  to 1.5 .

Block Diagram
9. Build the block diagram shown in the following illustration.

Generate Waveform VI (Functions»Select a VI… from the 
BridgeVIEW\Tutorial  directory)—Returns one point of a waveform. 
The VI requires a scalar index input, so wire the loop iteration termina
this input.
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Notice that the wire from the Generate Waveform VI becomes thicker a
changes to an array at the loop border.

The For Loop automatically accumulates the arrays at its boundary. Th
called auto-indexing. In this case, the numeric constant wired to the lo
count numeric input has the For Loop create a 100-element array (inde
0 to 99).

Bundle function (Functions»Cluster)—Assembles the plot components 
into a cluster. You need to resize the Bundle function icon before you 
wire it properly. Place the Positioning tool on the lower-left corner of th
icon. The tool transforms into the Resizing cursor shown at left. When
tool changes, click and drag down until a third input terminal appears.
Now, you can continue wiring your block diagram as shown in the previo
illustration.

Numeric Constant (Functions»Numeric)—Three numeric constants set 
the number of For Loop iterations, the initial X value, and the delta X val
Notice that you can pop up on the For Loop count terminal, shown at l
and select Create Constant to add and wire a numeric constant for tha
terminal automatically.

10. From the front panel, run the VI. The VI plots the auto-indexed 
waveform array on the waveform graph. The initial X value is 0 and 
the delta X value is 1.

11. Change the delta X value to 0.5 and the initial X value to 20. Run the 
VI again.

Notice that the graph now displays the same 100 points of data with a
starting value of 20 and a delta X of 0.5 for each point (see the X axis). In
a timed test, this graph might correspond to 50 seconds worth of data
starting at 20 seconds.

12. You can view any element in the waveform array by entering the in
of that element in the index display. If you enter a number greater t
the array size, the display dims, indicating that you do not have a 
defined element for that index.

If you want to view more than one element at a time, you can resize th
array indicator. Place the Positioning tool on the lower right corner of t
array. The tool transforms into the Resizing cursor shown at left. When
tool changes, drag to the right or straight down. The array now display
several elements in ascending index order, beginning with the elemen
corresponding to the specified index, as the following illustration show
BridgeVIEW User Manual 13-6 © National Instruments Corporation
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In the previous block diagram, you specified an initial X and a delta X value 
for the waveform. The default initial X value is zero and the delta X value 
is 1. So, you can wire the waveform array directly to the waveform gra
terminal without the initial X and delta X specified, as the following 
illustration shows.

13. Return to the block diagram. Delete the Bundle function and the 
numeric constants wired to it. To delete the function and constant
select the function and constants with the Positioning tool then pre
<Delete>. Select Edit»Remove Bad Wires. Finish wiring the block 
diagram as shown in the previous illustration.

14. Run the VI. Notice that the VI plots the waveform with an initial 
X value of 0 and a delta X value of 1.

index
© National Instruments Corporation 13-7 BridgeVIEW User Manual
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Multiplot Graphs
You can create multiplot waveform graphs by building an array of the d
type normally passed to a single-plot graph.

15. Continue building your block diagram as shown in the preceding 
diagram. 

Sine function (Functions»Numeric»Trigonometric)—In this activity, 
you use the function in a For Loop to build an array of points that repres
one cycle of a sine wave.

Build Array function (Functions»Array)—In this exercise, you use this 
function to create the proper data structure to plot two arrays on a wave
graph, which in this case is a 2D array. Enlarge the Build Array function
create two inputs by dragging a corner with the Positioning tool.

Pi constant (Functions»Numeric»Additional Numeric Constants)—
Remember that you can find the Multiply and Divide functions in 
Functions»Numeric.

16. Switch to the front panel. Run the VI.

Notice that the two waveforms plot on the same waveform graph. The
initial X value defaults to 0 and the delta X value defaults to 1 for both 
data sets.
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Note: You can change the appearance of a plot on the graph by popping up in th
legend for a particular plot. For example, you can change from a line graph t
a bar graph by choosing Common Plots»Bar Graph.

17. Save the VI as Graph Waveform Arrays.vi  in the 
BridgeVIEW\Tutorial directory . 

End of Activity 13-1.

In the previous example, the For Loop executed 100 times because a
constant of 100  was wired to the count terminal. The following activity 
illustrates another means of determining how many times a loop will 
execute.

Activity 13-2. Use Auto-Indexing on Input 
Arrays

Your objective is to open and operate a VI that uses auto-indexing in a 
For Loop to process an array.

1. Open the Separate Array Values VI by selecting File»Open…. The VI 
is located in Examples\G Examples\General\arrays.llb .
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2. Open the block diagram. The following illustration shows the bloc
diagram with both TRUE and FALSE cases visible.

Notice that the wire from Input Array  changes from a thick wire outside
the For Loop, indicating it is an array, to a thin wire inside the loop, 
indicating it is a single element. The ith element of the array is indexed 
automatically from the array during each iteration.

Using Auto-Indexing to Set the For Loop Count
Notice that the count terminal is left unwired. When you use auto-index
on an array entering a For Loop, the loop executes according to the siz
the array, eliminating the need to wire a value to the count terminal. If y
use auto-indexing for more than one array, or if you set the count in 
addition to auto-indexing an array, the actual number of iterations is th
smallest number possible.
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3. Run the VI. Of the eight input values, you will see four in the Positi
Array and four in the Negative Array.

4. From the block diagram, wire a constant of 5 to the count termina
the For Loop. Run the VI. You will see three values in the Positive
Array and two in the Negative Array, even though the input array s
has eight elements. This demonstrates that if N is set and you are
auto-indexing, the smaller number is used for the actual number o
iterations of the loop. 

5. Close the VI and do not save changes. 

End of Activity 13-2.

Using Array Functions
G has many functions to manipulate arrays located in Functions»Array. 
These functions include Replace Array Element, Search 1D Array, Sor
Array, Reverse 1D Array, and Multiply Array Elements. For more 
information about arrays and the array functions available, refer to Cha
14, Array and Cluster Controls and Indicators, in the G Programming 
Reference Manual or Online Reference»Function and VI Reference.

Build Array

Build Array function (Functions»Array)—You can use it to create an 
array from scalar values or from other arrays. Initially, the Build Array 
function appears with one scalar input.

You can add as many inputs as you need to the Build Array function, a
each input can be either a scalar or an array. To add more inputs, pop 
the left side of the function and select Add Element Input or Add Array 
Input . You also can enlarge the Build Array node with the Resizing cur
(place the Positioning tool at the corner of an object to transform it into
© National Instruments Corporation 13-11 BridgeVIEW User Manual
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Resizing cursor). You can remove inputs by shrinking the node with th
Resizing cursor, or by selecting Remove Input.

The following illustrations show two ways to create and initialize array
with values from block diagram constants. On the left, five string consta
are built into a 1D array of strings. On the right, three groups of numer
constants are built into three, 1D numeric arrays. Then, the three array
combined into a 2D numeric array. The result is a 3 x 3 array with the ro
3, 4, 7; –1, 6, 2; and 5, –2, 8.

You also can create an array by combining other arrays along with sc
elements. For example, suppose you have two arrays and three scala
elements that you want to combine into a new array with the order arra
scalar 1, scalar 2, array 2, and scalar 3.

Initialize Array
Use this function to create an array whose elements all have the same v
In the following illustration, this function creates a 1D array.

The element input determines the data type and the value of each elem
The dimension size input determines the length of the array. For exam
if element  is a long integer with the value of five and dimension size  
has a value of 100, the result is a 1D array of 100 long integers all set
five. You can wire the inputs from front panel control terminals, as sho
in the preceding illustration, from block diagram constants, or from 
calculations on other parts of your diagram.
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To create and initialize an array that has more than one dimension, po
on the lower-left side of the function and select Add Dimension. You also 
can use the Resizing cursor to enlarge the Initialize Array node and ad
more dimension size inputs, one for each additional dimension. You c
remove dimensions by shrinking the node by selecting Remove Dimen
from the function pop-up menu or with the Resizing cursor.

The following block diagram shows how to initialize a 3D array.

If all the dimension size inputs are zero, the function creates an empty a
of the specified type and dimension. 

Array Size
Array Size returns the number of elements in the input array. 

7 3 2 5

array

4
Number of
elements

2 rows
3 columns2D array
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Array Subset
You can use this function to extract a portion of an array or matrix.

Array Subset returns a portion of an array starting at index and contain
length elements. The following illustrations show examples of Array 
Subsets. Notice that the array index begins with 0.

Index Array
The Index Array function accesses an element of an array.

 

Array

Index

Length

2D Array

Row Index

Row Length

Column Index

Column Length

New 2D Array
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The following illustration shows an example of an Index Array function
accessing the third element of an array. Notice that the index of the th
element is 2 because the first element has index 0.

You also can use this function to slice off one or more dimensions of a
multi-dimensional array to create a subarray of the original. To do this
stretch the Index Array function to include two index inputs, and select 
Disable Indexing command on the pop-up menu of the second index 
terminal as shown in the following illustration. Now you have disabled t
access to a specific array column. By giving it a row index, the result is
array whose elements are the elements of the specified row of the 2D a
You also can disable indexing on the row terminal.

Notice that the index terminal symbol changes from a solid to an empty 
when you disable indexing. To restore a disabled index, use the Enable 
Indexing command from the same menu.

You can extract subarrays along any combination of dimensions. The
following illustration shows how to extract a 1D row or column arrays fro
a 2D array.

Array
Index

Element

Array

Disabled input
(empty box)
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From a 3D array, you can extract a 2D array by disabling two index 
terminals, or a 1D array by disabling a single index terminal. The followi
figure shows several ways to slice a 3D array.

The following rules govern the use of the Index Array function to slice 
arrays:

• The dimension of the output object must equal the number of disab
index terminals. For example:

– Zero disabled = scalar element

– One disabled = 1D component

– Two disabled = 2D component

• The values wired to enabled terminals must identify the output 
elements. 

Thus, you can interpret the lower left preceding example as a comman
generate a 1D array of all elements at column 0 and row 3. You can 
interpret the upper right example as a command to generate a 2D arra
page 1. The new, 0th element is the one closest to the original, as shown
the preceding illustration.

Extract Column

Extract Row
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Activity 13-3. Use the Build Array Function
Your objective is to use the Build Array function to combine elements an
arrays into one bigger array.

Front Panel
1. Create a new front panel, as shown in the following illustration. 

2. Place a digital control from the Controls»Numeric palette and label it 
scalar 1 . Change its representation to I32 .

3. Copy and paste it to create two other digital controls and label the
scalar 2  and scalar 3 .

4. Create an array of digital controls and label it array 1 . Copy and 
paste it and label it array 2 .

5. Expand the arrays and enter the values 1 through 9 in array 1 , 
scalar 1 , scalar 2 , array 2 , and scalar 3 , as shown in the 
illustration above.

6. Copy the array and paste it and change it to an indicator. Label it 
1D array . Expand it to show nine values. 
© National Instruments Corporation 13-17 BridgeVIEW User Manual
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Block Diagram
7. Place a Build Array function (Functions»Array) on the block 

diagram. Expand it with the Positioning tool to have five inputs.

8. Pop up on the first input in the Build Array node and select Change to 
Array . Do the same for the fourth input. 

9. Wire the arrays and scalars to the node. The output array is a 1D a
composed of the elements of array 1  followed by scalar 1 , 
scalar 2 , and the elements of array 2  and scalar 3 , as the 
following illustration shows. 

 

10. Run the VI. You can see the values in scalar 1 , scalar 2 , 
scalar 3 , array 1 , and array 2  appear in a single 1D array. 

11. Save the VI as Build Array.vi  in the BridgeVIEW\Tutorial  
directory. 

End of Activity 13-3.

Efficient Memory Usage: Minimizing Data Copies
To save memory, you can use single-precision arrays instead of 
double-precision arrays. For information about how memory is allocat
see the section Memory Usage in Chapter 26, Performance Issues, in the G 
Programming Reference Manual.
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Clusters
A cluster is a data type that can contain data elements of different typ
The cluster in the block diagram that you are building in this activity grou
related data elements from multiple places on the diagram, reducing w
clutter. When you use clusters, your subVIs require fewer connection 
terminals. A cluster is analogous to a record in Pascal or a struct in C. 
can think of a cluster as a bundle of wires, much like a telephone cabl
Each wire in the cable would represent a different element of the clust
The components include the initial X value (0), the delta X value (1), and 
the Y array (waveform data, provided by the numeric constants on the
block diagram). In G, use the Bundle function to assemble a cluster. F
more information about Clusters refer to Chapter 14, Array and Cluster 
Controls and Indicators, in the G Programming Reference Manual.

Graphs
A graph is a two-dimensional display of one or more data arrays called
plots. There are three types of graphs in the Controls»Graph palette:

• XY graph

• Waveform graph

• Intensity graph

This palette also contains the Historical Trend, which is an XY Graph 
specifically configured for displaying logged data in BridgeVIEW. The 
difference between a graph and a chart (discussed in Chapter 10, Loops and 
Charts, in this manual) is that a graph plots data as a block, whereas a c
plots data point by point, or array by array.

For examples of graph VIs, see Examples\G Examples\General\

Graphs .

Customizing Graphs
Both waveform and XY graphs have a number of optional parts that y
can show or hide using the Show submenu of the pop-up menu for the 
graph. The options include a legend, through which you can define th
color and style for a given plot, a palette from which you can change sca
and format options while the VI is running, and a cursor display. The 
following illustration of a graph shows all of the optional components 
except for the cursor display.
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Graph Cursors
You can place cursors and a cursor display on all the graphs in G, and
can label the cursor on the plot. With the graph attribute node, you can
and read cursors programmatically. You can set a cursor to lock onto a 
and you can move multiple cursors at the same time. There is no limit to
number of cursors a graph can have. The following illustration shows 
waveform graph with the cursor display.

Y scale

major grids
minor grids

legend

X scale

palette

cursor
style

control
cursor

movement
control

cursor
name

X position

Y position

Active Cursor

cursor movement
button for

lock to
plot control
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For more detailed information on customizing graphs, see Chapter 15
Graph and Chart Controls and Indicators, in the G Programming 
Reference Manual.

Refer to the ZoomGraph VI in Examples\G Examples\General\ 

Graphs\zoom.llb  for an example that reads cursor values and 
programmatically zooms in and out of a graph using the cursors.

Graph Axes
You can format the scales of a graph to represent either absolute or rel
time. Use absolute time format to display the time, date, or both for yo
scale. If you do not want BridgeVIEW to assume a date, use relative t
format. To select absolute or relative time format, pop up on the chart 
select the scale you want to modify. Select Formatting… . This enables the 
Formatting  dialog box, which you can use to specify different attributes
the chart.

Data Acquisition Arrays
Data returned from a plug-in data acquisition board using the Data 
Acquisition VIs can be in the form of a single value, a 1D array, or a 
2D array. You can find a number of graph examples located in 
Examples\G Examples\General\Graphs , which contains VIs to 
perform varied functions with arrays and graphs.
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Activity 13-4. Use the Graph and Analysis VIs
Your objective is to build a VI that measures temperature and displays t
values in real time. It also displays the average, maximum, and minimu
temperatures.

Front Panel
1. Create a new front panel as shown in the following illustration. Yo

can modify the point styles of the waveform chart and waveform gra
by popping up on their legends. Scale the charts as shown.

The Temperature waveform chart displays the temperature as it is acqu
After acquisition, the VI plots the data in Temp Graph . The Mean, Max, and 
Min  digital indicators display the average, maximum, and minimum 
temperatures.
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Block Diagram
2. Build the block diagram as shown in the following illustration:

Thermometer VI (Functions»Select a VI from the 
BridgeVIEW\Tutorial  directory)—Returns one temperature 
measurement.

Wait Until Next ms Multiple function (Functions»Time & Dialog)—In 
this exercise, this function ensures the For Loop executes every 
0.25 seconds (250 milliseconds).

Numeric constant (Functions»Numeric)—You also can pop up on the 
Wait Until Next ms Multiple function and select Create Constant to 
automatically create and wire the numeric constant.

Array Max & Min function (Functions»Array)—In this activity, this 
function returns the maximum and minimum temperature measured du
the acquisition.

Mean VI (Functions»Analysis»Probability and Statistics)—Returns the 
average of the temperature measurements.

Bundle function (Functions»Cluster)—Assembles the plot components 
into a cluster. The components include the initial X value (0), the delta X 
value (0.25), and the Y array (temperature data). Use the Positioning 
to resize the function by dragging one of the corners.
© National Instruments Corporation 13-23 BridgeVIEW User Manual
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The For Loop executes 40 times. The Wait Until Next ms Multiple functi
causes each iteration to take place every 250 milliseconds. The VI sto
the temperature measurements in an array created at the For Loop bo
(auto-indexing). After the For Loop completes execution, the array is 
passed on to the subVIs and Temp Graph .

3. Return to the front panel and run the VI.

4. Save the VI as Temperature Analysis.vi  in the 
BridgeVIEW\Tutorial  directory.

End of Activity 13-4.
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This chapter introduces VI Control VIs and provides an activity that 
explains how to use them within BridgeVIEW. The VI Control VIs allow
you to control when a VI is loaded into memory, run, and unloaded fro
memory. These VIs also allow you to accomplish the following 
dynamically:

• Resize a VI front panel

• Monitor the status of VI execution (running or idle)

• Monitor the status of a VI front panel (closed, open, or active)

You can reach the VI Control VIs through the Functions Palette from the 
Block Diagram window. The VI Control  subpalette is shown below.
dgeVIEW User Manual
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What Are VI Control VIs?
VI Control VIs are VIs you can use to load, call, and close other VIs 
dynamically. When you call a VI dynamically, you specify whether the
called VI opens its front panel and then closes the front panel when it 
finishes executing. You also can pass parameters to and receive data
the VIs you call dynamically. All of the VI Control VIs use error cluster
inputs and outputs to make error handling easier. For detailed informa
about any of the VI Control VIs, refer to the BridgeVIEW Online Reference 
by selecting Help»Online Reference.

As you develop larger BridgeVIEW applications, you might find it 
inconvenient to have all of the subVIs in memory at once. For exampl
assume you have written a number of VIs that act as user interfaces (M
for several subsystems within your process. One solution might be to h
a top-level VI that has each of these subVIs in its diagram. The top-leve
serves as a menu from which you choose the subVI to run, as shown i
front panel portion of the illustration below.

This VI contains a set of Booleans such that when the user presses a b
on the front panel, the proper subVI is executed. The diagram builds a
array of Booleans and checks the array for any TRUE values. The inde
the TRUE value is passed into a Case structure and each case contai
appropriate subVI, as shown in the previous illustration.
BridgeVIEW User Manual 14-2 © National Instruments Corporation
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The disadvantage of the above approach is that all subVIs are in memo
all times, regardless of which ones are needed. If each subVI is large, 
main menu VI might require a large amount of memory.

To avoid using so much memory, you can use the VI Control VIs to loa
and execute VIs dynamically. To do this, you must know the name of 
VI you want to access and its location on the computer or network. Th
illustration below demonstrates the same scenario described above, t
time using VI Control VIs.

In both of the previous examples, the top-level VI stops executing until 
subVI completes, which means the top-level VI stops responding to th
user interface. To keep both the top-level VI and other VIs responding
the user interface at all times, you can load and run VIs dynamically a
shown in Activity14-1.
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Activity 14-1. Use a VI Control VI
Your objective is to build a top-level VI that uses VI Control VIs to load
run, display, and unload two other VIs. The top-level VI will load both 
subVIs dynamically. Then, the top-level VI will open and run the subV
chosen by the user. 

Front Panel
1. Open a new front panel. Place a waveform chart and label it 

Trend #1 . Place a rectangular stop button and label it Close . Save 
the VI as HMI#1.vi  in the BridgeVIEW\Tutorial  directory.

2. Open a new front panel. Place a cluster with two rectangular butto
labeled HMI#1 and HMI#2. Create a button and label it Shutdown . At 
the end of this exercise, you will have three front panels, which wi
appear as shown below.
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3. Save this VI as VI Control2.vi  in the BridgeVIEW\Tutorial  
directory. This VI will call the HMI#1 and HMI#2 VIs.

Block Diagram
4. Build the block diagram of VI Control2.vi , as shown in the 

following illustrations.
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Preload Instrument VI (Functions»VI Control VIs )—Dynamically loads 
the two HMI subVIs into memory. 

Path Control (Pop up on Path input of Preload Instrument VI and choo
Create Control)—Provides the path to the subVIs to be called.

Array String constant (Functions»Array)—Provide the name of the 
subVIs to be called, HMI#1.vi and HMI#2.vi.

Cluster to Array (Functions»Cluster)—Converts the cluster of booleans
to a boolean array.

Search 1D Array (Function»Array )—Returns the index of the first TRUE
value it finds in the Boolean array. If you did not click on a button, Sea
1D array returns an index value of –1 and does nothing. If a Boolean v
is pressed, it returns the index value of the respective Boolean and then
and opens the selected subVI.

Run Instrument VI (Functions»VI Control VIs )—Executes the subVI that 
is loaded in memory and specified by the output of the Search 1D arra

Open Panel VI (Functions»VI Control VIs )—Displays the selected HMI 
subVIs front panel. 

Close Panel VI (Functions»VI Control VIs )—Closes the selected HMI 
subVIs front panel. 

Release Instrument VI (Functions»VI Control VIs )—Unloads the subVI 
from memory. 

Greater Than or Equal to 0 Function (Functions»Comparison)— Returns 
TRUE if the input value is greater than or equal to 0. Otherwise the func
returns FALSE. 

Boolean Constant (Functions»Numeric)—Supplies a constant TRUE or 
FALSE value to the Not Function, in this activity. Set this value by clickin
on the T or F portion of the constant with the Operating tool. The value
cannot be changed while the VI is executing. 
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Not Function (Functions»Comparison)—The node inverts the Boolean 
state of the While Loop. 

5. Save the VI. 

6. Build the block diagram of HMI#1, as shown in the following 
illustration. 

7. Save HMI#1.vi  Save a copy of this VI as HMI#2.vi  in the 
BridgeVIEW\Tutorial  directory.

8. Close HMI#1.vi  and HMI#2.vi . 

9. Run VI Control2.vi . Make sure that you have entered the corre
path in the VI path to HMI#1.vi & HMI#2.vi  section. Click on 
the HMI#1 button. The front panel of HMI#1.vi  appears. Now click 
on the HMI#2 button. The front panel of HMI#2.vi  appears.

10. Press the Shutdown button to close the front panels of HMI#1 and 
HMI#2 and stop VI Control2.vi .

End of Activity 14-1.
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Congratulations! You have completed the tutorial section of this manu
and are familiar with many aspects of G programming. Now, you need
apply that knowledge to develop your own applications. This chapter 
suggests some techniques to use when creating programs and offers 
programming style recommendations.

Use Top-Down Design
When you have a large project to manage, think top-down design. G has an 
advantage over other programming languages when it comes to top-d
design because you can start with the final user interface and then 
animate it. 

Make a List of User Requirements
Create a list of the panels that the user can interact with, the number a
type of controls and indicators for these panels, the need for real-time
analysis, data presentation, and so on. Next, create some dummy fron
panels you can show to the prospective users (or manipulate yourself
you are the user). Think about and discuss functions and features. Use
interactive process to redesign the user interface, as necessary. You m
need to do some low-level research at this early stage to be sure you 
meet specifications.

Design the VI Hierarchy
The power of G lies in the hierarchical nature of VIs. After you create a 
you can use it as a subVI in the block diagram of a higher level VI. You c
have an essentially unlimited number of layers in the hierarchy. 

Break the task to be accomplished, at logical places, into manageable
pieces. As the following flowchart shows, there are several major bloc
dgeVIEW User Manual
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you can expect to see in one form or another on every data acquisitio
system.

In some cases you might not need all of these blocks, or you might ne
different blocks. For example, some applications might include monitor
only, thus, you would not need to write data to the Real-Time Databas
Alternatively, you might need additional blocks, such as blocks 
representing user prompts. The main objective is to divide your 
programming task into high-level blocks that you can manage easily.

After you determine the high-level blocks you need, try to create a blo
diagram that uses those high-level blocks. For each block, create a new
VI (a nonfunctional prototype representing a future subVI). Give this st
VI an icon and create a front panel that contains the necessary inputs
outputs. You do not have to create a block diagram for this VI yet. Inste
see if this stub VI is a necessary part of your top-level block diagram.

After you assemble a group of these stub VIs, try to understand, in gen
terms, the function of each block, and how that block provides the des
results. Ask yourself whether any given block generates information th
some subsequent VI needs. If so, make sure that your top-level block
diagram sketch contains wires to pass the data between VIs.

Operator
Panel

Terminate
Manage

StateInitialize

Read
Data

Process
Data

Write
Data
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Try to avoid using unnecessary global variables, because they hide the
dependency between VIs. Use memory tags only when you need this
information in the Engine for historical logging or alarms. As your syste
gets larger, it becomes difficult to debug if you depend upon global 
variables and memory tags as your method for transferring informatio
between VIs. 

Write the Program
Now you are ready to write the program in G. 

• Use a modular approach by building subVIs where there is a logic
division of labor, or the potential for code reuse. 

• Solve the more general problems along with your specific ones. 

• Test your subVIs as you write them. This might involve constructio
of higher-level test routines, but it is much easier to catch the bug
one small module than in a hierarchy of several VIs.

As you consider the details of your subVIs, you might find that your init
design is incomplete. For example, you might realize you need to tran
more information from one subVI to another. You might have to 
re-evaluate your top-level design at this point. Using modular subVIs t
accomplish specific tasks makes it easier to manage your program 
reorganizations.

Plan Ahead with Connector Panes
If you think that you might need to add additional inputs or outputs later 
select a pattern with extra terminals. You can leave these extra termin
unconnected. That way, you do not have to change the connector pan
your VI if you find you need another input or output later on. By adding
extra, unused terminals, you can add an input or output with minimal ef
on your hierarchy.
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When linking controls and indicators to the connector, place inputs on
left, and outputs on the right. This prevents complicated, unclear wirin
patterns in your VIs.

If you create a group of subVIs that are used together often, try to give
subVIs a consistent connector pane, with common inputs in the same
location. This makes it easier to remember where to locate each input
without using the Help window. If you create a subVI that produces an
output that is used as the input to another subVI, try to align the input 
output connections. This simplifies your wiring patterns.

SubVIs with Required Inputs
On the front panel, you can edit required inputs for subVIs by clicking 
the icon pane, on the upper-right side of the window and choosing Show 
Connector»This Connection Is. From the submenu, choose between th
Required, Recommended, or Optional options. The following 
illustration displays the submenu options.

If you want to return to the icon pane in the front panel, pop up on the 
connector pane and select Show Icon. 

BAD Input
Location

GOOD Input
Location

OK Output
Location

OK Input
Location

BAD Output
Location

GOOD Output
Location
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Good Diagram Style
In general, avoid creating a block diagram that uses more than one or
screens of space. If a diagram becomes very large, decide whether so
components of your diagram could be reused by other VIs, or whethe
section of your diagram fits together as a logical component. If so, cons
breaking your diagram up into subVIs.

With forethought and careful planning, it is much easier to design diagra
that use subVIs to perform specific tasks. Using subVIs helps you man
changes and debug your diagrams quickly. You can determine the func
of a well-structured program after only a brief examination. 

Watch for Common Operations
As you design your programs, you might find that you perform a certa
operation frequently. Depending upon the situation, this might be a go
place to use subVIs or loops to perform an action repetitively.

For example, consider the following diagram, where three similar 
operations run independently.
© National Instruments Corporation 15-5 BridgeVIEW User Manual
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An alternative to this design is a loop, which performs the operation th
times. You can build an array of the different arguments and use 
auto-indexing to set the correct value for each iteration of the loop.

If the array elements are constant, you can use an array constant inste
building the array on the block diagram.

Use Left-to-Right Layouts
G was designed to use a left-to-right (and sometimes top-to-bottom) lay
All elements of your program should be organized in this fashion, whe
possible.

Check for Errors
When you perform any kind of I/O, you should consider the possibility
errors occurring. Almost all I/O functions return error information. If yo
are using direct I/O, make sure that your program checks for errors and
handle them appropriately.

The BridgeVIEW Engine handles system events and errors reported b
device servers. However, your VIs must handle any error conditions wit
their diagrams. For example, if a VI is unable to open a file properly, y
might want the VI to halt or inform the user of the error through a dialo
box. You also might want the VI to use an alternative path before alert
the user of the error. You can make these error-handling decisions in 
block diagram of your VI. 

The following list describes situations in which errors frequently occur

• Incorrect initialization of communication or data that has been writt
to an external device improperly

• Loss of power, broken, or improperly working external device
BridgeVIEW User Manual 15-6 © National Instruments Corporation
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• Change in functionality of an application or library when upgrading
operating system software

When an error occurs, you might not want certain subsequent operatio
take place. For instance, if an analog output operation fails because y
specify the wrong device, you might not want a subsequent analog inp
operation to take place.

One method for managing such a problem is to test for errors after ev
function, and put subsequent functions inside case structures. This ca
complicate your diagrams and ultimately hide the purpose of your 
application.

An alternative approach, which has been used successfully in a numb
applications and many of the VI libraries, is to incorporate error handli
in the subVIs that perform I/O. Each VI can have an error input and an e
output. You can design the VI to check the error input to see if an error
occurred previously. If there is an error, you can set up the VI to do noth
and pass the error input to the error output. If there is no error, the VI c
execute the operation and pass the result to the error output.

Note: In some cases, such as a Close operation, you might want the VI to perform
the operation regardless of the error that is passed into it. 

Using the preceding technique, you can wire several VIs together, 
connecting error inputs and outputs to propagate errors from one VI to
next. At the end of the series of VIs, you can use the Simple Error Han
VI to display a dialog box if an error occurs. The Simple Error Handler 
is located in Functions»Time & Dialog. In addition to encapsulating error
handling, you can use this technique to determine the order of severa
operations.

One of the main advantages in using the error input and output cluste
that you can use them to control the execution order of dissimilar 
operations. 

The error information is generally represented using a cluster containin
numeric error code, a string containing the name of the function that 
generated the error, and an error Boolean for quick testing. The follow
© National Instruments Corporation 15-7 BridgeVIEW User Manual
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illustration shows how you can use this in your own applications. Notic
that the While Loop stops if it detects an error.

Avoid Overuse of Sequence Structures
Because VIs can operate with a great deal of inherent parallelism, avo
overusing Sequence structures. Using a Sequence structure guarante
order of execution, but prohibits parallel operations. For instance, 
asynchronous tasks that use I/O devices (GPIB, serial ports, and data
acquisition boards) can run concurrently with other operations, if Seque
structures do not prevent them from doing so.

Sequence structures tend to hide parts of the program and interrupt th
natural left-to-right flow of data. You pay no performance penalty for usi
Sequence structures; however, when you need to sequence operation
might want to consider using data flow instead. For instance, in I/O 
operations you might use the error I/O technique described previously
ensure that one I/O operation occurs before the other.

Study the Examples
For further information on program design, you can examine the many
example block diagrams included in BridgeVIEW. These sample progra
can provide you with insights into programming style and technique. T
view these block diagrams, open any of the VIs in the Tutorial  or 
Examples  directories.
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This appendix describes error handling for BridgeVIEW VIs and conta
an explanation of the VIs in the BridgeVIEW VI library. In this appendix
the VIs are arranged alphabetically, first by VI Library name (Alarms 
and Events, Historical Data, System, Tags, and Tag Attributes), then b
VI name. 

Error Handling in the BridgeVIEW VI Library
Errors that occur in the VIs in the BridgeVIEW VI Library can be handle
in one of two ways: by the BridgeVIEW Engine or by each VI. The 
BridgeVIEW Engine handles errors for the Tags VIs and the Alarms a
Events VIs. The other VIs include standard error in  and error out  
parameters for error handling. 

These two methods of error handling are described in detail below. Fo
information about how you can handle errors in your own VIs, see the
section Check for Errors in Chapter 15, Program Design. 

Errors Reported by the BridgeVIEW Engine
BridgeVIEW reports error handling information for Tags VIs, Tag 
Attributes VIs, and Alarms and Events VIs to the system. If you try to 
access a tag that does not exist in the Tags VIs or the Alarms and Eve
VIs, the BridgeVIEW Engine reports an error. The error shows up in th
BridgeVIEW Engine Manager display. For more information about the
Engine Manager, see Chapter 2, BridgeVIEW Environment. 

Errors Not Reported by the BridgeVIEW Engine
If a BridgeVIEW VI does not report to the BridgeVIEW Engine, it uses
standard control and indicator (error in and error out ) to notify you that 
an error has occurred. The error in and error out  parameters are 
described here. 
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error in (no error)  is a cluster that describes the error status before this
executes. If error in indicates that an error occurred before this VI was 
called, this VI might choose not to execute its function, but just pass th
error through to its error out  cluster. If no error has occurred, this VI 
executes normally and sets its own error status in error out . Use the error 
handler VIs to look up the error code and to display the corresponding e
message. Using error in and error out  clusters is a convenient way to 
check errors and to specify execution order by wiring the error output fr
one subVI to the error input of the next. 

status is TRUE if an error occurred before this VI was called, o
FALSE if not. If status is TRUE, code is a nonzero error code. If 
status is FALSE, code can be 0 or a warning code. 

code is the number identifying an error or warning. If status is 
TRUE, code is a nonzero error code. If status is FALSE, code can 
be 0 or a warning code. Use the error handler VIs to look up t
meaning of this code and to display the corresponding error 
message.

source is a string that indicates the origin of the error, if any. 
Usually, source is the name of the VI in which the error occurred

error out is a cluster that describes the error status after this VI execu
If an error occurred before this VI was called, error out  is the same as 
error in . Otherwise, error out  shows the error, if any, that occurred in thi
VI. Use the error handler VIs to look up the error code and to display t
corresponding error message. Using error in and error out  clusters is a 
convenient way to check errors and to specify execution order by wiring
error output from one subVI to the error input of the next. 

status is TRUE if an error occurred, or FALSE if not. If status is 
TRUE, code is a nonzero error code. If status is FALSE, code can 
be 0 or a warning code. 

code is the number identifying an error or warning. If status is 
TRUE, code is a nonzero error code. If status is FALSE, code can 
be 0 or a warning code. Use the error handler VIs to look up t
meaning of this code and to display the corresponding error 
message.

source is a string that indicates the origin of the error, if any. 
Usually, source is the name of the VI in which the error occurre
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BridgeVIEW VI Library 
Many of the VIs in the BridgeVIEW VI Library are specific to 
BridgeVIEW, and are not part of the standard G library. These VIs inclu
Alarms and Events VIs, Historical Data VIs, System VIs, Tags VIs, an
Tag Attributes VIs. This section contains an explanation of the VIs spec
to BridgeVIEW. The VIs are arranged alphabetically, first by VI palette
name, then by VI name. 

For more information about standard G VIs, refer to the BridgeVIEW 
Online Reference. Select Help»Online Reference and choose the topic 
G Language»G Reference»G Function Reference.

To reach the BridgeVIEW VIs, choose Window»Show Functions Palette 
from the block diagram window. The Functions palette is shown below. 
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Alarms and Events VIs
Use the Alarms and Events VIs to acknowledge alarms, display alarm
summary or event history information, or obtain alarm summary status
information. The Alarms and Events subpalette is shown in the followi
illustration.

Acknowledge Alarm

Use the Acknowledge Alarm VI to acknowledge alarms on a tag or a group. Call this VI w
an Acknowledge button is pressed in your HMI. You can call this VI multiple times from
your HMI.

group/tag names is the list of tags that have alarms to be acknowledge

ack alarm(T) determines whether alarms on tags in group/tag names is 
acknowledged. If FALSE, this VI does nothing except return the shutdown 
status. If unwired, this input is TRUE by default. You can wire this input
your diagram so that acknowledge is called only when a front panel con
is TRUE. This eliminates the need to place a case structure in your ca
diagram.
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error  indicates that an error occurred when executing the Acknowledg
Alarm VI. This is probably a result of the tag or group name not being 
found. 

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, the Acknowledge Alarm VI returns immediately with shutdown 
TRUE. You can use shutdown to exit any loop that uses the Acknowledg
Alarm VI.

Get Alarm Summary Status

Use the Get Alarm Summary Status VI to check the status of alarms in the BridgeVIEW
system. You can call this VI multiple times from your HMI.

group/tag names determines the tags for which alarm status is to be re
Use group <ALL> to get the status of all of the tag alarms in the syste

read parameters is a cluster of parameters for filtering out the alarms fo
which status is checked. 

min priority  is the minimum priority of alarms to read. If left 
unwired, alarms corresponding to priority level 1 and above a
reported.

max priority  is the maximum priority of alarms to read. If left 
unwired, alarms corresponding to priority level 15 and below a
reported.

filter ACK alarms?  determines whether acknowledged alarms
are read. 

alarm summary status contains information about the alarms currently i
the BridgeVIEW system.

# active alarms is the number of alarms currently in the 
BridgeVIEW system.

any alarm? is an indication of any tag in the system that is in 
alarm, irrespective of its acknowledgement status.

# unack alarms is the number of unacknowledged alarms in th
system.
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any unack alarm? is an indication of any tag in the system that 
in alarm and unacknowledged.

Read Alarm Summary

Use the Read Alarm Summary VI to display current alarm information for a set of tags o
groups within a given alarm priority range. You also can filter out acknowledged alarms.
VI formats the alarm summary information for display in an Alarm Summary Display in y
HMI. If you specify a timeout value greater than 0, this VI returns when the current alarm
information changes, or the timeout value is exceeded, whichever occurs first. The changed? 
output alerts you as to whether the current alarm information has changed.

The format  and color codes inputs determine how to format and color code summary 
information. The Read Alarm Summary VI returns all the information needed to update
Alarm Summary Display in your HMI. Part of the table indicator formatting is done throu
attribute nodes which only can exist in your diagram. The column headers display the 
column header information and must be wired to your table Column Headers[] attribute i
are displaying column headers. This is updated when the VI is executed for the first time, 
if you change the format during program operation. The initialize headers output is TRUE 
when you need to update the column headers attribute. 

You should wire the summary data output directly to your Alarm Summary Display. Wire
the row colors output to the Active Cell and Cell FG Color attributes inside of a While Loo
Wiring the Alarm Summary Display attributes like this formats the table to show differe
line colors for different alarm states. If you use the HMI G Wizard, this code is generate
you automatically. 

The entire Alarm Summary Display, including attributes, is updated only if the current a
information changes, and if there was no timeout. Table indicator updates can be slow for 
large tables, so it is a good idea to update the table only if changed? is TRUE. Notice that 
changed? is always TRUE after the first execution of the VI.
BridgeVIEW User Manual A-6 © National Instruments Corporation
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read parameters is a cluster of parameters for filtering out the alarms re

min priority  is the minimum priority of alarms to read. If left 
unwired, alarms corresponding to priority level 1 and above a
reported.

max priority  is the maximum priority of alarms to read. If left 
unwired, alarms corresponding to priority level 15 and below a
reported.

filter ACK alarms?  determines whether acknowledged alarms
are read.

group/tag names determines the tags for which alarm conditions are rea

timeout (secs) (1) specifies how many seconds to wait before reading t
tag alarms. If timeout is 0, the alarms are read immediately. If it is wired
the VI waits indefinitely until a new alarm occurs or the Real-Time 
Database shuts down, whichever occurs first.

format  allows you to compose the alarm message you want to display
the tags.

Date determines whether to display the date.

Date Format determines the format of the date, if it is selected f
displaying.

Time determines whether to display the time.

Time Format determines the format of the time, if it is selected
for displaying.

Tag Name determines whether to display the name of the tag 
in alarm.

Group Name determines whether to display the name of the 
group that the tag in alarm belongs to.
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Alarm Value determines whether to display the value of the ta
that caused the alarm.

Alarm State determines whether to display the type of alarm 
(HI_HI, LO, etc.).

Alarm Ack State determines whether to display the status of th
user who acknowledged the alarm. 

Alarm Priority  determines whether to display the priority of th
alarm state.

Alarm Limit  determines whether to display the alarm limit.

Operator Name determines whether to display the operator 
name.

Alarm Message determines whether to display the 
user-configured alarm message. This applies to discrete tags 

color codes is a cluster of parameters that determine the colors for the
messages in the Alarm Summary Display.

event determines the color for events. The Alarm Summary 
Display does not include events. 

ack alarm determines the color for acknowledged alarms.

unack alarm determines the color for unacknowledged alarms

normal determines the color for tags that are currently in norm
state, but have an unacknowledged alarm. 

buffer size determines the number of entries to be displayed in the ala
summary display. The default setting is 10.

initialize headers is TRUE when the summary data has been read for t
first time, indicating that column headers should be updated.

column headers represents the information displayed in the alarm 
summary. Wire this output to the Column Headers[] attribute of the Ala
Summary Display in your HMI.

summary data lists the alarms that currently exist is the system and ha
been filtered with the user specified priority and filter parameters.

row colors is an array of colors for the alarms displayed. Wire this outp
to the Cell FG Color attribute of the Alarm Summary Display in your HM
BridgeVIEW User Manual A-8 © National Instruments Corporation
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alarm summary status contains information about the alarms currently i
the BridgeVIEW system.

# active alarms is the number of alarms currently in the 
BridgeVIEW system.

any alarm? indicates any tag in the system that is in alarm, 
irrespective of its acknowledgement status.

# unack alarms is the number of unacknowledged alarms in th
system.

any unack alarm? indicates any tag in the system that is in alar
and unacknowledged.

error  indicates that an error occurred when executing the Read Alarm
Summary VI. It was probably a problem with the group/tag names.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, the Read Alarm Summary VI returns immediately with shutdown 
TRUE. You can use shutdown to exit any While Loop that calls Read 
Alarm Summary VI.

changed? is TRUE if a new alarm was read. If changed? is FALSE, the 
Read Alarm Summary VI probably timed out before the Alarm Summa
Display was updated.

Read Event History

Use the Read Event History VI to display all the alarms and events that have occurred
set of tags or tag groups within a given alarm priority range. You also can filter out 
acknowledged tags. The Read Event History VI formats the event history information f
display in an Event History Display indicator in your HMI. If you specify a timeout value 
greater than 0, this VI returns when the event history information changes, or the timeout 
value is exceeded, whichever occurs first. The changed? output alerts you as to whether the
event history information has been updated.

The format  and color codes inputs tell the Read Event History VI how to format and colo
code event history information. The Read Event History VI returns all the information ne
to update the Event History Display indicator. Part of the Event History Display indicat
formatting is done through attribute nodes which only can exist in your diagram. The column 
headers display the table column header information and must be wired to your table Co
Headers[] attribute if you are displaying column headers. Normally this is updated only w
the VI is executed for the first time, assuming you do not change the format  control during 
© National Instruments Corporation A-9 BridgeVIEW User Manual
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program operation. The initialize headers output is TRUE when you need to update the 
Column Headers attribute. 

Wire the history data output directly to your Event History Display. Wire the row colors 
output to the Active Cell and Cell FG Color attributes inside a While Loop. Wiring the Ev
History Display attributes formats the table to show different line colors for different ala
states or events. You can generate this code automatically by using the HMI G Wizard

The entire Event History Display, including attributes, is updated only if the event histo
information changes, and there was no timeout. Table indicator updates can be slow fo
tables, so it is usually a good idea to update the table only if the changed? indicator is TRUE. 
Notice that the changed? indicator is always TRUE after the first execution of the VI. 

read parameters is a cluster of parameters for filtering out the alarms r

min priority  is the minimum priority of alarms read. If left 
unwired, alarms corresponding to priority level 1 and above a
reported.

max priority  is the maximum priority of alarms read. If left 
unwired, alarms corresponding to priority level 15 and below a
reported.

filter ACK alarms?  determines whether acknowledged alarms
are read.

group/tag names determines the tags for which alarm conditions and 
events are read. 
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timeout (secs)(1) specifies how many seconds to wait before reading th
tag alarms and events. If timeout is 0, the alarms and events are read 
immediately. If it is wired, the VI waits indefinitely until a new alarm or
event occurs or the Real-Time Database shuts down, whichever occu
first.

format  allows you to compose the alarm message you want to display
the tags.

Date determines whether to display the date.

Date Format determines the format of the date, if it is selected f
displaying.

Time determines whether to display the time.

Time Format determines the format of the time, if it is selected
for displaying.

Tag Name determines whether to display the name of the tag 
in alarm.

Group Name determines whether to display the name of the 
group that the tag in alarm belongs to.

Alarm Value determines whether to display the value of the ta
that caused the alarm.

Alarm State determines whether to display the type of alarm 
(HI_HI, LO, etc.).

Alarm Ack State determines whether to display the status of th
user who acknowledged the alarm. 

Alarm Priority  determines whether to display the priority of th
alarm state.

Alarm Limit  determines whether to display the alarm limit.

Operator Name determines whether to display the operator 
name.

Alarm Message determines whether to display the 
user-configured alarm message. This applies to discrete tags 
© National Instruments Corporation A-11 BridgeVIEW User Manual
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color codes is a cluster of parameters that determine the colors for the
messages in the Alarm Summary Display.

event determines the color for events.

ack alarm determines the color for acknowledged alarms.

unack alarm determines the color for unacknowledged alarms

normal determines the color for tags not in alarm.

buffer size determines the number of entries to be displayed in the eve
history display. The default setting is 10. 

initialize headers is TRUE when the history data has been read for the fi
time, indicating that column headers should be updated.

column headers represents the information displayed in the event histo
Wire this output to the Column Headers[] attribute of the Alarm Summa
Display in your HMI.

history data is the list of alarms and events that have occurred in the 
system and have been filtered with the user specified read parameters

row colors is an array of colors for the alarms and events to be display
Wire this output to the Cell FG Color attribute of the Event History Displ
in your HMI.

alarm summary status contains information about the alarms currently i
the BridgeVIEW system.

# active alarms is the number of alarms currently in the 
BridgeVIEW system.

any alarm? indicates any tag in the system that is in alarm, 
irrespective of its acknowledgement status.

# unack alarms is the number of unacknowledged alarms in th
system.

any unack alarm? indicates any tag in the system that is in alar
and unacknowledged.
BridgeVIEW User Manual A-12 © National Instruments Corporation
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error  indicates that an error occurred when executing the Read Event
History VI. It was probably a problem with the group/tag name.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, the Read Event History VI returns immediately with shutdown 
TRUE. You can use shutdown to exit any While Loop that calls the Read
Event History VI.

changed? is TRUE if a new alarm or event was read. If changed? is 
FALSE, Read Event History probably timed out before the Event Histo
Display was updated.

Read Tag Alarm

Use the Read Tag Alarm VI to read detailed alarm status for a tag from the Real-Time
Database. You probably want to use the Read Tag Alarm VI in the portion of your prog
where you monitor alarm information for specific tags. The Read Tag Alarm VI indicate
whether a tag is in alarm, which alarm state it is in, when the alarm occurred, at which 
it occurred, and whether it has been acknowledged. If you specify a timeout value that is 
greater than 0, the Read Tag Alarm VI returns when the tag changes alarm state or th
timeout is exceeded, whichever occurs first. The changed? indicator alerts you to whether 
the Read Tag Alarm VI returned a new value.

tag name is the name of the tag.

timeout (secs) (0) specifies how many seconds to wait for the tag alarm
state to be updated in the Real-Time Database before reading the 
Real-Time Database for the latest alarm information. If timeout is 0, the 
Read Tag Alarm VI reads the Real-Time Database immediately and ret
the tag alarm status without waiting. If timeout is –1, Read Tag Alarm 
waits indefinitely until the tag alarm state changes, or the Real-Time 
Database shuts down, whichever occurs first. If a timeout occurs before the 
value is updated, Read Tag Alarm returns the most current tag alarm 
© National Instruments Corporation A-13 BridgeVIEW User Manual
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from the Real-Time Database, and timeout is set to TRUE. The default 
value is 0.

in alarm  is TRUE if the tag is in alarm.

alarm ack indicates whether the tag alarm has been acknowledged. If
acknowledged, alarm ack is TRUE.

alarm value is the tag value when it changed alarm states. Notice that
tag alarm value is updated only when the tag changes alarm states, a
not necessarily the most recent alarm value.

alarm timestamp indicates the time when the tag alarm state last chang

alarm state indicates the name of the most recent alarm state for the t

error  indicates that an error occurred when executing Read Alarm Tag
that the value returned by Read Tag Alarm is not valid.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, the Read Tag Alarm VI no longer waits for a change in the tag alarm 
state and returns immediately with both timeout and shutdown TRUE. 
You can use shutdown to exit any loop that uses the Read Tag Alarm V

changed? is TRUE when Read Tag Alarm returns a new alarm state fro
the Real-Time Database. If changed? is FALSE, the Read Tag Alarm VI 
probably timed out before the tag alarm state was updated. 

alarm message is the user defined string message displayed along with 
alarm notification for a discrete tag. Notice that this output is not valid 
any tag type other than discrete. 
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Historical Data VIs
Use the Historical Data VIs to obtain or read historical data about a ta
resample trend data, compute statistical data for a historical trend, or 
convert historical trend data to a spreadsheet format. The Historical D
subpalette is shown below.

Call HTV

Use the Call HTV VI to include the Historical Trend Viewer (HTV) in your HMI applicatio
programmatically. Wire no inputs to launch the HTV in its default state, or wire one or m
inputs to override the defaults.

If the HTV is running when this VI is called, already running returns TRUE and the HTV 
appears at the front of the screen. The inputs are not used in this case.

scf path is the path of the .scf  file that contains configuration information
for the tags to be displayed. If the Engine is running, the HTV ignores t
input and uses the active .scf  file. 
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data directory is the path to the directory containing the Citadel historic
database files. If the Engine is running, the HTV ignores this input and u
the active Citadel data directory. If the Engine is not running and the .scf  
path is not empty, the HTV ignores this input and uses the Citadel dat
directory found in the .scf  file. 

launch (T) determines whether to launch the HTV. If TRUE, the Call HT
VI starts the HTV. If FALSE, the VI does nothing.

tag list is the array of tags to be displayed in the HTV.

plot attributes is a cluster of parameters to set the color, point style, an
line style of the trend display.

colors is an array of colors to be used.

points is an array of points to be used. Use the position in the tre
palette to determine the value for each point style. The defaul
value is 0 (no point).

lines is an array of line styles to be used. Use the position in th
trend palette to determine the value for each line style. The def
value is 0 (solid line).

error in  is a cluster that describes the error status before this VI execu
For more information about this control, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

start time is the time to be displayed at the beginning of the trend.

stop time is the time to be displayed at the end of the trend.

already running indicates whether the HTV is running when the Call HT
VI executes. If the HTV is running, this VI returns TRUE.

error out is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Decimate Historical Trend

Use the Decimate Historical Trend VI to take XY historical trend data, and decimate 
(resample) it from the start timestamp to the stop timestamp. The decimated trend output
is a 1D array of the value at each time interval from the start timestamp to the stop 
timestamp. 

check start/stop time? determines whether the first and last data points
the historical trend  should be used if the requested start timestamp or 
stop timestamp is not in the data set. By default, this value is TRUE.

historical trend is the historical trend to be decimated.

timestamp is the date and time for the value.

value is the value of the tag at the timestamp.

start timestamp is the timestamp at which the decimated trend starts. 
start timestamp is unwired, the decimated trend output starts at the firs
timestamp in the historical trend.

stop timestamp is the desired stop time of the decimated trend. If stop 
timestamp is unwired, the decimated trend output ends at or before the
timestamp in the historical trend.

time interval determines the interval at which the trend is decimated o
resampled. If unwired, data is extracted with the default interval of 
1 second.

decimated trend is a list of historical trend  values starting at first 
timestamp. Each trend value is time interval seconds apart.

first timestamp is the actual time associated with the first point in the 
decimated trend.

last timestamp is the actual time associated with the last point in the 
decimated trend.
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Decimate Historical Trends

Use the Decimate Historical Trends VI to decimate (resample) XY historical trend data 
the time interval specified from start timestamp to stop timestamp. The decimated trend 
output is a 2D array of instantaneous values, each time interval  seconds apart, starting at 
start timestamp. Each column in the 2D array contains one decimated trend.

If start timestamp is left unwired, the decimated trend values start at the first timestam
the historical trend. If the stop timestamp is left unwired, the decimated trend ends at the
point nearest the last timestamp in the historical trend.

check start/stop time? determines whether the requested start and sto
times are checked against data available in the historical trends input. If 
this value is TRUE, the start and stop timestamps are checked agains
first and last timestamp in the historical trend. A requested start/stop t
out of the range of the trend is not used—the first/last timestamp in th
trend is used. 

To override this and use the input values regardless of the data points i
trend, set this input to FALSE.

historical trends is a set of historical trends to be decimated.

timestamp is the date and time for the value.

value is the value of the tag at the timestamp.

start timestamp is the timestamp at which the decimated trend starts. 
start timestamp is unwired, the decimated trend output starts at the firs
timestamp in the historical trend.

stop timestamp is the desired stop time of the decimated trend. If stop 
timestamp is unwired, the decimated trend output ends at or before the
timestamp in the historical trend.

time interval determines the interval at which the trend is decimated o
resampled. If unwired, data is extracted with the default interval of 
1 second.
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decimated trends is a list of decimated historical trends starting at first 
timestamp. Each trend value is time interval seconds apart.

first timestamp is the actual time associated with the first point in the 
decimated trend.

last timestamp is the actual time associated with the last point in the 
decimated trend.

Get Historical Tag List

Use the Get Historical Tag List VI to obtain the list of tags that have historical data avai
in the historical database. 

Citadel path in is the path to the directory containing the Citadel historic
database. If this path is empty, the VI attempts to use the historical da
directory configured in the active .scf  file. If this has not been configured,
the VI prompts you to select a data directory.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

history tag list is the list of tag names that have historical data logged.

Citadel path out is the path to the directory containing historical data file

first timestamp is the date and time associated with the first data point
logged in the given set of historical data files.

last timestamp is the date and time associated with the last data point 
logged in the given set of historical data files.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Get Historical Trend Info

Use the Get Historical Trend Info VI to obtain the first and last timestamp available in t
historical database for a given tag, and the type of the tag, whether analog or discrete.

Citadel path in is the path to the directory containing the Citadel historic
database. If this path is empty, the VI attempts to use the historical da
directory configured in the active .scf  file. If this has not been configured,
the VI prompts you to select a data directory.

tag name is the tag about which you want to obtain historical trend 
information. 

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

data type is the type of tag, whether discrete, analog, or bit array.

Citadel path out is the path to the directory containing historical data file

first timestamp is the date and time associated with the first value logg
in the database for this tag.

last timestamp is the date and time associated with the last value logge
the database for this tag.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Historical Trend Statistics

Use the Historical Trend Statistics VI to compute statistical data for a historical trend. 
Statistics include minimum value, maximum value, average and standard deviations. T
statistics skip invalid input points (where value = NaN). The average and standard deviatio
are weighted according to the time duration of each valid input point. The last point in 
historical trend is not included in the average and standard deviation because the time i
associated with it is unknown.

historical trend is the tag trend data upon which statistics are compute

timestamp is the date and time for the value.

value is the value of the tag at the timestamp.

time ON (ETM) is the amount of time for which data has known values
the trend. It is roughly the same as the amount of time historical loggin
was turned on for the tag. 

Qual is the ratio of time the trend has known values to the total time elap
in the trend. 

max value is the maximum value in the historical trend. This output 
ignores invalid points (value = NaN).

min value is the minimum value in the historical trend. This output ignor
invalid points (value = NaN).

average is the average for the values in the historical trend. This is a 
weighted average. Each point is weighted according to its time duratio
average ignores time intervals with invalid points (value = NaN). The last 
point in the trend is not included in average, because there is no known 
time interval associated with it.
© National Instruments Corporation A-21 BridgeVIEW User Manual



Appendix A HMI Function Reference

is a 
me 

use 

 

e 

e tab 
e date, 
 date, 
to a 

p 

 and 
r, set 
std dev is the standard deviation for values in the historical trend. This 
weighted standard deviation. Each point is weighted according to its ti
duration. Std dev ignores time intervals with invalid points (value = NaN). 
The last point in the trend is not included in the standard deviation, beca
there is no known time interval associated with it.

# stops is the number of transitions from logging on to logging off in the
trend. 

# starts is the number of transitions from logging off to logging on in th
trend. 

Historical Trends to Spreadsheet

Use the Historical Trends to Spreadsheet VI to converts a set of historical trends into th
delimited string format, which spreadsheet programs can read. The columns created ar
time, tag name 1 value, tag name 2 value, and so on. A header is created labelling the
time, and tag names. The output of this VI can be saved in a file, and then imported in
spreadsheet program.

You can wire in the delimiter you want. The delimiter is a tab by default. You also can 
override the date and time formatting by wiring in the date & time format cluster. 

check start/stop time? determines whether the requested start and sto
times are checked against data available in the historical trends input. By 
default the decimation does not start until data is available in all trends,
ends as soon as any trend has no more data. To override this behavio
this input to FALSE.
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date & time format is a cluster that contains settings used to format th
date and time in the spreadsheet string. 

date format (0) determines the format for the date (MM/DD/YYYY 
or DD/MM/YYYY).

time format  determines whether a 12-hour (AM/PM) or 24-hou
format is used. 

delimiter (tab) is the separator used in the spreadsheet format. The def
separator is a tab.

historical data is the set of historical data trends to convert to spreadsh
format.

tag names is the list of tag names corresponding to the historical trend
These tag names are used as column headers when converted into 
spreadsheet format.

sample interval (1 sec) determines the time interval for each historical 
trend. If unwired, the data is sampled at one-second intervals.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

start timestamp is the timestamp for which the spreadsheet rows start
start timestamp is unwired, the spreadsheet rows start at the first 
timestamp in the historical data. 

stop timestamp is the timestamp for which the spreadsheet rows end. 
stop timestamp is unwired, the spreadsheet rows start at the last timesta
in the historical data. 

spreadsheet string contains spreadsheet formatted data that can be writ
to a text file. This file can be opened into spreadsheets like Excel.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Read Historical Trend

Use the Read Historical Trend VI to read the historical data for a given tag from user spe
start and stop dates and times, up to the maximum number of points specified. If start 
timestamp and stop timestamp are not wired, all historical data for the tag is returned, up
the maximum points per trend specified. If max points per trend is left unwired, all points 
between the start timestamp and stop timestamp are returned.

You can use this VI to read history information for analog, discrete or bit array tags. Al
values are returned as floating point values.

max points in trend is the maximum number of points to read. If the valu
is less than zero, all points available between start timestamp and stop 
timestamp are returned. Otherwise, the number of points in the trend is
minimum of the actual number of data points between start timestamp, 
stop timestamp, and max points in trend.

Citadel path in is the path to the directory containing the Citadel historic
database. If this path is empty, the VI attempts to use the historical da
directory configured in the active .scf  file. If this has not been configured,
the VI prompts you to select a data directory.

tag name is the tag for which you want to read historical data. If the tag
not logged in the historical database, you will get an empty trend.

start timestamp is the date and time associated with the first data point
be retrieved from the historical database. If this input is unwired, the d
is extracted starting at the first point available for the tag.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

stop timestamp (now) is the date and time associated with the last data
point to be retrieved from the historical database. If this input is unwire
the data is extracted up to the last point available for the tag.

Citadel path out is the path to directory containing historical data files.
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historical trend is the tag trend data read from the historical database,
starting at the date and time specified by start timestamp, and stopping at 
the date and time specified by stop timestamp or up to max points per 
trend, whichever is smaller. If these start timestamp and stop timestamp 
values are left unwired, all the logged data up to max points per trend for 
the tag is returned.

timestamp is the date and time for value.

value is the value of the tag at the timestamp.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Read Historical Trends

Use the Read Historical Trends VI to read the historical data for a given set of tags fro
user specified start and stop date and time, up to max points per trend. If the inputs for start 
timestamp and stop timestamp are not wired, all historical data for the tags is returned, 
to the max points per trend specified. If max points per trend is left unwired, all points 
between start timestamp and stop timestamp are returned.

You can use this VI to read history information for analog, discrete or bit array tags. Al
values are returned as floating point values. 

max points per trend is the maximum number of points to read. If the 
value is less than zero, all points available between start timestamp and 
stop timestamp are returned. Otherwise, the number of points in the tre
is the minimum of the actual number of data points between start 
timestamp, stop timestamp, and max points in trend.

Citadel path in is the path to directory containing the Citadel historical
database. If this path is empty, the VI prompts the user for the citadel fo
path.
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tag names is the list of tags for which you want to read historical data. 
one or more of the tags is not logged in the historical database, you wil
an empty trend for that tag.

stop timestamp (now) is the date and time associated with the last data
point to be retrieved from the historical database. If this input is unwire
the data is extracted up to the last point available for the tag.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

start timestamp is the date and time associated with the first data point
be retrieved from the historical database. If this input is unwired, the d
is extracted starting at the first point available for the tag.

Citadel path out is the path to directory containing the historical databa

historical trends is the tag trend data read from the historical database
starting at the date and time specified by start timestamp, and stopping at 
the date and time specified by stop timestamp or up to max points per 
trend, whichever is smaller. If these start and stop timestamp values a
unwired, all the logged data up to max points per trend for the tag is 
returned.

timestamp is the date and time for the value.

value is the value of the tag at the timestamp.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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System VIs
Use the System VIs to obtain information or monitor the access level of
current operator, to launch or shut down BridgeVIEW, or to enable or 
disable event logging, historical data logging or printing. The System 
subpalette is shown below.

 

Enable Event Logging

Use the Enable Event Logging VI to turn on or off logging of alarms and events for all 
in the system programmatically.

Enable evt log (T) determines whether to turn event logging on or off.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Enable Historical Data Logging

Use the Enable Historical Data Logging VI to turn on or off data logging for all tags in t
system programmatically.

Enable hst logging (T) determines whether to turn historical data loggin
on or off.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Enable Printing

Use the Enable Printing VI to turn on or off printing of alarms and events for all tags in
system programmatically. 

Enable printing  (T) determines whether to turn printing on or off.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Engine Launch

Use the Engine Launch VI to launch the BridgeVIEW Engine programmatically. Norma
the BridgeVIEW Engine is launched automatically when you execute any of the VIs tha
access the Real-Time Database. Use this VI if you want to control when the Engine is 
launched explicitly.

If configuration file to use is unwired, BridgeVIEW automatically uses the last 
configuration file you viewed or edited. Use launch engine to control whether the Engine is
launched.

The outputs indicate whether the Engine is running already and which configuration fil
being used. These outputs are valid only if launch engine is TRUE.

configuration file to use specifies exactly which Tag Configuration file 
the BridgeVIEW Engine should use. You must provide the complete p
to the configuration file. If unwired, the last configuration you viewed o
edited is used.

launch engine determines whether to launch the BridgeVIEW Engine, 
provided that it is not already running. If FALSE, the VI does nothing. 
unwired, this input is TRUE by default. You can wire this input if you d
or do not want to launch the Engine based on logic in your program.

configuration file in use indicates which BridgeVIEW configuration file 
is currently in use.

already launched indicates whether the BridgeVIEW Engine was 
launched already when this VI was called. If so, the BridgeVIEW Engi
is left undisturbed and this VI returns which configuration file is being 
used.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, calling this VI does nothing. 
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Engine Shutdown

Use the Engine Shutdown VI to shut down the BridgeVIEW Engine from your HMI. Yo
must terminate your application immediately after calling this VI. The BridgeVIEW Eng
does not shut down until all VIs that are accessing the Real-Time Database finish. If yo
not terminate your application, after a few seconds a dialog box prompts you to stop y
application so that the BridgeVIEW Engine can complete shutdown.

Shutdown engine determines whether the BridgeVIEW Engine shuts 
down. If TRUE, this VI notifies the BridgeVIEW Engine to shut down. I
FALSE, the VI does nothing. This parameter is TRUE by default.

Get Engine Status

Use this VI to query the BridgeVIEW engine status. The outputs indicate whether the en
is loaded, running, or shutting down, and which configuration file is being used.

configuration file in use indicates which BridgeVIEW configuration file 
currently is in use.

loaded indicates whether the BridgeVIEW engine currently is loaded.

running  indicates whether the BridgeVIEW engine currently is running

shutdown indicates whether the engine has been stopped and is shutt
down.
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Get Tag Status Info

Use the Get Tag Status Info VI to obtain status information associated with tags. Tag s
information can be broken down into two types:

• Status information from BridgeVIEW—This status can be from the Engine or a Ser
It consists of details about the status and whether it is an error or warning.

• Status information from a Server—Only the status code is reported. Check your se
documentation for a description of this status.

tag status can be broken down into status information from BridgeVIEW
(Engine or Server), and status information from a server or a user erro

reported by indicates whether the status was reported by the BridgeVIE
Engine or a server.

description gives the details of the part of the status reported by 
BridgeVIEW.

BridgeVIEW status is the numeric representation of the portion of the 
status reported by BridgeVIEW.

warning (F): error (T)  indicates if the portion of status reported by 
BridgeVIEW is an error (if it is negative), or a warning (if it is positive).

server status/user error is either the numeric value of the portion of tag 
status posted by the device server (refer to your server documentation
details on this value) or an indication of user error.
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Post System Error or Event

Use this VI to post an error or event message from your HMI to the System Error/Even
display on the Engine Manager. The message you post is logged to the system log file
BridgeVIEW\Syslog  directory. The format of the message is as follows: 

EVENT/ERROR <date> <time> <Message>

The date and time represent the timestamp when the message is posted.

Message is the Error or Event that you want to report. The format of th
message that actually is posted is as follows: 

EVENT/ERROR <date> <time> <Message>

Type determines the type of message to be posted. By default, it is an e
If you are reporting an event, write a TRUE to the switch. Depending o
your selection, the word EVENT or ERROR automatically is incorporat
in the message that is posted.

timestamp is broken down into date and time strings and incorporated
the message that gets posted. If this input is left unwired, the current 
timestamp is taken and posted as a part of the message.
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Tag Status Handler

Use the Tag Status Handler VI to obtain a description of the tag status, by breaking it d
into warning or error conditions coming from BridgeVIEW as well as the device server.
also identifies where the error or warning occurred. The information for looking up stat
derived from the inputs: tag status, source, server error codes, server error descriptions, 
and from an internal error description lookup that describes all the status values returned
the Engine or a Server in BridgeVIEW.

source is a string you can use to describe the VI that is the source of 
warning or error indicated by tag status. This is returned as a part of th
message string if there is an error.

tag status can be broken down into status information from BridgeVIEW
(Engine or Server); and status information from a server or a user erro

type of dialog (OK msg:1) determines what type of dialog box is 
displayed, if any. Regardless of its value, the VI returns error informat
and a message describing the error. According to the value, the VI does
of the following:

• Displays no dialog box. This is useful if you want to have programma
control over how an error is handled.

• Displays a dialog box with a single OK button. After the user respon
the VI returns control to the main VI. This is the default setting.

• Displays a dialog box with buttons allowing the user to continue or
stop. If the user cancels, the VI calls the Stop function to halt execut

server error codes is an array of numeric error codes defined for your 
device server(s).

server error descriptions is an array of descriptions of server error code
If an incoming error matches one in server error codes, the VI uses the 
corresponding description from server error descriptions in the message.

message describes the tag status by breaking it down into the error or 
warning returned by BridgeVIEW as well as the error or warning, if an
returned by the device server. The part of the message describing the s
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error code comes from the input you specify in server error descriptions. 
It also contains information about the source of the error.

Security VIs
  

Check Operator Privileges

Use this VI to check the current user’s privileges and produce a Boolean output indicat
the currently logged in user has the privilege. Additional inputs can be sent to display a d
box with a message (OK or OK/Cancel) and/or launch the login prompt if the current u
does not have the requested privilege.

  

privilege to check inspects the privileges of the current BridgeVIEW use
to see if he or she has been granted this privilege.

prompt for login (F)  opens the Login dialog box if the current 
BridgeVIEW user does not have the requested privilege, and the inpu
is TRUE.
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dialog type (none) displays a dialog box if the current BridgeVIEW use
does not have the requested privilege, and the message input is not e
The type of dialog box is determined by the following input:

• OK—A dialog box appears displaying a message and an OK  button. If 
the prompt for login  input is TRUE, the login dialog box appears after
the message dialog box is closed.

• OK/Cancel—A dialog box displaying a message and OK  and Cancel 
buttons. If the prompt for login  input is TRUE, the login dialog box 
appears when the OK  button in the message dialog box is pressed.

message is the message to display if the dialog type input is not none , and 
the current BridgeVIEW user does not have the requested privilege.

user has privilege is TRUE if the current BridgeVIEW user has the 
requested privilege.

login cancelled is TRUE if the current BridgeVIEW user does not have th
requested privilege, prompt for login was TRUE, and the login dialog box 
was cancelled.

Get Operator Name

Use the Get Operator Name VI to obtain the current operator name, access level, and 
level name. 

 

operator name is the login name of the current BridgeVIEW user.

access level is the numeric access level assigned to the current 
BridgeVIEW user.

access level name is a descriptive name associated with the numeric acc
level assigned to the current BridgeVIEW user.
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Invoke Login Dialog

Use the Invoke Login Dialog VI to launch the BridgeVIEW Login dialog box. If the user
selects Cancel in the Login dialog box, the previous user remains active. 

 

operator name is the login name of the current BridgeVIEW user.

access level is the numeric access level assigned to the current 
BridgeVIEW user.

access level name is a descriptive name associated with the numeric acc
level assigned to the current BridgeVIEW user.

cancelled indicates whether the user pressed Cancel in the Login dialog 
box, aborting the login.

Programmatic Login

Use the Programmatic Login VI to programmatically log in a user.

user name is the name of the user to be logged in to BridgeVIEW.

user password is the password of the user to be logged in to BridgeVIE

user name out is the name of the user to be logged in to BridgeVIEW. 
the login fails, this is the name of the user currently logged in to 
BridgeVIEW.

access level is the numeric access level assigned to the current 
BridgeVIEW user.

access level name is a descriptive name associated with the numeric acc
level assigned to the current BridgeVIEW user.
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login successful? is TRUE if the user name and user password are corre
and the user was successfully logged into BridgeVIEW.

error  is an error code that describes the result of the programmatic log
and can have one of the following values.

Programmatic Logout

Use this VI to log out the current user, so no operator is logged into the system.

logout (T) determines if the current BridgeVIEW user should be logged
out of the system. If TRUE, the current user is logged out of the 
BridgeVIEW system. If FALSE, the logout operation does not occur.

logout message describes the result of the logout operation.

Security Monitor

Use this VI to monitor the access level of the current BridgeVIEW operator. By default,
VI times out after one second, returning to the current operator access level. When an op
logs in, this VI returns immediately.

timeout (secs) (1) specifies how long to wait for a user to log in.

visibility access level (0) determines the value of “Visible” attribute 
setting. If the current operator access level is greater than or equal to 
visibility access level, the “Visible” attribute setting  indicator is TRUE. 
Otherwise, “Visible” attribute setting is FALSE. 

0  Login successful (No Error)

1  Invalid Password

2  Invalid User Name
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operability access level determines the value for the “Disabled” attribute 
value output. If the current operator access level is greater than or equ
operability access level, “Disabled” attribute value  is 0 (enabled). 
Otherwise, “Disabled” attribute value is 1 (disabled) or 2 (grayed out), 
depending on the setting of the gray out on disable input.

gray out on disable (T) determines if the “Disabled” attribute value  is 
1 (disable) or 2 (disable and gray out) if a user access level is not grea
than or equal to operability access level.

“Visible” attribute setting  is the value to send to the “Visible”  attribute 
of the control or indicator to which security is applied. 

“Disabled” attribute value  is the value to send to the “Disabled”  attribute 
of the control or indicator to which security is applied. 

shutdown indicates that the BridgeVIEW Engine is shutting down.

Note: When you use this VI in your operator interface loops, you do not want th
timeout value to be too long, or your front panel can take a long time to 
finish execution. Similarly, setting timeout to 0 seconds degrades the 
overall performance of your interface because this VI is called too often
too quickly.

User Account List

Use this VI to generate a list of BridgeVIEW user accounts.

user accounts is a list of BridgeVIEW user accounts.
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Tags VIs
Use the Tags VIs to read the latest value for a tag, write a new value t
tag, or obtain data for a real-time trend. The Tags subpalette is shown
below.

Read Tag

Use the Read Tag VI to read the latest value of a tag from the Real-Time Database. F
immediate polling of the tag value, leave timeout (secs) unwired. To wait until the value is 
updated before reading it, wire a timeout value in seconds to timeout. The Read Tag VI 
returns with the most recent Real-Time Database value when it is updated, the timeout is 
exceeded, or the Real-Time Database is shutting down, whichever occurs first. Use th
changed? output to determine whether the value changed since the last read.

Note: Use a separate Read Tag VI for each tag you want to monitor. Do not p
the Read Tag VI in a loop to read a different tag each iteration of the loop
This results in slower program performance. The Read Tag VI is designe
to save information about the tag internally for efficient operation. This 
information is updated every time the tag name changes.
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tag name is the name of the tag.

timeout (secs) (0) specifies how many seconds to wait for the tag value
be updated in the Real-Time Database before reading the Real-Time 
Database for the latest value. If timeout is 0, the Read Tag VI reads the 
Real-Time Database immediately and returns the tag value without 
waiting. If timeout is –1, Read Tag waits indefinitely until the tag value
updated, or the Engine shuts down, whichever occurs first. If a timeou
occurs before the value is updated, Read Tag returns the most recent 
from the Real-Time Database, and is set to TRUE. The default value i

in alarm  is TRUE if the tag is in alarm.

value status returns the status of the value. If value status is greater than 
or equal to 0, the value returned by Read Tag is valid and there is a war
about the tag value. If value status is less than 0, either the device serve
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

value is the latest value of the tag read from the Real-Time Database.

value timestamp returns the timestamp for when the tag value was 
updated. 

error  indicates that an error occurred when executing the Read Tag V
that the value output returned by Read Tag is not valid. See value status 
for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, the Read Tag VI no longer waits for tags to be updated and retu
immediately with both timeout and shutdown TRUE. You can use 
shutdown to exit any loop that uses the Read Tag VI. 

changed? is TRUE when the Read Tag VI returns a new value from th
Real-Time Database. If changed? is FALSE, the Read Tag VI probably 
timed out before the tag value was updated. 
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Read Tag (bit array)

Use the Read Tag (bit array) VI to read the latest value for a given bit array tag from th
Real-Time Database. For immediate polling of the tag value, leave timeout (secs) unwired. 
To wait until the value is updated before reading it, wire a timeout value, in seconds, to
timeout input. The Read Tag (bit array) VI returns with the most recent Real-Time Data
value when it is updated, the timeout is exceeded, or the Real-Time Database is shutt
down, whichever occurs first. Use the changed? output to determine whether the value 
changed since the last read.

Note: Use a separate Read Tag (bit array) VI for each tag you want to monito
Do not put the Read Tag (bit array) VI in a loop to read a different tag eac
iteration of the loop. This results in slower program performance. The 
Read Tag (bit array) VI is designed to save information about the tag 
internally for efficient operation. This information is updated every time 
the tag name changes.

tag name is the name of the bit array tag.

timeout (secs) (0) specifies how many seconds to wait for the tag value
be updated in the Real-Time Database before reading the Real-Time 
Database for the latest value. If timeout is the default value of 0, the Read
Tag (bit array) VI reads the Real-Time Database immediately and retu
the tag value without waiting. If timeout is –1, Read Tag (bit array) waits
indefinitely until the tag value is updated, or the BridgeVIEW Engine sh
down, whichever occurs first. If a timeout occurs before the value is 
updated, Read Tag (bit array) returns the most recent value from the 
Real-Time Database, and timeout is set to TRUE. 

in alarm  is TRUE if the tag is in alarm.
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value status returns the status of the value. If value status is greater than 
or equal to 0, the value returned by Read Tag is valid and there is a war
about the tag value. If value status is less than 0, either the device serve
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

value is the latest bit array value of the bit array tag read from the 
Real-Time Database.

value timestamp returns the timestamp for when the tag value was las
updated. 

error  indicates that an error occurred when executing the Read Tag (b
array) VI, or that the value output returned by Read Tag (bit array) is no
valid. See value status for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Read Tag (bit array) no longer waits for tags to be updated and re
immediately with both timeout and shutdown TRUE. You can use 
shutdown to exit any loop that uses Read Tag (bit array). 

changed? is TRUE when Read Tag (bit array) returns a new value from 
Real-Time Database. If changed? is FALSE, Read Tag (bit array) probably
timed out before the tag value was updated. 

Read Tag (discrete)

Use the Read Tag (discrete) VI to read the latest value for a given discrete (or Boolean
from the Real-Time Database. For immediate polling of the tag value, leave timeout (secs) 
unwired. To wait until the value is updated before reading it, wire a timeout value in sec
to timeout. The Read Tag (discrete) VI returns with the most recent Real-Time Databa
value when it is updated, the timeout is exceeded, or the Real-Time Database is shutt
down, whichever occurs first. Use the changed? output to determine whether the value 
changed since the last read.

Note: Use a separate Read Tag (discrete) VI for each tag you want to monitor.
other words, for example, do not put the Read Tag (discrete) VI in a loo
to read a different tag for each iteration of the loop. This results in slowe
program performance. The Read Tag(discrete) VI is designed to save 
information about the tag internally for efficient operation. This 
information is updated every time the tag name changes.
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tag name is the name of the discrete tag.

timeout (secs) (0) specifies how many seconds to wait for the tag value
be updated in the Real-Time Database before reading the Real-Time 
Database for the latest value. If timeout is 0, the Read Tag (discrete) VI 
reads the Real-Time Database immediately and returns the tag value 
without waiting. If timeout is –1, Read Tag (discrete) waits indefinitely 
until the tag value is updated, or the BridgeVIEW Engine shuts down, 
whichever occurs first. If a timeout occurs before the value is updated
Read Tag (discrete) returns the most recent value from the Real-Time
Database, and timeout is set to TRUE. The default value is 0.

in alarm  is TRUE if the tag is in alarm.

value status returns the status of the value. If value status is greater than 
or equal to 0, the value returned by Read Tag is valid and there is a war
about the tag value. If value status is less than 0, either the device serve
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

value is the latest value of the discrete tag read from the Real-Time 
Database.

value timestamp returns the timestamp for when the tag value was las
updated. 

error  indicates that an error occurred when executing the Read Tag 
(discrete) VI, or that the value output returned by Read Tag(discrete) is no
valid. See value status for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Read Tag (discrete) no longer waits for tags to be updated and re
immediately with both timeout and shutdown TRUE. You can use 
shutdown to exit any loop that uses Read Tag (discrete). 
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changed? is TRUE when Read Tag (discrete) returns a new value from 
Real-Time Database. If changed? is FALSE, Read Tag (discrete) probably
timed out before the tag value was updated. 

Read Tag (string)

Use the Read Tag (string) VI to read the latest value for the tag from the Real-Time Data
If timeout is 0, Read Tag (string) VI returns the current Tag value and update timestamp
the Real-Time Database, otherwise the Read Tag (string) VI waits up to the specified timeout 
for the tag to be updated in the Real-Time Database, and returns the new value. 

Note: Use a separate Read Tag (string) VI for each tag you want to monitor. D
not put the Read Tag (string) VI in a loop to read a different tag each 
iteration of the loop. This results in slower program performance. The 
Read Tag(string) VI is designed to save information about the tag 
internally for efficient operation. This information is updated every time 
the tag name changes.

tag name is the name of the tag.

timeout (secs) (0) specifies how many seconds to wait for the tag value
be updated in the Real-Time Database before reading the Real-Time 
Database for the latest value. If timeout is the default value of 0, the Read
Tag (string) VI reads the Real-Time Database immediately and returns
tag value without waiting. If timeout is –1, Read Tag (string) waits 
indefinitely until the tag value is updated, or the Real-Time Database s
down, whichever occurs first. If a timeout occurs before the value is 
updated, Read Tag (string) returns the most recent value from the 
Real-Time Database, and timeout is set to TRUE.

in alarm  is TRUE if the tag is in alarm.

value status returns the status of the value. If value status is greater than 
or equal to 0, the value returned by Read Tag is valid and there is a war
about the tag value. If value status is less than 0, either the device serve
has reported an error indicating there is a problem with the tag, or 
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BridgeVIEW has reported an error indicating there is a problem using 
the tag.

value is the latest value of the tag read from the Real-Time Database.

value timestamp returns the timestamp for when the tag value was las
updated.

error  indicates that an error occurred when executing the Read Tag (str
VI, or that the value output returned by Read Tag(string) is not valid. Se
value status for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Read Tag (string) no longer waits for Tags to be updated and re
immediately with both timeout and shutdown TRUE. You can use 
shutdown to exit any loop that uses the Read Tag (string) VI.

changed? is TRUE when the Read Tag (string) VI returns a new value
from the Real-Time Database. If changed? is FALSE, Read Tag (string) 
probably timed out before the tag value was updated.

Trend Tags

Use the Trend Tags VI to set data for a real-time trend chart in your HMI. The Trend Tag
supports analog, discrete, and bit array tags. The Trend Tags VI formats data for one o
tags such that it can be wired directly to a trend (waveform chart). The Trend Tags VI re
after each time interval with the next set of points for the trend. 

Place each Trend Tags VI in its own While Loop, assuming that each loop is running a
different time interval. 

tag names is the name of each tag to be trended.

scale to % determines how the trend data is scaled. If scale to % is FALSE, 
trend data is in engineering units. If scale to % is TRUE, trend data is in 
% of full scale (0 to 100%). The default setting for scale to % is FALSE. 

time interval (secs) (1) is the time interval in seconds for reading the ta
values for the real-time trend. The default time interval is 1 second. 
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trend data contains the data from each tag, formatted for wiring to a 
waveform chart. These values are either in engineering units, or scale
specified by scale mode. 

error  indicates that an error occurred when executing Trend Tags, or 
one or more tag values could not be accessed.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Trend Tags returns immediately with shutdown TRUE, and trend 
data might no longer be valid. You can use shutdown to exit any loop that 
uses the Trend Tags VI.

config change indicates that configuration of the Trend Tags VI has 
changed since the last execution. This could be because of a change 
list of tags in the trend, the time interval input, or the scale to % input. 
Optionally use this output to reinitialize your waveform chart because p
history data will be no longer valid.

Write Tag

Use the Write Tag VI to update the Real-Time Database with a new value for memory, o
and Input/Output tags. The value also is sent to the server if it is an output or Input/Ou
tag. If the tag is an input only tag, the Write Tag VI causes a system error because inpu
only can be updated by servers. If the tag is configured as an Input/Output tag, the tag
is passed to the server when Write Tag VI is called but not written to the RTDB. The R
is updated with the new value when the server polls it and passes it back to the Bridge
Engine. This maintains correct time synchronization in the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 

status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write operation wa
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successful. If status is less than 0, either the device server has reported
error indicating there is a problem with the tag, or BridgeVIEW has 
reported an error indicating there is a problem using the tag.

error  indicates that an error occurred when executing the Write Tag VI
that the status of the tag is bad. See status for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Write Tag no longer waits for tags to be updated and returns 
immediately with both timeout and shutdown TRUE. You can use 
shutdown to exit any loop that uses the Write Tag VI. 

Write Tag (bit array)

Use the Write Tag (bit array) VI to update the Real-Time Database with a new value fo
memory, output, and Input/Output tags. The value also is sent to the server if it is an o
or Input/Output tag. If the tag is an input only tag, the Write Tag (bit array) VI causes a sy
error because input tags only can be updated by servers. If the tag is configured as an
Input/Output tag, the tag value is passed to the server when Write Tag (bit array) VI is c
but not written to the RTDB. The RTDB is updated with the new value when the server 
it and passes it back to the BridgeVIEW Engine. This maintains correct time synchroniz
in the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag (bit array
operation was successful. If status is less than 0, either the device server
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

error  indicates that an error occurred when executing the Write Tag (b
array) VI, or that the status of the tag is bad. See status for the specific error 
condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. You
can use shutdown to exit any loop that uses the Write Tag (bit array) VI

Write Tag (discrete)

Use the Write Tag (discrete) VI to update the Real-Time Database with a new value fo
memory, output, and Input/Output tags. The value also is sent to the server if it is an o
or Input/Output tag. If the tag is an input only tag, the Write Tag (discrete) VI causes a sy
error because input tags only can be updated by servers. If the tag is configured as an
Input/Output tag, the tag value is passed to the server when Write Tag (discrete) VI is 
but not written to the RTDB. The RTDB is updated with the new value when the server 
it and passes it back to the BridgeVIEW Engine. This maintains correct time synchroniz
in the RTDB.

tag name is the name of the output tag.

value is the value written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag (discrete
operation was successful. If status is less than 0, either the device server
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

error  indicates that an error occurred when executing the Write Tag 
(discrete) VI, or that the status of the tag is bad. See status for the specific 
error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. You
can use shutdown to exit any loop that uses the Write Tag (discrete) VI

Write Tag (string)

Use the Write Tag (string) VI to update the Real-Time Database with a new value for 
memory, output, and Input/Output tags. The value also is sent to the server if it is an o
or Input/Output tag. If the tag is an input only tag, the Write Tag (string) VI causes a sy
error because input tags only can be updated by servers. If the tag is configured as an
Input/Output tag, the tag value is passed to the server when Write Tag (string) VI is calle
not written to the RTDB. The RTDB is updated with the new value when the server po
and passes it back to the BridgeVIEW Engine. This maintains correct time synchroniza
in the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output Tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag (string) 
operation was successful. If status is less than 0, either the device server
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

error  indicates that an error occurred when executing the Write Tag 
(string) VI, or that the status of the tag is bad. See status for the specific 
error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. You
can use shutdown to exit any loop that uses the Write Tag (string) VI.

Write Tag on Change

Use the Write Tag on Change VI to update the Real-Time Database with a new value 
memory, output, and Input/Output tags. The value also is sent to the server if it is an o
or Input/Output tag. The value is updated and sent to the server only if the tag value is
different from the previous time the VI was executed.   Use this VI if you do not need to 
output values to the RTDB and server unless there really is a value change. This save
from adding code to your diagram to check value changes.

If the tag is an input only tag, Write Tag on Change VI causes a system error because
tags can only be updated by servers. If the tag is configured as an Input/Output tag, th
value is passed to the server when Write Tag on Change VI is called but not written to
RTDB. The RTDB is updated with the new value when the server polls it and passes it
to the BridgeVIEW Engine. This maintains correct time synchronization in the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag on Chan
operation was successful. If status is less than 0, either the device server
has reported an error indicating there is a problem with the tag, or 
BridgeVIEW has reported an error indicating there is a problem using 
tag.

error  indicates that an error occurred when executing Write Tag on 
Change or that the status of the tag is bad. See the status output for the 
specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. You
can use shutdown to exit any loop that uses Write Tag on Change. 

Write Tag on Change (bit array)

Use the Write Tag on Change (bit array) VI to update the Real-Time Database with a n
value for memory, output, and Input/Output tags. The value also is sent to the server if
an output or Input/Output tag. The value is updated and sent to the server only if the tag
is different from the previous time the VI was executed.   Use this VI if you do not need
pass output values to the RTDB and server unless there really is a value change. This
you from adding code to your diagram to check value changes.

If the tag is an input only tag, Write Tag on Change (bit array)VI causes a system erro
because input tags only can be updated by servers. If the tag is configured as an Input/
tag, the tag value is passed to the server when Write Tag on Change (bit array)VI is call
not written to the RTDB. The RTDB is updated with the new value when the server po
and passes it back to the BridgeVIEW Engine. This maintains correct time synchroniza
in the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag on Chan
(bit array) operation was successful. If status is less than 0, either the 
device server has reported an error indicating there is a problem with 
tag, or BridgeVIEW has reported an error indicating there is a problem
using the tag.

error  indicates that an error occurred when executing Write Tag on 
Change (bit array) or that the status of the tag is bad. See the status output 
for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. You
can use shutdown to exit any loop that uses the Write Tag on Change 
(bit array). 

Write Tag on Change (discrete)

Use the Write Tag on Change (discrete)VI to update the Real-Time Database with a n
value for memory, output, and Input/Output tags. The value also is sent to the server if
an output or Input/Output tag. The value is updated and sent to the server only if the tag
is different from the previous time the VI was executed.   Use this VI if you do not need
pass output values to the RTDB and server unless there really is a value change. This
you from adding code to your diagram to check value changes.

If the tag is an input only tag, Write Tag on Change (discrete)VI causes a system error be
input tags only can be updated by servers. If the tag is configured as an Input/Output ta
tag value is passed to the server when Write Tag on Change (discrete)VI is called but 
written to the RTDB. The RTDB is updated with the new value when the server polls it
passes it back to the BridgeVIEW Engine. This maintains correct time synchronization
the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.

generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 
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status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag on Chan
(discrete) operation was successful. If status is less than 0, either the device
server has reported an error indicating there is a problem with the tag,
BridgeVIEW has reported an error indicating there is a problem using 
the tag.

error  indicates that an error occurred when executing Write Tag on 
Change (discrete) or that the status of the tag is bad. See the status output 
for the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Write Tag on Change (discrete) no longer waits for the tag to be
updated and returns immediately with both timeout and shutdown TRUE. 
You can use shutdown to exit any loop that uses Write Tag on Change 
(discrete).

Write Tag on Change (string)

Use the Write Tag on Change (string) VI to update the Real-Time Database with a new 
for memory, output, and Input/Output tags. The value also is sent to the server if it is an o
or Input/Output tag. The value is updated and sent to the server only if the tag value is
different from the previous time the VI was executed.   Use this VI if you do not need to 
output values to the RTDB and server unless there really is a value change. This save
from adding code to your diagram to check value changes.

If the tag is an input only tag, Write Tag on Change (string) VI causes a system error be
input tags only can be updated by servers. If the tag is configured as an Input/Output ta
tag value is passed to the server when Write Tag on Change (string) VI is called but n
written to the RTDB. The RTDB is updated with the new value when the server polls it
passes it back to the BridgeVIEW Engine. This maintains correct time synchronization
the RTDB.

tag name is the name of the output tag.

value is the value to be written to the output tag.
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generate event (F) determines whether a user change event is generat
for the write operation on the tag. If the tag is configured with event logg
on, this tag event can be displayed in the Event History Display in you
HMI and logged to a .evt  file. By default, generate event is FALSE. 

status returns the current status of the value written in the Real-Time 
Database. If status is greater than or equal to 0, the Write Tag on Chan
(string) operation was successful. If status is less than 0, either the device
server has reported an error indicating there is a problem with the tag,
BridgeVIEW has reported an error indicating there is a problem using 
the tag.

error  indicates that an error occurred when executing Write Tag on 
Change (string) or that the status of the tag is bad. See the status output for 
the specific error condition.

shutdown indicates that the BridgeVIEW Engine is shutting down. In th
case, Write Tag on Change (string) no longer waits for the tag to be upd
and returns immediately with both timeout and shutdown TRUE. You can 
use shutdown to exit any loop that uses Write Tag on Change (string).

Tag Attributes VIs
Use the Tag Attributes VIs to get and set tag configuration parameters
currently used by the BridgeVIEW Engine for tag processing 
programmatically. The Tag Attributes subpalette is shown below.
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Get Analog Tag Alarm Limit

Use the Get Analog Tag Alarm Limit VI to obtain limit information for a single tag value
alarm for an analog tag. Use the Alarm type input (HI_HI, HI, LO, LO_LO) to specify th
desired alarm limit information.

tag name is the name of the tag about whether you want to obtain 
information.

alarm type determines the type of alarm for which information is querie
For analog tags, the various alarm types are HI_HI, HI, LO and LO_LO

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

alarms enabled indicates whether alarms are enabled for a tag. If TRU
tag value alarms as well as bad status alarms are enabled for this tag
depending on the enable setting for the particular alarm types. If FALS
all alarms are disabled for this tag, regardless of the enable settings fo
particular alarm types.

tag value alarm enabled indicates whether alarms specified by alarm 
type are enabled. If FALSE, they are disabled. If TRUE, alarm type 
alarms are enabled.

limit  is the value corresponding to a given alarm type. For example, fo
HI_HI alarm, limit  is the value the tag must exceed to go to the HI_HI 
alarm state.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

priority is the priority of the analog alarm being queried. The valid ran
is between 1 and 15, where 15 is the highest priority and 1 is the lowe
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Get Bit Array Tag Alarm Setting

Use the Get Bit Array Tag Alarm Setting VI to obtain alarm setting information for bit 
array tags. 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

alarms enabled indicates whether alarms are enabled for this tag. If 
TRUE, alarms are enabled for this tag. If FALSE, alarms are disabled.

tag value alarm enabled indicates whether alarms generated by chang
in the value of the tag are enabled. If TRUE, alarms are enabled. If FAL
they are disabled.

alarm on ALL indicates how many individual bits must be in alarm befo
the entire bit array tag is in alarm. If TRUE, an alarm is generated if all 
bits are in alarm. If FALSE, an alarm is generated if any of the bits in t
bit array tag are in alarm.

invert mask indicates the bits in the bit array tag that must be inverted
before calculating whether the tag is in alarm. invert mask is represented 
in hexadecimal.

select mask indicates the bits in the bit array tag to be used for the alar
calculation.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

priority is the priority of the alarm for a bit array tag. The valid range is
between 1 and 15, where 15 is the highest priority and 1 is the lowest
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Get Discrete Tag Alarm Setting

Use the Get Discrete Tag Alarm Setting VI to obtain alarm setting information for 
discrete tags. 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

alarms enabled indicates whether alarms are enabled for a tag. If TRU
tag value alarms as well as bad status alarms are enabled for this tag
depending on the enable setting for the particular alarm types. If FALS
all alarms are disabled for this tag, regardless of the enable settings fo
particular alarm types.

tag value alarm enabled indicates whether alarms generated by chang
in the value of the tag are enabled. If FALSE, they are disabled. If TRU
they are enabled.

alarm on low indicates whether an alarm is generated depending on th
discrete tag value. If FALSE, an alarm is generated if the discrete tag v
is high. If TRUE, an alarm is generated if the discrete tag value is low.

priority is the priority of the alarm for a discrete tag. The valid range is
between 1 and 15, where 15 is the highest priority and 1 is the lowest

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

alarm message is the user defined string message displayed along with 
alarm notification.
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Get Group List

Use the Get Group List VI to returns a list of all configured groups in the system. By def
this VI includes the <ALL> group in the list.

include <ALL> (T)  determines whether the <ALL> group should be 
included in the list. The default is TRUE. 

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

group list is the list of currently configured groups.

no .scf loaded is TRUE if there is no .scf  file currently loaded in the 
system.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Alarm Enabled

Use the Get Tag Alarm Enabled VI to indicate whether alarms are enabled for the tag.
VI also indicates whether alarms are acknowledged automatically when a tag previous
alarm returns to normal. 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 
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enabled indicates whether alarms are enabled for a tag. If TRUE, tag va
alarms as well as bad status alarms are enabled for this tag, dependin
the enable setting for the particular alarm types. If FALSE, all alarms a
disabled for this tag, regardless of the enable settings for the particula
alarm types.

auto acknowledge indicates whether alarms are acknowledged 
automatically when a tag goes back to normal from an alarm state. If auto 
acknowledge is TRUE, the alarm is acknowledged automatically when t
tag returns to normal. If it is FALSE, the user must acknowledge the ala

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Attribute

Use the Get Tag Attributes VI to obtain the value of a tag attribute. The tag attribute  input 
provides a large list for selection. Each attribute is selected by specifying its numeric c
The value of the attribute selected is returned upon execution. If the attribute returns a
numeric, use the value output. If the attribute returns a Boolean, use the value (discrete) 
output. For more information about the tag attributes you can query with this VI, refer to
of the four configuration attributes tables in the section How Do You Configure Tags? in 
Chapter 3, Tag Configuration, in this manual. 

If the attribute returns a numeric output, value (discrete) returns a FALSE if the value is zero
and a TRUE if the value is nonzero. If the attribute returns a discrete output, value returns a 
1 or 0, corresponding to TRUE or FALSE in value (discrete).

tag name is the name of the tag about which you want to obtain 
information.

tag attribute (0, <none>) is a list of various parameters that you can que
for a tag. Each attribute has a numeric code.

Note: By opening the front panel of this VI and selecting an attribute from the 
tag attribute ring control, you can see which numeric code corresponds 
each attribute.
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error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

value is the numeric value of the attribute being queried. If the attribute
returns a Boolean, value returns 1 or 0 corresponding to value (discrete).

value (discrete) is the value of the Boolean attribute being queried. If th
attribute returns a numeric, value (discrete) returns FALSE if value is 0, 
and TRUE if value is nonzero.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Bad Status Alarm Info

Use the Get Tag Bad Status Alarm Info VI to determine whether alarms are enabled fo
tag. This VI also returns whether the bad status alarm is enabled, and its priority. 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

alarms enabled indicates whether alarms are enabled for this tag. If 
TRUE, tag value alarms as well as bad status alarms are enabled for 
tag, depending on the enable setting for the particular alarm types. If 
FALSE, all alarms are disabled for this tag, regardless of the enable set
for the particular alarm types.

bad status alarm enabled indicates whether bad status alarms are 
generated for a tag if it has a bad status.

priority is the priority of the bad status alarm for a tag. The valid range
between 1 and 15, where 15 is the highest priority and 1 is the lowest
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error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Description Group

Use the Get Tag Description Group VI to obtain a tag data type (analog, discrete, bit arr
string), description, and the group to which the tag belongs.

 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

data type is the tag type (analog, discrete, bit array, or string).

description is the user-defined description for the tag.

tag group is the tag group to which the tag belongs.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Get Tag I/O Connection Info

Use the Get Tag I/O Connection Info VI to obtain information on how the tag is connecte
a real-world I/O point. Outputs include data type (analog, discrete, bit array, or string), se
I/O group, item, access rights (Memory, Input, Output, I/O), and length. For bit array ta
length is the number of discrete points in the tag. For string tags, length is the number of 
This output is not used for analog and discrete tags. 

 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

data type is the tag type (analog, discrete, string, or bit array).

server indicates the device server used for this tag. It is not applicable
memory tags, which have no servers associated with them by definitio

I/O group  is the name of the I/O group the item is used with.

item is the channel, register, or item name.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

access rights indicates whether the tag is a Memory, Input, Output, or 
Input/Output tag. 

length is the maximum length for the tag. This field is applicable to bit 
array and string tags only. It is not used for analog or discrete tags.
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Get Tag List

Use the Get Tag List VI to return a list of all tags in a group. By default, group is <ALL>, so 
the VI returns all configured tags.

group (<ALL>)  determines what tags are in a list. The default is <ALL>, 
so that the VI returns all configured tags in tag list.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

tag list is the list of tags contained in group.

no .scf loaded is TRUE if there is no .scf  file currently loaded in the 
system.

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Logging Info

Use the Get Tag Logging Info VI to determine whether a tag is configured for logging 
historical data or alarms and events to disk. 

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

log data is TRUE if the tag is configured for logging data to the Citadel
historical database.
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log/print events is TRUE if events are to be logged or printed for this ta

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 

Get Tag Range and Units

Use the Get Tag Range and Units VI to obtain the engineering range for the tag in a c
of Minimum , Maximum , and Increment. You can wire this format to a scale attribute nod
for a graph, slide, or vessel. Increment is set to 0, which means that BridgeVIEW calculate
the scale increment automatically. units is the tag engineering units.

tag name is the name of the tag about which you want to obtain 
information.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

eng range is the range of the tag in engineering units. If you are plottin
data on a chart, waveform graph, XY graph, slide or vessel, you can w
this output directly to the X Range (All Elements) or Y Range (All 
Elements) Attribute Node.

Minimum  is the user defined minimum tag value.

Maximum  is the user defined maximum tag value.

Increment is the delta in which the value increments. It is not 
user defined value and is always 0. Increment determines how 
the chart or graph computes an increment based on the Minimum , 
Maximum , and the data set being plotted.

units is the name of units for engineering values. This parameter applie
analog tags only. For discrete, bit array, and string tags, units is an empty 
string. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Set Multiple Tag Attributes

Use the Set Multiple Tag Attributes VI to reconfigure several attributes for a list of tags
groups of tags programmatically. You must have the Engine running for the changes to
effect. Otherwise, this VI returns an error. For more information about the tag attributes
can change with this VI, refer to any of the five configuration attributes tables in the se
How Do You Configure Tags? in Chapter 3, Tag Configuration, in this manual. Also see the
Tag Attributes VIs section in Chapter 7, Advanced Application Topics.

Because the attribute value is a numeric, for discrete attributes, use 1 or 0 to represent
or FALSE respectively. All the attributes are set for each tag in group/tag name.

group/tag names is the list of tags, or groups of tags, for which you wan
to set attributes.

attributes and values is a list of attributes and values to be set. You ca
select multiple attributes and their corresponding values, and they will
applied to all the tags. For more information about the tag attributes you
change with this VI, refer to any of the four configuration attributes tab
in the section How Do You Configure Tags? in Chapter 3, Tag 
Configuration, in this manual.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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Set Tag Attribute

Use the Set Tag Attribute VI to reconfigure an attribute for a list of tags or groups of ta
programmatically. You must have the Engine running for the change to take effect. 
Otherwise, this VI returns an error. For more information about the tag attributes you c
change with this VI, refer to any of the five configuration attributes tables in the section How 
Do You Configure Tags? in Chapter 3, Tag Configuration, in this manual. Also see the Tag 
Attributes VIs section in Chapter 7, Advanced Application Topics.

The tag attribute input provides a large list for selection.Each attribute is selected by 
sepcifying its numeric code. Use value to set the value of the attribute selected. If the attribu
is a Boolean, use a 1 or 0 in value.

group/tag names is a list of tags or groups of tags, for which you want t
set an attribute.

tag attribute (0, <none>) is the parameter to be set for each tag in 
group/tag names. For more information about the tag attributes you ca
change with this VI, refer to any of the four configuration attributes tab
in the section How Do You Configure Tags? in Chapter 3, Tag 
Configuration.

Note: By opening the front panel of this VI and selecting an attribute from the 
tag attribute ring control, you can see which numeric code corresponds 
each attribute.

value is the numeric value of the attribute being set. If the attribute is a
Boolean, use 1 or 0 for value.

error in (no error)  is a cluster that describes the error status before this
executes. For more information about this control, see the section Errors 
Not Reported by the BridgeVIEW Engine in this appendix. 

error out  is a cluster that describes the error status after this VI execu
For more information about this indicator, see the section Errors Not 
Reported by the BridgeVIEW Engine in this appendix. 
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This appendix describes the Citadel database and the Open Datab
Connectivity (ODBC) driver, and includes a table that lists data 
transform commands. 

The Citadel threaded historical database includes an Open Databa
Connectivity (ODBC) driver. This driver enables other applications 
directly retrieve data from Citadel using Structured Query Languag
(SQL) queries. In order to use the SQL ODBC interface to 
BridgeVIEW, you must have installed the Citadel ODBC driver from
the BridgeVIEW CD.

What is ODBC?
ODBC is a standard developed by Microsoft. It defines the mechanis
for accessing data resident in database management systems (DBM
Virtually all Windows-based applications that can retrieve data from
database support ODBC.

Because Citadel allows simultaneous real-time access by multiple 
applications, the ODBC Driver can retrieve data from the Citadel 
database even while BridgeVIEW is running. There is no need to 
interrupt data collection in order to query the database. In fact, the 
ODBC Driver allows multiple ODBC applications to perform SQL 
queries simultaneously.

Configuring the ODBC Driver
1. Shutdown all applications that might currently be using ODBC.

Such applications include spreadsheets, word processors, data
programs, MS Query, etc. You do not need to shutdown 
BridgeVIEW.

2. If you are using Windows 95, click the Start button, point to 
Settings, then click on Control Panel. Otherwise, in the Main 
program group, choose the Control Panel icon.

3. In the Control Panel dialog box, choose the 32-bit ODBC
geVIEW User Manual
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4. In the Data Sources dialog box, choose Drivers….
 

5. Choose the Citadel driver and select Setup….
 

6. Make changes as appropriate. For each data source you want 
select the historical logging directory that was configured in you
Tag Configuration (*.scf) file. For example, if you want to query
the historical data created by the Tanks System example, direct
modify the database path to C:\BridgeVIEW\Examples\User 

Applications\Tank System\Data . You can also modify the 
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name of the data source to reflect the application. An example o
modified ODBC Setup dialog is shown below.

 

Note: Some applications are not completely ODBC compliant. If you plan to us
Microsoft Query, Microsoft Access or Visual Basic, ensure Maximum 
Column Name Length does not exceed 62 characters. These packages 
cannot handle longer tag names. Other packages that are truly 
ODBC-compliant should be able to handle tag names up to 126 characte
long. All threads whose tag names exceed the Maximum Column Name 
Length are excluded from queries.

If you plan to use Microsoft Access or Visual Basic, select Convert special 
characters. This forces BridgeVIEW tag names into a format acceptable b
these applications by replacing characters within the tag names as follow

7. Select OK  and CLOSE to exit.

Original Character Converted To

period (.) backslash ( \ )

ampersand ( & ) at sign ( @ ) 

exclamation ( ! ) vertical bar ( | ) 
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What is SQL?
Structured Query Language (SQL) is an industry-standard languag
used for retrieving, updating and managing data. As far as BridgeVIE
is concerned, you can use SQL to build queries that extract data fr
Citadel. Beyond simple data extraction, the Citadel ODBC driver al
includes many built-in data transforms that greatly simplify statistic
analysis of retrieved data.

How Do You Access Citadel Data?
The ODBC driver presents Citadel data to other applications as a 
Threads table. The table contains a field or column for each data 
member logged to the Citadel database.

Threads Table
The Threads table also contains three fields you can use to specify q
criteria and to time-stamp retrieved data: Interval , LocalTime  and 
UTCTime. 

Interval  allows you to specify the query’s value sample rate. Interval  
can range from 10ms to several years. By default, Interval  is 1 (one 
day).

Remember, Citadel only logs a value when the value changes (it is
event-driven). But using Interval , you can query Citadel for values 
evenly spaced over a period of time. 

LocalTime and UTCTime indicate the time-stamps of when values ar
logged. Citadel actually stores the time in UTCTime format and derives 
LocalTime from the stored time. When you do not specify a time, 
Citadel assumes midnight of the current day.

The following query’s where clause takes advantage of Interval  and 
LocalTime to select data over a specified time at one minute interva
Notice that time and date formats are the same as those used in 
BridgeVIEW.

SELECT * FROM Threads 

WHERE LocalTime > "12/1 10:00"

AND LocalTime < "12/2 13:00"

AND Interval = "1:00"
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Data Transforms
Your queries can include special commands that perform data 
transforms, making it easy to manipulate and analyze historical dat
The following table lists data transform commands.

Table B-1.     Data Transform Commands

Data Transform Command Description

Min{tag name} Returns the minimum for tag name 
across the interval.

Max{tag name} Returns the maximum for tag name 
across the interval.

Avg{tag name} Returns the average for tag name acros
the interval.

StDev{tag name} Returns the standard deviation for tag 
name across the interval.

Starts{tag name} Returns the number of starts (number o
transitions from OFF to ON) for tag 
name across the interval.

Stops{Datapoint} Returns the number of stops (number o
transitions from ON to OFF) for 
Datapoint across the interval.

ETM{Datapoint} Returns the amount of time Datapoint 
was in the ON state across the interva

Qual{Datapoint} There might be gaps in the historical 
data threads in Citadel due to machine
shutdown or BridgeVIEW shutdown. 
Qual returns the ratio of time for which 
valid data exists for a datapoint across
the interval, to the length of the interval
itself. Thus if valid data exists for only 
one-half of the interval, Qual would 
return 0.5.
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These data transforms allow you to directly calculate and retrieve 
complex information from the database such as averages and stan
deviations. This time saving feature eliminates the need of extractin
raw data first, and then massaging it in another application to come
with the needed information. 

Assume, for example, that we want to find out how many times a 
compressor motor started in December. We also want to know its t
runtime for the month. The following query would provide the answe

SELECT "Starts{MotorRun}",

"ETM{MotorRun}"

FROM Threads 

WHERE LocalTime >= "12/1/95" 

AND LocalTime < "1/1/96"

AND Interval = "31"

SQL Examples
The following examples are typical query statements; however, you
queries may be much more involved, depending on your system 
requirements.

• Retrieves the most recent (current) value of every tag logged to 
Citadel.

SELECT *

FROM Threads 

• Retrieves the value of every tag logged today in one second 
increments. Note the interval value is specified within 

quotation marks.

SELECT *

FROM Threads 

WHERE Interval=“0:01”

• Retrieves and time-stamps the value of Powder  in one second 
increments from 8:50 this morning to now. Tag names are 
surrounded by quotes.

SELECT LocalTime, “Powder”

FROM Threads

WHERE LocalTime>“8:50”

AND Interval=“0:01”
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• Retrieves and time-stamps the value of Liquid  input in one 
minute intervals for the month of October. Also indicates the 
input’s highest occurring value within each minute.

SELECT LocalTime, “Liquid”, “Max{Liquid}”

FROM Threads

WHERE LocalTime>“10/1/96”

AND LocalTime<“11/1/96”

AND Interval=“1:00”

• Retrieves an oven’s temperature set point and value at 3:00 p.m
and shows the highest, lowest, and average temperatures betwe
p.m. and 3 p.m..

SELECT LocalTime, "OVEN1_SP", "OVEN1_PV", 
"Max{OVEN1_PV}", "Min{OVEN1_PV}", 
"Avg{OVEN1_PV}" 

FROM Threads

WHERE  LocalTime >= "14:00"

AND LocalTime < "15:00"

AND Interval = "1:00:00"

Queries Using Specific Applications
The following sections include information on queries using specific
applications.

Using Microsoft Query with Citadel

Note: The exact operation of Microsoft Query may change from version to 
version. Look in the on-line help for Microsoft Query for how to connect 
to an ODBC Data Source for the exact instructions for your version of 
Microsoft Query.

Microsoft Query is a graphical data retrieval tool supplied with 
Microsoft Office and Microsoft Excel. It allows you to build your SQL
statement using interactive dialog boxes. Let’s step through a somew
involved example to show you a few simple tricks. 

To activate MS Query, double-click the MS Query icon, typically 
found in the MS Office program group. If you cannot find the icon, loo
in C:\Program Files\Common Files\MicroSoft 

Shared\MSQuery\Msqry32.exe . MS Query is not part of an MS 
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Office standard installation, so if you do not find it on your system, y
will need to install it from your MS Office disks.

Choose File»New Query… to begin and select the data source you ha
setup for your Citadel historical directory as shown here. You migh
need to press Other… to access a list of data sources to select. 

 

Note: If MS Query is unable to connect to a Citadel data source, then you hav
not yet logged data to Citadel; or the Database path you specified in the 
ODBC Setup dialog box is incorrect. 

Note: If the Citadel data source isn’t listed in the Select Data Source dialog bo
you may not have accessed it yet. Choose Other… and select Citadel from 
among the ODBC data sources. If Citadel isn’t listed as an ODBC Data 
Source, you need to install it. See the Configuring the ODBC Driver section 
for more information.

In the Add Tables dialog box, double click Threads. Then close the
dialog box. 

 

BridgeVIEW User Manual B-8 © National Instruments Corporation



Appendix B Citadel and Open Database Connectivity

ds 
 list 
to 

e 

nk 

 

e 
cify 
MS Query should now present the full Query Window with the Threa
table shown. Notice the list of tag names in the Threads table. This
is a comprehensive list of all tags whose values have been logged 
Citadel.

To view the value of a field, simply double click on it or drag it to th
data pane.

 

To view a data transform value, enter the function directly into a bla
column. For example, to view the minimum value of Liquid , you 
would enter “min{Liquid}”. Take special note of the use of quotation
marks and braces. 

The above data set was retrieved using no specifying criteria, so th
ODBC driver used the default criteria. There are several ways to spe
criteria. For this example, we’ll use the criteria pane. Click on the View 
Criteria  button. 
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To add a field to the criteria pane, simply drag it from the list of field
to the Criteria Field

 

When you enter qualifying criteria values, be sure to use the syntax
demonstrated in the where clauses of the SQL Examples found in t
chapter. To specify a starting time of 9:45 today, for example, you 
would enter >= "9:45" .

As soon as you specify a criteria, Microsoft Query immediately 
retrieves the specified data. You can save your query at any stage o
development. By the way, as you build your query, the application 
builds an SQL statement. When you click on the SQL button, you can 
view and edit the query statement, as shown in the following dialog b
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Using Microsoft Excel with Citadel

Note: The exact operation of Microsoft Excel may change from version to 
version. Look in the on-line help for Microsoft Excel for how to connect to
an ODBC Data Source for the exact instructions for your version of 
Microsoft Excel.

To extract data from Citadel, activate Excel and choose Data(Get 
External Data…. This Excel command directly activates Microsoft 
Query. From here you can use an existing query or create a new o
See the Using Microsoft Query with Citadel section. 

When you finish building your query, return the result set by choosi
File(Return Data to Microsoft Excel…. Excel responds by presenting
the Get External Data dialog box, enabling you to change or confirm 
destination cells of the result set. If you want to update the result s
later by requerying Citadel, be sure that Keep Query Definition remains 
selected. Choose OK  to write the data into the Excel worksheet. 

 

To update your result set, select any cell within the worksheet’s res
set, choose Data»Get External Data…, and click on the Refresh button.
© National Instruments Corporation B-11 BridgeVIEW User Manual



Appendix B Citadel and Open Database Connectivity

t 

t 

 

 

oft 
e to 
lity 
ust 
ps. 

e 
Using Microsoft Access with Citadel

Note: The exact operation of Microsoft Access may change from version to 
version. Look in the on-line help for Microsoft Access for how to connec
to an ODBC Data Source for the exact instructions for your version of 
Microsoft Access.

Note: The SQL/92 standard states that a delimited identifier is any string of no
more than 128 characters enclosed in quotation marks. It further states 
that characters within a delimited identifier are exempt from SQL syntax
checking. Unfortunately, Microsoft Access performs its own syntax 
checking for ODBC queries using a non-standard SQL syntax—even 
within delimited identifiers. For this reason, National Instruments 
provides a Convert Special Characters selection in the Citadel ODBC Setup
dialog box. When selected, the ODBC driver converts the disallowed 
characters to something acceptable to Access, as follows: 

Therefore, a BridgeVIEW identifier such as Modbus1.40001 will be seen by 
Access, as the delimited identifier Modbus1\40001.

When you query Citadel data using MS Access, You must use Micros
Access’s non-standard SQL syntax in your select statement. Be sur
use the special characters that are converted for Access compatibi
and double quotes around BridgeVIEW thread names. Finally, you m
use square brackets [ ] around identifiers, and #’s around time stam
For example, to retrieve LocalTime, Liquid, and Powder where 
LocalTime is less than 10/22/95 18:00:00, and where Interval is on
second, enter:

SELECT LocalTime, ["Liquid"], ["Powder"] 

FROM Threads 

WHERE LocalTime < #10/22/96 6:00:00 PM# 

AND Interval = '0:01'

Disallowed Character Converted To

period (.) backslash ( \ )

ampersand ( & ) at sign ( @ ) 

exclamation ( ! ) vertical bar ( | ) 
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To query Citadel from within MS Access, open a database, select 
File(Get External Data… and then click Import .  In the Import 
dialog box, in the Files of Type box, select ODBC Databases(). In the 
SQL Data Sources dialog box, choose your Citadel Data Source, a
shown here. 

 

Then, in the Import Objects dialog box, choose Threads. The new table 
should now be attached to your database. 

 

Now you can build queries in Access that will extract data directly fro
the Citadel database.
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Using Visual Basic with Citadel

Note: The exact operation of Visual Basic may change from version to version
Look in the on-line help for Visual Basic for how to connect to an ODBC
Data Source for the exact instructions for your version of Visual Basic.

Note: Visual Basic software relies on Microsoft Access DLLs for performing 
ODBC queries. Because it uses Access’s non-standard SQL syntax, be s
that Convert Special Characters is selected in the Citadel ODBC Setup 
dialog box. See note in the Using Microsoft Access with Citadel section.

Using Citadel’s ODBC Driver in Visual Basic is the same as using a
other ODBC driver. To retrieve and view data, you’ll have to create
Data control and at least one text control. 

First Place a Data control on an open form. Set its Connect property to 
DSN=Citadel (or whatever name you gave the Citadel data source) 
double-click on its Record Source property to identify Threads as its 
source table.

You can leave the Record Source property set to Threads if you wish to
select all of the data for all of the threads in the Citadel database, or
can narrow your query by entering an SQL select statement in the 
Record Source property. For example, to retrieve LocalTime, Liquid,
and Powder where LocalTime is greater than 10/20/95 18:00:00 an
less than 18:30:00, and where Interval is one minute, enter:

SELECT LocalTime, ["Liquid "], ["Powder "] 

FROM Threads 

WHERE LocalTime > #11/20/95 6:00:00 PM# 

AND LocalTime < #11/20/95 6:30:00 PM# 

AND Interval = '1:0'

You must use Microsoft Access’s SQL syntax in your select stateme
Also remember to use the special characters that are converted for
Access compatibility and double quotes around BridgeVIEW thread
names to identify them as delimited identifiers. Finally, Access SQL 
requires square brackets [ ] around identifiers, and #’s around time
stamps.
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Now place a Text control on the form. Set its Data Source property to 
the name of your Data control—for example, Data1. Click on the Data 
Field property to highlight it and then using the property sheet’s 
drop-down combo box, select the desired field name. All logged da
members should be listed including LocalTime, Interval, Liquid, etc
Repeat this step for each data member you want to display on your f
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For your convenience, this appendix contains forms to help you gather the information nece
to help us solve your technical problems and a form you can use to comment on the produ
documentation. When you contact us, we need the information on the Technical Support For
the configuration form, if your manual contains one, about your system configuration to an
your questions as quickly as possible.

National Instruments has technical assistance through electronic, fax, and telephone syste
quickly provide the information you need. Our electronic services include a bulletin board ser
an FTP site, a fax-on-demand system, and e-mail support. If you have a hardware or softw
problem, first try the electronic support systems. If the information available on these syste
does not answer your questions, we offer fax and telephone support through our technical s
centers, which are staffed by applications engineers.

Electronic Services

National Instruments has BBS and FTP sites dedicated for 24-hour support with a collectio
files and documents to answer most common customer questions. From these sites, you c
download the latest instrument drivers, updates, and example programs. For recorded instru
on how to use the bulletin board and FTP services and for BBS automated information, ca
(512) 795-6990. You can access these services at:

United States: (512) 794-5422
Up to 14,400 baud, 8 data bits, 1 stop bit, no parity

United Kingdom: 01635 551422
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

France: 01 48 65 15 59
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

To access our FTP site, log on to our Internet host, ftp.natinst.com , as anonymous  and use 
your Internet address, such as joesmith@anywhere.com , as your password. The support files an
documents are located in the /support  directories.

Bulletin Board Support

FTP Support
geVIEW User Manual
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Fax-on-Demand is a 24-hour information retrieval system containing a library of documents
wide range of technical information. You can access Fax-on-Demand from a touch-tone tele
at (512) 418-1111.

You can submit technical support questions to the applications engineering team through e
at the Internet address listed below. Remember to include your name, address, and phone n
so we can contact you with solutions and suggestions.

support@natinst.com

Telephone and Fax Support
National Instruments has branch offices all over the world. Use the list below to find the tech
support number for your country. If there is no National Instruments office in your country, 
contact the source from which you purchased your software to obtain support.

Telephone  Fax

Australia 03 9879 5166 03 9879 6277
Austria 0662 45 79 90 0 0662 45 79 90 19
Belgium 02 757 00 20 02 757 03 11
Brazil 011 288 3336 011 288 8528
Canada (Ontario) 905 785 0085 905 785 0086
Canada (Quebec) 514 694 8521 514 694 4399
Denmark 45 76 26 00 45 76 26 02
Finland 09 725 725 11 09 725 725 55
France 01 48 14 24 24 01 48 14 24 14
Germany 089 741 31 30 089 714 60 35
Hong Kong 2645 3186 2686 8505
Israel 03 6120092 03 6120095
Italy 02 413091 02 41309215
Japan 03 5472 2970 03 5472 2977
Korea 02 596 7456 02 596 7455
Mexico 5 520 2635 5 520 3282
Netherlands 0348 433466 0348 430673
Norway 32 84 84 00 32 84 86 00
Singapore 2265886 2265887
Spain 91 640 0085 91 640 0533
Sweden 08 730 49 70 08 730 43 70
Switzerland 056 200 51 51 056 200 51 55
Taiwan 02 377 1200 02 737 4644
United Kingdom 01635 523545 01635 523154
United States 512 795 8248 512 794 5678

Fax-on-Demand Support

E-Mail Support (currently U.S. only)
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Technical Support Form
Photocopy this form and update it each time you make changes to your software or hardwar
use the completed copy of this form as a reference for your current configuration. Completin
form accurately before contacting National Instruments for technical support helps our 
applications engineers answer your questions more efficiently.

If you are using any National Instruments hardware or software products related to this pro
include the configuration forms from their user manuals. Include additional pages if necess

Name ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Fax ( ___ )___________________ Phone ( ___ )____________________________________

Computer brand ________________ Model ________________ Processor_______________

Operating system (include version number) ________________________________________

Clock speed ______MHz   RAM _____MB  Display adapter _________________________

Mouse ___yes   ___no     Other adapters installed ___________________________________

Hard disk capacity _____MB Brand __________________________________________

Instruments used _____________________________________________________________

___________________________________________________________________________

National Instruments hardware product model __________  Revision ___________________

Configuration _______________________________________________________________

National Instruments software product ____________________________ Version _________

Configuration _______________________________________________________________

The problem is: ______________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

List any error messages: _______________________________________________________

___________________________________________________________________________

___________________________________________________________________________

The following steps reproduce the problem:________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________
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BridgeVIEW Hardware and Software 
Configuration Form
Record the settings and revisions of your hardware and software on the line to the right of 
item. Complete a new copy of this form each time you revise your software or hardware 
configuration, and use this form as a reference for your current configuration. Completing t
form accurately before contacting National Instruments for technical support helps our 
applications engineers answer your questions more efficiently.

National Instruments Products
DAQ hardware ___________________________________________________________

Interrupt level of hardware __________________________________________________

DMA channels of hardware _________________________________________________

Base I/O address of hardware ________________________________________________

Programming choice _______________________________________________________

BridgeVIEW version _______________________________________________________

Other boards in system _____________________________________________________

Base I/O address of other boards _____________________________________________

DMA channels of other boards _______________________________________________

Interrupt level of other boards _______________________________________________

Other Products
Application Software Developer _______________________________________________

Computer make and model __________________________________________________

Microprocessor ___________________________________________________________

Clock frequency or speed ___________________________________________________

Type of video board installed ________________________________________________

Operating system version ___________________________________________________

Operating system mode ____________________________________________________

Programming language _____________________________________________________

Programming language version ______________________________________________

Other boards in system _____________________________________________________

Base I/O address of other boards _____________________________________________

DMA channels of other boards _______________________________________________

Interrupt level of other boards _______________________________________________
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Documentation Comment Form
National Instruments encourages you to comment on the documentation supplied with our
products. This information helps us provide quality products to meet your needs.

Title: BridgeVIEW™ User Manual

Edition Date: October 1997

Part Number: 321294B-01

Please comment on the completeness, clarity, and organization of the manual.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

If you find errors in the manual, please record the page numbers and describe the errors.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

Thank you for your help.

Name _____________________________________________________________________

Title ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Phone ( ___ )__________________________  Fax ( ___ ) ____________________________

Mail to: Technical Publications Fax to: Technical Publications
National Instruments Corporation National Instruments Corporation
6504 Bridge Point Parkway (512) 794-5678
Austin, TX  78730-5039
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Prefix Meanings Value

m- milli- 10–3

µ- micro- 10–6

n- nano- 10–9

A

access level Determines which access privileges a user has for certain BridgeVIE
utilities. Access level values are between 0 and 255.

ACK (Acknowledge) The sequence action that indicates recognition of a new alarm.

alarm An abnormal process condition. In BridgeVIEW, an alarm occurs if a t
value goes out of its defined alarm limits or if a tag has bad status. 

Alarm Summary A display of tags currently in alarm, or a display of tags previously in 
unacknowledged alarm state that have returned to a normal state.

analog tag A continuous value representation of a connection to a real-world I/O p
or memory variable. This type of tag can vary continuously over a rang
values within a signal range.

application software The application created using the BridgeVIEW Development System
executed in the BridgeVIEW Run-Time System environment.

Application 
Programming Interface

A specification of a set of software functions and their input and return
parameters.

array An ordered, indexed set of data elements of the same type.
dgeVIEW User Manual
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ASCII American Standard Code for Information Interchange.

attribute node A special block diagram node you can use to control the appearance
functionality of controls and indicators.

B

bit array tag A multibit value representation of a connection to a real-world I/O poin
memory variable. In BridgeVIEW, this type of tag can be comprised of 
to 32 discrete values.

block diagram A pictorial description or representation of a program or algorithm. In
BridgeVIEW, the block diagram, which consists of executable icons cal
nodes and wires that carry data between the nodes, is the source cod
the VI. The block diagram resides in the Diagram window of the VI.

Boolean controls and 
indicators

Front panel objects used to manipulate and display or input and outpu
Boolean (TRUE or FALSE) data. Several styles are available, such as
switches, buttons and LEDs.

breakpoint Mode that halts execution when a subVI is called. You set a breakpoi
clicking on the Breakpoint button in the execution palette.

BridgeVIEW A program development application for real-time process monitoring a
control. BridgeVIEW uses the graphical development environment 
called G.

BridgeVIEW Engine The heart of the BridgeVIEW system. It maintains the Real-Time Data
of all tag values and alarm states. The BV Engine runs as a separate 
process, independent of your HMI application. 

BridgeVIEW Run-Time 
System

An execution environment for applications created using the BridgeVIE
Development System.

broken VI VI that cannot be compiled or run; signified by a broken arrow in the R
button.
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Case structure Conditional branching control structure, which executes one and onl
of its subdiagrams based on its input. It is the combination of the IF, THE
ELSE, and CASE statements in control flow languages.

Citadel A database for storing historical tag values.

cluster A set of ordered, unindexed data elements of any data type including
numeric, Boolean, string, array, or cluster. The elements must be all 
controls or all indicators.

coercion dot A gray dot on a terminal to indicate that one of two terminals wired toge
has been converted to match the data type representation of the other

connector Part of the VI or function node that contains its input and output termin
through which data passes to and from the node.

connector pane Region in the upper right corner of a front panel window that display
VI terminal pattern. It underlies the icon pane.

constant See universal constant and user-defined constant.

D

data flow Programming system consisting of executable nodes in which nodes 
execute only when they have received all required input data and prod
output automatically when they have executed.

deadband In process instrumentation, the range through which an input signal 
vary, upon reversal of direction, without initiating an observable change
output signal. Deadband is usually expressed in percent of range.
See log deadband and update deadband. 

device An instrument or controller that is addressable as a single entity and 
controls or monitors real-world I/O points. A device is often connected
the host computer through some type of communication network, or ca
a plug-in device.
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device server An application that communicates with and manages a peripheral har
device such as a Programmable Logic Control (PLC), remote I/O devic
plug-in device. Device servers pass tag values to the BridgeVIEW Eng
in real time.

discrete tag A two-state (on/off) value representation of a connection to a real-wo
I/O point. In BridgeVIEW, this type of tag can be either a one (TRUE) 
a zero (FALSE).

E

Engine See BridgeVIEW Engine.

engineering units (EU) Terms of data measurement, as degrees Celsius, pounds, grams an

error message An indication of a software or hardware malfunction, or an unaccept
data entry attempt.

event Something that happens to a tag in the BridgeVIEW system. Events inc
tags going into or out of alarm state and the user setting a tag value. 

event driven 
programming

A method of programming whereby the program waits on an event 
occurring before executing one or more functions.

F

For Loop Iterative loop structure that executes its subdiagram a set number of t
Equivalent to conventional code: 
For i = 0 to n – 1, do....

formula node Node that executes formulas that you enter as text. Especially useful
lengthy formulas that would be cumbersome to build in block diagram
form.

frame Subdiagram of a Sequence Structure.

free label Label on the front panel or block diagram that does not belong to any o
object.

front panel The interactive user interface of a VI. Modeled from the front panel o
physical instruments, it is composed of switches, slides, meters, graph
charts, gauges, LEDs, and other controls and indicators.
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G The graphical programming language used to develop BridgeVIEW 
applications.

group See tag group or I/O group.

H

Help window Special window that displays the names and locations of the terminal
a function or subVI, the description of controls and indicators, the valu
of universal constants, and descriptions and data types of control attrib
The window also accesses the Online Reference.

historical trend A plot of data (values versus time) showing values that were previou
acquired in the system or logged to disk.

Historical Trend Viewer 
(HTV)

A utility that accesses historical data from the Citadel historical databa

HMI G Wizard A utility in BridgeVIEW that automates the process of generating HMI
diagram code.

Human Machine 
Interface (HMI)

A graphical user interface for the user to interact with the BridgeVIEW
system.

I

icon Graphical representation of a node on a block diagram.

icon pane Region in the upper right corner of the Panel and Diagram windows t
displays the VI icon.

input tag A tag that accepts Real-Time Database values from a device server.

Input/Output (I/O) tag A tag that accepts Real-Time Database values from a device server 
sends values to the server.
© National Instruments Corporation G-5 BridgeVIEW User Manual
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I/O Group A set of related server items, all of which share the same server updat
and deadband.

item A channel or variable in a real-world device that is monitored or control
by a BridgeVIEW device server.

L

LabVIEW Laboratory Virtual Instrument Engineering Workbench. A program 
development application used commonly for test and measurement 
purposes.

log deadband The range through which a tag value must change before it is logged
Citadel.

log resolution The smallest change in a tag value stored in the historical database.

M

MB Megabytes of memory.

Man Machine 
Interface (MMI)

See Human Machine Interface (HMI).

O

object Generic term for any item on the front panel or block diagram, includin
controls, nodes, wires, and imported pictures.

OPC OLE for Process Control. A COM-based standard defined by the OPC
foundation that specifies how to interact with device servers. COM is a
Microsoft 32-bit Windows technology.

operating tool Tool used to enter data into controls as well as operate them. Resem
pointing finger.

operator The person who initiates and monitors the operation of a process.

output tag A tag that sends values to a device server whenever it is updated in 
Real-Time Database.
BridgeVIEW User Manual G-6 © National Instruments Corporation



Glossary

nel 

 

trol 

ght 

ertain 

can 
.

l to 
r is 

hat is 

e.
P

palette A display of pictures that represent possible options.

Panel G Wizard A utility in BridgeVIEW that automates the process of creating front pa
controls.

Panel window VI window that contains the front panel, the execution palette and the
icon/connector pane.

PID See Proportional Integral Derivative Control.

PLC See Programmable Logic Control.

polling A method of sequentially observing each I/O point or user interface con
to determine if it is ready to receive data or request computer action.

pop up To call up a special menu by clicking, usually on an object, with the ri
mouse button.

pop-up menus Menus accessed by popping up, usually on an object. Menu options p
to that object specifically.

positioning tool Tool used to move and resize objects. Resembles an arrow.

Programmable Logic 
Control (PLC)

A device with multiple inputs and outputs that contains a program you 
alter. BridgeVIEW Device Servers establish communication with PLCs

Proportional Integral 
Derivative (PID) Control

A combination of proportional, integral, and derivative control actions. 
Refers to a control method in which the controller output is proportiona
the error, its time history, and the rate at which it is changing. The erro
the difference between the observed and desired values of a variable t
under control action.

pseudocode Simplified language-independent representation of programming cod
© National Instruments Corporation G-7 BridgeVIEW User Manual
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range The region between the limits within which a quantity is measured, 
received, or transmitted expressed by stating the lower and upper ran
values.

Real-Time Database 
(RTDB)

An in-memory snapshot of all tags in the system.

real-time trend A plot of data (values versus time) that is updated as each new point
acquired in the Real-Time Database.

reentrant execution Mode in which calls to multiple instances of a subVI can execute in pa
with distinct and separate data storage.

representation Subtype of the numeric data type, of which there are signed and uns
byte, word, and long integers, as well as single-, double-, and 
extended-precision floating-point numbers, both real and complex.

resizing handles Angled handles on the corner of objects that indicate resizing points

RTDB See Real-Time Database.

S

sampling period The time interval between observations in a periodic sampling contro
system.

SCADA Supervisory Control and Data Acquisition.

sensor A device that produces a voltage or current output representative of s
physical property being measured, such as speed, temperature, or flo

sequence local A terminal that passes data between the frames of a Sequence Stru

Sequence structure Program control structure that executes its subdiagrams in numeric
Commonly used to force nodes that are not data-dependent to execut
desired order.

shift register Optional mechanism in loop structures used to pass the value of a va
from one iteration of a loop to a subsequent iteration.
BridgeVIEW User Manual G-8 © National Instruments Corporation
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string tag An ASCII character representation of a connection to a real-world 
I/O point.

structure Program control element, such as a Sequence, Case, For Loop, or 
While Loop.

subVI A VI called on the diagram of another VI.

supervisory control Control in which the control loops operate independently subject to 
intermittent corrective action.

system developer The creator of the application software to be executed in the BridgeV
Run-Time System.

system errors
System errors

Errors that happen in the BridgeVIEW system, like a server going dow
System errors are displayed in a dialog box, on the Engine User Interf
and also are logged in a syslog file.

system events
System events

Events that occur in the BridgeVIEW system, like an operator logging 
or a utility starting up. System events are logged in a syslog file.

T

tag A connection to a real-world I/O point or a memory variable. Tags can
one of four data types: analog, binary, discrete, or string.

tag attributes Parameters pertaining to a tag, like its alarm, limits, or Engineering U
Tag attributes are configured in the Tag Configuration Editor but can b
changed dynamically using the Tag Attributes VIs.

Tag Browser A utility to view the configuration parameters of a tag, as configured in
Tag Configuration Editor.

Tag Configuration Editor A utility to configure various parameters of a tag, such as connection
information, scaling, or logging.

tag group A set of tags primarily used for reporting and acknowledging alarms. A
can be associated with only one tag group. All tags belong to the grou
<ALL> by default.

Tag Monitor A utility to view the current value of a tag, along with its status and ala
state.
© National Instruments Corporation G-9 BridgeVIEW User Manual
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tag status A variable that determines the validity of a tag value. A negative stat
represents an error, a positive status represents a warning, and a stat
zero represents a good tag value.

terminal Object or region on a node through which data passes.

timestamp The exact time and date at which a tag value was sampled. Tag valu
stored with their timestamps in the RTDB.

top-level VI VI at the top of the VI hierarchy. This term distinguishes the VI from it
subVIs.

trend A view of data over time. Trends can display real-time or historical da

U

universal constant Uneditable block diagram object that emits a particular ASCII charac
standard numeric constant, for example, pi.

update deadband The range through which a tag value must change before it is update
Real-Time Database.

user See operator.

user-defined constant Block diagram object that emits a value you set.

V

VI See virtual instrument.

VI library Special file that contains a collection of related VIs for a specific use.

virtual instrument A program in the graphical programming language G; so-called becau
models the appearance and function of a physical instrument.
BridgeVIEW User Manual G-10 © National Instruments Corporation
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While Loop Post-iterative test loop structure that repeats a section of code until a 
condition is met. Comparable to a Do loop or a Repeat-Until loop in 
conventional programming languages

wire Data path between nodes.

wiring tool Tool used to define data paths between source and sink terminals.

Wizard See HMI G Wizard and Panel G Wizard.

Wizard lock A glyph that appears on a tag loop to indicate BridgeVIEW has protec
the association between a front panel object and the automatically 
generated block diagram. If a Wizard lock exists on a tag loop, you can
modify that block diagram. Once you have released the Wizard lock, t
association is broken and the Wizard no longer protects that tag loop.
© National Instruments Corporation G-11 BridgeVIEW User Manual
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A
access levels and privileges, 7-1

See also security.
defaults (table), 7-13
finding access levels, 7-15
finding environment access privileges, 7-16
modifying

access privileges, 7-19
list of available user access levels, 7-19

Access Levels dialog box, 7-15
Acknowledge Alarm VI, A-4
alarm limit, 5-1
alarm priority, 5-2
alarm states, 5-1
alarm summary

applying security (activity), 7-22
building (activity), 5-3
displaying, 5-2
purpose and use, 5-2

alarms
acknowledging, 5-6

ACK button, 5-6
activity, 5-7
Auto Ack on Normal option, 5-6
User Must Ack option, 5-6

configuring logging and printing, 5-10
defining group of tags for alarming, 3-19
Event Configuration dialog box

event logging and printing selections 
(table), 5-11

illustration, 5-10
log and print format selections, 5-12

logging, 5-13
printing, 5-14
purpose and use, 1-7, 5-1
tag configuration, 3-29

alarm deadband on analog tags, 3-35
analog tags, 3-33
Auto Ack on Normal option, 3-37
configuration attributes (table), 3-30
discrete tags, 3-34
enabling alarms, 3-33
keeping alarms unacknowledged, 3-36
string tags, 3-35
types of alarms, 3-29
User Must Ack option, 3-37

viewing, 5-14
Alarms and Events VIs, A-4

Acknowledge Alarm, A-4
effect on startup and shutdown, 4-24
Get Alarm Summary Status, A-5
locating, A-4
purpose and use, 4-16, 4-19
Read Alarm Summary, A-6
Read Event History, A-9
Read Tag Alarm, A-13

Alarms Configuration Attributes (table), 3-30
Alignment ring, 2-3
analog tags

alarm configuration, 3-33
alarm deadband, 3-35
creating, 3-3
purpose and use, 3-7
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scaling, 3-25
analog tag scaling dialog box, 3-26
assigning units, 3-27
linear scaling, 3-26
square root scaling, 3-26

array functions
Array Size, 13-13
Array Subset, 13-14
Build Array, 13-11
Index Array, 13-14
Initialize Array, 13-12
using Build Array function (activity), 

13-17
Array Max & Min function, 13-23
array shell, 13-2
Array Size function, 13-13
array string constant, 14-6
Array Subset function, 13-14
arrays, 13-2

auto-indexing, 13-3
auto-indexing (activity), 13-4

block diagram, 13-5
front panel, 13-4
multiplot graphs, 13-8
setting For Loop count, 13-10

controls, constants, and indicators, 13-3
creating and initializing, 13-2
data acquisition arrays in graphs, 13-21
efficient memory usage: minimizing data 

copies, 13-18
index, 13-2
input arrays (activity), 13-9

setting For Loop count with 
auto-indexing, 13-10

purpose and use, 1-5
resizing array indicator, 13-6

attribute nodes, 12-1
activity, 12-3

block diagram, 12-4
front panel, 12-3

creating, 12-1
Help window, 12-2
modifying by expanding node, 12-1
purpose and use, 1-5, 12-1

auto-indexing. See arrays.
axis text, modifying (note), 10-21

B
bit array tags

alarm configuration, 3-34
creating, 3-3
purpose and use, 3-7
scaling, 3-28

Bit Array Tag Configuration dialog 
box, 3-28

scaling examples (table), 3-29
block diagram

generating with HMI G Wizard, 4-8
program design, 15-5

avoiding overuse of Sequence 
structures, 15-8

checking for errors, 15-6
common operations, 15-5
left-to-right layouts, 15-6
studying examples, 15-8

purpose and use, 2-3
toolbar and buttons, 2-3

Boolean constants
adding to subVI, 9-32
VI Control VI, 14-6

Boolean controls and indicators, 2-7
Boolean switches

changing mechanical action (activity), 
10-9
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possible choices for mechanical action, 
10-8

Latch Until Released, 10-9
Latch When Pressed, 10-8
Latch When Released, 10-9
Switch Until Released, 10-8
Switch When Pressed, 10-8
Switch When Released, 10-8

Breakpoint tool, 2-5
BridgeVIEW

architecture, 1-8
features, 1-1
getting started, 1-10
installation, 1-2
overview, 1-3
purpose and use, 1-3
required system configuration, 1-2
system control

System VIs, 7-7
VI Control VIs, 7-6

BridgeVIEW Configuration file, 3-2
BridgeVIEW Engine

functions, 1-9
increasing throughput using deadband, 

3-22
overview, 1-3
parameter configuration, 3-44

memory allocation parameters 
(table), 3-45

stopping and starting programmatically, 
7-8

BridgeVIEW Engine Manager. See Engine 
Manager.

BridgeVIEW environment, 2-1
Engine Manager, 2-13
G programming language
online help, 2-23
Project menu items (table), 2-11

system errors and events, 2-16
Tag Browser utility, 2-17
Tag Monitor, 2-20

BridgeVIEW System Log file, 2-15
BridgeVIEW VI Library

Alarms and Events VIs, A-4
Acknowledge Alarm, A-4
effect on startup and shutdown, 4-24
Get Alarm Summary Status, A-5
locating, A-4
purpose and use, 4-16, 4-19
Read Alarm Summary, A-6
Read Event History, A-9
Read Tag Alarm, A-13

error handling, A-1
errors not reported by BridgeVIEW 

Engine, A-1
errors reported by BridgeVIEW 

Engine, A-1
Historical Data VIs, A-15

Call HTV, A-15
Decimate Historical Trend, A-17
Decimate Historical Trends, A-18
Get Historical Tag List, 6-4, A-19
Get Historical Trend Info, A-20
Historical Trend Statistics, 6-7, A-21
Historical Trends to Spreadsheet, 

A-22
locating, A-15
Read Historical Trend, A-24
Read Historical Trends, 6-5, A-25

Security VIs
Check Operator Privileges, A-34
Get Operator Name, A-35
Invoke Login Dialog, A-36
Programmatic Login, A-36
Programmatic Logout, A-37
Security Monitor, A-37
User Account List, A-38
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System VIs, A-27
Enable Event Logging, 7-8, A-27
Enable historical data logging, 7-8, 

A-28
Enable printing, 7-8, A-28
Engine Launch, 7-8, A-29
Engine Shutdown, A-30
Get Engine Status, A-30
Get Tag Status Info, A-31
locating, A-27
Post System Error or Event, A-32
Tag Status Handler, A-33

Tag Attributes VIs, A-54
Get Analog Tag Alarm Limit, A-55
Get Bit Array Tag Alarm Setting, 

A-56
Get Discrete Tag Alarm Setting, 

A-57
Get Group List, A-58
Get Tag Alarm Enabled, A-58
Get Tag Attribute, A-59
Get Tag Bad Status Alarm Info, A-60
Get Tag Description Group, A-61
Get Tag I/O Connection Info, A-62
Get Tag List, A-63
Get Tag Logging Info, A-63
Get Tag Range and Units, A-64
Set Multiple Tag Attributes, A-65
Set Tag Attribute, A-66

Tags VIs, A-39
locating, A-39
Read Tag, A-39
Read Tag (bit array), A-41
Read Tag (discrete), A-42
Read Tag (string), A-44
Trend Tags, A-45
Write Tag, A-46
Write Tag (bit array), A-47
Write Tag (discrete), A-48
Write Tag (string), A-49

Write Tag on Change, A-50
Write Tag on Change (bit array), 

A-51
Write Tag on Change (discrete), 

A-52
Write Tag on Change (string), A-53

broken VIs, 9-23
Build Array function

activity, 13-17
multiplot graph, 13-8
purpose and use, 13-11

bulletin board support, C-1
Bundle function

auto-indexing, 13-6
creating multiplot chart, 10-20
graphs and analysis VIs, 13-23

C
Call HTV VI, A-15
Call Instrument VI, 7-7
case, 11-1
Case structure, 11-1

activity, 11-2
block diagram, 11-3
front panel, 11-2
VI logic, 11-4

diagram identifier, 11-1
illustration, 11-2
incrementing and decrementing 

subdiagrams, 11-1
out-of-range cases (note), 11-2
purpose and use, 1-5
subdiagram display window, 11-1

charts, 10-2
See also graphs.
activity, 10-3
creating multiplot chart and customizing 

trends (activity), 10-19
faster updates, 10-3
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.

modes, 10-2
purpose and use, 1-4, 10-2
stacked versus overlaid plots, 10-3
waveform chart

For Loop (activity), 10-25
placing on subVI, 9-30
using with While Loop (activity), 

10-5
Check Operator Privileges VI, A-34
Citadel Historical Database

data transform commands (table), B-5
ODBC driver, B-1
overview, 6-2

Citadel threaded database
retrieving data, B-6

Close Panel VI
controlling panel visibility, 7-7
VI Control VI, 14-6

Cluster to Array function, 14-6
clusters

purpose and use, 1-5, 13-19
coercion dot, 10-24
Color Box Constant, 12-4
Color Copy tool, 2-5
Color tool, 2-5
Compound Arithmetic function, 10-16
Configuration Wizard, 3-18
connection

configuring. See tag configuration; 
connection.

tag attributes, 1-6
constants

adding to VIs, 9-2
array constants, 13-3
tag, 4-17

Continuous Run button, 2-3
Control Editor, 4-12
controls and indicators, 2-6

adding to VIs, 9-2
array, 13-3
Boolean, 2-7

HMI G Wizard operations (table), 4-4
numeric, 2-7
string, 2-7
tag, 2-8

Controls palette, 2-5, 4-3
cursors, graph, 13-20
customer communication, xxvi, C-1
customizing VIs. See subVI note setup 

(activity), 9-1

D
data flow, in G, 2-1
data logging

See historical data logging and extraction
data types

See tag data types.
DDE server

connecting tag to, 3-19
using with BridgeVIEW, 8-7

deadband
alarm deadband on analog tags, 3-35
increasing engine throughput, 3-22
logging (table), 3-21
purpose and use, 3-22
setting update too high (note), 3-22
updating (table), 3-21

debugging VIs
activity, 9-24
overview, 9-23

Decimate Historical Trend VI, A-17
Decimate Historical Trends VI, A-18
deleting tags, 3-3
device servers. See servers.
digital indicator

adding to array, 13-5
For Loop (activity), 10-25

Disable Indexing command, 13-15
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discrete tags
alarm configuration, 3-34
creating, 3-3
purpose and use, 3-7

Distribution ring, 2-3
Divide function

adding to subVI, 9-22
Sequence structure, 11-10
shift register, 10-16

documentation
conventions used in manual, xxiv
organization of manual, xxi
related documentation, xxv

documenting VIs, 9-11
Dynamic Data Exchange server

See DDE server.

E
Edit User Accounts dialog box, 7-18
editing tags, 3-3

multiple tags, 3-3
electronic support services, C-1
e-mail support, C-2
Enable Event Logging VI, 7-8, A-27
Enable historical data logging VI, 7-8, A-28
Enable Indexing command, 13-15
Enable Launch VI, 7-8
Enable printing VI, 7-8, A-28
Engine

communication with device servers 
(note), 3-3

Engine Launch VI, A-29
Engine Manager

See also BridgeVIEW Engine.
Enable error, 2-14
Engine Status, 2-14
illustration, 2-13

Log Events, 2-14
Log Historical Data, 2-14
Print Events, 2-14
Quit Engine, 2-14
Run/Stop Engine, 2-14
Server Browser, 2-14
Show/Hide System Event Display, 2-14

Engine Shutdown VI, A-30
engineering units

assigning to an analog tag, 3-27
conversion by BridgeVIEW Engine, 1-8

environment security. See security.
error handling in BridgeVIEW VI Library, 

A-1
error checking in programs, 15-6
errors not reported by BridgeVIEW 

Engine, A-1
errors reported by BridgeVIEW Engine, 

A-1
System errors, 2-16

Event Configuration dialog box
event logging and printing selections 

(table), 5-11
illustration, 5-10
log and print format selections (table), 

5-12
event history

displaying history information, 5-6
purpose and use, 5-2

event-driven programming, implementing, 
4-25

events
configuring logging and printing, 5-10
Event Configuration dialog box

event logging and printing selections
(table), 5-11

illustration, 5-10
log and print format selections 

(table), 5-12
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logging
procedure, 5-13
setting file paths, 3-44
shift configuration, 3-44
stopping and starting 

programmatically, 7-8
turning on at startup, 3-44

printing, 5-14
stopping and starting 

programmatically, 7-8
purpose and use, 1-3, 1-7
System events, 2-16
types of events, 1-7
viewing, 5-14

execution highlighting, 9-25
Execution Options, 9-29
extracting historical data

See historical data logging and extraction.

F
fax and telephone support, C-2
Fax-on-Demand support, C-2
file

.scf , 3-2
BridgeVIEW Configuration, 3-2
SCADA Configuration, 3-2

Font ring, 2-3
For Loops, 10-22

See also shift registers.
activity, 10-25
count terminal, 10-23
iteration terminal, 10-23
numeric conversion, 10-24
purpose and use, 1-4
sizing, 10-22
using auto-indexing to set, 13-10

front panel
building an HMI with multiple panels, 7-1
building front panel objects, 4-3
buttons, 2-3
configuring objects programmatically, 

4-16
customizing, 4-12

Control Editor, 4-12
importing graphics, 4-13

overview, 2-2
Panel G Wizard,  7-2

FTP support, C-1
Functions palette, 2-6
functions, adding to VIs, 9-8

G
G programming language, 2-1

See also HMI G Wizard; program design.
building Human Machine Interface, 4-24

basic principles, 4-2
configuring HMI indicators using tag 

attributes, 4-31
displaying real-time trends, 4-29
event-driven programming, 4-25
initializing and shutting down 

multiple-loop applications, 4-28
polled programming, 4-27

controls and indicators, 2-6
Boolean, 2-7
numeric, 2-7
string, 2-7
tag, 2-8

Controls palette, 2-5
data flow, 2-1
Functions palette, 2-6
overview, 1-4, 2-1
Tools palette, 2-4
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VIs, 2-2
block diagram, 2-3
front panel, 2-2
icon/connector, 2-4
opening and running (activity), 2-8

General Attributes dialog box, 3-8
Generate Waveform VI, 13-4
Get Alarm Summary Status VI, A-5
Get Analog Tag Alarm Limit VI, A-55
Get Bit Array Tag Alarm Setting VI, A-56
Get Discrete Tag Alarm Setting VI, A-57
Get Engine Status VI, A-30
Get Group List VI, A-58
Get Historical Tag List, A-19
Get Historical Tag List VI

example, 6-4
purpose and use, A-19

Get Historical Trend Info VI, A-20
Get Operator Name VI, A-35
Get Panel Size VI, 7-7
Get Tag Alarm Enabled VI, A-58
Get Tag Attribute VI, A-59
Get Tag Bad Status Alarm Info VI, A-60
Get Tag Description Group VI, A-61
Get Tag I/O Connection Info VI, A-62
Get Tag List VI, A-63
Get Tag Logging Info VI, A-63
Get Tag Range and Units VI, A-64
Get Tag Status Info VI, A-31
graphics, importing for front panel

activity, 4-13
overview, 4-13

graphs, 13-19
See also charts.
axes, 13-21
customizing, 13-19
data acquisition arrays, 13-21
graph and analysis VIs (activity), 13-22
graph cursors, 13-20
purpose and use, 1-5

types of graphs, 13-19
waveform graph

adding to array, 13-5
creating multiplot waveform graphs,

13-8
Greater Or Equal To 0? function

Case structure, 11-3
VI Control VI, 14-6

Greater or Equal? function, 12-4

H
help. See online help.
Hierarchy window, 9-14

buttons for options, 9-14
displaying dependencies, 9-14
illustration, 9-14
searching for visible nodes, 9-15

Highlight Execution button, 2-4, 9-25
historical data logging and extraction

See also Historical Trend Viewer (HTV).
Citadel Historical Database, 6-2, B-1
configuring tags to log data or events, 

3-23
Historical Data VIs, 6-4

activity, 6-6
example, 6-4
list of VIs, 6-4
VI reference, A-15

logging, 6-2
configuring, 6-3
steps, 6-2
techniques for turning on and off, 6-2

overview, 1-7
setting file paths, 3-44
stopping and starting programmatically, 

7-8
trends, 6-1
turning on at startup, 3-44
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Historical Data VIs, 6-4, A-15
activity, 6-6
Call HTV, A-15
Decimate Historical Trend, A-17
Decimate Historical Trends, A-18
example, 6-4
Get Historical Tag List, 6-4, A-19
Get Historical Trend Info, A-20
Historical Trend Statistics, A-21
Historical Trend Statistics VI, 6-7
Historical Trends to Spreadsheet, A-22
list of VIs, 6-4
locating, A-15
Read Historical Trend, A-24
Read Historical Trends, 6-5, A-25

Historical Logging Configuration dialog box
illustration, 6-3
parameters (table), 6-4

Historical Trend Statistics VI
example, 6-7
purpose and use, A-21

Historical Trend Viewer (HTV), 6-9
activity, 6-16
exporting data to spreadsheet, 6-14
illustration, 6-9
incorporating into HMI

applications, 6-15
launching, 2-11
live mode, 6-15
online help, 6-14
plot colors and style in trend

changing, 6-13
Select Tags dialog box, 6-10
selecting tags to display, 6-10
tag, time, and color preferences

setting, 6-14
time axis, changing, 6-11

manual changes, 6-12
panning button functions, 6-11

timespan of displayed data
changing, 6-12

viewing newly logged data, 6-15
viewing tag value at specific point in time,

6-13
Y axis, changing, 6-13
zooming in on a trend, 6-13

Historical Trends to Spreadsheet VI, A-22
HMI G Wizard

alarm acknowledgement (activity), 5-7
building alarm summary (activity), 5-3
dialog box, 4-7
front panel object and Wizard subdiagram

association, 4-8
generating block diagram, 4-8
invoking, 4-7
operations on front panel objects (table)

Boolean control, 4-4
Boolean indicator, 4-5
historical trend or XY graph 

indicator, 4-6
numeric control, 4-4, 4-5
numeric indicator, 4-4, 4-5
real-time trend or waveform chart 

indicator, 4-6
table indicator, 4-6

Wizard lock, 4-8
HMI. See Human Machine Interface.
HTV. See Historical Trend Viewer (HTV).
Human Machine Interface, 4-1

See also BridgeVIEW VI Library.
building, 4-2

front panel objects, 4-3
HMI G Wizard, 4-3

customizing front panel objects, 4-12
configuring programmatically, 4-16
Control Editor, 4-12
importing graphics, 4-13

activity, 4-13
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G programming principles, 4-24
basic principles, 4-2
configuring HMI indicators using tag 

attributes, 4-31
displaying real-time trends, 4-29
event-driven programming, 4-25
initializing and shutting down 

multiple-loop applications, 4-28
polled programming, 4-27

HMI G Wizard, 4-3
activity, 4-9
operations (table), 4-4

incorporating Historical Trend Viewer 
(HTV), 6-15

monitoring and controlling tags, 4-16
reading tags (activity), 4-21
tag data type, 4-17
Tags VIs and Alarms and Events VIs, 

4-19
effect on startup and shutdown, 

4-24
VIs for, 4-16

overview, 1-1, 1-9, 4-1
purpose and use, 4-1

I
I/O Group configuration, 3-12

attributes (table), 3-13
dialog box, 3-13
options, 3-12
server configuration options, 3-14

icon and connector, 9-15
color icons (note), 9-17
connector programming considerations, 

15-3
adding extra unconnected terminals, 

15-3
subVIs with required inputs, 15-4

creating (activity), 9-18
defining connectors, 9-17
purpose and use, 2-4

Icon Editor window, 9-16
buttons, 9-17
illustration, 9-16
tools, 9-16

Increment function, 11-9
Index Array function, 13-14
industrial automation device servers. See 

servers.
Initialize Array function, 13-12
installing BridgeVIEW, 1-2
Interval query field, B-4
Invoke Login Dialog, A-36
item, 8-1

configuration options, 3-16

J
junction, 9-6

L
Labeling tool, 2-4
Live Mode (HTV), 6-15
LocalTime query field, B-4
logging

alarms and events, 5-13
configuration, 5-10

historical data
See historical data logging and 

extraction.
logging in and out, 7-15

programmatically, 7-17
prompting operator to log in, 7-17
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loops
See also For Loops; shift registers; While 

Loops.
initializing and shutting down 

multiple-loop applications, 4-28
purpose and use, 1-4

M
Man Machine Interface. See Human Machine 

Interface.
manual. See documentation.
Max & Min function, 10-27
Mean VI, 13-23
memory

configurable memory allocation 
parameters (table), 3-45

efficient use with arrays, 13-18
VI Control VI considerations, 14-2

memory tags, 3-17
when not to use, 3-17
when to use, 3-17

Microsoft Access
retrieving Citadel data, B-13

Microsoft Excel
retrieving Citadel data, B-11

Microsoft Query
retrieving Citadel data, B-7

multiple-loop applications, initializing and 
shutting down, 4-28

multiplot chart, creating (activity), 10-19
multiplot graphs, creating, 13-8
Multiply function, 11-9

N
NI-DAQ server, installing, 8-3
Not Equal? function, 11-9
Not function

adding to subVI, 9-32
VI Control VI, 14-7

numeric constants
adding to subVI, 9-22
auto-indexing, 13-6
Case structure, 11-4
For Loop, 10-26
graph and analysis VIs (activity), 13-22
Sequence structure, 11-9
shift register, 10-26

numeric controls and indicators, 2-7
numeric conversion, 10-24

O
Object pop-up menu tool, 2-5
ODBC driver, B-1

threads table, B-4
using, B-6

One Button Dialog function, 11-4
online help

accessing, 2-23
Historical Trend Viewer (HTV), 6-14
links to online help files, 2-24
simple/complex help view, 2-23

OPC server
connection to tags, 3-18

Open Database Connectivity (ODBC) driver,
B-1

Open Panel VI
controlling panel visibility, 7-7
VI Control VI, 14-6
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, 
operability, 7-20
Operating tool, 2-4
operations

configuring
See tag configuration, operations

types of operations, 1-6
operator, 4-1
Operator Interface Security, 7-20

controlling visibility attributes, 7-20
limiting user access to operator interface 

panels, 7-20

P
Panel G Wizard, 7-2
panel size and visibility, controlling, 7-7
password, changing, 7-16
Pause/Continue button, 2-3
pi constant, 13-8
polled programming, implementing, 4-27
polymorphism, 13-1
pop-up menus

Object pop-up menu tool, 2-5
popping up on objects, 2-6

Positioning tool, 2-4
Post System Error or Event VI, A-32
Preload Instrument VI

controlling panel visibility, 7-7
VI Control VI, 14-6

printing alarms and events, 5-14
configuration, 5-10

privileges
See access levels and privileges.

Privileges dialog box, 7-16
Probe tool, 2-5, 9-24

program design, 15-1
See also G programming language.
good diagram style, 15-5

avoiding overuse of Sequence 
structures, 15-8

checking for errors, 15-6
common operations, 15-5
left-to-right layouts, 15-6
studying examples, 15-8

planning ahead with connector panes, 
15-3

adding extra unconnected terminals
15-3

subVIs with required inputs, 15-4
top-down design, 15-1

designing VI hierarchy, 15-1
list of user requirements, 15-1
writing the program, 15-3

Programmatic Login VI, A-36
Programmatic Logout VI, A-37
Project menu, 2-11

Historical Trend Viewer, 2-11
Launch Engine, 2-11
Security»Access Levels, 2-11
Security»Change Password, 2-12
Security»Edit User Accounts, 2-12
Security»Login, 2-12
Security»Logout, 2-12
Security»Privileges, 2-12
Server Tools»Server Browser, 2-12
Tag»Browser, 2-12
Tag»Configuration, 2-13
Tag»Monitor, 2-13
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R
Random Number function

Attribute Node, 12-4
For Loop, 10-26
Sequence structure, 11-9
shift register, 10-16

Read Alarm Summary VI, A-6
Read Event History VI, A-9
Read Historical Trend VI, A-24
Read Historical Trends VI

example, 6-6
purpose and use, A-25

Read Tag VI, A-39
Read Tag (bit array) VI, A-41
Read Tag (discrete) VI, A-42
Read Tag (string) VI, A-44
Read Tag Alarm VI, A-13
Real-Time Database, 1-6, 1-9, 3-1

See also BridgeVIEW Engine; tag 
configuration; operations.

real-time trends, displaying, 4-29
Release Instrument VI, 14-6
Resize panel VIs, 7-7
Round to Nearest function, 11-9
RTDB. See Real-Time Database.
Run button, 2-3

broken Run button, 9-23
Run Instrument VI, 14-6

S
SCADA Configuration file, 3-2

contents, 3-2
running one .scf  file at a time (note), 3-3

scaling, 3-23
configuration. See tag configuration, 

scaling.
purpose and use, 1-6

.scf  file, 3-2
scope chart, 10-2

Scroll tool, 2-5
Search 1D Array function, 14-6
security

assigning to alarm summary application
(activity), 7-22

environment security, 7-13
Access Levels dialog box, 7-15
changing password, 7-16
creating and modifying user 

accounts, 7-18
Edit User Accounts dialog box, 7-18
finding access level, 7-15
finding environment access 

privileges, 7-16
identifying current operator, 7-17
logging in and out, 7-15
modifying access privileges, 7-19
modifying list of available user 

access levels, 7-19
Privileges dialog box, 7-16
prompting operator to log in, 7-17
restricting access, 7-17

Operator Interface Security, 7-20
controlling visibility attributes, 7-20
limiting user access to operator 

interface panels, 7-21
overview, 1-8
Project menu items

Security»Access Levels, 2-11
Security»Change Password, 2-12
Security»Edit User Accounts, 2-12
Security»Login, 2-12
Security»Logout, 2-12
Security»Privileges, 2-12

Security Monitor VI, A-37
Security VIs

Check Operator Privileges, A-34
Get Operator Name, A-35
Invoke Login Dialog, A-36
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Programmatic Login, A-36
Programmatic Logout, A-37
Security Monitor, A-37
User Account List, A-38

Select Tags to Monitor dialog box, 2-22
selector, 11-1
sequence local variable, 11-9
Sequence structure, 11-5

activity, 11-5
block diagram, 11-6
front panel, 11-5

avoiding overuse, 15-8
diagram identifier, 11-1
illustration, 11-5
incrementing and decrementing 

subdiagrams, 11-1
overview, 11-5
purpose and use, 1-5
subdiagram display window, 11-1

Server Browser
illustration, 2-16
launching, 2-11
main screen (illustration), 8-8
Show Server User Interface button, 2-16
unregistered servers, 8-9
viewing BridgeVIEW server 

configuration, 8-7
Server Browser button, 8-7
server configuration

options, 3-14
servers

See also Server Browser.
communication with Engine (note), 3-3
DDE servers and BridgeVIEW, 8-7
developing IA device servers, 8-10
installation and configuration, 8-2

launching server configuration 
utilities from Tag Configuration 
Editor, 3-46

NI-DAQ server, 8-3
registering simulation servers, 8-5
using BridgeVIEW Device Servers 

CD, 8-4
items, 8-1
overview, 1-9
purpose and use, 8-1
viewing server configuration, 8-6

registered server device and item 
parameters, 8-9

Server Browser, 8-5
View Server Device Information 

dialog box, 8-6
Set Multiple Tag Attributes VI, A-65
Set Tag Attribute VI, A-66
setting file paths, 3-44
shift configuration, 3-44
shift registers, 10-13

creating, 10-13
creating multiplot chart and customizing 

trends (activity), 10-19
displaying running average on chart 

(activity), 10-15
overview, 10-13
uninitialized shift registers, 10-17

Sine function, 13-8
single-stepping through VI, 9-23
spreadsheets

exporting configuration fields, 3-5
Historical Trends to Spreadsheet VI, A-2
important points, 3-5
importing data (note), 3-6
saving trend data

Historical Trend Viewer (HTV), 6-14
storing tag configuration data, 3-5

Square Root function, 11-3
Status Details dialog box, 2-22
Step Into button, 2-4
Step Out button, 2-4, 9-23
Step Over button, 2-4, 9-23
BridgeVIEW User Manual I-14 © National Instruments Corporation



Index
Stop button, 2-3
string constant, 11-4
string controls and indicators, 2-8
string tags

alarm configuration, 3-35
creating, 3-3
purpose and use, 3-7

strip chart, 10-2
Structured query language

examples, B-6
structures, 10-1

See also Case structure; loops; Sequence 
structure.

Subtract function, 11-9
subVI node setup

activity, 9-27
block diagram for subVI, 9-31
front panel for subVI, 9-30
user information dialog box

block diagram, 9-28
Execution Options, 9-29
front panel, 9-27
Windows Options, 9-29

SubVI Node Setup dialog box, 9-26
subVIs

calling (activity), 9-20
block diagram, 9-21
opening front panel, 9-20

Hierarchy window, 9-14
icon and connector, 9-15

color icons (note), 9-17
creating (activity), 9-18
defining connectors, 9-17
Icon Editor window, 9-15

opening, operating, and changing, 9-20
purpose and use, 9-13

sweep chart, 10-2
System errors, 2-16

System Event Display
illustration, 2-15
items displayed, 2-15
showing/hiding, 2-14
using, 2-15

System events, 2-16
System VIs, 7-7, A-27

Enable Event Logging, 7-8, A-27
Enable historical data logging, 7-8, A-28
Enable printing, 7-8, A-28
Engine Launch, 7-8, A-29
Engine Shutdown, A-30
Get Engine Status, A-30
Get Tag Status Info, A-31
locating, 4-17, A-27
Post System Error or Event, A-32
Security. See Security VIs.
Tag Status Handler, A-33

T
tag

attributes, 3-8
connection to DDE server, 3-19
connection to OPC server, 3-18

Tag Attribute VIs, A-54
configuring HMI indicators 

programmatically, 4-31
Get Analog Tag Alarm Limit, A-55
Get Bit Array Tag Alarm Setting, A-56
Get Discrete Tag Alarm Setting, A-57
Get Group List, A-58
Get Tag Alarm Enabled, A-58
Get Tag Attribute, A-59
Get Tag Bad Status Alarm Info, A-60
Get Tag Description Group, A-61
Get Tag I/O Connection Info, A-62
Get Tag List, A-63
Get Tag Logging Info, A-63
Get Tag Range and Units, A-64
© National Instruments Corporation I-15 BridgeVIEW User Manual



Index

5

location of, 4-17
Set Multiple Tag Attributes, A-65
Set Tag Attribute, A-66

tag attributes, 3-8
activity, 7-10
reading or changing programmatically, 

7-9
Tag Attributes palette, 7-9
Tag Browser utility, 2-17

fields
Access rights, 2-18
Alarms enabled, 2-19
Auto Ack, 2-19
Browse, 2-18
Configuration File, 2-18
Configured Tags, 2-18
Description, 2-18
Engine Status, 2-18
Full Scale, 2-19
Group, 2-18
Item, 2-18
Name, 2-18
Server, 2-18
Type, 2-18
Units, 2-19
Zero Scale, 2-19

illustration, 2-17
launching, 2-11
purpose and use, 2-19

tag configuration, 3-6
See also Tag Configuration Editor
accessing or changing in your application, 

3-46
activity, 3-37

configuration settings (table), 3-39
historical logging and alarm 

acknowledgement (table), 3-41
registering Tanks Server, 3-37
saving configuration file, 3-42

viewing tag configuration, 3-42
viewing tag value and status, 3-43

alarms, 3-29, 3-33
alarm deadband on analog tags, 3-3
analog tags, 3-33
bit array tags, 3-34
discrete tags, 3-34
enabling alarms, 3-33
keeping alarm unacknowledged, 

3-36
string tags, 3-35
types of alarms, 3-29

alarms configuration attributes (table)
Alarm Deadband, 3-30
Alarm Invert Mask, 3-32
Alarm Message, 3-32
Alarm On, 3-31
Alarm Select Mask, 3-32
Alarms Enabled, 3-30
Auto Ack, 3-30
Bad Status Enabled, 3-30
Bad Status Priority, 3-30
Discrete Enabled, 3-31
Discrete Priority, 3-31
HI Enabled, 3-30
HI Limit, 3-30
HI Priority, 3-31
HI_HI Enabled, 3-30
HI_HI Limit, 3-30
HI_HI Priority, 3-30
LO Enabled, 3-31
LO Limit, 3-31
LO Priority, 3-31
LO_LO Enabled, 3-31
LO_LO Limit, 3-31
LO_LO Priority, 3-31
Tag Last Modified, 3-32
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connection
connecting tag to an OPC server, 

3-18
connecting tag to DDE server, 3-19
defining group of tags for alarming, 

3-19
generate tags from server 

information, 3-18
I/O Group configuration

server configuration options, 
3-14

item configuration
options, 3-16

memory tags, 3-17
data types, 3-7
general configuration attributes (table), 

3-9
Maximum Length, 3-9
Tag Description, 3-9
Tag Group, 3-9
Tag Name, 3-9

I/O Group Configuration Attributes 
(table), 3-13

Communication Resource, 3-14
Device Comm Resource, 3-14
I.O Group Update Deadband, 3-14
I/O Group Description, 3-13
I/O Group Device, 3-14
I/O Group Name, 3-13
I/O Group Update Rate (secs), 3-13
Server Name, 3-14

operations, 3-20
increasing engine throughput using 

deadband, 3-22
logging data or events, 3-23
setting deadband, 3-22
Tag Operations dialog box, 3-20

operations configuration attributes 
(table), 3-21

Initial Value, 3-22

Log Data, 3-21
Log Data Deadband, 3-21
Log Resolution, 3-21
Log/Print Events, 3-21
Set Initial Value, 3-22
Update Deadband, 3-21

scaling
analog tags, 3-25
bit array tags, 3-28
discrete tags, 3-23
string tags (note), 3-25

scaling configuration attributes (table), 
3-24

Coerce, 3-24
Eng Full Scale, 3-24
Eng Zero Scale, 3-24
Raw Full Scale, 3-24
Raw Zero Scale, 3-24
Scaling, 3-24
Scaling Invert Mask, 3-25
Scaling Select Mask, 3-25
Units, 3-24

setting initial tag value at startup, 3-23
Tag Configuration Editor, 3-2

See also tag configuration.
creating, editing or deleting tags, 3-3
editing multiple tags simultaneously, 3-3
Engine parameter configuration, 3-44

configurable memory allocation 
parameters (table), 3-45

overriding default settings, 3-44
setting file paths for historical and 

event files, 3-44
shift configuration, 3-44
turning on historical and event 

logging at startup, 3-44
illustration, 3-2
launching, 2-13, 3-2
launching server configuration utilities, 

3-46
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Set Tag Parameter Defaults dialog box, 
3-4

setting default values for configuration 
fields, 3-4

spreadsheets for storing configuration 
data, 3-5

tag controls and indicators, 2-8
tag data types, 3-7

analog, 3-7
bit array, 3-7
discrete, 3-7
monitoring and controlling tags in HMI, 

4-17
overview, 1-5
string, 3-7

Tag Monitor utility, 2-20
fields

Monitor Timeout (secs), 2-21
Select Tags to Monitor, 2-21
Status Details, 2-21
Tag Display Table, 2-21
Trigger Tag, 2-21

illustration, 2-20
launching, 2-13
overview, 2-20
Select Tags to Monitor dialog box, 2-22
Status Details dialog box, 2-22
viewing tag value and status, 3-43

tag operations
types of operations, 1-6

tag scaling
purpose and use, 1-6

Tag Status Handler VI, A-33
tags

See also tag configuration.
creating, 3-3
data types. See tag data types.
deleting, 3-3
editing, 3-3
editing multiple tags simultaneously, 3-3

monitoring and controlling in HMI, 4-16
reading tags (activity), 4-21
tag data type, 4-17
Tag VIs and Alarms and Events VIs

effect on startup and shutdown, 
4-24

VIs for, 4-16
monitoring and controlling in HMI

Tag VIs and Alarms and Events VIs,
4-19

purpose and use, 1-3, 3-1
types, 1-5, 3-1

Tags VIs, A-39
effect on startup and shutdown, 4-24
locating, A-39
purpose and use, 4-16
Read Tag, A-39
Read Tag (bit array), A-41
Read Tag (discrete), A-42
Read Tag (string), A-44
Trend Tags, A-45
Write Tag, A-46
Write Tag (bit array), A-47
Write Tag (discrete), A-48
Write Tag (string), A-49
Write Tag on Change, A-50
Write Tag on Change (bit array), A-51
Write Tag on Change (discrete), A-52
Write Tag on Change (string), A-53

technical support, C-1
telephone and fax support, C-2
Temp&Vol VI, 9-32
terminals, adding to VIs, 9-4
Thermometer VI, 13-23
Threads table, B-4
tip strips, 9-5
Tools palette, 2-4
top-down design. See program design.
Trend Tags VI, A-45
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trends
See also Historical Trend Viewer (HTV).
historical trends, 6-1
purpose and use, 1-7, 6-1
real-time trends, 6-1

U
User Account List VI, A-38
UTCTime query field, B-4

V
vertical switch

Boolean switch (activity), 10-9
placing on front panel, 10-5

VI Control VIs, 14-1
activity, 14-4

block diagram, 14-5
Close Panel VI, 14-6
front panel, 14-4
Open Panel VI, 14-6
Preload Instrument VI, 14-6
Release Instrument VI, 14-6
Run Instrument VI, 14-6

locating, 7-6, 14-1
memory considerations, 14-2
panel size and visibility, controlling, 7-7
purpose and use, 1-5, 7-6, 14-2

VI Setup dialog box, 9-26
View Server Device Information dialog box, 

8-9
viewing new data automatically after logging, 

6-15
VIs, 2-2

See also BridgeVIEW VI Library; 
program design; subVIs.

block diagram, 2-3
components, 1-4, 2-2
creating, 9-1

activity, 9-7
controls, constants, and indicators, 

9-2
documenting VIs, 9-11
hierarchy of VIs, 9-1
Hierarchy window, 9-14
saving as individual files, 9-2
saving in VI libraries, 9-2
terminals, 9-4
wires, 9-4

customizing, 9-26
debugging, 9-23

activity, 9-24
overview, 9-23

front panel, 2-2
icon/connector, 2-4
opening and running (activity), 2-8
overview, 1-3
purpose and use, 1-4, 9-1
subVI node setup, 9-26

activity, 9-27
System VIs, 7-7
VI Control VIs, 7-6
VI Setup dialog box, 9-26

visibility, 7-20
Visual Basic

retrieving Citadel data, B-14

W
Wait Until Next ms Multiple function

adding to subVI, 9-32
attribute node, 12-5
graph and analysis VIs, 13-23
shift register, 10-16

waveform chart
See also charts.
For Loop (activity), 10-25
placing on subVI, 9-30
using with While Loop (activity), 10-5
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waveform graph
See also graphs.
adding to array, 13-5
creating multiplot waveform graphs, 13-8

While Loops, 10-4
See also shift registers.
acquiring and displaying data (activity), 

10-5
block diagram, 10-6
front panel, 10-5

equivalent pseudocode, 10-4
mechanical action of Boolean switches, 

10-8
changing (activity), 10-9
possible choices, 10-8

preventing code execution, 10-11
purpose and use, 1-4, 10-4
timing, 10-10

activity, 10-10
overview, 10-10

Windows Options, 9-29

wires, 9-4
bad wires, 9-7
purpose and use, 9-4
selecting and deleting, 9-6
stretching, 9-6
tip strips, 9-5

Wiring tool, 2-4, 9-4
Wiring tool hot spot, 9-4
Wizard lock, 4-8
Write Tag VI, A-46
Write Tag (bit array) VI, A-47
Write Tag (discrete) VI, A-48
Write Tag (string) VI, A-49
Write Tag on Change VI, A-50
Write Tag on Change (bit array) VI, A-51
Write Tag on Change (discrete) VI, A-52
Write Tag on Change (string) VI, A-53

X
X and Y axes, rescaling, 10-20
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